]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
10c308a668f0718f29451c361786c93aae56329a
[packages/gcl.git] / gcl.spec
1
2 Summary:        GNU Common Lisp
3 Summary(pl):    GNU Common Lisp
4 Name:           gcl
5 Version:        2.4.3
6 Release:        2
7 License:        LGPL v2
8 Group:          Development/Languages
9 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
10 Patch0:         %{name}-make.patch
11 Patch1:         %{name}-OPT.patch
12 Patch2:         %{name}-info.patch
13 Patch3:         %{name}-libgmp.patch
14 Patch4:         %{name}-bdf.patch
15 URL:            http://www.ma.utexas.edu/users/wfs/gcl.html
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gmp-devel
19 BuildRequires:  tk-devel
20 BuildRequires:  xemacs
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 ExclusiveArch:  %{ix86} sparc
23
24 %description
25 The GNU Common Lisp system, based on KCL.
26
27 %description -l pl
28 System GNU Common Lisp, bazuj±cy na KCL.
29
30 %package tk
31 Summary:        Tcl/tk bindings for GNU Common Lisp
32 Summary(pl):    Interfejs Tcl/tk do GNU Common Lisp
33 Group:          Development/Languages
34 Requires:       %{name} = %{version}
35
36 %description tk
37 Tcl/tk bindings for GNU Common Lisp.
38
39 %description tk -l pl
40 Intefejs Tcl/tk dla GNU Common Lisp.
41
42 %prep
43 %setup  -q
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47 %patch3 -p1
48 %patch4 -p1
49
50 %build
51 rm -f missing
52 %{__aclocal}
53 %{__autoconf}
54 cp -f /usr/share/automake/config.* .
55 GCC="%{__cc}"; export GCC
56 # note: full path to xemacs must be passed
57 EMACS=/usr/bin/xemacs; export EMACS
58 %configure \
59         --enable-notify=no
60
61 %{__make} OPTFLAGS="%{rpmcflags}" \
62         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
67         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
68         $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
69
70 (cd info
71 rm -f *info*
72 makeinfo gcl-si.texi gcl-tk.texi
73 install gcl*info* $RPM_BUILD_ROOT%{_infodir})
74 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
75
76 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
77 install info/*info* $RPM_BUILD_ROOT%{_infodir}
78 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
79 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
80 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
81         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
82
83 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
84
85 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
86 #!/bin/sh
87 exec %{_libdir}/gcl/unixport/saved_gcl \
88         -dir {_libdir}/gcl/unixport/ \
89         -libdir %{_libdir}/gcl/ \
90         -eval '(setq si::*allow-gzipped-file* t)' \
91         "$@"
92 EOF
93
94 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
95 #!/bin/sh
96 exec %{_libdir}/gcl/unixport/saved_gcl \
97         -dir {_libdir}/gcl/unixport/ \
98         -libdir %{_libdir}/gcl/ \
99         -eval '(setq si::*allow-gzipped-file* t)' \
100         -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
101         "$@"
102 EOF
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
109
110 %postun
111 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
112
113 %post tk
114 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
115
116 %postun tk
117 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
118
119 %files
120 %defattr(644,root,root,755)
121 %doc readme faq ChangeLog
122 %attr(755,root,root) %{_bindir}/gcl
123 %attr(755,root,root) %{_bindir}/gcl.exe
124 %{_libdir}/gcl/cmpnew
125 %{_libdir}/gcl/lsp
126 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
127 %{_infodir}/gcl-si.info*
128 %{_mandir}/man1/*
129
130 %files tk
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/gcl-tk
133 %dir %{_libdir}/gcl/gcl-tk
134 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
135 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
136 %{_libdir}/gcl/gcl-tk/*.o
137 %{_libdir}/gcl/gcl-tk/*.tcl
138 %{_infodir}/gcl-tk.info*
This page took 0.055984 seconds and 3 git commands to generate.