]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
0a61ab9a29b8548616d0bcdcba9021f8cb7dc40e
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp
2 Summary(pl):    GNU Common Lisp
3 Name:           gcl
4 Version:        2.4.1
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Group(cs):      Vývojové prostøedky/Programovací jazyky
9 Group(da):      Udvikling/Sprog
10 Group(de):      Entwicklung/Sprachen
11 Group(es):      Desarrollo/Lenguajes
12 Group(fr):      Development/Langues
13 Group(is):      Þróunartól/Forritunarmál
14 Group(it):      Sviluppo/Linguaggi
15 Group(ja):      ³«È¯/¸À¸ì
16 Group(no):      Utvikling/Programmeringsspråk
17 Group(pl):      Programowanie/Jêzyki
18 Group(pt):      Desenvolvimento/Linguagens
19 Group(ru):      òÁÚÒÁÂÏÔËÁ/ñÚÙËÉ
20 Group(sl):      Razvoj/Jeziki
21 Group(sv):      Utveckling/Språk
22 Group(uk):      òÏÚÒÏÂËÁ/íÏ×É
23 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
24 Patch0:         %{name}-make.patch
25 Patch1:         %{name}-OPT.patch
26 Patch2:         %{name}-info.patch
27 Patch3:         %{name}-libgmp.patch
28 URL:            http://www.gnu.org/projects/gcl
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  gmp-devel
32 BuildRequires:  tk-devel
33 BuildRequires:  xemacs
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The GNU Common Lisp system, based on KCL.
38
39 %description -l pl
40 System GNU Common Lisp, bazuj±cy na KCL.
41
42 %package tk
43 Summary:        Tcl/tk bindings for GNU Common Lisp
44 Summary(pl):    Interfejs Tcl/tk do GNU Common Lisp
45 Group:          Development/Languages
46 Group(cs):      Vývojové prostøedky/Programovací jazyky
47 Group(da):      Udvikling/Sprog
48 Group(de):      Entwicklung/Sprachen
49 Group(es):      Desarrollo/Lenguajes
50 Group(fr):      Development/Langues
51 Group(is):      Þróunartól/Forritunarmál
52 Group(it):      Sviluppo/Linguaggi
53 Group(ja):      ³«È¯/¸À¸ì
54 Group(no):      Utvikling/Programmeringsspråk
55 Group(pl):      Programowanie/Jêzyki
56 Group(pt):      Desenvolvimento/Linguagens
57 Group(ru):      òÁÚÒÁÂÏÔËÁ/ñÚÙËÉ
58 Group(sl):      Razvoj/Jeziki
59 Group(sv):      Utveckling/Språk
60 Group(uk):      òÏÚÒÏÂËÁ/íÏ×É
61 Requires:       %{name} = %{version}
62
63 %description tk
64 Tcl/tk bindings for GNU Common Lisp.
65
66 %description tk -l pl
67 Intefejs Tcl/tk dla GNU Common Lisp.
68
69 %prep
70 %setup  -q
71 %patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74 %patch3 -p1
75
76 %build
77 rm -f missing
78 aclocal
79 autoconf
80 cp -f /usr/share/automake/config.* .
81 GCC="%{__cc}"; export GCC
82 %configure2_13 \
83         --enable-notify=no
84
85 %{__make} OPTFLAGS="%{rpmcflags}" \
86         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
91         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
92         $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
93
94 (cd info
95 rm -f *info*
96 makeinfo gcl-si.texi gcl-tk.texi
97 install gcl*info* $RPM_BUILD_ROOT%{_infodir})
98 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
99
100 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
101 install info/*info* $RPM_BUILD_ROOT%{_infodir}
102 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
103 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
104 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
105         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
106
107 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
108
109 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
110 #!/bin/sh
111 exec %{_libdir}/gcl/unixport/saved_gcl \
112         -dir {_libdir}/gcl/unixport/ \
113         -libdir %{_libdir}/gcl/ \
114         -eval '(setq si::*allow-gzipped-file* t)' \
115         "$@"
116 EOF
117
118 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
119 #!/bin/sh
120 exec %{_libdir}/gcl/unixport/saved_gcl \
121         -dir {_libdir}/gcl/unixport/ \
122         -libdir %{_libdir}/gcl/ \
123         -eval '(setq si::*allow-gzipped-file* t)' \
124         -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
125         "$@"
126 EOF
127
128 gzip -9nf readme faq ChangeLog
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
135
136 %postun
137 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
138
139 %post tk
140 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
141
142 %postun tk
143 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
144
145 %files
146 %defattr(644,root,root,755)
147 %doc *.gz
148 %attr(755,root,root) %{_bindir}/gcl
149 %attr(755,root,root) %{_bindir}/gcl.exe
150 %{_libdir}/gcl/cmpnew
151 %{_libdir}/gcl/lsp
152 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
153 %{_infodir}/gcl-si.info*
154 %{_mandir}/man1/*
155
156 %files tk
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/gcl-tk
159 %dir %{_libdir}/gcl/gcl-tk
160 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
161 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
162 %{_libdir}/gcl/gcl-tk/*.o
163 %{_libdir}/gcl/gcl-tk/*.tcl
164 %{_infodir}/gcl-tk.info*
This page took 0.131683 seconds and 3 git commands to generate.