]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- updated to 4.0.0-20050130.
[packages/gcc4.git] / gcc4.spec
1 #
2 # Conditional build:
3 %bcond_without  ada             # build without ADA support
4 %bcond_without  fortran         # build without Fortran support
5 %bcond_without  java            # build without Java support
6 %bcond_without  objc            # build without ObjC support
7 #
8 # TODO:
9 #               - http://gcc.gnu.org/PR11203 (inline-asm)
10 #               - http://gcc.gnu.org/PR18648 (missed tree-optimization)
11 #               - disable internal zlib usage
12 #               - translations from gcc.spec:HEAD
13 #
14 %define         _snap           20050130
15 #
16 Summary:        GNU Compiler Collection: the C compiler and shared files
17 Summary(pl):    Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
18 Name:           gcc
19 Epoch:          5
20 Version:        4.0.0
21 Release:        0.%{_snap}.1
22 License:        GPL
23 Group:          Development/Languages
24 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
25 #Source0:       ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
26 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/%{name}-4.0-%{_snap}.tar.bz2
27 # Source0-md5:  5040ba840d0367c378f73c739418b3e2
28 Patch0:         %{name}-info.patch
29 Patch1:         %{name}-nolocalefiles.patch
30 Patch2:         %{name}-nodebug.patch
31 Patch3:         %{name}-ada-link-new-libgnat.patch
32 Patch4:         %{name}-ada-link.patch
33 URL:            http://gcc.gnu.org/
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  binutils >= 2:2.15.94.0.1
37 BuildRequires:  bison
38 BuildRequires:  fileutils >= 4.0.41
39 BuildRequires:  flex
40 %if %{with ada}
41 BuildRequires:  gcc(ada)
42 BuildRequires:  gcc-ada
43 %endif
44 BuildRequires:  gettext-devel
45 BuildRequires:  glibc-devel >= 2.2.5-20
46 BuildRequires:  gmp-devel
47 BuildRequires:  libmpfr-devel
48 BuildRequires:  perl-devel
49 BuildRequires:  texinfo >= 4.1
50 BuildRequires:  zlib-devel
51 Requires:       binutils >= 2:2.15.94.0.1
52 Requires:       libgcc = %{epoch}:%{version}-%{release}
53 Provides:       cpp = %{epoch}:%{version}-%{release}
54 %{?with_ada:Provides:   gcc(ada)}
55 Obsoletes:      cpp
56 Obsoletes:      egcs-cpp
57 Obsoletes:      gcc-cpp
58 Obsoletes:      gcc-ksi
59 Obsoletes:      gont
60 Conflicts:      glibc-devel < 2.2.5-20
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _slibdir        /%{_lib}
64
65 %description
66 A compiler aimed at integrating all the optimizations and features
67 necessary for a high-performance and stable development environment.
68
69 This package contains the C compiler and some files shared by various
70 parts of the GNU Compiler Collection. In order to use another GCC
71 compiler you will need to install the appropriate subpackage.
72
73 %description -l pl
74 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
75 wyprodukowania szybkiego i stabilnego kodu wynikowego.
76
77 Ten pakiet zawiera kompilator C i pliki wspó³dzielone przez ró¿ne
78 czê¶ci kolekcji kompilatorów GNU (GCC). ¯eby u¿ywaæ innego kompilatora
79 z GCC, trzeba zainstalowaæ odpowiedni podpakiet.
80
81 %package -n libgcc
82 Summary:        Shared gcc library
83 Summary(pl):    Biblioteka gcc
84 Group:          Libraries
85 Obsoletes:      libgcc1
86
87 %description -n libgcc
88 Shared gcc library.
89
90 %description -n libgcc -l pl
91 Biblioteka dynamiczna gcc.
92
93 %package -n libmudflap
94 Summary:        GCC mudflap shared support library
95 Group:          Libraries
96
97 %description -n libmudflap
98 The libmudflap libraries are used by GCC for instrumenting pointer and
99 array dereferencing operations.
100
101 %package -n libmudflap-devel
102 Summary:        Development files for GCC mudflap library
103 Group:          Development/Libraries
104 Requires:       libmudflap = %{epoch}:%{version}-%{release}
105
106 %description -n libmudflap-devel
107 The libmudflap libraries are used by GCC for instrumenting pointer and
108 array dereferencing operations. This package contains development
109 files.
110
111 %package -n libmudflap-static
112 Summary:        Static GCC mudflap library
113 Group:          Development/Libraries
114 Requires:       libmudflap-devel = %{epoch}:%{version}-%{release}
115
116 %description -n libmudflap-static
117 The libmudflap libraries are used by GCC for instrumenting pointer and
118 array dereferencing operations. This package contains static
119 libraries.
120
121 %package ada
122 Summary:        Ada support for gcc
123 Summary(pl):    Obs³uga Ady do gcc
124 Group:          Development/Languages
125 Requires:       %{name} = %{epoch}:%{version}-%{release}
126 Requires:       libgnat = %{epoch}:%{version}-%{release}
127 Obsoletes:      gcc-gnat
128 Obsoletes:      gnat-devel
129
130 %description ada
131 This package adds experimental support for compiling Ada programs.
132
133 %description ada -l pl
134 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów w
135 Adzie.
136
137 %package -n libgnat
138 Summary:        Ada standard libraries
139 Summary(pl):    Biblioteki standardowe dla Ady
140 Group:          Development/Libraries
141 Obsoletes:      gnat
142 Obsoletes:      libgnat1
143
144 %description -n libgnat
145 This package contains shared libraries needed to run programs written
146 in Ada.
147
148 %description -n libgnat -l pl
149 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów
150 napisanych w Adzie.
151
152 %package -n libgnat-static
153 Summary:        Static Ada standard libraries
154 Summary(pl):    Statyczne biblioteki standardowe dla Ady
155 Group:          Development/Libraries
156 Obsoletes:      gnat-static
157
158 %description -n libgnat-static
159 This package contains static libraries for programs written in Ada.
160
161 %description -n libgnat-static -l pl
162 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
163 Adzie.
164
165 %package c++
166 Summary:        C++ support for gcc
167 Summary(pl):    Obs³uga C++ dla gcc
168 Group:          Development/Languages
169 Requires:       %{name} = %{epoch}:%{version}-%{release}
170 Obsoletes:      egcc-c++
171 Obsoletes:      egcs-c++
172
173 %description c++
174 This package adds C++ support to the GNU Compiler Collection. It
175 includes support for most of the current C++ specification, including
176 templates and exception handling. It does not include a standard C++
177 library, which is available separately.
178
179 %description c++ -l pl
180 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
181 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
182 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
183
184 %package -n libstdc++
185 Summary:        GNU C++ library
186 Summary(pl):    Biblioteki GNU C++
187 Group:          Libraries
188 Obsoletes:      libg++
189 Obsoletes:      libstdc++3
190
191 %description -n libstdc++
192 This is the GNU implementation of the standard C++ libraries, along
193 with additional GNU tools. This package includes the shared libraries
194 necessary to run C++ applications.
195
196 %description -n libstdc++ -l pl
197 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
198 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
199 uruchomienia aplikacji napisanych w C++.
200
201 %package -n libstdc++-devel
202 Summary:        Header files and documentation for C++ development
203 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
204 Group:          Development/Libraries
205 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
206 Requires:       glibc-devel
207 Requires:       libstdc++ = %{epoch}:%{version}-%{release}
208 Obsoletes:      libg++-devel
209 Obsoletes:      libstdc++3-devel
210
211 %description -n libstdc++-devel
212 This is the GNU implementation of the standard C++ libraries. This
213 package includes the header files needed for C++ development and
214 library documentation.
215
216 %description -n libstdc++-devel -l pl
217 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
218 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
219 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
220
221 %package -n libstdc++-static
222 Summary:        Static C++ standard library
223 Summary(pl):    Statyczna biblioteka standardowa C++
224 Group:          Development/Libraries
225 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
226
227 %description -n libstdc++-static
228 Static C++ standard library.
229
230 %description -n libstdc++-static -l pl
231 Statyczna biblioteka standardowa C++.
232
233 %package fortran
234 Summary:        Fortran 95 support for gcc
235 Summary(pl):    Obs³uga Fortranu 95 dla gcc
236 Group:          Development/Languages/Fortran
237 Requires:       libgfortran = %{epoch}:%{version}-%{release}
238 Obsoletes:      egcs-g77
239 Obsoletes:      gcc-g77
240
241 %description fortran
242 This package adds support for compiling Fortran 95 programs with the
243 GNU compiler.
244
245 %description fortran -l pl
246 Ten pakiet dodaje obs³ugê Fortranu 95 do kompilatora gcc. Jest
247 potrzebny do kompilowania programów pisanych w jêzyku Fortran 95.
248
249 %package -n libgfortran
250 Summary:        Fortran 95 Libraries
251 Summary(pl):    Biblioteki Fortranu 95
252 Group:          Development/Libraries
253 Obsoletes:      libg2c
254
255 %description -n libgfortran
256 Fortran 95 Libraries.
257
258 %description -n libgfortran -l pl
259 Biblioteki Fortranu 95.
260
261 %package -n libgfortran-static
262 Summary:        Static Fortran 95 Libraries
263 Summary(pl):    Statyczne Biblioteki Fortranu 95
264 Group:          Development/Libraries
265 Requires:       libgfortran = %{epoch}:%{version}-%{release}
266 Obsoletes:      libg2c-static
267
268 %description -n libgfortran-static
269 Static Fortran 95 Libraries.
270
271 %description -n libgfortran-static -l pl
272 Statyczne biblioteki Fortranu 95.
273
274 %package java
275 Summary:        Java support for gcc
276 Summary(pl):    Obs³uga Javy dla gcc
277 Group:          Development/Languages/Java
278 Requires:       %{name} = %{epoch}:%{version}-%{release}
279 Requires:       libgcj = %{epoch}:%{version}-%{release}
280 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
281 Requires:       java-shared
282 Provides:       gcj = %{epoch}:%{version}-%{release}
283
284 %description java
285 This package adds experimental support for compiling Java(tm) programs
286 and bytecode into native code. To use this you will also need the
287 libgcj package.
288
289 %description java -l pl
290 Wsparcie dla kompilowania programów Java(tm) zarówno do bajt-kodu jak
291 i do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
292 by³o przeprowadziæ kompilacjê.
293
294 %package -n libgcj
295 Summary:        Java Class Libraries
296 Summary(pl):    Biblioteki Klas Javy
297 Group:          Libraries
298 Requires:       zlib
299 Obsoletes:      libgcj3
300
301 %description -n libgcj
302 Java Class Libraries.
303
304 %description -n libgcj -l pl
305 Biblioteki Klas Javy.
306
307 %package -n libgcj-devel
308 Summary:        Development files for Java Class Libraries
309 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
310 Group:          Development/Libraries
311 Requires:       libgcj = %{epoch}:%{version}-%{release}
312 Obsoletes:      libgcj3-devel
313
314 %description -n libgcj-devel
315 Development files for Java Class Libraries.
316
317 %description -n libgcj-devel -l pl
318 Pliki nag³ówkowe dla Bibliotek Klas Javy.
319
320 %package -n libgcj-static
321 Summary:        Static Java Class Libraries
322 Summary(pl):    Statyczne Biblioteki Klas Javy
323 Group:          Development/Libraries
324 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
325 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
326
327 %description -n libgcj-static
328 Static Java Class Libraries.
329
330 %description -n libgcj-static -l pl
331 Statyczne Biblioteki Klas Javy.
332
333 %package -n libffi
334 Summary:        Foreign Function Interface library
335 Summary(pl):    Biblioteka zewnêtrznych wywo³añ funkcji
336 Group:          Libraries
337
338 %description -n libffi
339 The libffi library provides a portable, high level programming
340 interface to various calling conventions. This allows a programmer to
341 call any function specified by a call interface description at run
342 time.
343
344 %description -n libffi -l pl
345 Biblioteka libffi dostarcza przeno¶nego, wysokopoziomowego
346 miêdzymordzia do ró¿nych konwencji wywo³añ funkcji. Pozwala to
347 programi¶cie wywo³ywaæ dowolne funkcje podaj±c konwencjê wywo³ania w
348 czasie wykonania.
349
350 %package -n libffi-devel
351 Summary:        Development files for Foreign Function Interface library
352 Summary(pl):    Pliki nag³ówkowe dla libffi
353 Group:          Development/Libraries
354 Requires:       libffi = %{epoch}:%{version}-%{release}
355
356 %description -n libffi-devel
357 Development files for Foreign Function Interface library.
358
359 %description -n libffi-devel -l pl
360 Pliki nag³ówkowe dla libffi.
361
362 %package -n libffi-static
363 Summary:        Static Foreign Function Interface library
364 Summary(pl):    Statyczna biblioteka libffi
365 Group:          Development/Libraries
366 Requires:       libffi-devel = %{epoch}:%{version}-%{release}
367
368 %description -n libffi-static
369 Static Foreign Function Interface library.
370
371 %description -n libffi-static -l pl
372 Statyczna biblioteka libffi.
373
374 %package java-tools
375 Summary:        Shared java tools
376 Summary(pl):    Wspó³dzielone narzêdzia javy
377 Group:          Development/Languages/Java
378 Provides:       jar = %{epoch}:%{version}-%{release}
379 Provides:       java-shared
380 Obsoletes:      fastjar
381 Obsoletes:      java-shared
382 Obsoletes:      jar
383
384 %description java-tools
385 This package contains tools that are common for every Java(tm)
386 implementation, such as rmic or jar.
387
388 %description java-tools -l pl
389 Pakiet ten zawiera narzêdzia wspólne dla ka¿dej implementacji
390 Javy(tm), takie jak rmic czy jar.
391
392 %package objc
393 Summary:        Objective C support for gcc
394 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
395 Group:          Development/Languages
396 Requires:       %{name} = %{epoch}:%{version}-%{release}
397 Requires:       libobjc = %{epoch}:%{version}-%{release}
398 Obsoletes:      egcc-objc
399 Obsoletes:      egcs-objc
400
401 %description objc
402 This package adds Objective C support to the GNU Compiler Collection.
403 Objective C is a object oriented derivative of the C language, mainly
404 used on systems running NeXTSTEP. This package does not include the
405 standard objective C object library.
406
407 %description objc -l pl
408 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
409 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
410 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
411 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
412
413 %package -n libobjc
414 Summary:        Objective C Libraries
415 Summary(pl):    Biblioteki Obiektowego C
416 Group:          Libraries
417 Obsoletes:      libobjc1
418
419 %description -n libobjc
420 Objective C Libraries.
421
422 %description -n libobjc -l pl
423 Biblioteki Obiektowego C.
424
425 %package -n libobjc-static
426 Summary:        Static Objective C Libraries
427 Summary(pl):    Statyczne Biblioteki Obiektowego C
428 Group:          Development/Libraries
429 Requires:       libobjc = %{epoch}:%{version}-%{release}
430
431 %description -n libobjc-static
432 Static Objective C Libraries.
433
434 %description -n libobjc-static -l pl
435 Statyczne biblioteki Obiektowego C.
436
437 %prep
438 # prerelease
439 #setup -q -n gcc-%{version}-%{_snap}
440 # snapshot
441 %setup -q -n gcc-4.0-%{_snap}
442 # final
443 #setup -q -n gcc-%{version}
444
445 %patch0 -p1
446 %patch1 -p1
447 %{!?debug:%patch2 -p1}
448 %patch3 -p1
449 %patch4 -p1
450
451 # because we distribute modified version of gcc...
452 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
453 perl -pi -e 's@(bug_report_url.*<URL:).*";@$1http://bugs.pld-linux.org/>";@' gcc/version.c
454
455 mv ChangeLog ChangeLog.general
456
457 %build
458 cd gcc
459 %{__autoconf}
460 cd ..
461 cp -f /usr/share/automake/config.sub .
462
463 rm -rf obj-%{_target_platform}
464 install -d obj-%{_target_platform}
465 cd obj-%{_target_platform}
466
467 CFLAGS="%{rpmcflags}" \
468 CXXFLAGS="%{rpmcflags}" \
469 TEXCONFIG=false \
470 ../configure \
471         --prefix=%{_prefix} \
472         --libdir=%{_libdir} \
473         --libexecdir=%{_libexecdir} \
474         --infodir=%{_infodir} \
475         --mandir=%{_mandir} \
476         --enable-shared \
477         --enable-threads=posix \
478         --enable-__cxa_atexit \
479         --enable-languages="c,c++%{?with_fortran:,f95}%{?with_objc:,objc}%{?with_ada:,ada}%{?with_java:,java}" \
480         --enable-c99 \
481         --enable-long-long \
482 %ifarch amd64
483         --disable-multilib \
484 %else
485         --enable-multilib \
486 %endif
487         --enable-nls \
488         --with-gnu-as \
489         --with-gnu-ld \
490         --with-system-zlib \
491         --with-slibdir=%{_slibdir} \
492         --without-x \
493         --enable-cmath \
494         %{_target_platform}
495
496 cd ..
497
498 %{__make} -C obj-%{_target_platform} \
499         profiledbootstrap \
500         GCJFLAGS="%{rpmcflags}" \
501         BOOT_CFLAGS="%{rpmcflags}" \
502         STAGE1_CFLAGS="%{rpmcflags}" \
503         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
504         mandir=%{_mandir} \
505         infodir=%{_infodir}
506
507 %install
508 rm -rf $RPM_BUILD_ROOT
509 install -d $RPM_BUILD_ROOT{/lib,%{_aclocaldir},%{_datadir},%{_infodir}}
510
511 cd obj-%{_target_platform}
512
513 %{__make} -j1 install \
514         mandir=%{_mandir} \
515         infodir=%{_infodir} \
516         DESTDIR=$RPM_BUILD_ROOT
517
518 install gcc/specs $RPM_BUILD_ROOT%{_libdir}/gcc/%{_target_platform}/%{version}
519
520 %ifarch sparc64
521 ln -sf  $RPM_BUILD_ROOT%{_bindir}/sparc64-pld-linux-gcc \
522         $RPM_BUILD_ROOT%{_bindir}/sparc-pld-linux-gcc
523 %endif
524
525 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
526 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
527
528 %if %{with fortran}
529 ln -sf gfortran $RPM_BUILD_ROOT%{_bindir}/g95
530 echo ".so gfortran.1" > $RPM_BUILD_ROOT%{_mandir}/man1/g95.1
531 %endif
532
533 %if %{with ada}
534 # move ada shared libraries to proper place...
535 mv -f   $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/adalib/*.so.1 \
536         $RPM_BUILD_ROOT%{_libdir}
537 # check if symlink to be made is valid
538 test -f $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so.1
539 ln -sf  libgnat-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so
540 ln -sf  libgnarl-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnarl-4.0.so
541 ln -sf  libgnat-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnat.so
542 ln -sf  libgnarl-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnarl.so
543 ln -sf  %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
544 %endif
545
546 cd ..
547
548 %if %{with java}
549 install -d java-doc
550 cp -f   libjava/READ* java-doc
551 cp -f   fastjar/README java-doc/README.fastjar
552 cp -f   libffi/README java-doc/README.libffi
553 cp -f   libffi/LICENSE java-doc/LICENSE.libffi
554 %endif
555 %if %{with objc}
556 cp -f   libobjc/README gcc/objc/README.libobjc
557 %endif
558
559 # avoid -L poisoning in *.la - there should be only -L%{_libdir}/gcc/*/%{version}
560 for f in libstdc++.la libsupc++.la %{?with_java:libgcj.la};
561 do
562         perl -pi -e 's@-L[^ ]*[acs.] @@g' $RPM_BUILD_ROOT%{_libdir}/$f
563 done
564 # normalize libdir, to avoid propagation of unnecessary RPATHs by libtool
565 for f in libstdc++.la libsupc++.la \
566         %{?with_fortran:libgfortran.la libgfortranbegin.la} \
567         %{?with_java:libgcj.la lib-org-w3c-dom.la lib-org-xml-sax.la libffi.la} \
568         %{?with_objc:libobjc.la};
569 do
570         perl -pi -e "s@^libdir='.*@libdir='/usr/%{_lib}'@" $RPM_BUILD_ROOT%{_libdir}/$f
571 done
572
573 # include/ contains install-tools/include/* and headers that were fixed up
574 # by fixincludes, we don't want former
575 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
576 mkdir   $gccdir/tmp
577 # we have to save these however
578 %{?with_java:mv -f $gccdir/include/{gcj,libffi/ffitarget.h} $gccdir/tmp}
579 %{?with_objc:mv -f $gccdir/include/objc $gccdir/tmp}
580 mv -f   $gccdir/include/syslimits.h $gccdir/tmp
581 rm -rf  $gccdir/include
582  mv -f  $gccdir/tmp $gccdir/include
583 cp -f   $gccdir/install-tools/include/*.h $gccdir/include
584 # but we don't want anything more from install-tools
585 rm -rf  $gccdir/install-tools
586
587 %find_lang gcc
588 %find_lang libstdc\+\+
589
590 %clean
591 rm -rf $RPM_BUILD_ROOT
592
593 %post
594 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
595
596 %postun
597 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
598
599 %post ada
600 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
601
602 %postun ada
603 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
604
605 %post fortran
606 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
607
608 %postun fortran
609 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
610
611 %post java
612 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
613
614 %postun java
615 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
616
617 %post   -p /sbin/ldconfig -n libgcc
618 %postun -p /sbin/ldconfig -n libgcc
619 %post   -p /sbin/ldconfig -n libmudflap
620 %postun -p /sbin/ldconfig -n libmudflap
621 %post   -p /sbin/ldconfig -n libgnat
622 %postun -p /sbin/ldconfig -n libgnat
623 %post   -p /sbin/ldconfig -n libstdc++
624 %postun -p /sbin/ldconfig -n libstdc++
625 %post   -p /sbin/ldconfig -n libgfortran
626 %postun -p /sbin/ldconfig -n libgfortran
627 %post   -p /sbin/ldconfig -n libgcj
628 %postun -p /sbin/ldconfig -n libgcj
629 %post   -p /sbin/ldconfig -n libffi
630 %postun -p /sbin/ldconfig -n libffi
631 %post   -p /sbin/ldconfig -n libobjc
632 %postun -p /sbin/ldconfig -n libobjc
633
634 %files -f gcc.lang
635 %defattr(644,root,root,755)
636 %doc ChangeLog.general MAINTAINERS bugs.html faq.html
637 %doc gcc/{ChangeLog,ONEWS,README.Portability}
638 %dir %{_libdir}/gcc
639 %dir %{_libdir}/gcc/*
640 %dir %{_libdir}/gcc/*/*
641 %dir %{_libdir}/gcc/*/*/include
642
643 %attr(755,root,root) %{_bindir}/*-gcc*
644 %attr(755,root,root) %{_bindir}/gcc
645 %attr(755,root,root) %{_bindir}/gccbug
646 %attr(755,root,root) %{_bindir}/gcov
647 %attr(755,root,root) %{_bindir}/cc
648 %attr(755,root,root) %{_bindir}/cpp
649
650 %{_mandir}/man1/cc.1*
651 %{_mandir}/man1/cpp.1*
652 %{_mandir}/man1/gcc.1*
653 %{_mandir}/man1/gcov.1*
654
655 %{_infodir}/cpp*
656 %{_infodir}/gcc*
657
658 %attr(755,root,root) /lib/cpp
659
660 %attr(755,root,root) %{_slibdir}/lib*.so
661 %{_libdir}/gcc/*/*/libgcov.a
662 %{_libdir}/gcc/*/*/libgcc.a
663 %{_libdir}/gcc/*/*/libgcc_eh.a
664 %{_libdir}/gcc/*/*/specs
665 %attr(644,root,root) %{_libdir}/gcc/*/*/crt*.o
666 %ifarch sparc64
667 %{_libdir}/gcc/*/*/*/libgcc.a
668 %{_libdir}/gcc/*/*/*/libgcc_eh.a
669 %attr(644,root,root) %{_libdir}/gcc/*/*/*/crt*.o
670 %endif
671 %ifarch ppc
672 %attr(644,root,root) %{_libdir}/gcc/*/*/ecrt*.o
673 %attr(644,root,root) %{_libdir}/gcc/*/*/ncrt*.o
674 %{_libdir}/gcc/*/*/nof
675 %dir %{_libdir}/nof
676 %endif
677 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1
678 %attr(755,root,root) %{_libdir}/gcc/*/*/collect2
679
680 %{_libdir}/gcc/*/*/include/*.h
681
682 %files -n libgcc
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_slibdir}/lib*.so.*
685
686 %files -n libmudflap
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/libmudflap*.so.*.*.*
689
690 %files -n libmudflap-devel
691 %defattr(644,root,root,755)
692 %{_includedir}/mf-runtime.h
693 %{_libdir}/libmudflap*.la
694 %attr(755,root,root) %{_libdir}/libmudflap*.so
695
696 %files -n libmudflap-static
697 %defattr(644,root,root,755)
698 %{_libdir}/libmudflap*.a
699
700 %if %{with ada}
701 %files ada
702 %defattr(644,root,root,755)
703 %doc gcc/ada/ChangeLog
704 %attr(755,root,root) %{_bindir}/gnat*
705 %attr(755,root,root) %{_bindir}/gpr*
706 %attr(755,root,root) %{_libdir}/libgnarl*.so
707 %attr(755,root,root) %{_libdir}/libgnat*.so
708 %attr(755,root,root) %{_libdir}/gcc/*/*/gnat1
709 %{_libdir}/gcc/*/*/adainclude
710 %dir %{_libdir}/gcc/*/*/adalib
711 %{_libdir}/gcc/*/*/adalib/*.ali
712 %{_libdir}/gcc/*/*/adalib/g-trasym.o
713 %{_libdir}/gcc/*/*/adalib/libgccprefix.a
714 %ifarch %{ix86}
715 %{_libdir}/gcc/*/*/adalib/libgmem.a
716 %endif
717 %{_datadir}/gnat
718 %{_infodir}/gnat*
719
720 %files -n libgnat
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/libgnarl*.so.1
723 %attr(755,root,root) %{_libdir}/libgnat*.so.1
724
725 %files -n libgnat-static
726 %defattr(644,root,root,755)
727 %{_libdir}/gcc/*/*/adalib/libgnarl.a
728 %{_libdir}/gcc/*/*/adalib/libgnat.a
729 %endif
730
731 %files c++
732 %defattr(644,root,root,755)
733 %doc gcc/cp/{ChangeLog,NEWS}
734 %attr(755,root,root) %{_bindir}/g++
735 %attr(755,root,root) %{_bindir}/*-g++
736 %attr(755,root,root) %{_bindir}/c++
737 %attr(755,root,root) %{_bindir}/*-c++
738 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1plus
739 %{_libdir}/libsupc++.a
740 %{_libdir}/libsupc++.la
741 %{_mandir}/man1/g++.1*
742
743 %files -n libstdc++ -f libstdc++.lang
744 %defattr(644,root,root,755)
745 %doc libstdc++-v3/{ChangeLog,README}
746 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
747
748 %files -n libstdc++-devel
749 %defattr(644,root,root,755)
750 %doc libstdc++-v3/docs/html
751 %dir %{_includedir}/c++
752 %{_includedir}/c++/%{version}
753 %if %{with java}
754 %exclude %{_includedir}/c++/%{version}/java
755 %exclude %{_includedir}/c++/%{version}/javax
756 %exclude %{_includedir}/c++/%{version}/gcj
757 %exclude %{_includedir}/c++/%{version}/gnu
758 %endif
759 %exclude %{_includedir}/c++/%{version}/*/bits/stdc++.h.gch
760 %{_libdir}/libstdc++.la
761 %attr(755,root,root) %{_libdir}/libstdc++.so
762
763 %files -n libstdc++-static
764 %defattr(644,root,root,755)
765 %{_libdir}/libstdc++.a
766
767 %if %{with fortran}
768 %files fortran
769 %defattr(644,root,root,755)
770 %doc gcc/fortran/ChangeLog
771 %attr(755,root,root) %{_bindir}/g95
772 %attr(755,root,root) %{_bindir}/gfortran
773 %{_infodir}/gfortran*
774 %attr(755,root,root) %{_libdir}/gcc/*/*/f951
775 %{_libdir}/libgfortranbegin.a
776 %{_libdir}/libgfortranbegin.la
777 %{_libdir}/libgfortran.la
778 %attr(755,root,root) %{_libdir}/libgfortran.so
779 %{_mandir}/man1/g95.1*
780 %{_mandir}/man1/gfortran.1*
781
782 %files -n libgfortran
783 %defattr(644,root,root,755)
784 %doc libgfortran/{AUTHORS,README,ChangeLog}
785 %attr(755,root,root) %{_libdir}/libgfortran.so.*.*.*
786
787 %files -n libgfortran-static
788 %defattr(644,root,root,755)
789 %{_libdir}/libgfortran.a
790 %endif
791
792 %if %{with java}
793 %files java
794 %defattr(644,root,root,755)
795 %doc gcc/java/ChangeLog java-doc/*
796 %attr(755,root,root) %{_bindir}/gcj*
797 %attr(755,root,root) %{_bindir}/gij
798 %attr(755,root,root) %{_bindir}/grepjar
799 %attr(755,root,root) %{_bindir}/jcf-dump
800 %attr(755,root,root) %{_bindir}/jv-*
801 %attr(755,root,root) %{_bindir}/*-gcj*
802 %attr(755,root,root) %{_libdir}/gcc/*/*/jc1
803 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
804 %{_infodir}/gcj*
805 %{_mandir}/man1/gcj*
806 %{_mandir}/man1/gij*
807 %{_mandir}/man1/grepjar*
808 %{_mandir}/man1/jcf-*
809 %{_mandir}/man1/jv-*
810
811 %files java-tools
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_bindir}/grmi*
814 %attr(755,root,root) %{_bindir}/fastjar
815 %{_mandir}/man1/grmi*
816 %{_mandir}/man1/fastjar*
817 %{_infodir}/fastjar*
818
819 %files -n libgcj
820 %defattr(644,root,root,755)
821 %doc libjava/{ChangeLog,LIBGCJ_LICENSE,NEWS,README,THANKS}
822 %attr(755,root,root) %{_bindir}/addr2name.awk
823 %attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
824 %attr(755,root,root) %{_libdir}/libgij.so.*.*.*
825 %attr(755,root,root) %{_libdir}/lib-org*.so.*.*.*
826 %{_libdir}/logging.properties
827
828 %files -n libgcj-devel
829 %defattr(644,root,root,755)
830 %{_includedir}/c++/%{version}/java
831 %{_includedir}/c++/%{version}/javax
832 %{_includedir}/c++/%{version}/gcj
833 %{_includedir}/c++/%{version}/gnu
834 %{_libdir}/gcc/*/*/include/gcj
835 %dir %{_libdir}/security
836 %{_libdir}/security/*
837 %dir %{_datadir}/java
838 %{_datadir}/java/libgcj*.jar
839 %{_libdir}/lib*cj.spec
840 %{_libdir}/lib*cj*.la
841 %attr(755,root,root) %{_libdir}/lib*cj*.so
842 %{_libdir}/libgij.la
843 %attr(755,root,root) %{_libdir}/libgij.so
844 %attr(755,root,root) %{_libdir}/lib-org-*.so
845 %{_libdir}/lib-org-*.la
846 %{_pkgconfigdir}/libgcj.pc
847
848 %files -n libgcj-static
849 %defattr(644,root,root,755)
850 %{_libdir}/lib*cj*.a
851 %{_libdir}/libgij.a
852 %{_libdir}/lib-org-*.a
853
854 %files -n libffi
855 %defattr(644,root,root,755)
856 %doc libffi/{ChangeLog,ChangeLog.libgcj,LICENSE,README}
857 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
858
859 %files -n libffi-devel
860 %defattr(644,root,root,755)
861 %{_libdir}/gcc/*/*/include/ffitarget.h
862 %attr(755,root,root) %{_libdir}/libffi.so
863 %{_libdir}/libffi.la
864 %{_includedir}/ffi.h
865
866 %files -n libffi-static
867 %defattr(644,root,root,755)
868 %{_libdir}/libffi.a
869 %endif
870
871 %if %{with objc}
872 %files objc
873 %defattr(644,root,root,755)
874 %doc gcc/objc/README
875 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1obj
876 %attr(755,root,root) %{_libdir}/libobjc.so
877 %{_libdir}/libobjc.la
878 %{_libdir}/gcc/*/*/include/objc
879
880 %files -n libobjc
881 %defattr(644,root,root,755)
882 %doc libobjc/{ChangeLog,README*}
883 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
884
885 %files -n libobjc-static
886 %defattr(644,root,root,755)
887 %{_libdir}/libobjc.a
888 %endif
This page took 0.117769 seconds and 4 git commands to generate.