]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- ada link patch updated.
[packages/gcc4.git] / gcc4.spec
1 #
2 # Conditional build:
3 %bcond_without  ada             # build without ADA support
4 %bcond_without  fortran         # build without Fortran support
5 %bcond_without  java            # build without Java support
6 %bcond_without  objc            # build without ObjC support
7
8 %bcond_with     bootstrap
9
10 %if %{with bootstrap}
11 %undefine       with_fortran
12 %undefine       with_java
13 %undefine       with_objc
14 %endif
15
16 #
17 # TODO:
18 #               - http://gcc.gnu.org/PR11203 (inline-asm)
19 #               - http://gcc.gnu.org/PR18648 (missed tree-optimization)
20 #               - disable internal zlib usage
21 #               - translations from gcc.spec:HEAD
22 #
23 %define         _snap           20050130
24 #
25 Summary:        GNU Compiler Collection: the C compiler and shared files
26 Summary(pl):    Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
27 Name:           gcc
28 Epoch:          5
29 Version:        4.0.0
30 Release:        0.%{_snap}.4
31 License:        GPL
32 Group:          Development/Languages
33 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
34 #Source0:       ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
35 #Source0:       ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/%{name}-4.0-%{_snap}.tar.bz2
36 Source0:        http://pld-nptl.ds14.agh.edu.pl/gcc-4.0-%{_snap}.tar.bz2
37 # Source0-md5:  5040ba840d0367c378f73c739418b3e2
38 Patch0:         %{name}-info.patch
39 Patch1:         %{name}-nolocalefiles.patch
40 Patch2:         %{name}-nodebug.patch
41 Patch3:         %{name}-ada-link-new-libgnat.patch
42 Patch4:         %{name}-ada-link.patch
43 URL:            http://gcc.gnu.org/
44 BuildRequires:  autoconf
45 BuildRequires:  automake
46 BuildRequires:  binutils >= 2:2.15.94.0.1
47 BuildRequires:  bison
48 BuildRequires:  fileutils >= 4.0.41
49 BuildRequires:  flex
50 %if %{with ada}
51 BuildRequires:  gcc(ada)
52 BuildRequires:  gcc-ada
53 %endif
54 BuildRequires:  gettext-devel
55 BuildRequires:  glibc-devel >= 2.2.5-20
56 BuildRequires:  gmp-devel
57 BuildRequires:  libmpfr-devel
58 BuildRequires:  perl-devel
59 BuildRequires:  texinfo >= 4.1
60 BuildRequires:  zlib-devel
61 Requires:       binutils >= 2:2.15.94.0.1
62 Requires:       libgcc = %{epoch}:%{version}-%{release}
63 Provides:       cpp = %{epoch}:%{version}-%{release}
64 %{?with_ada:Provides:   gcc(ada)}
65 Obsoletes:      cpp
66 Obsoletes:      egcs-cpp
67 Obsoletes:      gcc-cpp
68 Obsoletes:      gcc-ksi
69 Obsoletes:      gont
70 Conflicts:      glibc-devel < 2.2.5-20
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %define         _slibdir        /%{_lib}
74
75 %description
76 A compiler aimed at integrating all the optimizations and features
77 necessary for a high-performance and stable development environment.
78
79 This package contains the C compiler and some files shared by various
80 parts of the GNU Compiler Collection. In order to use another GCC
81 compiler you will need to install the appropriate subpackage.
82
83 %description -l pl
84 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
85 wyprodukowania szybkiego i stabilnego kodu wynikowego.
86
87 Ten pakiet zawiera kompilator C i pliki wspó³dzielone przez ró¿ne
88 czê¶ci kolekcji kompilatorów GNU (GCC). ¯eby u¿ywaæ innego kompilatora
89 z GCC, trzeba zainstalowaæ odpowiedni podpakiet.
90
91 %package -n libgcc
92 Summary:        Shared gcc library
93 Summary(pl):    Biblioteka gcc
94 Group:          Libraries
95 Obsoletes:      libgcc1
96
97 %description -n libgcc
98 Shared gcc library.
99
100 %description -n libgcc -l pl
101 Biblioteka dynamiczna gcc.
102
103 %package -n libmudflap
104 Summary:        GCC mudflap shared support library
105 Group:          Libraries
106
107 %description -n libmudflap
108 The libmudflap libraries are used by GCC for instrumenting pointer and
109 array dereferencing operations.
110
111 %package -n libmudflap-devel
112 Summary:        Development files for GCC mudflap library
113 Group:          Development/Libraries
114 Requires:       libmudflap = %{epoch}:%{version}-%{release}
115
116 %description -n libmudflap-devel
117 The libmudflap libraries are used by GCC for instrumenting pointer and
118 array dereferencing operations. This package contains development
119 files.
120
121 %package -n libmudflap-static
122 Summary:        Static GCC mudflap library
123 Group:          Development/Libraries
124 Requires:       libmudflap-devel = %{epoch}:%{version}-%{release}
125
126 %description -n libmudflap-static
127 The libmudflap libraries are used by GCC for instrumenting pointer and
128 array dereferencing operations. This package contains static
129 libraries.
130
131 %package ada
132 Summary:        Ada support for gcc
133 Summary(pl):    Obs³uga Ady do gcc
134 Group:          Development/Languages
135 Requires:       %{name} = %{epoch}:%{version}-%{release}
136 Requires:       libgnat = %{epoch}:%{version}-%{release}
137 Obsoletes:      gcc-gnat
138 Obsoletes:      gnat-devel
139
140 %description ada
141 This package adds experimental support for compiling Ada programs.
142
143 %description ada -l pl
144 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów w
145 Adzie.
146
147 %package -n libgnat
148 Summary:        Ada standard libraries
149 Summary(pl):    Biblioteki standardowe dla Ady
150 Group:          Development/Libraries
151 Obsoletes:      gnat
152 Obsoletes:      libgnat1
153
154 %description -n libgnat
155 This package contains shared libraries needed to run programs written
156 in Ada.
157
158 %description -n libgnat -l pl
159 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów
160 napisanych w Adzie.
161
162 %package -n libgnat-static
163 Summary:        Static Ada standard libraries
164 Summary(pl):    Statyczne biblioteki standardowe dla Ady
165 Group:          Development/Libraries
166 Obsoletes:      gnat-static
167
168 %description -n libgnat-static
169 This package contains static libraries for programs written in Ada.
170
171 %description -n libgnat-static -l pl
172 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
173 Adzie.
174
175 %package c++
176 Summary:        C++ support for gcc
177 Summary(pl):    Obs³uga C++ dla gcc
178 Group:          Development/Languages
179 Requires:       %{name} = %{epoch}:%{version}-%{release}
180 Obsoletes:      egcc-c++
181 Obsoletes:      egcs-c++
182
183 %description c++
184 This package adds C++ support to the GNU Compiler Collection. It
185 includes support for most of the current C++ specification, including
186 templates and exception handling. It does not include a standard C++
187 library, which is available separately.
188
189 %description c++ -l pl
190 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
191 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
192 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
193
194 %package -n libstdc++
195 Summary:        GNU C++ library
196 Summary(pl):    Biblioteki GNU C++
197 Group:          Libraries
198 Obsoletes:      libg++
199 Obsoletes:      libstdc++3
200
201 %description -n libstdc++
202 This is the GNU implementation of the standard C++ libraries, along
203 with additional GNU tools. This package includes the shared libraries
204 necessary to run C++ applications.
205
206 %description -n libstdc++ -l pl
207 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
208 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
209 uruchomienia aplikacji napisanych w C++.
210
211 %package -n libstdc++-devel
212 Summary:        Header files and documentation for C++ development
213 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
214 Group:          Development/Libraries
215 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
216 Requires:       glibc-devel
217 Requires:       libstdc++ = %{epoch}:%{version}-%{release}
218 Obsoletes:      libg++-devel
219 Obsoletes:      libstdc++3-devel
220
221 %description -n libstdc++-devel
222 This is the GNU implementation of the standard C++ libraries. This
223 package includes the header files needed for C++ development and
224 library documentation.
225
226 %description -n libstdc++-devel -l pl
227 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
228 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
229 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
230
231 %package -n libstdc++-static
232 Summary:        Static C++ standard library
233 Summary(pl):    Statyczna biblioteka standardowa C++
234 Group:          Development/Libraries
235 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
236
237 %description -n libstdc++-static
238 Static C++ standard library.
239
240 %description -n libstdc++-static -l pl
241 Statyczna biblioteka standardowa C++.
242
243 %package fortran
244 Summary:        Fortran 95 support for gcc
245 Summary(pl):    Obs³uga Fortranu 95 dla gcc
246 Group:          Development/Languages/Fortran
247 Requires:       libgfortran = %{epoch}:%{version}-%{release}
248 Obsoletes:      egcs-g77
249 Obsoletes:      gcc-g77
250
251 %description fortran
252 This package adds support for compiling Fortran 95 programs with the
253 GNU compiler.
254
255 %description fortran -l pl
256 Ten pakiet dodaje obs³ugê Fortranu 95 do kompilatora gcc. Jest
257 potrzebny do kompilowania programów pisanych w jêzyku Fortran 95.
258
259 %package -n libgfortran
260 Summary:        Fortran 95 Libraries
261 Summary(pl):    Biblioteki Fortranu 95
262 Group:          Development/Libraries
263 Obsoletes:      libg2c
264
265 %description -n libgfortran
266 Fortran 95 Libraries.
267
268 %description -n libgfortran -l pl
269 Biblioteki Fortranu 95.
270
271 %package -n libgfortran-static
272 Summary:        Static Fortran 95 Libraries
273 Summary(pl):    Statyczne Biblioteki Fortranu 95
274 Group:          Development/Libraries
275 Requires:       libgfortran = %{epoch}:%{version}-%{release}
276 Obsoletes:      libg2c-static
277
278 %description -n libgfortran-static
279 Static Fortran 95 Libraries.
280
281 %description -n libgfortran-static -l pl
282 Statyczne biblioteki Fortranu 95.
283
284 %package java
285 Summary:        Java support for gcc
286 Summary(pl):    Obs³uga Javy dla gcc
287 Group:          Development/Languages/Java
288 Requires:       %{name} = %{epoch}:%{version}-%{release}
289 Requires:       libgcj = %{epoch}:%{version}-%{release}
290 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
291 Requires:       java-shared
292 Provides:       gcj = %{epoch}:%{version}-%{release}
293
294 %description java
295 This package adds experimental support for compiling Java(tm) programs
296 and bytecode into native code. To use this you will also need the
297 libgcj package.
298
299 %description java -l pl
300 Wsparcie dla kompilowania programów Java(tm) zarówno do bajt-kodu jak
301 i do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
302 by³o przeprowadziæ kompilacjê.
303
304 %package -n libgcj
305 Summary:        Java Class Libraries
306 Summary(pl):    Biblioteki Klas Javy
307 Group:          Libraries
308 Requires:       zlib
309 Obsoletes:      libgcj3
310
311 %description -n libgcj
312 Java Class Libraries.
313
314 %description -n libgcj -l pl
315 Biblioteki Klas Javy.
316
317 %package -n libgcj-devel
318 Summary:        Development files for Java Class Libraries
319 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
320 Group:          Development/Libraries
321 Requires:       libgcj = %{epoch}:%{version}-%{release}
322 Obsoletes:      libgcj3-devel
323
324 %description -n libgcj-devel
325 Development files for Java Class Libraries.
326
327 %description -n libgcj-devel -l pl
328 Pliki nag³ówkowe dla Bibliotek Klas Javy.
329
330 %package -n libgcj-static
331 Summary:        Static Java Class Libraries
332 Summary(pl):    Statyczne Biblioteki Klas Javy
333 Group:          Development/Libraries
334 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
335 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
336
337 %description -n libgcj-static
338 Static Java Class Libraries.
339
340 %description -n libgcj-static -l pl
341 Statyczne Biblioteki Klas Javy.
342
343 %package -n libffi
344 Summary:        Foreign Function Interface library
345 Summary(pl):    Biblioteka zewnêtrznych wywo³añ funkcji
346 Group:          Libraries
347
348 %description -n libffi
349 The libffi library provides a portable, high level programming
350 interface to various calling conventions. This allows a programmer to
351 call any function specified by a call interface description at run
352 time.
353
354 %description -n libffi -l pl
355 Biblioteka libffi dostarcza przeno¶nego, wysokopoziomowego
356 miêdzymordzia do ró¿nych konwencji wywo³añ funkcji. Pozwala to
357 programi¶cie wywo³ywaæ dowolne funkcje podaj±c konwencjê wywo³ania w
358 czasie wykonania.
359
360 %package -n libffi-devel
361 Summary:        Development files for Foreign Function Interface library
362 Summary(pl):    Pliki nag³ówkowe dla libffi
363 Group:          Development/Libraries
364 Requires:       libffi = %{epoch}:%{version}-%{release}
365
366 %description -n libffi-devel
367 Development files for Foreign Function Interface library.
368
369 %description -n libffi-devel -l pl
370 Pliki nag³ówkowe dla libffi.
371
372 %package -n libffi-static
373 Summary:        Static Foreign Function Interface library
374 Summary(pl):    Statyczna biblioteka libffi
375 Group:          Development/Libraries
376 Requires:       libffi-devel = %{epoch}:%{version}-%{release}
377
378 %description -n libffi-static
379 Static Foreign Function Interface library.
380
381 %description -n libffi-static -l pl
382 Statyczna biblioteka libffi.
383
384 %package java-tools
385 Summary:        Shared java tools
386 Summary(pl):    Wspó³dzielone narzêdzia javy
387 Group:          Development/Languages/Java
388 Provides:       jar = %{epoch}:%{version}-%{release}
389 Provides:       java-shared
390 Obsoletes:      fastjar
391 Obsoletes:      java-shared
392 Obsoletes:      jar
393
394 %description java-tools
395 This package contains tools that are common for every Java(tm)
396 implementation, such as rmic or jar.
397
398 %description java-tools -l pl
399 Pakiet ten zawiera narzêdzia wspólne dla ka¿dej implementacji
400 Javy(tm), takie jak rmic czy jar.
401
402 %package objc
403 Summary:        Objective C support for gcc
404 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
405 Group:          Development/Languages
406 Requires:       %{name} = %{epoch}:%{version}-%{release}
407 Requires:       libobjc = %{epoch}:%{version}-%{release}
408 Obsoletes:      egcc-objc
409 Obsoletes:      egcs-objc
410
411 %description objc
412 This package adds Objective C support to the GNU Compiler Collection.
413 Objective C is a object oriented derivative of the C language, mainly
414 used on systems running NeXTSTEP. This package does not include the
415 standard objective C object library.
416
417 %description objc -l pl
418 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
419 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
420 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
421 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
422
423 %package -n libobjc
424 Summary:        Objective C Libraries
425 Summary(pl):    Biblioteki Obiektowego C
426 Group:          Libraries
427 Obsoletes:      libobjc1
428
429 %description -n libobjc
430 Objective C Libraries.
431
432 %description -n libobjc -l pl
433 Biblioteki Obiektowego C.
434
435 %package -n libobjc-static
436 Summary:        Static Objective C Libraries
437 Summary(pl):    Statyczne Biblioteki Obiektowego C
438 Group:          Development/Libraries
439 Requires:       libobjc = %{epoch}:%{version}-%{release}
440
441 %description -n libobjc-static
442 Static Objective C Libraries.
443
444 %description -n libobjc-static -l pl
445 Statyczne biblioteki Obiektowego C.
446
447 %prep
448 # prerelease
449 #setup -q -n gcc-%{version}-%{_snap}
450 # snapshot
451 %setup -q -n gcc-4.0-%{_snap}
452 # final
453 #setup -q -n gcc-%{version}
454
455 %patch0 -p1
456 %patch1 -p1
457 %{!?debug:%patch2 -p1}
458 %patch3 -p1
459 %patch4 -p1
460
461 # because we distribute modified version of gcc...
462 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
463 perl -pi -e 's@(bug_report_url.*<URL:).*";@$1http://bugs.pld-linux.org/>";@' gcc/version.c
464
465 mv ChangeLog ChangeLog.general
466
467 %build
468 cd gcc
469 %{__autoconf}
470 cd ..
471 cp -f /usr/share/automake/config.sub .
472
473 rm -rf obj-%{_target_platform}
474 install -d obj-%{_target_platform}
475 cd obj-%{_target_platform}
476
477 CFLAGS="%{rpmcflags}" \
478 CXXFLAGS="%{rpmcflags}" \
479 TEXCONFIG=false \
480 ../configure \
481         --prefix=%{_prefix} \
482         --libdir=%{_libdir} \
483         --libexecdir=%{_libexecdir} \
484         --infodir=%{_infodir} \
485         --mandir=%{_mandir} \
486         --enable-shared \
487         --enable-threads=posix \
488         --enable-__cxa_atexit \
489         --enable-languages="c,c++%{?with_fortran:,f95}%{?with_objc:,objc}%{?with_ada:,ada}%{?with_java:,java}" \
490         --enable-c99 \
491         --enable-long-long \
492 %ifarch amd64
493         --disable-multilib \
494 %else
495         --enable-multilib \
496 %endif
497         --enable-nls \
498         --with-gnu-as \
499         --with-gnu-ld \
500         --with-system-zlib \
501         --with-slibdir=%{_slibdir} \
502         --without-x \
503         --enable-cmath \
504         %{_target_platform}
505
506 cd ..
507
508 %{__make} -C obj-%{_target_platform} \
509         %{!?with_bootstrap:profiledbootstrap} \
510         GCJFLAGS="%{rpmcflags}" \
511         BOOT_CFLAGS="%{rpmcflags}" \
512         STAGE1_CFLAGS="%{rpmcflags} -O0" \
513         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
514         mandir=%{_mandir} \
515         infodir=%{_infodir}
516
517 %install
518 rm -rf $RPM_BUILD_ROOT
519 install -d $RPM_BUILD_ROOT{/lib,%{_aclocaldir},%{_datadir},%{_infodir}}
520
521 cd obj-%{_target_platform}
522
523 %{__make} -j1 install \
524         mandir=%{_mandir} \
525         infodir=%{_infodir} \
526         DESTDIR=$RPM_BUILD_ROOT
527
528 install gcc/specs $RPM_BUILD_ROOT%{_libdir}/gcc/%{_target_platform}/%{version}
529
530 %ifarch sparc64
531 ln -sf  $RPM_BUILD_ROOT%{_bindir}/sparc64-pld-linux-gcc \
532         $RPM_BUILD_ROOT%{_bindir}/sparc-pld-linux-gcc
533 %endif
534
535 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
536 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
537
538 %if %{with fortran}
539 ln -sf gfortran $RPM_BUILD_ROOT%{_bindir}/g95
540 echo ".so gfortran.1" > $RPM_BUILD_ROOT%{_mandir}/man1/g95.1
541 %endif
542
543 %if %{with ada}
544 # move ada shared libraries to proper place...
545 mv -f   $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/adalib/*.so.1 \
546         $RPM_BUILD_ROOT%{_libdir}
547 # check if symlink to be made is valid
548 test -f $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so.1
549 ln -sf  libgnat-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so
550 ln -sf  libgnarl-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnarl-4.0.so
551 ln -sf  libgnat-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnat.so
552 ln -sf  libgnarl-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnarl.so
553 ln -sf  %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
554 %endif
555
556 cd ..
557
558 %if %{with java}
559 install -d java-doc
560 cp -f   libjava/READ* java-doc
561 cp -f   fastjar/README java-doc/README.fastjar
562 cp -f   libffi/README java-doc/README.libffi
563 cp -f   libffi/LICENSE java-doc/LICENSE.libffi
564 %endif
565 %if %{with objc}
566 cp -f   libobjc/README gcc/objc/README.libobjc
567 %endif
568
569 # avoid -L poisoning in *.la - there should be only -L%{_libdir}/gcc/*/%{version}
570 for f in libstdc++.la libsupc++.la %{?with_java:libgcj.la};
571 do
572         perl -pi -e 's@-L[^ ]*[acs.] @@g' $RPM_BUILD_ROOT%{_libdir}/$f
573 done
574 # normalize libdir, to avoid propagation of unnecessary RPATHs by libtool
575 for f in libstdc++.la libsupc++.la \
576         %{?with_fortran:libgfortran.la libgfortranbegin.la} \
577         %{?with_java:libgcj.la lib-org-w3c-dom.la lib-org-xml-sax.la libffi.la} \
578         %{?with_objc:libobjc.la};
579 do
580         perl -pi -e "s@^libdir='.*@libdir='/usr/%{_lib}'@" $RPM_BUILD_ROOT%{_libdir}/$f
581 done
582
583 # include/ contains install-tools/include/* and headers that were fixed up
584 # by fixincludes, we don't want former
585 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
586 mkdir   $gccdir/tmp
587 # we have to save these however
588 %{?with_java:mv -f $gccdir/include/{gcj,libffi/ffitarget.h} $gccdir/tmp}
589 %{?with_objc:mv -f $gccdir/include/objc $gccdir/tmp}
590 mv -f   $gccdir/include/syslimits.h $gccdir/tmp
591 rm -rf  $gccdir/include
592  mv -f  $gccdir/tmp $gccdir/include
593 cp -f   $gccdir/install-tools/include/*.h $gccdir/include
594 # but we don't want anything more from install-tools
595 rm -rf  $gccdir/install-tools
596
597 %find_lang gcc
598 %find_lang libstdc\+\+
599
600 %clean
601 rm -rf $RPM_BUILD_ROOT
602
603 %post
604 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
605
606 %postun
607 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
608
609 %post ada
610 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
611
612 %postun ada
613 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
614
615 %post fortran
616 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
617
618 %postun fortran
619 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
620
621 %post java
622 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
623
624 %postun java
625 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
626
627 %post   -p /sbin/ldconfig -n libgcc
628 %postun -p /sbin/ldconfig -n libgcc
629 %post   -p /sbin/ldconfig -n libmudflap
630 %postun -p /sbin/ldconfig -n libmudflap
631 %post   -p /sbin/ldconfig -n libgnat
632 %postun -p /sbin/ldconfig -n libgnat
633 %post   -p /sbin/ldconfig -n libstdc++
634 %postun -p /sbin/ldconfig -n libstdc++
635 %post   -p /sbin/ldconfig -n libgfortran
636 %postun -p /sbin/ldconfig -n libgfortran
637 %post   -p /sbin/ldconfig -n libgcj
638 %postun -p /sbin/ldconfig -n libgcj
639 %post   -p /sbin/ldconfig -n libffi
640 %postun -p /sbin/ldconfig -n libffi
641 %post   -p /sbin/ldconfig -n libobjc
642 %postun -p /sbin/ldconfig -n libobjc
643
644 %files -f gcc.lang
645 %defattr(644,root,root,755)
646 %doc ChangeLog.general MAINTAINERS bugs.html faq.html
647 %doc gcc/{ChangeLog,ONEWS,README.Portability}
648 %dir %{_libdir}/gcc
649 %dir %{_libdir}/gcc/*
650 %dir %{_libdir}/gcc/*/*
651 %dir %{_libdir}/gcc/*/*/include
652
653 %attr(755,root,root) %{_bindir}/*-gcc*
654 %attr(755,root,root) %{_bindir}/gcc
655 %attr(755,root,root) %{_bindir}/gccbug
656 %attr(755,root,root) %{_bindir}/gcov
657 %attr(755,root,root) %{_bindir}/cc
658 %attr(755,root,root) %{_bindir}/cpp
659
660 %{_mandir}/man1/cc.1*
661 %{_mandir}/man1/cpp.1*
662 %{_mandir}/man1/gcc.1*
663 %{_mandir}/man1/gcov.1*
664
665 %{_infodir}/cpp*
666 %{_infodir}/gcc*
667
668 %attr(755,root,root) /lib/cpp
669
670 %attr(755,root,root) %{_slibdir}/lib*.so
671 %{_libdir}/gcc/*/*/libgcov.a
672 %{_libdir}/gcc/*/*/libgcc.a
673 %{_libdir}/gcc/*/*/libgcc_eh.a
674 %{_libdir}/gcc/*/*/specs
675 %attr(644,root,root) %{_libdir}/gcc/*/*/crt*.o
676 %ifarch sparc64
677 %{_libdir}/gcc/*/*/*/libgcc.a
678 %{_libdir}/gcc/*/*/*/libgcc_eh.a
679 %attr(644,root,root) %{_libdir}/gcc/*/*/*/crt*.o
680 %endif
681 %ifarch ppc
682 %attr(644,root,root) %{_libdir}/gcc/*/*/ecrt*.o
683 %attr(644,root,root) %{_libdir}/gcc/*/*/ncrt*.o
684 %{_libdir}/gcc/*/*/nof
685 %dir %{_libdir}/nof
686 %endif
687 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1
688 %attr(755,root,root) %{_libdir}/gcc/*/*/collect2
689
690 %{_libdir}/gcc/*/*/include/*.h
691
692 %files -n libgcc
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_slibdir}/lib*.so.*
695
696 %files -n libmudflap
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/libmudflap*.so.*.*.*
699
700 %files -n libmudflap-devel
701 %defattr(644,root,root,755)
702 %{_includedir}/mf-runtime.h
703 %{_libdir}/libmudflap*.la
704 %attr(755,root,root) %{_libdir}/libmudflap*.so
705
706 %files -n libmudflap-static
707 %defattr(644,root,root,755)
708 %{_libdir}/libmudflap*.a
709
710 %if %{with ada}
711 %files ada
712 %defattr(644,root,root,755)
713 %doc gcc/ada/ChangeLog
714 %attr(755,root,root) %{_bindir}/gnat*
715 %attr(755,root,root) %{_bindir}/gpr*
716 %attr(755,root,root) %{_libdir}/libgnarl*.so
717 %attr(755,root,root) %{_libdir}/libgnat*.so
718 %attr(755,root,root) %{_libdir}/gcc/*/*/gnat1
719 %{_libdir}/gcc/*/*/adainclude
720 %dir %{_libdir}/gcc/*/*/adalib
721 %{_libdir}/gcc/*/*/adalib/*.ali
722 %{_libdir}/gcc/*/*/adalib/g-trasym.o
723 %{_libdir}/gcc/*/*/adalib/libgccprefix.a
724 %ifarch %{ix86}
725 %{_libdir}/gcc/*/*/adalib/libgmem.a
726 %endif
727 %{_datadir}/gnat
728 %{_infodir}/gnat*
729
730 %files -n libgnat
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/libgnarl*.so.1
733 %attr(755,root,root) %{_libdir}/libgnat*.so.1
734
735 %files -n libgnat-static
736 %defattr(644,root,root,755)
737 %{_libdir}/gcc/*/*/adalib/libgnarl.a
738 %{_libdir}/gcc/*/*/adalib/libgnat.a
739 %endif
740
741 %files c++
742 %defattr(644,root,root,755)
743 %doc gcc/cp/{ChangeLog,NEWS}
744 %attr(755,root,root) %{_bindir}/g++
745 %attr(755,root,root) %{_bindir}/*-g++
746 %attr(755,root,root) %{_bindir}/c++
747 %attr(755,root,root) %{_bindir}/*-c++
748 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1plus
749 %{_libdir}/libsupc++.a
750 %{_libdir}/libsupc++.la
751 %{_mandir}/man1/g++.1*
752
753 %files -n libstdc++ -f libstdc++.lang
754 %defattr(644,root,root,755)
755 %doc libstdc++-v3/{ChangeLog,README}
756 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
757
758 %files -n libstdc++-devel
759 %defattr(644,root,root,755)
760 %doc libstdc++-v3/docs/html
761 %dir %{_includedir}/c++
762 %{_includedir}/c++/%{version}
763 %if %{with java}
764 %exclude %{_includedir}/c++/%{version}/java
765 %exclude %{_includedir}/c++/%{version}/javax
766 %exclude %{_includedir}/c++/%{version}/gcj
767 %exclude %{_includedir}/c++/%{version}/gnu
768 %endif
769 %exclude %{_includedir}/c++/%{version}/*/bits/stdc++.h.gch
770 %{_libdir}/libstdc++.la
771 %attr(755,root,root) %{_libdir}/libstdc++.so
772
773 %files -n libstdc++-static
774 %defattr(644,root,root,755)
775 %{_libdir}/libstdc++.a
776
777 %if %{with fortran}
778 %files fortran
779 %defattr(644,root,root,755)
780 %doc gcc/fortran/ChangeLog
781 %attr(755,root,root) %{_bindir}/g95
782 %attr(755,root,root) %{_bindir}/gfortran
783 %{_infodir}/gfortran*
784 %attr(755,root,root) %{_libdir}/gcc/*/*/f951
785 %{_libdir}/libgfortranbegin.a
786 %{_libdir}/libgfortranbegin.la
787 %{_libdir}/libgfortran.la
788 %attr(755,root,root) %{_libdir}/libgfortran.so
789 %{_mandir}/man1/g95.1*
790 %{_mandir}/man1/gfortran.1*
791
792 %files -n libgfortran
793 %defattr(644,root,root,755)
794 %doc libgfortran/{AUTHORS,README,ChangeLog}
795 %attr(755,root,root) %{_libdir}/libgfortran.so.*.*.*
796
797 %files -n libgfortran-static
798 %defattr(644,root,root,755)
799 %{_libdir}/libgfortran.a
800 %endif
801
802 %if %{with java}
803 %files java
804 %defattr(644,root,root,755)
805 %doc gcc/java/ChangeLog java-doc/*
806 %attr(755,root,root) %{_bindir}/gcj*
807 %attr(755,root,root) %{_bindir}/gij
808 %attr(755,root,root) %{_bindir}/grepjar
809 %attr(755,root,root) %{_bindir}/jcf-dump
810 %attr(755,root,root) %{_bindir}/jv-*
811 %attr(755,root,root) %{_bindir}/*-gcj*
812 %attr(755,root,root) %{_libdir}/gcc/*/*/jc1
813 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
814 %{_infodir}/gcj*
815 %{_mandir}/man1/gcj*
816 %{_mandir}/man1/gij*
817 %{_mandir}/man1/grepjar*
818 %{_mandir}/man1/jcf-*
819 %{_mandir}/man1/jv-*
820
821 %files java-tools
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_bindir}/grmi*
824 %attr(755,root,root) %{_bindir}/fastjar
825 %{_mandir}/man1/grmi*
826 %{_mandir}/man1/fastjar*
827 %{_infodir}/fastjar*
828
829 %files -n libgcj
830 %defattr(644,root,root,755)
831 %doc libjava/{ChangeLog,LIBGCJ_LICENSE,NEWS,README,THANKS}
832 %attr(755,root,root) %{_bindir}/addr2name.awk
833 %attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
834 %attr(755,root,root) %{_libdir}/libgij.so.*.*.*
835 %attr(755,root,root) %{_libdir}/lib-org*.so.*.*.*
836 %{_libdir}/logging.properties
837
838 %files -n libgcj-devel
839 %defattr(644,root,root,755)
840 %{_includedir}/c++/%{version}/java
841 %{_includedir}/c++/%{version}/javax
842 %{_includedir}/c++/%{version}/gcj
843 %{_includedir}/c++/%{version}/gnu
844 %{_libdir}/gcc/*/*/include/gcj
845 %dir %{_libdir}/security
846 %{_libdir}/security/*
847 %{_javadir}/libgcj*.jar
848 %{_libdir}/lib*cj.spec
849 %{_libdir}/lib*cj*.la
850 %attr(755,root,root) %{_libdir}/lib*cj*.so
851 %{_libdir}/libgij.la
852 %attr(755,root,root) %{_libdir}/libgij.so
853 %attr(755,root,root) %{_libdir}/lib-org-*.so
854 %{_libdir}/lib-org-*.la
855 %{_pkgconfigdir}/libgcj.pc
856
857 %files -n libgcj-static
858 %defattr(644,root,root,755)
859 %{_libdir}/lib*cj*.a
860 %{_libdir}/libgij.a
861 %{_libdir}/lib-org-*.a
862
863 %files -n libffi
864 %defattr(644,root,root,755)
865 %doc libffi/{ChangeLog,ChangeLog.libgcj,LICENSE,README}
866 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
867
868 %files -n libffi-devel
869 %defattr(644,root,root,755)
870 %{_libdir}/gcc/*/*/include/ffitarget.h
871 %attr(755,root,root) %{_libdir}/libffi.so
872 %{_libdir}/libffi.la
873 %{_includedir}/ffi.h
874
875 %files -n libffi-static
876 %defattr(644,root,root,755)
877 %{_libdir}/libffi.a
878 %endif
879
880 %if %{with objc}
881 %files objc
882 %defattr(644,root,root,755)
883 %doc gcc/objc/README
884 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1obj
885 %attr(755,root,root) %{_libdir}/libobjc.so
886 %{_libdir}/libobjc.la
887 %{_libdir}/gcc/*/*/include/objc
888
889 %files -n libobjc
890 %defattr(644,root,root,755)
891 %doc libobjc/{ChangeLog,README*}
892 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
893
894 %files -n libobjc-static
895 %defattr(644,root,root,755)
896 %{_libdir}/libobjc.a
897 %endif
This page took 0.115752 seconds and 4 git commands to generate.