]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- added gcj.texi fix; rel .2 (not that it builds, though)
[packages/gcc4.git] / gcc4.spec
1 #
2 # Conditional build:
3 %bcond_without  ada             # build without ADA support
4 %bcond_without  fortran         # build without Fortran support
5 %bcond_without  java            # build without Java support
6 %bcond_without  objc            # build without ObjC support
7 #
8 # TODO:
9 #               - http://gcc.gnu.org/PR11203 (inline-asm)
10 #               - http://gcc.gnu.org/PR18648 (missed tree-optimization)
11 #               - disable internal zlib usage
12 #               - translations from gcc.spec:HEAD
13 #
14 %define         _snap           20050109
15 #
16 Summary:        GNU Compiler Collection: the C compiler and shared files
17 Summary(pl):    Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
18 Name:           gcc
19 Epoch:          5
20 Version:        4.0.0
21 Release:        0.%{_snap}.2
22 License:        GPL
23 Group:          Development/Languages
24 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
25 #Source0:       ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
26 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/%{name}-4.0-%{_snap}.tar.bz2
27 # Source0-md5:  599c4ea4915c32accbb4dcfda1be4ca9
28 Patch0:         %{name}-info.patch
29 Patch1:         %{name}-nolocalefiles.patch
30 Patch2:         %{name}-nodebug.patch
31 Patch3:         %{name}-ada-link-new-libgnat.patch
32 Patch4:         %{name}-ada-link.patch
33 Patch5:         %{name}-gcj_texi_fix.patch
34 URL:            http://gcc.gnu.org/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  binutils >= 2:2.15.94.0.1
38 BuildRequires:  bison
39 BuildRequires:  fileutils >= 4.0.41
40 BuildRequires:  flex
41 %if %{with ada}
42 BuildRequires:  gcc(ada)
43 BuildRequires:  gcc-ada
44 %endif
45 BuildRequires:  gettext-devel
46 BuildRequires:  glibc-devel >= 2.2.5-20
47 BuildRequires:  gmp-devel
48 BuildRequires:  libmpfr-devel
49 BuildRequires:  perl-devel
50 BuildRequires:  texinfo >= 4.1
51 BuildRequires:  zlib-devel
52 Requires:       binutils >= 2:2.15.94.0.1
53 Requires:       libgcc = %{epoch}:%{version}-%{release}
54 Provides:       cpp = %{epoch}:%{version}-%{release}
55 %{?with_ada:Provides:   gcc(ada)}
56 Obsoletes:      cpp
57 Obsoletes:      egcs-cpp
58 Obsoletes:      gcc-cpp
59 Obsoletes:      gcc-ksi
60 Obsoletes:      gont
61 Conflicts:      glibc-devel < 2.2.5-20
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         _slibdir        /%{_lib}
65
66 %description
67 A compiler aimed at integrating all the optimizations and features
68 necessary for a high-performance and stable development environment.
69
70 This package contains the C compiler and some files shared by various
71 parts of the GNU Compiler Collection. In order to use another GCC
72 compiler you will need to install the appropriate subpackage.
73
74 %description -l pl
75 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
76 wyprodukowania szybkiego i stabilnego kodu wynikowego.
77
78 Ten pakiet zawiera kompilator C i pliki wspó³dzielone przez ró¿ne
79 czê¶ci kolekcji kompilatorów GNU (GCC). ¯eby u¿ywaæ innego kompilatora
80 z GCC, trzeba zainstalowaæ odpowiedni podpakiet.
81
82 %package -n libgcc
83 Summary:        Shared gcc library
84 Summary(pl):    Biblioteka gcc
85 Group:          Libraries
86 Obsoletes:      libgcc1
87
88 %description -n libgcc
89 Shared gcc library.
90
91 %description -n libgcc -l pl
92 Biblioteka dynamiczna gcc.
93
94 %package -n libmudflap
95 Summary:        GCC mudflap shared support library
96 Group:          Libraries
97
98 %description -n libmudflap
99 The libmudflap libraries are used by GCC for instrumenting pointer and
100 array dereferencing operations.
101
102 %package -n libmudflap-devel
103 Summary:        Development files for GCC mudflap library
104 Group:          Development/Libraries
105 Requires:       libmudflap = %{epoch}:%{version}-%{release}
106
107 %description -n libmudflap-devel
108 The libmudflap libraries are used by GCC for instrumenting pointer and
109 array dereferencing operations. This package contains development
110 files.
111
112 %package -n libmudflap-static
113 Summary:        Static GCC mudflap library
114 Group:          Development/Libraries
115 Requires:       libmudflap-devel = %{epoch}:%{version}-%{release}
116
117 %description -n libmudflap-static
118 The libmudflap libraries are used by GCC for instrumenting pointer and
119 array dereferencing operations. This package contains static
120 libraries.
121
122 %package ada
123 Summary:        Ada support for gcc
124 Summary(pl):    Obs³uga Ady do gcc
125 Group:          Development/Languages
126 Requires:       %{name} = %{epoch}:%{version}-%{release}
127 Requires:       libgnat = %{epoch}:%{version}-%{release}
128 Obsoletes:      gcc-gnat
129 Obsoletes:      gnat-devel
130
131 %description ada
132 This package adds experimental support for compiling Ada programs.
133
134 %description ada -l pl
135 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów w
136 Adzie.
137
138 %package -n libgnat
139 Summary:        Ada standard libraries
140 Summary(pl):    Biblioteki standardowe dla Ady
141 Group:          Development/Libraries
142 Obsoletes:      gnat
143 Obsoletes:      libgnat1
144
145 %description -n libgnat
146 This package contains shared libraries needed to run programs written
147 in Ada.
148
149 %description -n libgnat -l pl
150 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów
151 napisanych w Adzie.
152
153 %package -n libgnat-static
154 Summary:        Static Ada standard libraries
155 Summary(pl):    Statyczne biblioteki standardowe dla Ady
156 Group:          Development/Libraries
157 Obsoletes:      gnat-static
158
159 %description -n libgnat-static
160 This package contains static libraries for programs written in Ada.
161
162 %description -n libgnat-static -l pl
163 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
164 Adzie.
165
166 %package c++
167 Summary:        C++ support for gcc
168 Summary(pl):    Obs³uga C++ dla gcc
169 Group:          Development/Languages
170 Requires:       %{name} = %{epoch}:%{version}-%{release}
171 Obsoletes:      egcc-c++
172 Obsoletes:      egcs-c++
173
174 %description c++
175 This package adds C++ support to the GNU Compiler Collection. It
176 includes support for most of the current C++ specification, including
177 templates and exception handling. It does not include a standard C++
178 library, which is available separately.
179
180 %description c++ -l pl
181 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
182 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
183 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
184
185 %package -n libstdc++
186 Summary:        GNU C++ library
187 Summary(pl):    Biblioteki GNU C++
188 Group:          Libraries
189 Obsoletes:      libg++
190 Obsoletes:      libstdc++3
191
192 %description -n libstdc++
193 This is the GNU implementation of the standard C++ libraries, along
194 with additional GNU tools. This package includes the shared libraries
195 necessary to run C++ applications.
196
197 %description -n libstdc++ -l pl
198 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
199 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
200 uruchomienia aplikacji napisanych w C++.
201
202 %package -n libstdc++-devel
203 Summary:        Header files and documentation for C++ development
204 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
205 Group:          Development/Libraries
206 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
207 Requires:       glibc-devel
208 Requires:       libstdc++ = %{epoch}:%{version}-%{release}
209 Obsoletes:      libg++-devel
210 Obsoletes:      libstdc++3-devel
211
212 %description -n libstdc++-devel
213 This is the GNU implementation of the standard C++ libraries. This
214 package includes the header files needed for C++ development and
215 library documentation.
216
217 %description -n libstdc++-devel -l pl
218 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
219 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
220 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
221
222 %package -n libstdc++-static
223 Summary:        Static C++ standard library
224 Summary(pl):    Statyczna biblioteka standardowa C++
225 Group:          Development/Libraries
226 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
227
228 %description -n libstdc++-static
229 Static C++ standard library.
230
231 %description -n libstdc++-static -l pl
232 Statyczna biblioteka standardowa C++.
233
234 %package fortran
235 Summary:        Fortran 95 support for gcc
236 Summary(pl):    Obs³uga Fortranu 95 dla gcc
237 Group:          Development/Languages/Fortran
238 Requires:       libgfortran = %{epoch}:%{version}-%{release}
239 Obsoletes:      egcs-g77
240 Obsoletes:      gcc-g77
241
242 %description fortran
243 This package adds support for compiling Fortran 95 programs with the
244 GNU compiler.
245
246 %description fortran -l pl
247 Ten pakiet dodaje obs³ugê Fortranu 95 do kompilatora gcc. Jest
248 potrzebny do kompilowania programów pisanych w jêzyku Fortran 95.
249
250 %package -n libgfortran
251 Summary:        Fortran 95 Libraries
252 Summary(pl):    Biblioteki Fortranu 95
253 Group:          Development/Libraries
254 Obsoletes:      libg2c
255
256 %description -n libgfortran
257 Fortran 95 Libraries.
258
259 %description -n libgfortran -l pl
260 Biblioteki Fortranu 95.
261
262 %package -n libgfortran-static
263 Summary:        Static Fortran 95 Libraries
264 Summary(pl):    Statyczne Biblioteki Fortranu 95
265 Group:          Development/Libraries
266 Requires:       libgfortran = %{epoch}:%{version}-%{release}
267 Obsoletes:      libg2c-static
268
269 %description -n libgfortran-static
270 Static Fortran 95 Libraries.
271
272 %description -n libgfortran-static -l pl
273 Statyczne biblioteki Fortranu 95.
274
275 %package java
276 Summary:        Java support for gcc
277 Summary(pl):    Obs³uga Javy dla gcc
278 Group:          Development/Languages/Java
279 Requires:       %{name} = %{epoch}:%{version}-%{release}
280 Requires:       libgcj = %{epoch}:%{version}-%{release}
281 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
282 Requires:       java-shared
283 Provides:       gcj = %{epoch}:%{version}-%{release}
284
285 %description java
286 This package adds experimental support for compiling Java(tm) programs
287 and bytecode into native code. To use this you will also need the
288 libgcj package.
289
290 %description java -l pl
291 Wsparcie dla kompilowania programów Java(tm) zarówno do bajt-kodu jak
292 i do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
293 by³o przeprowadziæ kompilacjê.
294
295 %package -n libgcj
296 Summary:        Java Class Libraries
297 Summary(pl):    Biblioteki Klas Javy
298 Group:          Libraries
299 Requires:       zlib
300 Obsoletes:      libgcj3
301
302 %description -n libgcj
303 Java Class Libraries.
304
305 %description -n libgcj -l pl
306 Biblioteki Klas Javy.
307
308 %package -n libgcj-devel
309 Summary:        Development files for Java Class Libraries
310 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
311 Group:          Development/Libraries
312 Requires:       libgcj = %{epoch}:%{version}-%{release}
313 Obsoletes:      libgcj3-devel
314
315 %description -n libgcj-devel
316 Development files for Java Class Libraries.
317
318 %description -n libgcj-devel -l pl
319 Pliki nag³ówkowe dla Bibliotek Klas Javy.
320
321 %package -n libgcj-static
322 Summary:        Static Java Class Libraries
323 Summary(pl):    Statyczne Biblioteki Klas Javy
324 Group:          Development/Libraries
325 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
326 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
327
328 %description -n libgcj-static
329 Static Java Class Libraries.
330
331 %description -n libgcj-static -l pl
332 Statyczne Biblioteki Klas Javy.
333
334 %package -n libffi
335 Summary:        Foreign Function Interface library
336 Summary(pl):    Biblioteka zewnêtrznych wywo³añ funkcji
337 Group:          Libraries
338
339 %description -n libffi
340 The libffi library provides a portable, high level programming
341 interface to various calling conventions. This allows a programmer to
342 call any function specified by a call interface description at run
343 time.
344
345 %description -n libffi -l pl
346 Biblioteka libffi dostarcza przeno¶nego, wysokopoziomowego
347 miêdzymordzia do ró¿nych konwencji wywo³añ funkcji. Pozwala to
348 programi¶cie wywo³ywaæ dowolne funkcje podaj±c konwencjê wywo³ania w
349 czasie wykonania.
350
351 %package -n libffi-devel
352 Summary:        Development files for Foreign Function Interface library
353 Summary(pl):    Pliki nag³ówkowe dla libffi
354 Group:          Development/Libraries
355 Requires:       libffi = %{epoch}:%{version}-%{release}
356
357 %description -n libffi-devel
358 Development files for Foreign Function Interface library.
359
360 %description -n libffi-devel -l pl
361 Pliki nag³ówkowe dla libffi.
362
363 %package -n libffi-static
364 Summary:        Static Foreign Function Interface library
365 Summary(pl):    Statyczna biblioteka libffi
366 Group:          Development/Libraries
367 Requires:       libffi-devel = %{epoch}:%{version}-%{release}
368
369 %description -n libffi-static
370 Static Foreign Function Interface library.
371
372 %description -n libffi-static -l pl
373 Statyczna biblioteka libffi.
374
375 %package java-tools
376 Summary:        Shared java tools
377 Summary(pl):    Wspó³dzielone narzêdzia javy
378 Group:          Development/Languages/Java
379 Provides:       jar = %{epoch}:%{version}-%{release}
380 Provides:       java-shared
381 Obsoletes:      fastjar
382 Obsoletes:      java-shared
383 Obsoletes:      jar
384
385 %description java-tools
386 This package contains tools that are common for every Java(tm)
387 implementation, such as rmic or jar.
388
389 %description java-tools -l pl
390 Pakiet ten zawiera narzêdzia wspólne dla ka¿dej implementacji
391 Javy(tm), takie jak rmic czy jar.
392
393 %package objc
394 Summary:        Objective C support for gcc
395 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
396 Group:          Development/Languages
397 Requires:       %{name} = %{epoch}:%{version}-%{release}
398 Requires:       libobjc = %{epoch}:%{version}-%{release}
399 Obsoletes:      egcc-objc
400 Obsoletes:      egcs-objc
401
402 %description objc
403 This package adds Objective C support to the GNU Compiler Collection.
404 Objective C is a object oriented derivative of the C language, mainly
405 used on systems running NeXTSTEP. This package does not include the
406 standard objective C object library.
407
408 %description objc -l pl
409 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
410 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
411 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
412 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
413
414 %package -n libobjc
415 Summary:        Objective C Libraries
416 Summary(pl):    Biblioteki Obiektowego C
417 Group:          Libraries
418 Obsoletes:      libobjc1
419
420 %description -n libobjc
421 Objective C Libraries.
422
423 %description -n libobjc -l pl
424 Biblioteki Obiektowego C.
425
426 %package -n libobjc-static
427 Summary:        Static Objective C Libraries
428 Summary(pl):    Statyczne Biblioteki Obiektowego C
429 Group:          Development/Libraries
430 Requires:       libobjc = %{epoch}:%{version}-%{release}
431
432 %description -n libobjc-static
433 Static Objective C Libraries.
434
435 %description -n libobjc-static -l pl
436 Statyczne biblioteki Obiektowego C.
437
438 %prep
439 # prerelease
440 #setup -q -n gcc-%{version}-%{_snap}
441 # snapshot
442 %setup -q -n gcc-4.0-%{_snap}
443 # final
444 #setup -q -n gcc-%{version}
445
446 %patch0 -p1
447 %patch1 -p1
448 %{!?debug:%patch2 -p1}
449 %patch3 -p1
450 %patch4 -p1
451 %patch5 -p1
452
453 # because we distribute modified version of gcc...
454 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
455 perl -pi -e 's@(bug_report_url.*<URL:).*";@$1http://bugs.pld-linux.org/>";@' gcc/version.c
456
457 mv ChangeLog ChangeLog.general
458
459 %build
460 cd gcc
461 %{__autoconf}
462 cd ..
463 cp -f /usr/share/automake/config.sub .
464
465 rm -rf obj-%{_target_platform}
466 install -d obj-%{_target_platform}
467 cd obj-%{_target_platform}
468
469 CFLAGS="%{rpmcflags}" \
470 CXXFLAGS="%{rpmcflags}" \
471 TEXCONFIG=false \
472 ../configure \
473         --prefix=%{_prefix} \
474         --libdir=%{_libdir} \
475         --libexecdir=%{_libexecdir} \
476         --infodir=%{_infodir} \
477         --mandir=%{_mandir} \
478         --enable-shared \
479         --enable-threads=posix \
480         --enable-__cxa_atexit \
481         --enable-languages="c,c++%{?with_fortran:,f95}%{?with_objc:,objc}%{?with_ada:,ada}%{?with_java:,java}" \
482         --enable-c99 \
483         --enable-long-long \
484 %ifarch amd64
485         --disable-multilib \
486 %else
487         --enable-multilib \
488 %endif
489         --enable-nls \
490         --with-gnu-as \
491         --with-gnu-ld \
492         --with-system-zlib \
493         --with-slibdir=%{_slibdir} \
494         --without-x \
495         --enable-cmath \
496         %{_target_platform}
497
498 cd ..
499
500 %{__make} -C obj-%{_target_platform} \
501         profiledbootstrap \
502         GCJFLAGS="%{rpmcflags}" \
503         BOOT_CFLAGS="%{rpmcflags}" \
504         STAGE1_CFLAGS="%{rpmcflags}" \
505         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
506         mandir=%{_mandir} \
507         infodir=%{_infodir}
508
509 %install
510 rm -rf $RPM_BUILD_ROOT
511 install -d $RPM_BUILD_ROOT{/lib,%{_aclocaldir},%{_datadir},%{_infodir}}
512
513 cd obj-%{_target_platform}
514
515 %{__make} -j1 install \
516         mandir=%{_mandir} \
517         infodir=%{_infodir} \
518         DESTDIR=$RPM_BUILD_ROOT
519
520 install gcc/specs $RPM_BUILD_ROOT%{_libdir}/gcc/%{_target_platform}/%{version}
521
522 %ifarch sparc64
523 ln -sf  $RPM_BUILD_ROOT%{_bindir}/sparc64-pld-linux-gcc \
524         $RPM_BUILD_ROOT%{_bindir}/sparc-pld-linux-gcc
525 %endif
526
527 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
528 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
529
530 %if %{with fortran}
531 ln -sf gfortran $RPM_BUILD_ROOT%{_bindir}/g95
532 echo ".so gfortran.1" > $RPM_BUILD_ROOT%{_mandir}/man1/g95.1
533 %endif
534
535 %if %{with ada}
536 # move ada shared libraries to proper place...
537 mv -f   $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/adalib/*.so.1 \
538         $RPM_BUILD_ROOT%{_libdir}
539 # check if symlink to be made is valid
540 test -f $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so.1
541 ln -sf  libgnat-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so
542 ln -sf  libgnarl-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnarl-4.0.so
543 ln -sf  libgnat-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnat.so
544 ln -sf  libgnarl-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnarl.so
545 ln -sf  %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
546 %endif
547
548 cd ..
549
550 %if %{with java}
551 install -d java-doc
552 cp -f   libjava/READ* java-doc
553 cp -f   fastjar/README java-doc/README.fastjar
554 cp -f   libffi/README java-doc/README.libffi
555 cp -f   libffi/LICENSE java-doc/LICENSE.libffi
556 %endif
557 %if %{with objc}
558 cp -f   libobjc/README gcc/objc/README.libobjc
559 %endif
560
561 # avoid -L poisoning in *.la - there should be only -L%{_libdir}/gcc/*/%{version}
562 for f in libstdc++.la libsupc++.la %{?with_java:libgcj.la};
563 do
564         perl -pi -e 's@-L[^ ]*[acs.] @@g' $RPM_BUILD_ROOT%{_libdir}/$f
565 done
566 # normalize libdir, to avoid propagation of unnecessary RPATHs by libtool
567 for f in libstdc++.la libsupc++.la \
568         %{?with_fortran:libgfortran.la libgfortranbegin.la} \
569         %{?with_java:libgcj.la lib-org-w3c-dom.la lib-org-xml-sax.la libffi.la} \
570         %{?with_objc:libobjc.la};
571 do
572         perl -pi -e "s@^libdir='.*@libdir='/usr/%{_lib}'@" $RPM_BUILD_ROOT%{_libdir}/$f
573 done
574
575 # include/ contains install-tools/include/* and headers that were fixed up
576 # by fixincludes, we don't want former
577 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
578 mkdir   $gccdir/tmp
579 # we have to save these however
580 %{?with_java:mv -f $gccdir/include/{gcj,libffi/ffitarget.h} $gccdir/tmp}
581 %{?with_objc:mv -f $gccdir/include/objc $gccdir/tmp}
582 mv -f   $gccdir/include/syslimits.h $gccdir/tmp
583 rm -rf  $gccdir/include
584  mv -f  $gccdir/tmp $gccdir/include
585 cp -f   $gccdir/install-tools/include/*.h $gccdir/include
586 # but we don't want anything more from install-tools
587 rm -rf  $gccdir/install-tools
588
589 %find_lang gcc
590 %find_lang libstdc\+\+
591
592 %clean
593 rm -rf $RPM_BUILD_ROOT
594
595 %post
596 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
597
598 %postun
599 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
600
601 %post ada
602 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
603
604 %postun ada
605 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
606
607 %post fortran
608 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
609
610 %postun fortran
611 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
612
613 %post java
614 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
615
616 %postun java
617 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
618
619 %post   -p /sbin/ldconfig -n libgcc
620 %postun -p /sbin/ldconfig -n libgcc
621 %post   -p /sbin/ldconfig -n libmudflap
622 %postun -p /sbin/ldconfig -n libmudflap
623 %post   -p /sbin/ldconfig -n libgnat
624 %postun -p /sbin/ldconfig -n libgnat
625 %post   -p /sbin/ldconfig -n libstdc++
626 %postun -p /sbin/ldconfig -n libstdc++
627 %post   -p /sbin/ldconfig -n libgfortran
628 %postun -p /sbin/ldconfig -n libgfortran
629 %post   -p /sbin/ldconfig -n libgcj
630 %postun -p /sbin/ldconfig -n libgcj
631 %post   -p /sbin/ldconfig -n libffi
632 %postun -p /sbin/ldconfig -n libffi
633 %post   -p /sbin/ldconfig -n libobjc
634 %postun -p /sbin/ldconfig -n libobjc
635
636 %files -f gcc.lang
637 %defattr(644,root,root,755)
638 %doc ChangeLog.general MAINTAINERS bugs.html faq.html
639 %doc gcc/{ChangeLog,ONEWS,README.Portability}
640 %dir %{_libdir}/gcc
641 %dir %{_libdir}/gcc/*
642 %dir %{_libdir}/gcc/*/*
643 %dir %{_libdir}/gcc/*/*/include
644
645 %attr(755,root,root) %{_bindir}/*-gcc*
646 %attr(755,root,root) %{_bindir}/gcc
647 %attr(755,root,root) %{_bindir}/gccbug
648 %attr(755,root,root) %{_bindir}/gcov
649 %attr(755,root,root) %{_bindir}/cc
650 %attr(755,root,root) %{_bindir}/cpp
651
652 %{_mandir}/man1/cc.1*
653 %{_mandir}/man1/cpp.1*
654 %{_mandir}/man1/gcc.1*
655 %{_mandir}/man1/gcov.1*
656
657 %{_infodir}/cpp*
658 %{_infodir}/gcc*
659
660 %attr(755,root,root) /lib/cpp
661
662 %attr(755,root,root) %{_slibdir}/lib*.so
663 %{_libdir}/gcc/*/*/libgcov.a
664 %{_libdir}/gcc/*/*/libgcc.a
665 %{_libdir}/gcc/*/*/libgcc_eh.a
666 %{_libdir}/gcc/*/*/specs
667 %attr(644,root,root) %{_libdir}/gcc/*/*/crt*.o
668 %ifarch sparc64
669 %{_libdir}/gcc/*/*/*/libgcc.a
670 %{_libdir}/gcc/*/*/*/libgcc_eh.a
671 %attr(644,root,root) %{_libdir}/gcc/*/*/*/crt*.o
672 %endif
673 %ifarch ppc
674 %attr(644,root,root) %{_libdir}/gcc/*/*/ecrt*.o
675 %attr(644,root,root) %{_libdir}/gcc/*/*/ncrt*.o
676 %{_libdir}/gcc/*/*/nof
677 %dir %{_libdir}/nof
678 %endif
679 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1
680 %attr(755,root,root) %{_libdir}/gcc/*/*/collect2
681
682 %{_libdir}/gcc/*/*/include/*.h
683
684 %files -n libgcc
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_slibdir}/lib*.so.*
687
688 %files -n libmudflap
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/libmudflap*.so.*.*.*
691
692 %files -n libmudflap-devel
693 %defattr(644,root,root,755)
694 %{_includedir}/mf-runtime.h
695 %{_libdir}/libmudflap*.la
696 %attr(755,root,root) %{_libdir}/libmudflap*.so
697
698 %files -n libmudflap-static
699 %defattr(644,root,root,755)
700 %{_libdir}/libmudflap*.a
701
702 %if %{with ada}
703 %files ada
704 %defattr(644,root,root,755)
705 %doc gcc/ada/ChangeLog
706 %attr(755,root,root) %{_bindir}/gnat*
707 %attr(755,root,root) %{_bindir}/gpr*
708 %attr(755,root,root) %{_libdir}/libgnarl*.so
709 %attr(755,root,root) %{_libdir}/libgnat*.so
710 %attr(755,root,root) %{_libdir}/gcc/*/*/gnat1
711 %{_libdir}/gcc/*/*/adainclude
712 %dir %{_libdir}/gcc/*/*/adalib
713 %{_libdir}/gcc/*/*/adalib/*.ali
714 %{_libdir}/gcc/*/*/adalib/g-trasym.o
715 %{_libdir}/gcc/*/*/adalib/libgccprefix.a
716 %ifarch %{ix86}
717 %{_libdir}/gcc/*/*/adalib/libgmem.a
718 %endif
719 %{_datadir}/gnat
720 %{_infodir}/gnat*
721
722 %files -n libgnat
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libgnarl*.so.1
725 %attr(755,root,root) %{_libdir}/libgnat*.so.1
726
727 %files -n libgnat-static
728 %defattr(644,root,root,755)
729 %{_libdir}/gcc/*/*/adalib/libgnarl.a
730 %{_libdir}/gcc/*/*/adalib/libgnat.a
731 %endif
732
733 %files c++
734 %defattr(644,root,root,755)
735 %doc gcc/cp/{ChangeLog,NEWS}
736 %attr(755,root,root) %{_bindir}/g++
737 %attr(755,root,root) %{_bindir}/*-g++
738 %attr(755,root,root) %{_bindir}/c++
739 %attr(755,root,root) %{_bindir}/*-c++
740 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1plus
741 %{_libdir}/libsupc++.a
742 %{_libdir}/libsupc++.la
743 %{_mandir}/man1/g++.1*
744
745 %files -n libstdc++ -f libstdc++.lang
746 %defattr(644,root,root,755)
747 %doc libstdc++-v3/{ChangeLog,README}
748 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
749
750 %files -n libstdc++-devel
751 %defattr(644,root,root,755)
752 %doc libstdc++-v3/docs/html
753 %dir %{_includedir}/c++
754 %{_includedir}/c++/%{version}
755 %if %{with java}
756 %exclude %{_includedir}/c++/%{version}/java
757 %exclude %{_includedir}/c++/%{version}/javax
758 %exclude %{_includedir}/c++/%{version}/gcj
759 %exclude %{_includedir}/c++/%{version}/gnu
760 %endif
761 %exclude %{_includedir}/c++/%{version}/*/bits/stdc++.h.gch
762 %{_libdir}/libstdc++.la
763 %attr(755,root,root) %{_libdir}/libstdc++.so
764
765 %files -n libstdc++-static
766 %defattr(644,root,root,755)
767 %{_libdir}/libstdc++.a
768
769 %if %{with fortran}
770 %files fortran
771 %defattr(644,root,root,755)
772 %doc gcc/fortran/ChangeLog
773 %attr(755,root,root) %{_bindir}/g95
774 %attr(755,root,root) %{_bindir}/gfortran
775 %{_infodir}/gfortran*
776 %attr(755,root,root) %{_libdir}/gcc/*/*/f951
777 %{_libdir}/libgfortranbegin.a
778 %{_libdir}/libgfortranbegin.la
779 %{_libdir}/libgfortran.la
780 %attr(755,root,root) %{_libdir}/libgfortran.so
781 %{_mandir}/man1/g95.1*
782 %{_mandir}/man1/gfortran.1*
783
784 %files -n libgfortran
785 %defattr(644,root,root,755)
786 %doc libgfortran/{AUTHORS,README,ChangeLog}
787 %attr(755,root,root) %{_libdir}/libgfortran.so.*.*.*
788
789 %files -n libgfortran-static
790 %defattr(644,root,root,755)
791 %{_libdir}/libgfortran.a
792 %endif
793
794 %if %{with java}
795 %files java
796 %defattr(644,root,root,755)
797 %doc gcc/java/ChangeLog java-doc/*
798 %attr(755,root,root) %{_bindir}/gcj*
799 %attr(755,root,root) %{_bindir}/gij
800 %attr(755,root,root) %{_bindir}/grepjar
801 %attr(755,root,root) %{_bindir}/jcf-dump
802 %attr(755,root,root) %{_bindir}/jv-*
803 %attr(755,root,root) %{_bindir}/*-gcj*
804 %attr(755,root,root) %{_libdir}/gcc/*/*/jc1
805 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
806 %{_infodir}/gcj*
807 %{_mandir}/man1/gcj*
808 %{_mandir}/man1/gij*
809 %{_mandir}/man1/grepjar*
810 %{_mandir}/man1/jcf-*
811 %{_mandir}/man1/jv-*
812
813 %files java-tools
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_bindir}/grmi*
816 %attr(755,root,root) %{_bindir}/fastjar
817 %{_mandir}/man1/grmi*
818 %{_mandir}/man1/fastjar*
819 %{_infodir}/fastjar*
820
821 %files -n libgcj
822 %defattr(644,root,root,755)
823 %doc libjava/{ChangeLog,LIBGCJ_LICENSE,NEWS,README,THANKS}
824 %attr(755,root,root) %{_bindir}/addr2name.awk
825 %attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
826 %attr(755,root,root) %{_libdir}/libgij.so.*.*.*
827 %attr(755,root,root) %{_libdir}/lib-org*.so.*.*.*
828 %{_libdir}/logging.properties
829
830 %files -n libgcj-devel
831 %defattr(644,root,root,755)
832 %{_includedir}/c++/%{version}/java
833 %{_includedir}/c++/%{version}/javax
834 %{_includedir}/c++/%{version}/gcj
835 %{_includedir}/c++/%{version}/gnu
836 %{_libdir}/gcc/*/*/include/gcj
837 %dir %{_libdir}/security
838 %{_libdir}/security/*
839 %dir %{_datadir}/java
840 %{_datadir}/java/libgcj*.jar
841 %{_libdir}/lib*cj.spec
842 %{_libdir}/lib*cj*.la
843 %attr(755,root,root) %{_libdir}/lib*cj*.so
844 %{_libdir}/libgij.la
845 %attr(755,root,root) %{_libdir}/libgij.so
846 %attr(755,root,root) %{_libdir}/lib-org-*.so
847 %{_libdir}/lib-org-*.la
848 %{_pkgconfigdir}/libgcj.pc
849
850 %files -n libgcj-static
851 %defattr(644,root,root,755)
852 %{_libdir}/lib*cj*.a
853 %{_libdir}/libgij.a
854 %{_libdir}/lib-org-*.a
855
856 %files -n libffi
857 %defattr(644,root,root,755)
858 %doc libffi/{ChangeLog,ChangeLog.libgcj,LICENSE,README}
859 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
860
861 %files -n libffi-devel
862 %defattr(644,root,root,755)
863 %{_libdir}/gcc/*/*/include/ffitarget.h
864 %attr(755,root,root) %{_libdir}/libffi.so
865 %{_libdir}/libffi.la
866 %{_includedir}/ffi.h
867
868 %files -n libffi-static
869 %defattr(644,root,root,755)
870 %{_libdir}/libffi.a
871 %endif
872
873 %if %{with objc}
874 %files objc
875 %defattr(644,root,root,755)
876 %doc gcc/objc/README
877 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1obj
878 %attr(755,root,root) %{_libdir}/libobjc.so
879 %{_libdir}/libobjc.la
880 %{_libdir}/gcc/*/*/include/objc
881
882 %files -n libobjc
883 %defattr(644,root,root,755)
884 %doc libobjc/{ChangeLog,README*}
885 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
886
887 %files -n libobjc-static
888 %defattr(644,root,root,755)
889 %{_libdir}/libobjc.a
890 %endif
This page took 0.133262 seconds and 4 git commands to generate.