]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- info patch updated.
[packages/gcc4.git] / gcc4.spec
1 #
2 # Conditional build:
3 #
4 %bcond_without  ada             # build without ADA support
5 %bcond_without  fortran         # build without Fortran support
6 %bcond_without  java            # build without Java support
7 %bcond_without  objc            # build without ObjC support
8 #
9 # TODO:
10 #               - http://gcc.gnu.org/PR11203 (inline-asm)
11 #               - http://gcc.gnu.org/PR18648 (missed tree-optimization)
12 #               - disable internal zlib usage
13 #               - translations from gcc.spec:HEAD
14 #
15 %define         _snap           20050102
16 #
17 Summary:        GNU Compiler Collection: the C compiler and shared files
18 Summary(pl):    Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
19 Name:           gcc
20 Epoch:          5
21 Version:        4.0.0
22 Release:        0.%{_snap}.0.5
23 License:        GPL
24 Group:          Development/Languages
25 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
26 #Source0:       ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
27 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/%{name}-4.0-%{_snap}.tar.bz2
28 # Source0-md5:  d5bf439e5a0653f503aaf6bf28609e33
29 Patch0:         %{name}-info.patch
30 Patch1:         %{name}-nolocalefiles.patch
31 Patch2:         %{name}-nodebug.patch
32 Patch3:         %{name}-ada-link-new-libgnat.patch
33 Patch4:         %{name}-ada-link.patch
34 Patch5:         %{name}-pr18910.patch
35 Patch6:         %{name}-pr19030.patch
36 Patch7:         %{name}-pr18241.patch
37 URL:            http://gcc.gnu.org/
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  binutils >= 2:2.15.94.0.1
41 BuildRequires:  bison
42 BuildRequires:  fileutils >= 4.0.41
43 BuildRequires:  flex
44 %if %{with ada}
45 BuildRequires:  gcc(ada)
46 BuildRequires:  gcc-ada
47 %endif
48 BuildRequires:  gettext-devel
49 BuildRequires:  glibc-devel >= 2.2.5-20
50 BuildRequires:  gmp-devel
51 BuildRequires:  libmpfr-devel
52 BuildRequires:  perl-devel
53 BuildRequires:  texinfo >= 4.1
54 BuildRequires:  zlib-devel
55 Requires:       binutils >= 2:2.15.94.0.1
56 Requires:       libgcc = %{epoch}:%{version}-%{release}
57 Provides:       cpp = %{epoch}:%{version}-%{release}
58 %{?with_ada:Provides:   gcc(ada)}
59 Obsoletes:      cpp
60 Obsoletes:      egcs-cpp
61 Obsoletes:      gcc-cpp
62 Obsoletes:      gcc-ksi
63 Obsoletes:      gont
64 Conflicts:      glibc-devel < 2.2.5-20
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _slibdir        /%{_lib}
68
69 %description
70 A compiler aimed at integrating all the optimizations and features
71 necessary for a high-performance and stable development environment.
72
73 This package contains the C compiler and some files shared by various
74 parts of the GNU Compiler Collection. In order to use another GCC
75 compiler you will need to install the appropriate subpackage.
76
77 %description -l pl
78 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
79 wyprodukowania szybkiego i stabilnego kodu wynikowego.
80
81 Ten pakiet zawiera kompilator C i pliki wspó³dzielone przez ró¿ne
82 czê¶ci kolekcji kompilatorów GNU (GCC). ¯eby u¿ywaæ innego kompilatora
83 z GCC, trzeba zainstalowaæ odpowiedni podpakiet.
84
85 %package -n libgcc
86 Summary:        Shared gcc library
87 Summary(pl):    Biblioteka gcc
88 Group:          Libraries
89 Obsoletes:      libgcc1
90
91 %description -n libgcc
92 Shared gcc library.
93
94 %description -n libgcc -l pl
95 Biblioteka dynamiczna gcc.
96
97 %package -n libmudflap
98 Summary:        GCC mudflap shared support library
99 Group:          Libraries
100
101 %description -n libmudflap
102 The libmudflap libraries are used by GCC for instrumenting pointer and
103 array dereferencing operations.
104
105 %package -n libmudflap-devel
106 Summary:        Development files for GCC mudflap library
107 Group:          Development/Libraries
108 Requires:       libmudflap = %{epoch}:%{version}-%{release}
109
110 %description -n libmudflap-devel
111 The libmudflap libraries are used by GCC for instrumenting pointer and
112 array dereferencing operations. This package contains development
113 files.
114
115 %package -n libmudflap-static
116 Summary:        Static GCC mudflap library
117 Group:          Development/Libraries
118 Requires:       libmudflap-devel = %{epoch}:%{version}-%{release}
119
120 %description -n libmudflap-static
121 The libmudflap libraries are used by GCC for instrumenting pointer and
122 array dereferencing operations. This package contains static
123 libraries.
124
125 %package ada
126 Summary:        Ada support for gcc
127 Summary(pl):    Obs³uga Ady do gcc
128 Group:          Development/Languages
129 Requires:       %{name} = %{epoch}:%{version}-%{release}
130 Requires:       libgnat = %{epoch}:%{version}-%{release}
131 Obsoletes:      gcc-gnat
132 Obsoletes:      gnat-devel
133
134 %description ada
135 This package adds experimental support for compiling Ada programs.
136
137 %description ada -l pl
138 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów w
139 Adzie.
140
141 %package -n libgnat
142 Summary:        Ada standard libraries
143 Summary(pl):    Biblioteki standardowe dla Ady
144 Group:          Development/Libraries
145 Obsoletes:      gnat
146 Obsoletes:      libgnat1
147
148 %description -n libgnat
149 This package contains shared libraries needed to run programs written
150 in Ada.
151
152 %description -n libgnat -l pl
153 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów
154 napisanych w Adzie.
155
156 %package -n libgnat-static
157 Summary:        Static Ada standard libraries
158 Summary(pl):    Statyczne biblioteki standardowe dla Ady
159 Group:          Development/Libraries
160 Obsoletes:      gnat-static
161
162 %description -n libgnat-static
163 This package contains static libraries for programs written in Ada.
164
165 %description -n libgnat-static -l pl
166 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
167 Adzie.
168
169 %package c++
170 Summary:        C++ support for gcc
171 Summary(pl):    Obs³uga C++ dla gcc
172 Group:          Development/Languages
173 Requires:       %{name} = %{epoch}:%{version}-%{release}
174 Obsoletes:      egcc-c++
175 Obsoletes:      egcs-c++
176
177 %description c++
178 This package adds C++ support to the GNU Compiler Collection. It
179 includes support for most of the current C++ specification, including
180 templates and exception handling. It does not include a standard C++
181 library, which is available separately.
182
183 %description c++ -l pl
184 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
185 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
186 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
187
188 %package -n libstdc++
189 Summary:        GNU C++ library
190 Summary(pl):    Biblioteki GNU C++
191 Group:          Libraries
192 Obsoletes:      libg++
193 Obsoletes:      libstdc++3
194
195 %description -n libstdc++
196 This is the GNU implementation of the standard C++ libraries, along
197 with additional GNU tools. This package includes the shared libraries
198 necessary to run C++ applications.
199
200 %description -n libstdc++ -l pl
201 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
202 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
203 uruchomienia aplikacji napisanych w C++.
204
205 %package -n libstdc++-devel
206 Summary:        Header files and documentation for C++ development
207 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
208 Group:          Development/Libraries
209 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
210 Requires:       glibc-devel
211 Requires:       libstdc++ = %{epoch}:%{version}-%{release}
212 Obsoletes:      libg++-devel
213 Obsoletes:      libstdc++3-devel
214
215 %description -n libstdc++-devel
216 This is the GNU implementation of the standard C++ libraries. This
217 package includes the header files needed for C++ development and
218 library documentation.
219
220 %description -n libstdc++-devel -l pl
221 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
222 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
223 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
224
225 %package -n libstdc++-static
226 Summary:        Static C++ standard library
227 Summary(pl):    Statyczna biblioteka standardowa C++
228 Group:          Development/Libraries
229 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
230
231 %description -n libstdc++-static
232 Static C++ standard library.
233
234 %description -n libstdc++-static -l pl
235 Statyczna biblioteka standardowa C++.
236
237 %package fortran
238 Summary:        Fortran 95 support for gcc
239 Summary(pl):    Obs³uga Fortranu 95 dla gcc
240 Group:          Development/Languages/Fortran
241 Requires:       libgfortran = %{epoch}:%{version}-%{release}
242 Obsoletes:      egcs-g77
243 Obsoletes:      gcc-g77
244
245 %description fortran
246 This package adds support for compiling Fortran 95 programs with the
247 GNU compiler.
248
249 %description fortran -l pl
250 Ten pakiet dodaje obs³ugê Fortranu 95 do kompilatora gcc. Jest
251 potrzebny do kompilowania programów pisanych w jêzyku Fortran 95.
252
253 %package -n libgfortran
254 Summary:        Fortran 95 Libraries
255 Summary(pl):    Biblioteki Fortranu 95
256 Group:          Development/Libraries
257 Obsoletes:      libg2c
258
259 %description -n libgfortran
260 Fortran 95 Libraries.
261
262 %description -n libgfortran -l pl
263 Biblioteki Fortranu 95.
264
265 %package -n libgfortran-static
266 Summary:        Static Fortran 95 Libraries
267 Summary(pl):    Statyczne Biblioteki Fortranu 95
268 Group:          Development/Libraries
269 Requires:       libgfortran = %{epoch}:%{version}-%{release}
270 Obsoletes:      libg2c-static
271
272 %description -n libgfortran-static
273 Static Fortran 95 Libraries.
274
275 %description -n libgfortran-static -l pl
276 Statyczne biblioteki Fortranu 95.
277
278 %package java
279 Summary:        Java support for gcc
280 Summary(pl):    Obs³uga Javy dla gcc
281 Group:          Development/Languages/Java
282 Requires:       %{name} = %{epoch}:%{version}-%{release}
283 Requires:       libgcj = %{epoch}:%{version}-%{release}
284 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
285 Requires:       java-shared
286 Provides:       gcj = %{epoch}:%{version}-%{release}
287
288 %description java
289 This package adds experimental support for compiling Java(tm) programs
290 and bytecode into native code. To use this you will also need the
291 libgcj package.
292
293 %description java -l pl
294 Wsparcie dla kompilowania programów Java(tm) zarówno do bajt-kodu jak
295 i do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
296 by³o przeprowadziæ kompilacjê.
297
298 %package -n libgcj
299 Summary:        Java Class Libraries
300 Summary(pl):    Biblioteki Klas Javy
301 Group:          Libraries
302 Requires:       zlib
303 Obsoletes:      libgcj3
304
305 %description -n libgcj
306 Java Class Libraries.
307
308 %description -n libgcj -l pl
309 Biblioteki Klas Javy.
310
311 %package -n libgcj-devel
312 Summary:        Development files for Java Class Libraries
313 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
314 Group:          Development/Libraries
315 Requires:       libgcj = %{epoch}:%{version}-%{release}
316 Obsoletes:      libgcj3-devel
317
318 %description -n libgcj-devel
319 Development files for Java Class Libraries.
320
321 %description -n libgcj-devel -l pl
322 Pliki nag³ówkowe dla Bibliotek Klas Javy.
323
324 %package -n libgcj-static
325 Summary:        Static Java Class Libraries
326 Summary(pl):    Statyczne Biblioteki Klas Javy
327 Group:          Development/Libraries
328 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
329 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
330
331 %description -n libgcj-static
332 Static Java Class Libraries.
333
334 %description -n libgcj-static -l pl
335 Statyczne Biblioteki Klas Javy.
336
337 %package -n libffi
338 Summary:        Foreign Function Interface library
339 Summary(pl):    Biblioteka zewnêtrznych wywo³añ funkcji
340 Group:          Libraries
341
342 %description -n libffi
343 The libffi library provides a portable, high level programming
344 interface to various calling conventions. This allows a programmer to
345 call any function specified by a call interface description at run
346 time.
347
348 %description -n libffi -l pl
349 Biblioteka libffi dostarcza przeno¶nego, wysokopoziomowego
350 miêdzymordzia do ró¿nych konwencji wywo³añ funkcji. Pozwala to
351 programi¶cie wywo³ywaæ dowolne funkcje podaj±c konwencjê wywo³ania w
352 czasie wykonania.
353
354 %package -n libffi-devel
355 Summary:        Development files for Foreign Function Interface library
356 Summary(pl):    Pliki nag³ówkowe dla libffi
357 Group:          Development/Libraries
358 Requires:       libffi = %{epoch}:%{version}-%{release}
359
360 %description -n libffi-devel
361 Development files for Foreign Function Interface library.
362
363 %description -n libffi-devel -l pl
364 Pliki nag³ówkowe dla libffi.
365
366 %package -n libffi-static
367 Summary:        Static Foreign Function Interface library
368 Summary(pl):    Statyczna biblioteka libffi
369 Group:          Development/Libraries
370 Requires:       libffi-devel = %{epoch}:%{version}-%{release}
371
372 %description -n libffi-static
373 Static Foreign Function Interface library.
374
375 %description -n libffi-static -l pl
376 Statyczna biblioteka libffi.
377
378 %package java-tools
379 Summary:        Shared java tools
380 Summary(pl):    Wspó³dzielone narzêdzia javy
381 Group:          Development/Languages/Java
382 Provides:       jar = %{epoch}:%{version}-%{release}
383 Provides:       java-shared
384 Obsoletes:      fastjar
385 Obsoletes:      java-shared
386 Obsoletes:      jar
387
388 %description java-tools
389 This package contains tools that are common for every Java(tm)
390 implementation, such as rmic or jar.
391
392 %description java-tools -l pl
393 Pakiet ten zawiera narzêdzia wspólne dla ka¿dej implementacji
394 Javy(tm), takie jak rmic czy jar.
395
396 %package objc
397 Summary:        Objective C support for gcc
398 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
399 Group:          Development/Languages
400 Requires:       %{name} = %{epoch}:%{version}-%{release}
401 Requires:       libobjc = %{epoch}:%{version}-%{release}
402 Obsoletes:      egcc-objc
403 Obsoletes:      egcs-objc
404
405 %description objc
406 This package adds Objective C support to the GNU Compiler Collection.
407 Objective C is a object oriented derivative of the C language, mainly
408 used on systems running NeXTSTEP. This package does not include the
409 standard objective C object library.
410
411 %description objc -l pl
412 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
413 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
414 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
415 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
416
417 %package -n libobjc
418 Summary:        Objective C Libraries
419 Summary(pl):    Biblioteki Obiektowego C
420 Group:          Libraries
421 Obsoletes:      libobjc1
422
423 %description -n libobjc
424 Objective C Libraries.
425
426 %description -n libobjc -l pl
427 Biblioteki Obiektowego C.
428
429 %package -n libobjc-static
430 Summary:        Static Objective C Libraries
431 Summary(pl):    Statyczne Biblioteki Obiektowego C
432 Group:          Development/Libraries
433 Requires:       libobjc = %{epoch}:%{version}-%{release}
434
435 %description -n libobjc-static
436 Static Objective C Libraries.
437
438 %description -n libobjc-static -l pl
439 Statyczne biblioteki Obiektowego C.
440
441 %prep
442 # prerelease
443 #setup -q -n gcc-%{version}-%{_snap}
444 # snapshot
445 %setup -q -n gcc-4.0-%{_snap}
446 # final
447 #setup -q -n gcc-%{version}
448
449 %patch0 -p1
450 %patch1 -p1
451 %{!?debug:%patch2 -p1}
452 %patch3 -p1
453 %patch4 -p1
454 %patch5 -p1
455 %patch6 -p1
456 %patch7 -p1
457
458 # because we distribute modified version of gcc...
459 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
460 perl -pi -e 's@(bug_report_url.*<URL:).*";@$1http://bugs.pld-linux.org/>";@' gcc/version.c
461
462 mv ChangeLog ChangeLog.general
463
464 %build
465 cd gcc
466 %{__autoconf}
467 cd ..
468 cp -f /usr/share/automake/config.sub .
469
470 rm -rf obj-%{_target_platform}
471 install -d obj-%{_target_platform}
472 cd obj-%{_target_platform}
473
474 CFLAGS="%{rpmcflags}" \
475 CXXFLAGS="%{rpmcflags}" \
476 TEXCONFIG=false \
477 ../configure \
478         --prefix=%{_prefix} \
479         --libdir=%{_libdir} \
480         --libexecdir=%{_libexecdir} \
481         --infodir=%{_infodir} \
482         --mandir=%{_mandir} \
483         --enable-shared \
484         --enable-threads=posix \
485         --enable-__cxa_atexit \
486         --enable-languages="c,c++%{?with_fortran:,f95}%{?with_objc:,objc}%{?with_ada:,ada}%{?with_java:,java}" \
487         --enable-c99 \
488         --enable-long-long \
489 %ifarch amd64
490         --disable-multilib \
491 %else
492         --enable-multilib \
493 %endif
494         --enable-nls \
495         --with-gnu-as \
496         --with-gnu-ld \
497         --with-system-zlib \
498         --with-slibdir=%{_slibdir} \
499         --without-x \
500         --enable-cmath \
501         %{_target_platform}
502
503 cd ..
504
505 %{__make} -C obj-%{_target_platform} \
506         profiledbootstrap \
507         GCJFLAGS="%{rpmcflags}" \
508         BOOT_CFLAGS="%{rpmcflags}" \
509         STAGE1_CFLAGS="%{rpmcflags}" \
510         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
511         mandir=%{_mandir} \
512         infodir=%{_infodir}
513
514 %install
515 rm -rf $RPM_BUILD_ROOT
516 install -d $RPM_BUILD_ROOT{/lib,%{_aclocaldir},%{_datadir},%{_infodir}}
517
518 cd obj-%{_target_platform}
519
520 %{__make} -j1 install \
521         mandir=%{_mandir} \
522         infodir=%{_infodir} \
523         DESTDIR=$RPM_BUILD_ROOT
524
525 install gcc/specs $RPM_BUILD_ROOT%{_libdir}/gcc/%{_target_platform}/%{version}
526
527 %ifarch sparc64
528 ln -sf  $RPM_BUILD_ROOT%{_bindir}/sparc64-pld-linux-gcc \
529         $RPM_BUILD_ROOT%{_bindir}/sparc-pld-linux-gcc
530 %endif
531
532 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
533 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
534
535 %if %{with fortran}
536 ln -sf gfortran $RPM_BUILD_ROOT%{_bindir}/g95
537 echo ".so gfortran.1" > $RPM_BUILD_ROOT%{_mandir}/man1/g95.1
538 %endif
539
540 %if %{with ada}
541 # move ada shared libraries to proper place...
542 mv -f   $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/adalib/*.so.1 \
543         $RPM_BUILD_ROOT%{_libdir}
544 # check if symlink to be made is valid
545 test -f $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so.1
546 ln -sf  libgnat-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so
547 ln -sf  libgnarl-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnarl-4.0.so
548 ln -sf  libgnat-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnat.so
549 ln -sf  libgnarl-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnarl.so
550 ln -sf  %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
551 %endif
552
553 cd ..
554
555 %if %{with java}
556 install -d java-doc
557 cp -f   libjava/READ* java-doc
558 cp -f   fastjar/README java-doc/README.fastjar
559 cp -f   libffi/README java-doc/README.libffi
560 cp -f   libffi/LICENSE java-doc/LICENSE.libffi
561 %endif
562 %if %{with objc}
563 cp -f   libobjc/README gcc/objc/README.libobjc
564 %endif
565
566 # avoid -L poisoning in *.la - there should be only -L%{_libdir}/gcc/*/%{version}
567 for f in libstdc++.la libsupc++.la %{?with_java:libgcj.la};
568 do
569         perl -pi -e 's@-L[^ ]*[acs.] @@g' $RPM_BUILD_ROOT%{_libdir}/$f
570 done
571 # normalize libdir, to avoid propagation of unnecessary RPATHs by libtool
572 for f in libstdc++.la libsupc++.la \
573         %{?with_fortran:libgfortran.la libgfortranbegin.la} \
574         %{?with_java:libgcj.la lib-org-w3c-dom.la lib-org-xml-sax.la libffi.la} \
575         %{?with_objc:libobjc.la};
576 do
577         perl -pi -e "s@^libdir='.*@libdir='/usr/%{_lib}'@" $RPM_BUILD_ROOT%{_libdir}/$f
578 done
579
580 # include/ contains install-tools/include/* and headers that were fixed up
581 # by fixincludes, we don't want former
582 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
583 mkdir   $gccdir/tmp
584 # we have to save these however
585 %{?with_java:mv -f $gccdir/include/{gcj,libffi/ffitarget.h} $gccdir/tmp}
586 %{?with_objc:mv -f $gccdir/include/objc $gccdir/tmp}
587 mv -f   $gccdir/include/syslimits.h $gccdir/tmp
588 rm -rf  $gccdir/include
589  mv -f  $gccdir/tmp $gccdir/include
590 cp -f   $gccdir/install-tools/include/*.h $gccdir/include
591 # but we don't want anything more from install-tools
592 rm -rf  $gccdir/install-tools
593
594 %find_lang gcc
595 %find_lang libstdc\+\+
596
597 %clean
598 rm -rf $RPM_BUILD_ROOT
599
600 %post
601 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
602
603 %postun
604 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
605
606 %post ada
607 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
608
609 %postun ada
610 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
611
612 %post fortran
613 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
614
615 %postun fortran
616 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
617
618 %post java
619 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
620
621 %postun java
622 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
623
624 %post   -p /sbin/ldconfig -n libgcc
625 %postun -p /sbin/ldconfig -n libgcc
626 %post   -p /sbin/ldconfig -n libmudflap
627 %postun -p /sbin/ldconfig -n libmudflap
628 %post   -p /sbin/ldconfig -n libgnat
629 %postun -p /sbin/ldconfig -n libgnat
630 %post   -p /sbin/ldconfig -n libstdc++
631 %postun -p /sbin/ldconfig -n libstdc++
632 %post   -p /sbin/ldconfig -n libgfortran
633 %postun -p /sbin/ldconfig -n libgfortran
634 %post   -p /sbin/ldconfig -n libgcj
635 %postun -p /sbin/ldconfig -n libgcj
636 %post   -p /sbin/ldconfig -n libffi
637 %postun -p /sbin/ldconfig -n libffi
638 %post   -p /sbin/ldconfig -n libobjc
639 %postun -p /sbin/ldconfig -n libobjc
640
641 %files -f gcc.lang
642 %defattr(644,root,root,755)
643 %doc ChangeLog.general MAINTAINERS bugs.html faq.html
644 %doc gcc/{ChangeLog,ONEWS,README.Portability}
645 %dir %{_libdir}/gcc
646 %dir %{_libdir}/gcc/*
647 %dir %{_libdir}/gcc/*/*
648 %dir %{_libdir}/gcc/*/*/include
649
650 %attr(755,root,root) %{_bindir}/*-gcc*
651 %attr(755,root,root) %{_bindir}/gcc
652 %attr(755,root,root) %{_bindir}/gccbug
653 %attr(755,root,root) %{_bindir}/gcov
654 %attr(755,root,root) %{_bindir}/cc
655 %attr(755,root,root) %{_bindir}/cpp
656
657 %{_mandir}/man1/cc.1*
658 %{_mandir}/man1/cpp.1*
659 %{_mandir}/man1/gcc.1*
660 %{_mandir}/man1/gcov.1*
661
662 %{_infodir}/cpp*
663 %{_infodir}/gcc*
664
665 %attr(755,root,root) /lib/cpp
666
667 %attr(755,root,root) %{_slibdir}/lib*.so
668 %{_libdir}/gcc/*/*/libgcov.a
669 %{_libdir}/gcc/*/*/libgcc.a
670 %{_libdir}/gcc/*/*/libgcc_eh.a
671 %{_libdir}/gcc/*/*/specs
672 %attr(644,root,root) %{_libdir}/gcc/*/*/crt*.o
673 %ifarch sparc64
674 %{_libdir}/gcc/*/*/*/libgcc.a
675 %{_libdir}/gcc/*/*/*/libgcc_eh.a
676 %attr(644,root,root) %{_libdir}/gcc/*/*/*/crt*.o
677 %endif
678 %ifarch ppc
679 %attr(644,root,root) %{_libdir}/gcc/*/*/ecrt*.o
680 %attr(644,root,root) %{_libdir}/gcc/*/*/ncrt*.o
681 %{_libdir}/gcc/*/*/nof
682 %dir %{_libdir}/nof
683 %endif
684 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1
685 %attr(755,root,root) %{_libdir}/gcc/*/*/collect2
686
687 %{_libdir}/gcc/*/*/include/*.h
688
689 %files -n libgcc
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_slibdir}/lib*.so.*
692
693 %files -n libmudflap
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/libmudflap*.so.*.*.*
696
697 %files -n libmudflap-devel
698 %defattr(644,root,root,755)
699 %{_includedir}/mf-runtime.h
700 %{_libdir}/libmudflap*.la
701 %attr(755,root,root) %{_libdir}/libmudflap*.so
702
703 %files -n libmudflap-static
704 %defattr(644,root,root,755)
705 %{_libdir}/libmudflap*.a
706
707 %if %{with ada}
708 %files ada
709 %defattr(644,root,root,755)
710 %doc gcc/ada/ChangeLog
711 %attr(755,root,root) %{_bindir}/gnat*
712 %attr(755,root,root) %{_bindir}/gpr*
713 %attr(755,root,root) %{_libdir}/libgnarl*.so
714 %attr(755,root,root) %{_libdir}/libgnat*.so
715 %attr(755,root,root) %{_libdir}/gcc/*/*/gnat1
716 %{_libdir}/gcc/*/*/adainclude
717 %dir %{_libdir}/gcc/*/*/adalib
718 %{_libdir}/gcc/*/*/adalib/*.ali
719 %{_libdir}/gcc/*/*/adalib/g-trasym.o
720 %{_libdir}/gcc/*/*/adalib/libgccprefix.a
721 %ifarch %{ix86}
722 %{_libdir}/gcc/*/*/adalib/libgmem.a
723 %endif
724 %{_datadir}/gnat
725 %{_infodir}/gnat*
726
727 %files -n libgnat
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/libgnarl*.so.1
730 %attr(755,root,root) %{_libdir}/libgnat*.so.1
731
732 %files -n libgnat-static
733 %defattr(644,root,root,755)
734 %{_libdir}/gcc/*/*/adalib/libgnarl.a
735 %{_libdir}/gcc/*/*/adalib/libgnat.a
736 %endif
737
738 %files c++
739 %defattr(644,root,root,755)
740 %doc gcc/cp/{ChangeLog,NEWS}
741 %attr(755,root,root) %{_bindir}/g++
742 %attr(755,root,root) %{_bindir}/*-g++
743 %attr(755,root,root) %{_bindir}/c++
744 %attr(755,root,root) %{_bindir}/*-c++
745 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1plus
746 %{_libdir}/libsupc++.a
747 %{_libdir}/libsupc++.la
748 %{_mandir}/man1/g++.1*
749
750 %files -n libstdc++ -f libstdc++.lang
751 %defattr(644,root,root,755)
752 %doc libstdc++-v3/{ChangeLog,README}
753 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
754
755 %files -n libstdc++-devel
756 %defattr(644,root,root,755)
757 %doc libstdc++-v3/docs/html
758 %dir %{_includedir}/c++
759 %{_includedir}/c++/%{version}
760 %if %{with java}
761 %exclude %{_includedir}/c++/%{version}/java
762 %exclude %{_includedir}/c++/%{version}/javax
763 %exclude %{_includedir}/c++/%{version}/gcj
764 %exclude %{_includedir}/c++/%{version}/gnu
765 %endif
766 %exclude %{_includedir}/c++/%{version}/*/bits/stdc++.h.gch
767 %{_libdir}/libstdc++.la
768 %attr(755,root,root) %{_libdir}/libstdc++.so
769
770 %files -n libstdc++-static
771 %defattr(644,root,root,755)
772 %{_libdir}/libstdc++.a
773
774 %if %{with fortran}
775 %files fortran
776 %defattr(644,root,root,755)
777 %doc gcc/fortran/ChangeLog
778 %attr(755,root,root) %{_bindir}/g95
779 %attr(755,root,root) %{_bindir}/gfortran
780 %{_infodir}/gfortran*
781 %attr(755,root,root) %{_libdir}/gcc/*/*/f951
782 %{_libdir}/libgfortranbegin.a
783 %{_libdir}/libgfortranbegin.la
784 %{_libdir}/libgfortran.la
785 %attr(755,root,root) %{_libdir}/libgfortran.so
786 %{_mandir}/man1/g95.1*
787 %{_mandir}/man1/gfortran.1*
788
789 %files -n libgfortran
790 %defattr(644,root,root,755)
791 %doc libgfortran/{AUTHORS,README,ChangeLog}
792 %attr(755,root,root) %{_libdir}/libgfortran.so.*.*.*
793
794 %files -n libgfortran-static
795 %defattr(644,root,root,755)
796 %{_libdir}/libgfortran.a
797 %endif
798
799 %if %{with java}
800 %files java
801 %defattr(644,root,root,755)
802 %doc gcc/java/ChangeLog java-doc/*
803 %attr(755,root,root) %{_bindir}/gcj*
804 %attr(755,root,root) %{_bindir}/gij
805 %attr(755,root,root) %{_bindir}/grepjar
806 %attr(755,root,root) %{_bindir}/jcf-dump
807 %attr(755,root,root) %{_bindir}/jv-*
808 %attr(755,root,root) %{_bindir}/*-gcj*
809 %attr(755,root,root) %{_libdir}/gcc/*/*/jc1
810 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
811 %{_infodir}/gcj*
812 %{_mandir}/man1/gcj*
813 %{_mandir}/man1/gij*
814 %{_mandir}/man1/grepjar*
815 %{_mandir}/man1/jcf-*
816 %{_mandir}/man1/jv-*
817
818 %files java-tools
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_bindir}/grmi*
821 %attr(755,root,root) %{_bindir}/fastjar
822 %{_mandir}/man1/grmi*
823 %{_mandir}/man1/fastjar*
824 %{_infodir}/fastjar*
825
826 %files -n libgcj
827 %defattr(644,root,root,755)
828 %doc libjava/{ChangeLog,LIBGCJ_LICENSE,NEWS,README,THANKS}
829 %attr(755,root,root) %{_bindir}/addr2name.awk
830 %attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
831 %attr(755,root,root) %{_libdir}/libgij.so.*.*.*
832 %attr(755,root,root) %{_libdir}/lib-org*.so.*.*.*
833 %{_libdir}/logging.properties
834
835 %files -n libgcj-devel
836 %defattr(644,root,root,755)
837 %{_includedir}/c++/%{version}/java
838 %{_includedir}/c++/%{version}/javax
839 %{_includedir}/c++/%{version}/gcj
840 %{_includedir}/c++/%{version}/gnu
841 %{_libdir}/gcc/*/*/include/gcj
842 %dir %{_libdir}/security
843 %{_libdir}/security/*
844 %dir %{_datadir}/java
845 %{_datadir}/java/libgcj*.jar
846 %{_libdir}/lib*cj.spec
847 %{_libdir}/lib*cj*.la
848 %attr(755,root,root) %{_libdir}/lib*cj*.so
849 %{_libdir}/libgij.la
850 %attr(755,root,root) %{_libdir}/libgij.so
851 %attr(755,root,root) %{_libdir}/lib-org-*.so
852 %{_libdir}/lib-org-*.la
853 %{_pkgconfigdir}/libgcj.pc
854
855 %files -n libgcj-static
856 %defattr(644,root,root,755)
857 %{_libdir}/lib*cj*.a
858 %{_libdir}/libgij.a
859 %{_libdir}/lib-org-*.a
860
861 %files -n libffi
862 %defattr(644,root,root,755)
863 %doc libffi/{ChangeLog,ChangeLog.libgcj,LICENSE,README}
864 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
865
866 %files -n libffi-devel
867 %defattr(644,root,root,755)
868 %{_libdir}/gcc/*/*/include/ffitarget.h
869 %attr(755,root,root) %{_libdir}/libffi.so
870 %{_libdir}/libffi.la
871 %{_includedir}/ffi.h
872
873 %files -n libffi-static
874 %defattr(644,root,root,755)
875 %{_libdir}/libffi.a
876 %endif
877
878 %if %{with objc}
879 %files objc
880 %defattr(644,root,root,755)
881 %doc gcc/objc/README
882 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1obj
883 %attr(755,root,root) %{_libdir}/libobjc.so
884 %{_libdir}/libobjc.la
885 %{_libdir}/gcc/*/*/include/objc
886
887 %files -n libobjc
888 %defattr(644,root,root,755)
889 %doc libobjc/{ChangeLog,README*}
890 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
891
892 %files -n libobjc-static
893 %defattr(644,root,root,755)
894 %{_libdir}/libobjc.a
895 %endif
This page took 0.083986 seconds and 4 git commands to generate.