]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- release 6.2 - still testing
[packages/gcc4.git] / gcc4.spec
1 %define         STDC_VERSION 2.10.0
2 %define         GCJ_VERSION 2.95.1
3 Summary:        GNU Compiler Collection
4 Summary(pl):    Kolekcja kompilatorów GNU
5 Name:           gcc
6 Version:        2.95.2
7 Release:        6.2
8 License:        GPL
9 Group:          Development/Languages
10 Group(pl):      Programowanie/Jêzyki
11 Source0:        ftp://ftp.gnu.org/pub/gnu/gcc/%{name}-%{version}.tar.gz
12 Source1:        ftp://sourceware.cygnus.com/pub/java/libgcj-%{GCJ_VERSION}.tar.gz
13 Source2:        gcov.1
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-pld-linux.patch
16 Patch2:         %{name}-libstdc++.patch
17 Patch3:         %{name}-bootstrap.patch
18 Patch4:         %{name}-cpp-macro-doc.patch
19 Patch5:         %{name}-default-arch.patch
20 Patch6:         %{name}-cvs-updates-20000220.patch.gz
21 Patch7:         %{name}-libstdc++-out-of-mem.patch
22 Patch8:         %{name}-libstdc++-wstring.patch
23 Patch9:         %{name}-libstdc++-wall3.patch
24 Patch10:        %{name}-libstdc++-bastring.patch
25 Patch11:        %{name}-manpage.patch
26 Patch12:        %{name}-cpp-dos-newlines.patch
27 Patch13:        %{name}-g++-is-tree.patch
28 Patch14:        %{name}-gpc.patch
29 Patch15:        %{name}-arm-config.patch
30 Patch16:        %{name}-m68k-pic.patch
31 Patch17:        %{name}-sparc32-rfi.patch
32 Patch18:        %{name}-builtin-apply.patch
33 Patch19:        %{name}-gcj-backport.patch
34 Patch20:        %{name}-ppc-ice.patch
35 Patch21:        %{name}-ppc-descriptions.patch
36 Patch22:        %{name}-ppc-andrew-dwarf-eh.patch
37
38 Patch23:        %{name}-alpha-complex-float.patch
39 Patch24:        %{name}-emit-rtl.patch
40 Patch25:        %{name}-empty-struct-init.patch
41 Patch26:        %{name}-gcj-vs-iconv.patch
42 Patch27:        %{name}-libobjc.patch
43 Patch28:        %{name}-pointer-arith.patch
44
45 Patch100:       %{name}-glibc-2.2.patch
46 Requires:       binutils >= 2.9.1.0.25
47 Requires:       cpp = %{version}
48 URL:            http://gcc.gnu.org/
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 A compiler aimed at integrating all the optimizations and features
53 necessary for a high-performance and stable development environment.
54
55 %description -l pl
56 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
57 wyprodukowania szybkiego i stablinego kodu wynikowego.
58
59 %package c++
60 Summary:        C++ support for gcc
61 Summary(fr):    Support C++ pour le compilateur gcc
62 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
63 Summary(tr):    gcc için C++ desteði
64 Group:          Development/Languages
65 Group(pl):      Programowanie/Jêzyki
66 Obsoletes:      egcc-c++
67 Obsoletes:      egcs-c++
68
69 %description c++
70 This package adds C++ support to the GNU C compiler. It includes
71 support for most of the current C++ specification, including templates
72 and exception handling. It does not include a standard C++ library,
73 which is available separately.
74
75 %description -l de c++
76 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
77 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
78 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
79 sie ist getrennt erhältlich.
80
81 %description -l fr c++
82 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
83 support pour la plupart des spécifications actuelles de C++, dont les
84 modéles et la gestion des exceptions. Il ne comprend pas une
85 bibliothéque C++ standard, qui est disponible séparément.
86
87 %description -l pl c++
88 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
89 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
90 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
91
92 %description -l tr c++
93 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
94 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
95 C++ kitaplýðý bu pakette yer almaz.
96
97 %package objc
98 Summary:        Objective C support for gcc
99 Summary(de):    Objektive C-Unterstützung für gcc
100 Summary(fr):    Gestion d'Objective C pour gcc
101 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
102 Summary(tr):    gcc için Objective C desteði
103 Group:          Development/Languages
104 Group(pl):      Programowanie/Jêzyki
105 Obsoletes:      egcc-objc
106 Obsoletes:      egcs-objc
107
108 %description objc
109 This package adds Objective C support to the GNU C compiler. Objective
110 C is a object oriented derivative of the C language, mainly used on
111 systems running NeXTSTEP. This package does not include the standard
112 objective C object library.
113
114 %description -l de objc
115 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
116 Objective C ist ein objektorientiertes Derivat von C, das zur
117 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
118 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
119
120 %description -l fr objc
121 Ce package ajoute un support Objective C au compilateur C GNU.
122 L'Objective C est un langage orienté objetdérivé du langage C,
123 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
124 pas la bibliothéque Objective C standard.
125
126 %description -l pl objc
127 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
128 pakiecie nie ma jeszcze bibliotek C-obj.
129
130 %description -l tr objc
131 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
132 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
133 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
134 kitaplýðý bu pakette yer almaz.
135
136 %package g77
137 Summary:        Fortran 77 support for gcc
138 Summary(pl):    Wspomaganie Fortran 77 dla gcc
139 Group:          Development/Languages
140 Group(pl):      Programowanie/Jêzyki
141 Obsoletes:      egcs-g77
142
143 %description g77
144 This apckage adds support for compiling Fortran 77 programs with the
145 GNU compiler.
146
147 %description -l pl g77
148 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
149 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
150
151 %package chill
152 Summary:        CHILL support for gcc
153 Summary(pl):    Wspomoganie CHILL dla gcc
154 Group:          Development/Languages
155 Group(pl):      Programowanie/Jêzyki
156 Requires:       %{name} = %{version}
157
158 %description chill
159 This package adds support for compiling CHILL programs with the GNU
160 compiler.
161
162 Chill is the "CCITT High-Level Language", where CCITT is the old name
163 for what is now ITU, the International Telecommunications Union. It is
164 is language in the Modula2 family, and targets many of the same
165 applications as Ada (especially large embedded systems). Chill was
166 never used much in the United States, but is still being used in
167 Europe, Brazil, Korea, and other places.
168
169 %package java
170 Summary:        Java support for gcc
171 Summary(pl):    Wspomoganie Java dla gcc
172 Group:          Development/Languages
173 Group(pl):      Programowanie/Jêzyki
174 Requires:       %{name} = %{version}
175 Requires:       %{name}-libgcj = %{version}
176
177 %description java
178 This package adds experimental support for compiling Java(tm) programs
179 and bytecode into native code. To use this you will also need the
180 gcc-libgcj package.
181
182 %package libgcj
183 Summary:        Java runtime library for gcc
184 Group:          Libraries
185 Group(pl):      Biblioteki
186 Group(fr):      Librairies
187 URL:            http://sourceware.cygnus.com/java/
188 Requires:       zip >= 2.1
189
190 %description libgcj
191 The Java runtime library. You will need this package to compile your
192 Java programs using the gcc Java compiler (gcj).
193
194 %package libgcj-static
195 Summary:        Static java runtime library for gcc
196 Group:          Development/Libraries
197 Group(pl):      Programowanie/Biblioteki
198 Group(fr):      Development/Librairies
199 URL:            http://sourceware.cygnus.com/java/
200 Requires:       %{name}-libgcj = %{version}
201
202 %description libgcj-static
203 The static java runtime library. You will need this package to
204 staticly compile your Java programs using the gcc Java compiler (gcj).
205
206 %package -n libstdc++
207 Summary:        GNU c++ library
208 Summary(pl):    Biblioteki GNU C++ 
209 Group:          Libraries
210 Group(pl):      Biblioteki
211 Group(fr):      Development/Librairies
212 Version:        %{STDC_VERSION}
213 Obsoletes:      libg++
214
215 %description -n libstdc++
216 This is the GNU implementation of the standard C++ libraries, along
217 with additional GNU tools. This package includes the shared libraries
218 necessary to run C++ applications.
219
220 %description -l de -n libstdc++
221 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
222 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
223 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
224
225 %description -l fr -n libstdc++
226 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
227 des outils GNU supplémentaires. Ce package comprend les librairies
228 partagées nécessaires à l'exécution d'application C++.
229
230 %description -l pl -n libstdc++  
231 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
232 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
233 uruchomienia aplikacji napisanych w C++.
234
235 %description -l tr -n libstdc++
236 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
237 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
238
239 %package -n libstdc++-devel
240 Summary:        Header files and libraries for C++ development
241 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
242 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
243 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
244 Group:          Development/Libraries
245 Group(pl):      Programowanie/Biblioteki
246 Group(fr):      Development/Librairies
247 Version:        %{STDC_VERSION}
248 Requires:       libstdc++ = %{STDC_VERSION}
249 Requires:       %{name}-c++
250 Obsoletes:      libg++-devel
251
252 %description -n libstdc++-devel
253 This is the GNU implementation of the standard C++ libraries. This
254 package includes the header files and libraries needed for C++
255 development.
256
257 %description -l pl -n libstdc++-devel
258 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
259 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
260 programowaniu w jêzyku C++.
261
262 %package -n libstdc++-static
263 Summary:        Static c++ standard library
264 Summary(pl):    Biblioeka statyczna c++
265 Group:          Development/Libraries
266 Group(pl):      Programowanie/Biblioteki
267 Group(fr):      Development/Librairies
268 Version:        %{STDC_VERSION}
269 Requires:       libstdc++-devel = %{STDC_VERSION}
270
271 %description -n libstdc++-static
272 Static c++ standard library.
273
274 %description -l pl -n libstdc++-static
275 Biblioteka statyczna C++.
276
277 %package -n cpp
278 Summary:        The C Pre Processor
279 Summary(pl):    Preprocesor C
280 Group:          Development/Languages
281 Group(pl):      Programowanie/Jêzyki
282 Obsoletes:      egcs-cpp
283
284 %description -n cpp
285 The C preprocessor is a "macro processor" that is used automatically
286 by the C compiler to transform your program before actual compilation.
287 It is called a macro processor because it allows you to define
288 "macros", which are brief abbreviations for longer constructs.
289
290 The C preprocessor provides four separate facilities that you can use
291 as you see fit:
292
293 - Inclusion of header files. These are files of declarations that can
294   be substituted into your program.
295 - Macro expansion. You can define "macros", which are abbreviations
296   for arbitrary fragments of C code, and then the C preprocessor will
297   replace the macros with their definitions throughout the program.
298 - Conditional compilation. Using special preprocessing directives, you
299   can include or exclude parts of the program according to various
300   conditions.
301 - Line control. If you use a program to combine or rearrange source
302   files into an intermediate file which is then compiled, you can use
303   line control to inform the compiler of where each source line
304   originally came from.
305
306 %description -l pl -n cpp
307 Przeprocesor C jest "makro procesorem" który jest automatycznie
308 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
309 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
310 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
311 d³ugich konstrukcji w jêzyku C.
312
313 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
314
315 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
316   deklaracji polecenia do³±czenia innego pliku.
317 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
318   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
319   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
320 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
321   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
322   fragmenty obrabianego strumienia tekstów.
323 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
324   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
325   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
326   odpowiada fragment pliku wynikowego.
327
328 %prep
329 %setup -q
330 #%setup -q -a1 -D -T
331 #mv -f libgcj-%{GCJ_VERSION} libgcj
332 #mv -f libgcj/boehm-gc libgcj/libjava libgcj/zlib libgcj/zip .
333 %patch0 -p1
334 %patch1 -p1
335 %patch2 -p1
336 %patch3 -p1
337 %patch4 -p0
338 %patch5 -p0
339 %patch6 -p1
340 %patch7 -p0
341 %patch8 -p0
342 %patch9 -p0
343 %patch10 -p0
344 %patch11 -p0
345 %patch12 -p0
346 %patch13 -p1
347 %patch14 -p1
348 %ifarch arm
349 %patch15 -p0
350 %endif
351 %ifarch m68k
352 %patch16 -p0
353 %endif
354 %ifarch sparc sparc32
355 %patch17 -p0
356 %patch18 -p0
357 %patch19 -p1
358 %endif
359 %ifarch ppc
360 %patch20 -p0
361 %patch21 -p0
362 %patch22 -p0
363 %endif
364 %ifarch alpha
365 %patch23 -p1
366 %endif
367 %patch24 -p0
368 %patch25 -p0
369 %patch26 -p0
370 %patch27 -p0
371 %patch28 -p0
372 #%patch100 -p1
373
374 %build
375 (cd gcc; autoconf)
376 rm -rf obj-%{_target_platform}
377 install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
378
379 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
380 ../configure \
381         --prefix=%{_prefix} \
382         --infodir=%{_infodir} \
383         --enable-shared \
384 %ifnarch sparc sparc64
385         --enable-threads \
386         --enable-haifa \
387 %endif
388         --with-gnu-as \
389         --with-gnu-ld \
390         --with-gxx-include-dir="\$\{prefix\}/include/g++" \
391         %{_target_platform}
392
393 PATH=$PATH:/sbin:%{_sbindir}
394 touch  ../gcc/c-gperf.h
395
396 %{__make} LDFLAGS_FOR_TARGET="-s" \
397         mandir=%{_mandir} \
398         infodir=%{_infodir}
399
400 %install
401 rm -rf $RPM_BUILD_ROOT
402 install -d $RPM_BUILD_ROOT%{_datadir}
403
404 cd obj-%{_target_platform}
405 PATH=$PATH:/sbin:%{_sbindir}
406
407 %{__make} install \
408         prefix=$RPM_BUILD_ROOT%{_prefix} \
409         mandir=$RPM_BUILD_ROOT%{_mandir} \
410         infodir=$RPM_BUILD_ROOT%{_infodir}
411
412 %{__make} install \
413         prefix=$RPM_BUILD_ROOT%{_prefix} \
414         mandir=$RPM_BUILD_ROOT%{_mandir} \
415         infodir=$RPM_BUILD_ROOT%{_infodir} -C texinfo
416
417 strip $RPM_BUILD_ROOT%{_bindir}/* || :
418
419 strip $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/{cc1,cc1chill,cc1obj,cc1plus,cpp,f771,collect2,jc1,jvgenmain}
420 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so*
421
422 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
423
424 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
425 echo .so cccp.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cpp.1
426 install %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man1/
427
428 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
429
430 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
431
432 install -d $RPM_BUILD_ROOT/lib
433 (cd $RPM_BUILD_ROOT; \
434 ln -sf ../`dirname usr/lib/gcc-lib/%{_target_cpu}*/*/cpp`/cpp $RPM_BUILD_ROOT/lib/cpp)
435
436 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/{info/*.info*,man/man1/*} \
437           ../READ* ../ChangeLog ../gcc/ch/chill.brochure
438
439 %post
440 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
441
442 %postun
443 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
444
445 %post g77
446 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
447
448 %postun g77
449 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
450
451 %post chill
452 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
453
454 %postun chill
455 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
456
457 %post -n cpp
458 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
459
460 %postun -n cpp
461 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
462
463 %post libgcj  -p /sbin/ldconfig
464
465 %post   -p /sbin/ldconfig -n libstdc++
466 %postun -p /sbin/ldconfig -n libstdc++
467
468 %clean
469 rm -rf $RPM_BUILD_ROOT
470
471 %files
472 %defattr(644,root,root,755)
473 %doc READ* ChangeLog.gz
474
475 %dir %{_libdir}/gcc-lib
476 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
477 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
478 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
479
480 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
481 %attr(755,root,root) %{_bindir}/gcc
482 %attr(755,root,root) %{_bindir}/gcov
483 %attr(755,root,root) %{_bindir}/protoize
484 %attr(755,root,root) %{_bindir}/unprotoize
485 %attr(755,root,root) %{_bindir}/cc
486
487 %{_mandir}/man1/gcc.1*
488 %{_mandir}/man1/gcov.1*
489 %{_infodir}/gcc*
490
491 %{_libdir}/gcc-lib/%{_target_cpu}*/*/SYSCALLS.c.X
492 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
493 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
494 %{_libdir}/gcc-lib/%{_target_cpu}*/*/lib*.map
495 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
496
497 %ifnarch alpha
498 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
499 %endif
500
501 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
502
503 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
504 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
505 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
506 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
507 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
508 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
509 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
510 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
511 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/va-*.h
512 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
513
514 %files c++
515 %defattr(644,root,root,755)
516
517 %{_mandir}/man1/g++.1.gz
518
519 %attr(755,root,root) %{_bindir}/g++
520 %attr(755,root,root) %{_bindir}/c++
521 %attr(755,root,root) %{_bindir}/c++filt
522 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
523
524 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/exception
525 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new
526 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/typeinfo
527 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new.h
528
529 %files objc
530 %defattr(644,root,root,755)
531
532 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
533
534 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
535 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
536
537 %files g77
538 %defattr(644,root,root,755)
539
540 %attr(755,root,root) %{_bindir}/g77
541 %attr(755,root,root) %{_bindir}/f77
542
543 %{_infodir}/g77*
544
545 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
546 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
547
548 %{_mandir}/man1/g77.1*
549 %{_mandir}/man1/f77.1*
550
551 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
552
553 %files chill
554 %defattr(644,root,root,755)
555 %doc gcc/ch/chill.brochure.gz
556
557 %attr(755,root,root) %{_bindir}/chill
558
559 %{_infodir}/chill*
560
561 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
562 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
563 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
564
565 %files java
566 %defattr(644,root,root,755)
567
568 %attr(755,root,root) %{_bindir}/gcj
569 %attr(755,root,root) %{_bindir}/gcjh
570 %attr(755,root,root) %{_bindir}/jcf-dump
571 #%attr(755,root,root) %{_bindir}/jv-convert
572 %attr(755,root,root) %{_bindir}/jv-scan
573
574 #%{_libdir}/*.spec
575
576 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
577 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
578
579 #%files libgcj
580 #%defattr(644,root,root,755)
581 #
582 #%attr(755,root,root) %{_libdir}/lib*gcj*.so
583 #%attr(755,root,root) %{_libdir}/lib*gcj*.so.*.*.*
584
585 #%files libgcj-static
586 #%defattr(644,root,root,755)
587 #
588 #%{_libdir}/lib*gcj*.a
589 #%{_libdir}/lib*gcj*.la
590
591 %files -n libstdc++
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
594
595 %files -n libstdc++-devel
596 %defattr(644,root,root,755)
597 %{_includedir}/g++
598 %attr(755,root,root) %{_libdir}/libstdc++.so
599
600 %files -n libstdc++-static
601 %defattr(644,root,root,755)
602 %attr(644,root,root) %{_libdir}/libstdc++.a
603
604 %files -n cpp
605 %defattr(644,root,root,755)
606 %attr(755,root,root) /lib/cpp
607
608 %{_mandir}/man1/cpp.1*
609 %{_mandir}/man1/cccp.1*
610 %{_infodir}/cpp.info*.gz
611
612 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp
This page took 0.134428 seconds and 4 git commands to generate.