]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- changed source to .bz2
[packages/gcc4.git] / gcc4.spec
1 %define         SNAP            20020218
2 %define         DASHED_SNAP     2002-02-18
3 %define         GCC_VERSION     3.1
4 %define         STDC_VERSION    3.1
5 %define         GCJ_VERSION     3.1
6 %define         KSI_VERSION     pre47
7 Summary:        GNU Compiler Collection
8 Summary(pl):    Kolekcja kompilatorów GNU
9 Name:           gcc
10 Version:        %{GCC_VERSION}
11 Release:        0.%{SNAP}.1
12 License:        GPL
13 Group:          Development/Languages
14 Group(de):      Entwicklung/Sprachen
15 Group(pl):      Programowanie/Jêzyki
16 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/%{DASHED_SNAP}/%{name}-%{SNAP}.tar.bz2
17 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
18 Patch0:         gcc-slibdir.patch
19 Patch1:         gcc-paths.patch
20 BuildRequires:  bison
21 BuildRequires:  texinfo
22 BuildRequires:  zlib-devel
23 BuildRequires:  fileutils >= 4.0.41
24 BuildRequires:  autoconf
25 Requires:       binutils >= 2.9.1.0.25
26 Requires:       cpp = %{version}
27 URL:            http://gcc.gnu.org/
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _slibdir        /lib
31
32 %description
33 A compiler aimed at integrating all the optimizations and features
34 necessary for a high-performance and stable development environment.
35
36 %description -l pl
37 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
38 wyprodukowania szybkiego i stablinego kodu wynikowego.
39
40 %package c++
41 Summary:        C++ support for gcc
42 Summary(fr):    Support C++ pour le compilateur gcc
43 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
44 Summary(tr):    gcc için C++ desteði
45 Group:          Development/Languages
46 Group(de):      Entwicklung/Sprachen
47 Group(pl):      Programowanie/Jêzyki
48 Obsoletes:      egcc-c++
49 Obsoletes:      egcs-c++
50
51 %description c++
52 This package adds C++ support to the GNU C compiler. It includes
53 support for most of the current C++ specification, including templates
54 and exception handling. It does not include a standard C++ library,
55 which is available separately.
56
57 %description -l de c++
58 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
59 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
60 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
61 sie ist getrennt erhältlich.
62
63 %description -l fr c++
64 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
65 support pour la plupart des spécifications actuelles de C++, dont les
66 modéles et la gestion des exceptions. Il ne comprend pas une
67 bibliothéque C++ standard, qui est disponible séparément.
68
69 %description -l pl c++
70 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
71 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
72 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
73
74 %description -l tr c++
75 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
76 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
77 C++ kitaplýðý bu pakette yer almaz.
78
79 %package objc
80 Summary:        Objective C support for gcc
81 Summary(de):    Objektive C-Unterstützung für gcc
82 Summary(fr):    Gestion d'Objective C pour gcc
83 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
84 Summary(tr):    gcc için Objective C desteði
85 Group:          Development/Languages
86 Group(de):      Entwicklung/Sprachen
87 Group(pl):      Programowanie/Jêzyki
88 Obsoletes:      egcc-objc
89 Obsoletes:      egcs-objc
90 Requires:       libobjc = %{GCC_VERSION}
91 Requires:       gcc = %{GCC_VERSION}
92
93 %description objc
94 This package adds Objective C support to the GNU C compiler. Objective
95 C is a object oriented derivative of the C language, mainly used on
96 systems running NeXTSTEP. This package does not include the standard
97 objective C object library.
98
99 %description -l de objc
100 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
101 Objective C ist ein objektorientiertes Derivat von C, das zur
102 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
103 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
104
105 %description -l fr objc
106 Ce package ajoute un support Objective C au compilateur C GNU.
107 L'Objective C est un langage orienté objetdérivé du langage C,
108 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
109 pas la bibliothéque Objective C standard.
110
111 %description -l pl objc
112 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
113 pakiecie nie ma jeszcze bibliotek C-obj.
114
115 %description -l tr objc
116 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
117 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
118 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
119 kitaplýðý bu pakette yer almaz.
120
121 %package -n libobjc
122 Summary:        Objective C Libraries
123 Summary(pl):    Biblioteki Obiektowego C
124 Group:          Libraries
125 Group(de):      Libraries
126 Group(es):      Bibliotecas
127 Group(fr):      Librairies
128 Group(pl):      Biblioteki
129
130 %description -n libobjc
131 Objective C Libraries
132
133 %description -n libobjc -l pl
134 Biblioteki Obiektowego C
135
136 %package -n libobjc-static
137 Summary:        Static Objective C Libraries
138 Summary(pl):    Statyczne Biblioteki Obiektowego C
139 Group:          Development/Libraries
140 Group(de):      Entwicklung/Libraries
141 Group(fr):      Development/Librairies
142 Group(pl):      Programowanie/Biblioteki
143 Epoch:          2
144 Requires:       libobjc = %{GCC_VERSION}
145
146 %description -n libobjc-static
147 Static Objective C Libraries
148
149 %description -l pl -n libobjc-static
150 Statyczne Obiektowego C
151
152 %package g77
153 Summary:        Fortran 77 support for gcc
154 Summary(pl):    Wspomaganie Fortran 77 dla gcc
155 Group:          Development/Languages
156 Group(de):      Entwicklung/Sprachen
157 Group(pl):      Programowanie/Jêzyki
158 Obsoletes:      egcs-g77
159 Requires:       libg2c = %{GCC_VERSION}
160
161 %description g77
162 This apckage adds support for compiling Fortran 77 programs with the
163 GNU compiler.
164
165 %description -l pl g77
166 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
167 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
168
169 %package -n libg2c
170 Summary:        Fortran 77 Libraries
171 Summary(pl):    Biblioteki Fortranu 77
172 Group:          Libraries
173 Group(de):      Libraries
174 Group(es):      Bibliotecas
175 Group(fr):      Librairies
176 Group(pl):      Biblioteki
177
178 %description -n libg2c
179 Fortran 77 Libraries
180
181 %description -n libg2c -l pl
182 Biblioteki Fortranu 77
183
184 %package -n libg2c-static
185 Summary:        Static Fortran 77 Libraries
186 Summary(pl):    Statyczne Biblioteki Fortranu 77
187 Group:          Development/Libraries
188 Group(de):      Entwicklung/Libraries
189 Group(fr):      Development/Librairies
190 Group(pl):      Programowanie/Biblioteki
191 Epoch:          2
192 Requires:       libg2c = %{GCC_VERSION}
193
194 %description -n libg2c-static
195 Static Fortran 77 Libraries
196
197 %description -l pl -n libg2c-static
198 Statyczne Fortranu 77
199
200 %package chill
201 Summary:        CHILL support for gcc
202 Summary(pl):    Wspomoganie CHILL dla gcc
203 Group:          Development/Languages
204 Group(de):      Entwicklung/Sprachen
205 Group(pl):      Programowanie/Jêzyki
206 Requires:       %{name} = %{version}
207
208 %description chill
209 This package adds support for compiling CHILL programs with the GNU
210 compiler.
211
212 Chill is the "CCITT High-Level Language", where CCITT is the old name
213 for what is now ITU, the International Telecommunications Union. It is
214 is language in the Modula2 family, and targets many of the same
215 applications as Ada (especially large embedded systems). Chill was
216 never used much in the United States, but is still being used in
217 Europe, Brazil, Korea, and other places.
218
219 %package java
220 Summary:        Java support for gcc
221 Summary(pl):    Wspomoganie Java dla gcc
222 Group:          Development/Languages
223 Group(de):      Entwicklung/Sprachen
224 Group(pl):      Programowanie/Jêzyki
225 Requires:       %{name} = %{version}
226 Requires:       libgcj >= 3.0.0
227
228 %description java
229 This package adds experimental support for compiling Java(tm) programs
230 and bytecode into native code. To use this you will also need the
231 libgcj package.
232
233 %description -l pl java
234 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
235 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
236 przeprowadziæ kompilacjê.
237
238 %package -n libgcj
239 Summary:        Java Class Libraries
240 Summary(pl):    Biblioteki Klas Javy
241 Group:          Libraries
242 Group(de):      Libraries
243 Group(es):      Bibliotecas
244 Group(fr):      Librairies
245 Group(pl):      Biblioteki
246 Version:        %{GCJ_VERSION}
247 Epoch:          2
248 Requires:       zlib
249
250 %description -n libgcj
251 Java Class Libraries
252
253 %description -n libgcj -l pl
254 Biblioteki Klass Javy
255
256 %package -n libgcj-devel
257 Summary:        Development files for Java Class Libraries
258 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
259 Group:          Development/Libraries
260 Group(de):      Entwicklung/Libraries
261 Group(fr):      Development/Librairies
262 Group(pl):      Programowanie/Biblioteki
263 Version:        %{GCJ_VERSION}
264 Epoch:          2
265 Requires:       libgcj = %{GCJ_VERSION}
266 Requires:       %{name}-java
267
268 %description -n libgcj-devel
269 Development files for Java Class Libraries
270
271 %description -n libgcj-devel -l pl
272 Pliki nag³ówkowe dla Bibliotek Klass Javy
273
274 %package -n libgcj-static
275 Summary:        Static Java Class Libraries
276 Summary(pl):    Statyczne Biblioteki Klass Javy
277 Group:          Development/Libraries
278 Group(de):      Entwicklung/Libraries
279 Group(fr):      Development/Librairies
280 Group(pl):      Programowanie/Biblioteki
281 Version:        %{GCJ_VERSION}
282 Epoch:          2
283 Requires:       libstdc++-devel = %{GCJ_VERSION}
284
285 %description -n libgcj-static
286 Static Java Class Libraries
287
288 %description -l pl -n libgcj-static
289 Statyczne Biblioteki Klass Javy
290
291 %package -n libstdc++
292 Summary:        GNU c++ library
293 Summary(pl):    Biblioteki GNU C++ 
294 Group:          Libraries
295 Group(de):      Libraries
296 Group(es):      Bibliotecas
297 Group(fr):      Librairies
298 Group(pl):      Biblioteki
299 Version:        %{STDC_VERSION}
300 Obsoletes:      libg++
301
302 %description -n libstdc++
303 This is the GNU implementation of the standard C++ libraries, along
304 with additional GNU tools. This package includes the shared libraries
305 necessary to run C++ applications.
306
307 %description -l de -n libstdc++
308 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
309 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
310 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
311
312 %description -l fr -n libstdc++
313 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
314 des outils GNU supplémentaires. Ce package comprend les librairies
315 partagées nécessaires à l'exécution d'application C++.
316
317 %description -l pl -n libstdc++  
318 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
319 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
320 uruchomienia aplikacji napisanych w C++.
321
322 %description -l tr -n libstdc++
323 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
324 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
325
326 %package -n libstdc++-devel
327 Summary:        Header files and libraries for C++ development
328 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
329 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
330 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
331 Group:          Development/Libraries
332 Group(de):      Entwicklung/Libraries
333 Group(fr):      Development/Librairies
334 Group(pl):      Programowanie/Biblioteki
335 Version:        %{STDC_VERSION}
336 Requires:       libstdc++ = %{STDC_VERSION}
337 Requires:       %{name}-c++
338 Obsoletes:      libg++-devel
339
340 %description -n libstdc++-devel
341 This is the GNU implementation of the standard C++ libraries. This
342 package includes the header files and libraries needed for C++
343 development.
344
345 %description -l pl -n libstdc++-devel
346 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
347 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
348 programowaniu w jêzyku C++.
349
350 %package -n libstdc++-static
351 Summary:        Static c++ standard library
352 Summary(pl):    Biblioteka statyczna c++
353 Group:          Development/Libraries
354 Group(de):      Entwicklung/Libraries
355 Group(fr):      Development/Librairies
356 Group(pl):      Programowanie/Biblioteki
357 Version:        %{STDC_VERSION}
358 Requires:       libstdc++-devel = %{STDC_VERSION}
359
360 %description -n libstdc++-static
361 Static c++ standard library.
362
363 %description -l pl -n libstdc++-static
364 Biblioteka statyczna C++.
365
366 %package -n libgcc
367 Summary:        Shared gcc library
368 Summary(pl):    Biblioteka gcc
369 Group:          Libraries
370 Group(de):      Libraries
371 Group(fr):      Librairies
372 Group(pl):      Biblioteki
373 Version:        %{version}
374
375 %description -n libgcc
376 Shared gcc library.
377
378 %description -l pl -n libgcc
379 Biblioteka dynamiczna gcc.
380
381 %package -n cpp
382 Summary:        The C Pre Processor
383 Summary(pl):    Preprocesor C
384 Group:          Development/Languages
385 Group(de):      Entwicklung/Sprachen
386 Group(pl):      Programowanie/Jêzyki
387 Version:        %{version}
388 Obsoletes:      egcs-cpp
389 Obsoletes:      gcc-cpp
390
391 %description -n cpp
392 The C preprocessor is a "macro processor" that is used automatically
393 by the C compiler to transform your program before actual compilation.
394 It is called a macro processor because it allows you to define
395 "macros", which are brief abbreviations for longer constructs.
396
397 The C preprocessor provides four separate facilities that you can use
398 as you see fit:
399
400 - Inclusion of header files. These are files of declarations that can
401   be substituted into your program.
402 - Macro expansion. You can define "macros", which are abbreviations
403   for arbitrary fragments of C code, and then the C preprocessor will
404   replace the macros with their definitions throughout the program.
405 - Conditional compilation. Using special preprocessing directives, you
406   can include or exclude parts of the program according to various
407   conditions.
408 - Line control. If you use a program to combine or rearrange source
409   files into an intermediate file which is then compiled, you can use
410   line control to inform the compiler of where each source line
411   originally came from.
412
413 %description -l pl -n cpp
414 Przeprocesor C jest "makro procesorem" który jest automatycznie
415 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
416 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
417 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
418 d³ugich konstrukcji w jêzyku C.
419
420 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
421
422 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
423   deklaracji polecenia do³±czenia innego pliku.
424 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
425   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
426   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
427 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
428   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
429   fragmenty obrabianego strumienia tekstów.
430 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
431   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
432   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
433   odpowiada fragment pliku wynikowego.
434
435 %package ksi
436 Summary:        Ksi support for gcc
437 Summary(pl):    Wspomoganie Ksi dla gcc
438 Version:        %{GCC_VERSION}.%{KSI_VERSION}
439 Group:          Development/Languages
440 Group(de):      Entwicklung/Sprachen
441 Group(pl):      Programowanie/Jêzyki
442 Requires:       gcc = %{GCC_VERSION}
443
444 %description ksi
445 This package adds experimental support for compiling Ksi programs
446 into native code. You proabably don't need it, unless your are going
447 to develop a compiler using Ksi as intermediate representation or
448 you are using such compiler (like Gont).
449
450 %description -l pl ksi
451 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
452 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
453 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jakos reprezentacji
454 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
455
456
457 %prep
458 %setup -q -a1 -n %{name}-%{SNAP}
459 mv ksi-%{KSI_VERSION} gcc/ksi
460 %patch0 -p1
461 %patch1 -p1
462
463 %build
464 # cd gcc && autoconf; cd ..
465 # autoconf is not needed!
466 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
467
468 CFLAGS="%{rpmcflags}" \
469 CXXFLAGS="%{rpmcflags}" \
470 TEXCONFIG=false ../configure \
471         --prefix=%{_prefix} \
472         --infodir=%{_infodir} \
473         --mandir=%{_mandir} \
474         --enable-shared \
475         --enable-threads=posix \
476         --enable-languages="c,c++,f77,gcov,java,objc,ksi" \
477         --enable-long-long \
478         --enable-multilib \
479         --with-gnu-as \
480         --with-gnu-ld \
481         --with-system-zlib \
482         --with-slibdir=%{_slibdir} \
483         --without-x \
484         %{_target_platform}
485
486 PATH=$PATH:/sbin:%{_sbindir}
487
488 cd ..
489 %{__make} -C obj-%{_target_platform} bootstrap-lean \
490         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
491         mandir=%{_mandir} \
492         infodir=%{_infodir}
493
494 %install
495 rm -rf $RPM_BUILD_ROOT
496 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
497
498 cd obj-%{_target_platform}
499 PATH=$PATH:/sbin:%{_sbindir}
500
501 %{__make} install \
502         prefix=$RPM_BUILD_ROOT%{_prefix} \
503         mandir=$RPM_BUILD_ROOT%{_mandir} \
504         infodir=$RPM_BUILD_ROOT%{_infodir} \
505         slibdir=$RPM_BUILD_ROOT/lib
506
507 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
508 echo .so gcc.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
509
510 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
511 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
512
513 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
514  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/ ; \
515  ln -sf ../../../${LIBSTDC} libstdc++.so)
516
517 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
518         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
519
520 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
521
522 cd ..
523 gzip -9nf READ* ChangeLog
524 gzip -9nf gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
525
526 mkdir java-doc
527 mv -f libjava/doc/cni.sgml libjava/READ* java-doc
528 mv -f fastjar/README java-doc/README.fastjar
529 mv -f libffi/README java-doc/README.libffi
530 mv -f libffi/LICENSE java-doc/LICENSE.libffi
531 gzip -9nf java-doc/*
532
533 mv libobjc/README gcc/objc/README.libobjc
534 gzip -9nf gcc/objc/READ*
535
536 %find_lang %{name}
537
538 %post
539 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
540
541 %postun
542 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
543
544 %post g77
545 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
546
547 %postun g77
548 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
549
550 %post chill
551 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
552
553 %postun chill
554 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
555
556 %post java
557 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
558
559 %postun java
560 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
561
562 %post -n cpp
563 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
564
565 %postun -n cpp
566 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
567
568 %post ksi
569 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
570
571 %postun ksi
572 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
573
574 %post   -p /sbin/ldconfig -n libgcc
575 %postun -p /sbin/ldconfig -n libgcc
576 %post   -p /sbin/ldconfig -n libstdc++
577 %postun -p /sbin/ldconfig -n libstdc++
578 %post   -p /sbin/ldconfig -n libgcj
579 %postun -p /sbin/ldconfig -n libgcj
580 %post   -p /sbin/ldconfig -n libg2c
581 %postun -p /sbin/ldconfig -n libg2c
582 %post   -p /sbin/ldconfig -n libobjc
583 %postun -p /sbin/ldconfig -n libobjc
584
585 %clean
586 rm -rf $RPM_BUILD_ROOT
587
588 %files -f %{name}.lang
589 %defattr(644,root,root,755)
590 %doc READ* ChangeLog.gz
591 %dir %{_libdir}/gcc-lib
592 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
593 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
594 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
595 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
596 %attr(755,root,root) %{_bindir}/gcc
597 %attr(755,root,root) %{_bindir}/gccbug
598 %attr(755,root,root) %{_bindir}/gcov
599 %attr(755,root,root) %{_bindir}/cc
600
601 %{_mandir}/man1/gcc.1*
602 %{_mandir}/man1/cc.1*
603 %{_mandir}/man1/gcov.1*
604 %{_infodir}/gcc*
605
606 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
607 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
608 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
609 #%ifnarch alpha
610 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
611 #%endif
612 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
613 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
614
615 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
616 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
617 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
618 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
619 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
620 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
621 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
622 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
623 %ifarch %{ix86}
624 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/mmintrin.h
625 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/xmmintrin.h
626 %endif
627
628 %files c++
629 %defattr(644,root,root,755)
630 %{_mandir}/man1/g++.1.gz
631 %attr(755,root,root) %{_bindir}/g++
632 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
633 %attr(755,root,root) %{_bindir}/c++
634 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
635 %attr(755,root,root) %{_bindir}/c++filt
636 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
637 %attr(755,root,root) %{_libdir}/libsupc++.la
638 %{_libdir}/libsupc++.a
639
640 %files objc
641 %defattr(644,root,root,755)
642 %doc gcc/objc/*.gz
643 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
644 %attr(755,root,root) %{_libdir}/libobjc.so
645 %attr(755,root,root) %{_libdir}/libobjc.la
646 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
647
648 %files -n libobjc
649 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
650
651 %files -n libobjc-static
652 %{_libdir}/libobjc.a
653
654 %files g77
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_bindir}/g77
657 %attr(755,root,root) %{_bindir}/f77
658 %{_infodir}/g77*
659 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
660 %attr(755,root,root) %{_libdir}/libg2c.la
661 %attr(755,root,root) %{_libdir}/libg2c.so
662 %{_mandir}/man1/g77.1*
663 %{_mandir}/man1/f77.1*
664 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
665
666 %files -n libg2c
667 %attr(755,root,root) %{_libdir}/libg2c.so.*.*.*
668
669 %files -n libg2c-static
670 %{_libdir}/libg2c.a
671
672 %files ksi
673 %doc gcc/ksi/*.gz gcc/ksi/t/*.gz
674 %defattr(644,root,root,755)
675 %{_infodir}/ksi*
676 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
677
678 %ifarch no_longer_supported_by_gcc_team
679 %files chill
680 %defattr(644,root,root,755)
681 %doc gcc/ch/chill.brochure.gz
682
683 %attr(755,root,root) %{_bindir}/chill
684 %{_infodir}/chill*
685 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
686 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
687 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
688 %endif
689
690 %files java
691 %defattr(644,root,root,755)
692 %doc java-doc/*.gz
693 %attr(755,root,root) %{_bindir}/gcj*
694 %attr(755,root,root) %{_bindir}/gij
695 %attr(755,root,root) %{_bindir}/jcf-dump
696 %attr(755,root,root) %{_bindir}/jv-*
697 %attr(755,root,root) %{_bindir}/rmi*
698 %attr(755,root,root) %{_bindir}/jar
699 %attr(755,root,root) %{_bindir}/grepjar
700 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
701 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
702 %{_infodir}/gcj*
703 %{_mandir}/man1/jcf-*
704 %{_mandir}/man1/jv-*
705 %{_mandir}/man1/gij*
706 %{_mandir}/man1/gcj*
707
708 %files -n libgcj
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_bindir}/addr2name.awk
711 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
712
713 %files -n libgcj-devel
714 %defattr(644,root,root,755)
715 %{_includedir}/java
716 %{_includedir}/javax
717 %{_includedir}/org
718 %{_includedir}/gcj
719 %{_includedir}/j*.h
720 %{_includedir}/gnu/*
721 %{_libdir}/lib*cj.spec
722 %{_libdir}/security/*
723 %{_datadir}/libgcj.jar
724 %attr(755,root,root) %{_libdir}/lib*cj*.la
725 %attr(755,root,root) %{_libdir}/lib*cj*.so
726
727 %files -n libgcj-static
728 %defattr(644,root,root,755)
729 %{_libdir}/lib*cj*.a
730
731 %files -n libstdc++
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
734
735 %files -n libstdc++-devel
736 %defattr(644,root,root,755)
737 %doc libstdc++-v3/docs/html
738 %{_includedir}/g++*
739 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
740
741 %files -n libstdc++-static
742 %defattr(644,root,root,755)
743 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
744
745 %files -n libgcc
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_slibdir}/lib*.so*
748
749 %files -n cpp
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_slibdir}/cpp
752 %attr(755,root,root) %{_bindir}/cpp
753 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
754 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
755 %{_mandir}/man1/cpp.1*
756 %{_infodir}/cpp*
This page took 0.104453 seconds and 4 git commands to generate.