]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- renamed and moved to GCC_4 branch.
[packages/gcc4.git] / gcc4.spec
1 #
2 # TODO:
3 #               - http://gcc.gnu.org/PR11203
4 #               - http://gcc.gnu.org/PR18648
5 #               - disable internal zlib usage
6 #               - obsoletes
7 #               - bconds
8 #               - translations from gcc.spec:HEAD
9 #
10 %define         _snap           20041205
11 #
12 Summary:        GNU Compiler Collection: the C compiler and shared files
13 Summary(pl):    Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
14 Name:           gcc
15 Version:        4.0.0
16 Release:        0.%{_snap}.0.1
17 License:        GPL
18 Group:          Development/Languages
19 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
20 #Source0:       ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
21 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/%{name}-4.0-%{_snap}.tar.bz2
22 # Source0-md5:  18a3dfafa963ba3b8111a86c7ddeba05
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-nolocalefiles.patch
25 Patch2:         %{name}-nodebug.patch
26 Patch3:         %{name}-ada-link-new-libgnat.patch
27 Patch4:         %{name}-ada-link.patch
28 URL:            http://gcc.gnu.org/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  binutils >= 2:2.15.94.0.1
32 BuildRequires:  bison
33 BuildRequires:  fileutils >= 4.0.41
34 BuildRequires:  flex
35 BuildRequires:  gcc(ada)
36 BuildRequires:  gcc-ada
37 BuildRequires:  gettext-devel
38 BuildRequires:  glibc-devel >= 2.2.5-20
39 BuildRequires:  gmp-devel
40 BuildRequires:  libmpfr-devel
41 BuildRequires:  perl-devel
42 BuildRequires:  texinfo >= 4.1
43 BuildRequires:  zlib-devel
44 Requires:       binutils >= 2:2.15.94.0.1
45 Requires:       libgcc = %{epoch}:%{version}-%{release}
46 Provides:       cpp = %{epoch}:%{version}-%{release}
47 Provides:       gcc(ada)
48 Conflicts:      glibc-devel < 2.2.5-20
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _slibdir        /%{_lib}
52
53 %description
54 A compiler aimed at integrating all the optimizations and features
55 necessary for a high-performance and stable development environment.
56
57 This package contains the C compiler and some files shared by various
58 parts of the GNU Compiler Collection. In order to use another GCC
59 compiler you will need to install the appropriate subpackage.
60
61 %description -l pl
62 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
63 wyprodukowania szybkiego i stabilnego kodu wynikowego.
64
65 Ten pakiet zawiera kompilator C i pliki wspó³dzielone przez ró¿ne
66 czê¶ci kolekcji kompilatorów GNU (GCC). ¯eby u¿ywaæ innego kompilatora
67 z GCC, trzeba zainstalowaæ odpowiedni podpakiet.
68
69 %package -n libgcc
70 Summary:        Shared gcc library
71 Summary(pl):    Biblioteka gcc
72 Group:          Libraries
73
74 %description -n libgcc
75 Shared gcc library.
76
77 %description -n libgcc -l pl
78 Biblioteka dynamiczna gcc.
79
80 %package -n libmudflap
81 Summary:        GCC mudflap shared support library
82 Group:          Libraries
83
84 %description -n libmudflap
85 The libmudflap libraries are used by GCC for instrumenting pointer and
86 array dereferencing operations.
87
88 %package -n libmudflap-devel
89 Summary:        Development files for GCC mudflap library
90 Group:          Development/Libraries
91 Requires:       libmudflap = %{epoch}:%{version}-%{release}
92
93 %description -n libmudflap-devel
94 The libmudflap libraries are used by GCC for instrumenting pointer and
95 array dereferencing operations. This package contains development
96 files.
97
98 %package -n libmudflap-static
99 Summary:        Static GCC mudflap library
100 Group:          Development/Libraries
101 Requires:       libmudflap-devel = %{epoch}:%{version}-%{release}
102
103 %description -n libmudflap-static
104 The libmudflap libraries are used by GCC for instrumenting pointer and
105 array dereferencing operations. This package contains static
106 libraries.
107
108 %package ada
109 Summary:        Ada support for gcc
110 Summary(pl):    Obs³uga Ady do gcc
111 Group:          Development/Languages
112 Requires:       %{name} = %{epoch}:%{version}-%{release}
113 Requires:       libgnat = %{epoch}:%{version}-%{release}
114
115 %description ada
116 This package adds experimental support for compiling Ada programs.
117
118 %description ada -l pl
119 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów w
120 Adzie.
121
122 %package -n libgnat
123 Summary:        Ada standard libraries
124 Summary(pl):    Biblioteki standardowe dla Ady
125 Group:          Development/Libraries
126
127 %description -n libgnat
128 This package contains shared libraries needed to run programs written
129 in Ada.
130
131 %description -n libgnat -l pl
132 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów
133 napisanych w Adzie.
134
135 %package -n libgnat-static
136 Summary:        Static Ada standard libraries
137 Summary(pl):    Statyczne biblioteki standardowe dla Ady
138 Group:          Development/Libraries
139
140 %description -n libgnat-static
141 This package contains static libraries for programs written in Ada.
142
143 %description -n libgnat-static -l pl
144 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
145 Adzie.
146
147 %package c++
148 Summary:        C++ support for gcc
149 Summary(pl):    Obs³uga C++ dla gcc
150 Group:          Development/Languages
151 Requires:       %{name} = %{epoch}:%{version}-%{release}
152 Obsoletes:      egcc-c++
153 Obsoletes:      egcs-c++
154
155 %description c++
156 This package adds C++ support to the GNU Compiler Collection. It
157 includes support for most of the current C++ specification, including
158 templates and exception handling. It does not include a standard C++
159 library, which is available separately.
160
161 %description c++ -l pl
162 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
163 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
164 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
165
166 %package -n libstdc++
167 Summary:        GNU C++ library
168 Summary(pl):    Biblioteki GNU C++
169 Group:          Libraries
170
171 %description -n libstdc++
172 This is the GNU implementation of the standard C++ libraries, along
173 with additional GNU tools. This package includes the shared libraries
174 necessary to run C++ applications.
175
176 %description -n libstdc++ -l pl
177 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
178 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
179 uruchomienia aplikacji napisanych w C++.
180
181 %package -n libstdc++-devel
182 Summary:        Header files and documentation for C++ development
183 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
184 Group:          Development/Libraries
185 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
186 Requires:       libstdc++ = %{epoch}:%{version}-%{release}
187
188 %description -n libstdc++-devel
189 This is the GNU implementation of the standard C++ libraries. This
190 package includes the header files needed for C++ development and
191 library documentation.
192
193 %description -n libstdc++-devel -l pl
194 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
195 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
196 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
197
198 %package -n libstdc++-static
199 Summary:        Static C++ standard library
200 Summary(pl):    Statyczna biblioteka standardowa C++
201 Group:          Development/Libraries
202 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
203
204 %description -n libstdc++-static
205 Static C++ standard library.
206
207 %description -n libstdc++-static -l pl
208 Statyczna biblioteka standardowa C++.
209
210 %package fortran
211 Summary:        Fortran 95 support for gcc
212 Summary(pl):    Obs³uga Fortranu 95 dla gcc
213 Group:          Development/Languages/Fortran
214 Requires:       libgfortran = %{epoch}:%{version}-%{release}
215
216 %description fortran
217 This package adds support for compiling Fortran 95 programs with the
218 GNU compiler.
219
220 %description fortran -l pl
221 Ten pakiet dodaje obs³ugê Fortranu 95 do kompilatora gcc. Jest
222 potrzebny do kompilowania programów pisanych w jêzyku Fortran 95.
223
224 %package -n libgfortran
225 Summary:        Fortran 95 Libraries
226 Summary(pl):    Biblioteki Fortranu 95
227 Group:          Development/Libraries
228
229 %description -n libgfortran
230 Fortran 95 Libraries.
231
232 %description -n libgfortran -l pl
233 Biblioteki Fortranu 95.
234
235 %package -n libgfortran-static
236 Summary:        Static Fortran 95 Libraries
237 Summary(pl):    Statyczne Biblioteki Fortranu 95
238 Group:          Development/Libraries
239 Requires:       libgfortran = %{epoch}:%{version}-%{release}
240
241 %description -n libgfortran-static
242 Static Fortran 95 Libraries.
243
244 %description -n libgfortran-static -l pl
245 Statyczne biblioteki Fortranu 95.
246
247 %package java
248 Summary:        Java support for gcc
249 Summary(pl):    Obs³uga Javy dla gcc
250 Group:          Development/Languages/Java
251 Requires:       %{name} = %{epoch}:%{version}-%{release}
252 Requires:       libgcj = %{epoch}:%{version}-%{release}
253 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
254 Requires:       java-shared
255 Provides:       gcj = %{epoch}:%{version}-%{release}
256
257 %description java
258 This package adds experimental support for compiling Java(tm) programs
259 and bytecode into native code. To use this you will also need the
260 libgcj package.
261
262 %description java -l pl
263 Wsparcie dla kompilowania programów Java(tm) zarówno do bajt-kodu jak
264 i do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
265 by³o przeprowadziæ kompilacjê.
266
267 %package -n libgcj
268 Summary:        Java Class Libraries
269 Summary(pl):    Biblioteki Klas Javy
270 Group:          Libraries
271 Requires:       zlib
272
273 %description -n libgcj
274 Java Class Libraries.
275
276 %description -n libgcj -l pl
277 Biblioteki Klas Javy.
278
279 %package -n libgcj-devel
280 Summary:        Development files for Java Class Libraries
281 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
282 Group:          Development/Libraries
283 Requires:       %{name}-java = %{epoch}:%{version}-%{release}
284 Requires:       libgcj = %{epoch}:%{version}-%{release}
285
286 %description -n libgcj-devel
287 Development files for Java Class Libraries.
288
289 %description -n libgcj-devel -l pl
290 Pliki nag³ówkowe dla Bibliotek Klas Javy.
291
292 %package -n libgcj-static
293 Summary:        Static Java Class Libraries
294 Summary(pl):    Statyczne Biblioteki Klas Javy
295 Group:          Development/Libraries
296 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
297 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
298
299 %description -n libgcj-static
300 Static Java Class Libraries.
301
302 %description -n libgcj-static -l pl
303 Statyczne Biblioteki Klas Javy.
304
305 %package -n libffi
306 Summary:        Foreign Function Interface library
307 Summary(pl):    Biblioteka zewnêtrznych wywo³añ funkcji
308 Group:          Libraries
309
310 %description -n libffi
311 The libffi library provides a portable, high level programming
312 interface to various calling conventions. This allows a programmer to
313 call any function specified by a call interface description at run
314 time.
315
316 %description -n libffi -l pl
317 Biblioteka libffi dostarcza przeno¶nego, wysokopoziomowego
318 miêdzymordzia do ró¿nych konwencji wywo³añ funkcji. Pozwala to
319 programi¶cie wywo³ywaæ dowolne funkcje podaj±c konwencjê wywo³ania w
320 czasie wykonania.
321
322 %package -n libffi-devel
323 Summary:        Development files for Foreign Function Interface library
324 Summary(pl):    Pliki nag³ówkowe dla libffi
325 Group:          Development/Libraries
326 Requires:       libffi = %{epoch}:%{version}-%{release}
327
328 %description -n libffi-devel
329 Development files for Foreign Function Interface library.
330
331 %description -n libffi-devel -l pl
332 Pliki nag³ówkowe dla libffi.
333
334 %package -n libffi-static
335 Summary:        Static Foreign Function Interface library
336 Summary(pl):    Statyczna biblioteka libffi
337 Group:          Development/Libraries
338 Requires:       libffi-devel = %{epoch}:%{version}-%{release}
339
340 %description -n libffi-static
341 Static Foreign Function Interface library.
342
343 %description -n libffi-static -l pl
344 Statyczna biblioteka libffi.
345
346 %package java-tools
347 Summary:        Shared java tools
348 Summary(pl):    Wspó³dzielone narzêdzia javy
349 Group:          Development/Languages/Java
350 Provides:       jar = %{epoch}:%{version}-%{release}
351 Provides:       java-shared
352 Obsoletes:      fastjar
353 Obsoletes:      java-shared
354 Obsoletes:      jar
355
356 %description java-tools
357 This package contains tools that are common for every Java(tm)
358 implementation, such as rmic or jar.
359
360 %description java-tools -l pl
361 Pakiet ten zawiera narzêdzia wspólne dla ka¿dej implementacji
362 Javy(tm), takie jak rmic czy jar.
363
364 %package objc
365 Summary:        Objective C support for gcc
366 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
367 Group:          Development/Languages
368 Requires:       %{name} = %{epoch}:%{version}-%{release}
369 Requires:       libobjc = %{epoch}:%{version}-%{release}
370
371 %description objc
372 This package adds Objective C support to the GNU Compiler Collection.
373 Objective C is a object oriented derivative of the C language, mainly
374 used on systems running NeXTSTEP. This package does not include the
375 standard objective C object library.
376
377 %description objc -l pl
378 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
379 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
380 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
381 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
382
383 %package -n libobjc
384 Summary:        Objective C Libraries
385 Summary(pl):    Biblioteki Obiektowego C
386 Group:          Libraries
387
388 %description -n libobjc
389 Objective C Libraries.
390
391 %description -n libobjc -l pl
392 Biblioteki Obiektowego C.
393
394 %package -n libobjc-static
395 Summary:        Static Objective C Libraries
396 Summary(pl):    Statyczne Biblioteki Obiektowego C
397 Group:          Development/Libraries
398 Requires:       libobjc = %{epoch}:%{version}-%{release}
399
400 %description -n libobjc-static
401 Static Objective C Libraries.
402
403 %description -n libobjc-static -l pl
404 Statyczne biblioteki Obiektowego C.
405
406 %prep
407 # prerelease
408 #setup -q -n gcc-%{version}-%{_snap}
409 # snapshot
410 %setup -q -n gcc-4.0-%{_snap}
411 # final
412 #setup -q -n gcc-%{version}
413
414 %patch0 -p1
415 %patch1 -p1
416 %{!?debug:%patch2 -p1}
417 %patch3 -p1
418 %patch4 -p1
419
420 # because we distribute modified version of gcc...
421 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
422 perl -pi -e 's@(bug_report_url.*<URL:).*";@$1http://bugs.pld-linux.org/>";@' gcc/version.c
423
424 mv ChangeLog ChangeLog.general
425
426 %build
427 cd gcc
428 %{__autoconf}
429 cd ..
430 cp -f /usr/share/automake/config.sub .
431
432 rm -rf obj-%{_target_platform}
433 install -d obj-%{_target_platform}
434 cd obj-%{_target_platform}
435
436 CFLAGS="%{rpmcflags}" \
437 CXXFLAGS="%{rpmcflags}" \
438 TEXCONFIG=false \
439 ../configure \
440         --prefix=%{_prefix} \
441         --libdir=%{_libdir} \
442         --libexecdir=%{_libexecdir} \
443         --infodir=%{_infodir} \
444         --mandir=%{_mandir} \
445         --enable-shared \
446         --enable-threads=posix \
447         --enable-__cxa_atexit \
448         --enable-languages="c,c++,f95,objc,ada,java" \
449         --enable-c99 \
450         --enable-long-long \
451 %ifarch amd64
452         --disable-multilib \
453 %else
454         --enable-multilib \
455 %endif
456         --enable-nls \
457         --with-gnu-as \
458         --with-gnu-ld \
459         --with-system-zlib \
460         --with-slibdir=%{_slibdir} \
461         --without-x \
462         --enable-cmath \
463         %{_target_platform}
464
465 cd ..
466
467 %{__make} -C obj-%{_target_platform} \
468         profiledbootstrap \
469         GCJFLAGS="%{rpmcflags}" \
470         BOOT_CFLAGS="%{rpmcflags}" \
471         STAGE1_CFLAGS="%{rpmcflags}" \
472         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
473         mandir=%{_mandir} \
474         infodir=%{_infodir}
475
476 %install
477 rm -rf $RPM_BUILD_ROOT
478 install -d $RPM_BUILD_ROOT{/lib,%{_aclocaldir},%{_datadir},%{_infodir}}
479
480 cd obj-%{_target_platform}
481
482 %{__make} -j1 install \
483         mandir=%{_mandir} \
484         infodir=%{_infodir} \
485         DESTDIR=$RPM_BUILD_ROOT
486
487 %ifarch sparc64
488 ln -sf  $RPM_BUILD_ROOT%{_bindir}/sparc64-pld-linux-gcc \
489         $RPM_BUILD_ROOT%{_bindir}/sparc-pld-linux-gcc
490 %endif
491
492 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
493 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
494
495 ln -sf gfortran $RPM_BUILD_ROOT%{_bindir}/g95
496 echo ".so gfortran.1" > $RPM_BUILD_ROOT%{_mandir}/man1/g95.1
497
498 # move ada shared libraries to proper place...
499 mv -f   $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/adalib/*.so.1 \
500         $RPM_BUILD_ROOT%{_libdir}
501 # check if symlink to be made is valid
502 test -f $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so.1
503 ln -sf  libgnat-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so
504 ln -sf  libgnarl-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnarl-4.0.so
505 ln -sf  libgnat-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnat.so
506 ln -sf  libgnarl-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnarl.so
507 ln -sf  %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
508
509 cd ..
510
511 install -d java-doc
512 cp -f   libjava/READ* java-doc
513 cp -f   fastjar/README java-doc/README.fastjar
514 cp -f   libffi/README java-doc/README.libffi
515 cp -f   libffi/LICENSE java-doc/LICENSE.libffi
516 cp -f   libobjc/README gcc/objc/README.libobjc
517
518 # avoid -L poisoning in *.la - there should be only -L%{_libdir}/gcc/*/%{version}
519 for f in libstdc++.la libsupc++.la libgcj.la;
520 do
521         perl -pi -e 's@-L[^ ]*[acs.] @@g' $RPM_BUILD_ROOT%{_libdir}/$f
522 done
523 # normalize libdir, to avoid propagation of unnecessary RPATHs by libtool
524 for f in libstdc++.la libsupc++.la libgfortran.la libgfortranbegin.la \
525         libgcj.la lib-org-w3c-dom.la lib-org-xml-sax.la libffi.la libobjc.la;
526 do
527         perl -pi -e "s@^libdir='.*@libdir='/usr/%{_lib}'@" $RPM_BUILD_ROOT%{_libdir}/$f
528 done
529
530 # include/ contains install-tools/include/* and headers that were fixed up
531 # by fixincludes, we don't want former
532 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
533 mkdir   $gccdir/tmp
534 # we have to save these however
535 mv -f   $gccdir/include/{gcj,libffi/ffitarget.h,objc,syslimits.h} \
536         $gccdir/tmp
537 rm -rf  $gccdir/include
538 mv -f   $gccdir/tmp \
539         $gccdir/include
540 cp -f   $gccdir/install-tools/include/*.h \
541         $gccdir/include
542 # but we don't want anything more from install-tools
543 rm -rf  $gccdir/install-tools
544
545 %find_lang gcc
546 %find_lang libstdc\+\+
547
548 %clean
549 #rm -rf $RPM_BUILD_ROOT
550
551 %post
552 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
553
554 %postun
555 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
556
557 %post fortran
558 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
559
560 %postun fortran
561 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
562
563 %post java
564 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
565
566 %postun java
567 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
568
569 %post   -p /sbin/ldconfig -n libgcc
570 %postun -p /sbin/ldconfig -n libgcc
571 %post   -p /sbin/ldconfig -n libstdc++
572 %postun -p /sbin/ldconfig -n libstdc++
573 %post   -p /sbin/ldconfig -n libobjc
574 %postun -p /sbin/ldconfig -n libobjc
575 %post   -p /sbin/ldconfig -n libgfortran
576 %postun -p /sbin/ldconfig -n libgfortran
577 %post   -p /sbin/ldconfig -n libgcj
578 %postun -p /sbin/ldconfig -n libgcj
579 %post   -p /sbin/ldconfig -n libgnat
580 %postun -p /sbin/ldconfig -n libgnat
581 %post   -p /sbin/ldconfig -n libffi
582 %postun -p /sbin/ldconfig -n libffi
583
584 %files -f gcc.lang
585 %defattr(644,root,root,755)
586 %doc ChangeLog.general MAINTAINERS bugs.html faq.html
587 %doc gcc/{ChangeLog,ONEWS,README.Portability}
588 %dir %{_libdir}/gcc
589 %dir %{_libdir}/gcc/*
590 %dir %{_libdir}/gcc/*/*
591 %dir %{_libdir}/gcc/*/*/include
592
593 %attr(755,root,root) %{_bindir}/*-gcc*
594 %attr(755,root,root) %{_bindir}/gcc
595 %attr(755,root,root) %{_bindir}/gccbug
596 %attr(755,root,root) %{_bindir}/gcov
597 %attr(755,root,root) %{_bindir}/cc
598 %attr(755,root,root) %{_bindir}/cpp
599
600 %{_mandir}/man1/cc.1*
601 %{_mandir}/man1/cpp.1*
602 #lang(ja) %{_mandir}/ja/man1/cpp.1*
603 %{_mandir}/man1/gcc.1*
604 #lang(fr) %{_mandir}/fr/man1/gcc.1*
605 #lang(ja) %{_mandir}/ja/man1/gcc.1*
606 %{_mandir}/man1/gcov.1*
607
608 %{_infodir}/cpp*
609 %{_infodir}/gcc*
610
611 %attr(755,root,root) /lib/cpp
612
613 %attr(755,root,root) %{_slibdir}/lib*.so
614 %{_libdir}/gcc/*/*/libgcov.a
615 %{_libdir}/gcc/*/*/libgcc.a
616 %{_libdir}/gcc/*/*/libgcc_eh.a
617 %{_libdir}/gcc/*/*/specs
618 %attr(644,root,root) %{_libdir}/gcc/*/*/crt*.o
619 %ifarch sparc64
620 %{_libdir}/gcc/*/*/*/libgcc.a
621 %{_libdir}/gcc/*/*/*/libgcc_eh.a
622 %attr(644,root,root) %{_libdir}/gcc/*/*/*/crt*.o
623 %endif
624 %ifarch ppc
625 %attr(644,root,root) %{_libdir}/gcc/*/*/ecrt*.o
626 %attr(644,root,root) %{_libdir}/gcc/*/*/ncrt*.o
627 %{_libdir}/gcc/*/*/nof
628 %dir %{_libdir}/nof
629 %endif
630 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1
631 %attr(755,root,root) %{_libdir}/gcc/*/*/collect2
632
633 %{_libdir}/gcc/*/*/include/*.h
634 #exclude %{_libdir}/gcc/*/*/include/g2c.h
635
636 %files -n libgcc
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_slibdir}/lib*.so.*
639
640 %files -n libmudflap
641 %defattr(644,root,root,755)
642
643 %files -n libmudflap-devel
644 %defattr(644,root,root,755)
645
646 %files -n libmudflap-static
647 %defattr(644,root,root,755)
648
649 %files ada
650 %defattr(644,root,root,755)
651 %doc gcc/ada/ChangeLog
652 %attr(755,root,root) %{_bindir}/gnat*
653 %attr(755,root,root) %{_bindir}/gpr*
654 %attr(755,root,root) %{_libdir}/libgnarl*.so
655 %attr(755,root,root) %{_libdir}/libgnat*.so
656 %attr(755,root,root) %{_libdir}/gcc/*/*/gnat1
657 %{_libdir}/gcc/*/*/adainclude
658 %dir %{_libdir}/gcc/*/*/adalib
659 %{_libdir}/gcc/*/*/adalib/*.ali
660 %{_libdir}/gcc/*/*/adalib/g-trasym.o
661 %{_libdir}/gcc/*/*/adalib/libgccprefix.a
662 %ifarch %{ix86}
663 %{_libdir}/gcc/*/*/adalib/libgmem.a
664 %endif
665 %{_datadir}/gnat
666 %{_infodir}/gnat*
667
668 %files -n libgnat
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/libgnarl*.so.1
671 %attr(755,root,root) %{_libdir}/libgnat*.so.1
672
673 %files -n libgnat-static
674 %defattr(644,root,root,755)
675 %{_libdir}/gcc/*/*/adalib/libgnarl.a
676 %{_libdir}/gcc/*/*/adalib/libgnat.a
677
678 %files c++
679 %defattr(644,root,root,755)
680 %doc gcc/cp/{ChangeLog,NEWS}
681 %attr(755,root,root) %{_bindir}/g++
682 %attr(755,root,root) %{_bindir}/*-g++
683 %attr(755,root,root) %{_bindir}/c++
684 %attr(755,root,root) %{_bindir}/*-c++
685 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1plus
686 %{_libdir}*/libsupc++.la
687 %ifarch ppc
688 %{_libdir}/nof/libsupc++.la
689 %{_libdir}/nof/libsupc++.a
690 %endif
691 %{_libdir}*/libsupc++.a
692 %{_mandir}/man1/g++.1*
693 #lang(ja) %{_mandir}/ja/man1/g++.1*
694
695 %files -n libstdc++ -f libstdc++.lang
696 %defattr(644,root,root,755)
697 %doc libstdc++-v3/{ChangeLog,README}
698 %attr(755,root,root) %{_libdir}*/libstdc++.so.*.*.*
699 %ifarch ppc
700 %attr(755,root,root) %{_libdir}/nof/libstdc++.so.*.*.*
701 %endif
702
703 %files -n libstdc++-devel
704 %defattr(644,root,root,755)
705 %doc libstdc++-v3/docs/html
706 %dir %{_includedir}/c++
707 %{_includedir}/c++/%{version}
708 %exclude %{_includedir}/c++/%{version}/*/bits/stdc++.h.gch
709 %attr(755,root,root) %{_libdir}*/libstdc++.so
710 %{_libdir}*/libstdc++.la
711 %ifarch ppc
712 %attr(755,root,root) %{_libdir}/nof/libstdc++.so
713 %{_libdir}/nof/libstdc++.la
714 %endif
715
716 %files -n libstdc++-static
717 %defattr(644,root,root,755)
718 %{_libdir}*/libstdc++.a
719 %ifarch ppc
720 %{_libdir}/nof/libstdc++.a
721 %endif
722
723 %files fortran
724 %defattr(644,root,root,755)
725 %doc gcc/fortran/ChangeLog
726 %attr(755,root,root) %{_bindir}/g95
727 %attr(755,root,root) %{_bindir}/gfortran
728 %{_infodir}/gfortran*
729 %attr(755,root,root) %{_libdir}/gcc/*/*/f951
730 %{_libdir}*/libgfortranbegin.a
731 %{_libdir}*/libgfortran.la
732 %attr(755,root,root) %{_libdir}*/libgfortran.so
733 %ifarch ppc
734 %{_libdir}/nof/libgfortranbegin.a
735 %{_libdir}/nof/libgfortran.la
736 %attr(755,root,root) %{_libdir}/nof/libgfortran.so
737 %endif
738 #{_libdir}/gcc/*/*/include/g2c.h
739 %{_mandir}/man1/g95.1*
740 %{_mandir}/man1/gfortran.1*
741 #lang(ja) %{_mandir}/ja/man1/g77.1*
742 #lang(ja) %{_mandir}/ja/man1/f77.1*
743
744 %files -n libgfortran
745 %defattr(644,root,root,755)
746 %doc libgfortran/{AUTHORS,README,ChangeLog}
747 %attr(755,root,root) %{_libdir}*/libgfortran.so.*.*.*
748 %ifarch ppc
749 %attr(755,root,root) %{_libdir}/nof/libgfortran.so.*.*.*
750 %endif
751
752 %files -n libgfortran-static
753 %defattr(644,root,root,755)
754 %{_libdir}*/libgfortran.a
755 %ifarch ppc
756 %{_libdir}/nof/libgfortran.a
757 %endif
758
759 %files java
760 %defattr(644,root,root,755)
761 %doc gcc/java/ChangeLog java-doc/*
762 %attr(755,root,root) %{_bindir}/gcj*
763 %attr(755,root,root) %{_bindir}/gij
764 %attr(755,root,root) %{_bindir}/jcf-dump
765 %attr(755,root,root) %{_bindir}/jv-*
766 %attr(755,root,root) %{_bindir}/grepjar
767 %attr(755,root,root) %{_bindir}/*-gcj*
768 %attr(755,root,root) %{_libdir}/gcc/*/*/jc1
769 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
770 %{_infodir}/gcj*
771 %{_mandir}/man1/jcf-*
772 %{_mandir}/man1/jv-*
773 %{_mandir}/man1/gij*
774 %{_mandir}/man1/gcj*
775 %{_mandir}/man1/grepjar*
776
777 %files java-tools
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_bindir}/grmi*
780 %attr(755,root,root) %{_bindir}/fastjar
781 %{_mandir}/man1/grmi*
782 %{_mandir}/man1/fastjar*
783 %{_infodir}/fastjar*
784
785 %files -n libgcj
786 %defattr(644,root,root,755)
787 %doc libjava/{ChangeLog,LIBGCJ_LICENSE,NEWS,README,THANKS}
788 %attr(755,root,root) %{_bindir}/addr2name.awk
789 %attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
790 %attr(755,root,root) %{_libdir}/lib-org*.so.*.*.*
791 %ifarch ppc
792 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so.*
793 %endif
794 %{_libdir}/logging.properties
795
796 %files -n libgcj-devel
797 %defattr(644,root,root,755)
798 %{_includedir}/c++/%{version}/java
799 %{_includedir}/c++/%{version}/javax
800 %{_includedir}/c++/%{version}/gcj
801 #{_includedir}/j*.h
802 %{_includedir}/c++/%{version}/gnu/*
803 %{_libdir}/gcc/*/*/include/gcj
804 %dir %{_libdir}/security
805 %{_libdir}/security/*
806 %dir %{_datadir}/java
807 %{_datadir}/java/libgcj*.jar
808 %{_libdir}/lib*cj.spec
809 %{_libdir}/lib*cj*.la
810 %attr(755,root,root) %{_libdir}/lib*cj*.so
811 %attr(755,root,root) %{_libdir}/lib-org-*.so
812 %{_libdir}/lib-org-*.la
813 %ifarch ppc
814 %{_libdir}/nof/lib*cj*.la
815 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so
816 %endif
817 %{_pkgconfigdir}/libgcj.pc
818
819 %files -n libgcj-static
820 %defattr(644,root,root,755)
821 %{_libdir}/lib*cj*.a
822 %{_libdir}/lib-org-*.a
823 %ifarch ppc
824 %{_libdir}/nof/lib*cj*.a
825 %endif
826
827 %files -n libffi
828 %defattr(644,root,root,755)
829 %doc libffi/{ChangeLog,ChangeLog.libgcj,LICENSE,README}
830 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
831
832 %files -n libffi-devel
833 %defattr(644,root,root,755)
834 %{_libdir}/gcc/*/*/include/ffitarget.h
835 %attr(755,root,root) %{_libdir}/libffi.so
836 %{_libdir}/libffi.la
837 %{_includedir}/ffi.h
838
839 %files -n libffi-static
840 %defattr(644,root,root,755)
841 %{_libdir}/libffi.a
842
843 %files objc
844 %defattr(644,root,root,755)
845 %doc gcc/objc/README
846 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1obj
847 %attr(755,root,root) %{_libdir}*/libobjc.so
848 %{_libdir}*/libobjc.la
849 %ifarch ppc
850 %attr(755,root,root) %{_libdir}/nof/libobjc.so
851 %{_libdir}/nof/libobjc.la
852 %endif
853 %{_libdir}/gcc/*/*/include/objc
854
855 %files -n libobjc
856 %defattr(644,root,root,755)
857 %doc libobjc/{ChangeLog,README*}
858 %attr(755,root,root) %{_libdir}*/libobjc.so.*.*.*
859 %ifarch ppc
860 %attr(755,root,root) %{_libdir}/nof/libobjc.so.*.*.*
861 %endif
862
863 %files -n libobjc-static
864 %defattr(644,root,root,755)
865 %{_libdir}*/libobjc.a
866 %ifarch ppc
867 %{_libdir}/nof/libobjc.a
868 %endif
This page took 0.139681 seconds and 4 git commands to generate.