]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- gcc.gnu.org is back.
[packages/gcc4.git] / gcc4.spec
1 #
2 # Conditional build:
3 %bcond_without  ada             # build without ADA support
4 %bcond_without  fortran         # build without Fortran support
5 %bcond_without  java            # build without Java support
6 %bcond_without  objc            # build without ObjC support
7
8 %bcond_with     bootstrap
9
10 %if %{with bootstrap}
11 %undefine       with_fortran
12 %undefine       with_java
13 %undefine       with_objc
14 %endif
15
16 #
17 # TODO:
18 #               - http://gcc.gnu.org/PR11203 (inline-asm)
19 #               - http://gcc.gnu.org/PR18648 (missed tree-optimization)
20 #               - disable internal zlib usage
21 #               - translations from gcc.spec:HEAD
22 #
23 %define         _snap           20050130
24 #
25 Summary:        GNU Compiler Collection: the C compiler and shared files
26 Summary(pl):    Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
27 Name:           gcc
28 Epoch:          5
29 Version:        4.0.0
30 Release:        0.%{_snap}.4
31 License:        GPL
32 Group:          Development/Languages
33 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
34 #Source0:       ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
35 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/%{name}-4.0-%{_snap}.tar.bz2
36 # Source0-md5:  5040ba840d0367c378f73c739418b3e2
37 Patch0:         %{name}-info.patch
38 Patch1:         %{name}-nolocalefiles.patch
39 Patch2:         %{name}-nodebug.patch
40 Patch3:         %{name}-ada-link-new-libgnat.patch
41 Patch4:         %{name}-ada-link.patch
42 URL:            http://gcc.gnu.org/
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 BuildRequires:  binutils >= 2:2.15.94.0.1
46 BuildRequires:  bison
47 BuildRequires:  fileutils >= 4.0.41
48 BuildRequires:  flex
49 %if %{with ada}
50 BuildRequires:  gcc(ada)
51 BuildRequires:  gcc-ada
52 %endif
53 BuildRequires:  gettext-devel
54 BuildRequires:  glibc-devel >= 2.2.5-20
55 BuildRequires:  gmp-devel
56 BuildRequires:  libmpfr-devel
57 BuildRequires:  perl-devel
58 BuildRequires:  texinfo >= 4.1
59 BuildRequires:  zlib-devel
60 Requires:       binutils >= 2:2.15.94.0.1
61 Requires:       libgcc = %{epoch}:%{version}-%{release}
62 Provides:       cpp = %{epoch}:%{version}-%{release}
63 %{?with_ada:Provides:   gcc(ada)}
64 Obsoletes:      cpp
65 Obsoletes:      egcs-cpp
66 Obsoletes:      gcc-cpp
67 Obsoletes:      gcc-ksi
68 Obsoletes:      gont
69 Conflicts:      glibc-devel < 2.2.5-20
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _slibdir        /%{_lib}
73
74 %description
75 A compiler aimed at integrating all the optimizations and features
76 necessary for a high-performance and stable development environment.
77
78 This package contains the C compiler and some files shared by various
79 parts of the GNU Compiler Collection. In order to use another GCC
80 compiler you will need to install the appropriate subpackage.
81
82 %description -l pl
83 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
84 wyprodukowania szybkiego i stabilnego kodu wynikowego.
85
86 Ten pakiet zawiera kompilator C i pliki wspó³dzielone przez ró¿ne
87 czê¶ci kolekcji kompilatorów GNU (GCC). ¯eby u¿ywaæ innego kompilatora
88 z GCC, trzeba zainstalowaæ odpowiedni podpakiet.
89
90 %package -n libgcc
91 Summary:        Shared gcc library
92 Summary(pl):    Biblioteka gcc
93 Group:          Libraries
94 Obsoletes:      libgcc1
95
96 %description -n libgcc
97 Shared gcc library.
98
99 %description -n libgcc -l pl
100 Biblioteka dynamiczna gcc.
101
102 %package -n libmudflap
103 Summary:        GCC mudflap shared support library
104 Group:          Libraries
105
106 %description -n libmudflap
107 The libmudflap libraries are used by GCC for instrumenting pointer and
108 array dereferencing operations.
109
110 %package -n libmudflap-devel
111 Summary:        Development files for GCC mudflap library
112 Group:          Development/Libraries
113 Requires:       libmudflap = %{epoch}:%{version}-%{release}
114
115 %description -n libmudflap-devel
116 The libmudflap libraries are used by GCC for instrumenting pointer and
117 array dereferencing operations. This package contains development
118 files.
119
120 %package -n libmudflap-static
121 Summary:        Static GCC mudflap library
122 Group:          Development/Libraries
123 Requires:       libmudflap-devel = %{epoch}:%{version}-%{release}
124
125 %description -n libmudflap-static
126 The libmudflap libraries are used by GCC for instrumenting pointer and
127 array dereferencing operations. This package contains static
128 libraries.
129
130 %package ada
131 Summary:        Ada support for gcc
132 Summary(pl):    Obs³uga Ady do gcc
133 Group:          Development/Languages
134 Requires:       %{name} = %{epoch}:%{version}-%{release}
135 Requires:       libgnat = %{epoch}:%{version}-%{release}
136 Obsoletes:      gcc-gnat
137 Obsoletes:      gnat-devel
138
139 %description ada
140 This package adds experimental support for compiling Ada programs.
141
142 %description ada -l pl
143 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów w
144 Adzie.
145
146 %package -n libgnat
147 Summary:        Ada standard libraries
148 Summary(pl):    Biblioteki standardowe dla Ady
149 Group:          Development/Libraries
150 Obsoletes:      gnat
151 Obsoletes:      libgnat1
152
153 %description -n libgnat
154 This package contains shared libraries needed to run programs written
155 in Ada.
156
157 %description -n libgnat -l pl
158 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów
159 napisanych w Adzie.
160
161 %package -n libgnat-static
162 Summary:        Static Ada standard libraries
163 Summary(pl):    Statyczne biblioteki standardowe dla Ady
164 Group:          Development/Libraries
165 Obsoletes:      gnat-static
166
167 %description -n libgnat-static
168 This package contains static libraries for programs written in Ada.
169
170 %description -n libgnat-static -l pl
171 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
172 Adzie.
173
174 %package c++
175 Summary:        C++ support for gcc
176 Summary(pl):    Obs³uga C++ dla gcc
177 Group:          Development/Languages
178 Requires:       %{name} = %{epoch}:%{version}-%{release}
179 Obsoletes:      egcc-c++
180 Obsoletes:      egcs-c++
181
182 %description c++
183 This package adds C++ support to the GNU Compiler Collection. It
184 includes support for most of the current C++ specification, including
185 templates and exception handling. It does not include a standard C++
186 library, which is available separately.
187
188 %description c++ -l pl
189 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
190 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
191 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
192
193 %package -n libstdc++
194 Summary:        GNU C++ library
195 Summary(pl):    Biblioteki GNU C++
196 Group:          Libraries
197 Obsoletes:      libg++
198 Obsoletes:      libstdc++3
199
200 %description -n libstdc++
201 This is the GNU implementation of the standard C++ libraries, along
202 with additional GNU tools. This package includes the shared libraries
203 necessary to run C++ applications.
204
205 %description -n libstdc++ -l pl
206 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
207 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
208 uruchomienia aplikacji napisanych w C++.
209
210 %package -n libstdc++-devel
211 Summary:        Header files and documentation for C++ development
212 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
213 Group:          Development/Libraries
214 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
215 Requires:       glibc-devel
216 Requires:       libstdc++ = %{epoch}:%{version}-%{release}
217 Obsoletes:      libg++-devel
218 Obsoletes:      libstdc++3-devel
219
220 %description -n libstdc++-devel
221 This is the GNU implementation of the standard C++ libraries. This
222 package includes the header files needed for C++ development and
223 library documentation.
224
225 %description -n libstdc++-devel -l pl
226 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
227 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
228 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
229
230 %package -n libstdc++-static
231 Summary:        Static C++ standard library
232 Summary(pl):    Statyczna biblioteka standardowa C++
233 Group:          Development/Libraries
234 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
235
236 %description -n libstdc++-static
237 Static C++ standard library.
238
239 %description -n libstdc++-static -l pl
240 Statyczna biblioteka standardowa C++.
241
242 %package fortran
243 Summary:        Fortran 95 support for gcc
244 Summary(pl):    Obs³uga Fortranu 95 dla gcc
245 Group:          Development/Languages/Fortran
246 Requires:       libgfortran = %{epoch}:%{version}-%{release}
247 Obsoletes:      egcs-g77
248 Obsoletes:      gcc-g77
249
250 %description fortran
251 This package adds support for compiling Fortran 95 programs with the
252 GNU compiler.
253
254 %description fortran -l pl
255 Ten pakiet dodaje obs³ugê Fortranu 95 do kompilatora gcc. Jest
256 potrzebny do kompilowania programów pisanych w jêzyku Fortran 95.
257
258 %package -n libgfortran
259 Summary:        Fortran 95 Libraries
260 Summary(pl):    Biblioteki Fortranu 95
261 Group:          Development/Libraries
262 Obsoletes:      libg2c
263
264 %description -n libgfortran
265 Fortran 95 Libraries.
266
267 %description -n libgfortran -l pl
268 Biblioteki Fortranu 95.
269
270 %package -n libgfortran-static
271 Summary:        Static Fortran 95 Libraries
272 Summary(pl):    Statyczne Biblioteki Fortranu 95
273 Group:          Development/Libraries
274 Requires:       libgfortran = %{epoch}:%{version}-%{release}
275 Obsoletes:      libg2c-static
276
277 %description -n libgfortran-static
278 Static Fortran 95 Libraries.
279
280 %description -n libgfortran-static -l pl
281 Statyczne biblioteki Fortranu 95.
282
283 %package java
284 Summary:        Java support for gcc
285 Summary(pl):    Obs³uga Javy dla gcc
286 Group:          Development/Languages/Java
287 Requires:       %{name} = %{epoch}:%{version}-%{release}
288 Requires:       libgcj = %{epoch}:%{version}-%{release}
289 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
290 Requires:       java-shared
291 Provides:       gcj = %{epoch}:%{version}-%{release}
292
293 %description java
294 This package adds experimental support for compiling Java(tm) programs
295 and bytecode into native code. To use this you will also need the
296 libgcj package.
297
298 %description java -l pl
299 Wsparcie dla kompilowania programów Java(tm) zarówno do bajt-kodu jak
300 i do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
301 by³o przeprowadziæ kompilacjê.
302
303 %package -n libgcj
304 Summary:        Java Class Libraries
305 Summary(pl):    Biblioteki Klas Javy
306 Group:          Libraries
307 Requires:       zlib
308 Obsoletes:      libgcj3
309
310 %description -n libgcj
311 Java Class Libraries.
312
313 %description -n libgcj -l pl
314 Biblioteki Klas Javy.
315
316 %package -n libgcj-devel
317 Summary:        Development files for Java Class Libraries
318 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
319 Group:          Development/Libraries
320 Requires:       libgcj = %{epoch}:%{version}-%{release}
321 Obsoletes:      libgcj3-devel
322
323 %description -n libgcj-devel
324 Development files for Java Class Libraries.
325
326 %description -n libgcj-devel -l pl
327 Pliki nag³ówkowe dla Bibliotek Klas Javy.
328
329 %package -n libgcj-static
330 Summary:        Static Java Class Libraries
331 Summary(pl):    Statyczne Biblioteki Klas Javy
332 Group:          Development/Libraries
333 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
334 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
335
336 %description -n libgcj-static
337 Static Java Class Libraries.
338
339 %description -n libgcj-static -l pl
340 Statyczne Biblioteki Klas Javy.
341
342 %package -n libffi
343 Summary:        Foreign Function Interface library
344 Summary(pl):    Biblioteka zewnêtrznych wywo³añ funkcji
345 Group:          Libraries
346
347 %description -n libffi
348 The libffi library provides a portable, high level programming
349 interface to various calling conventions. This allows a programmer to
350 call any function specified by a call interface description at run
351 time.
352
353 %description -n libffi -l pl
354 Biblioteka libffi dostarcza przeno¶nego, wysokopoziomowego
355 miêdzymordzia do ró¿nych konwencji wywo³añ funkcji. Pozwala to
356 programi¶cie wywo³ywaæ dowolne funkcje podaj±c konwencjê wywo³ania w
357 czasie wykonania.
358
359 %package -n libffi-devel
360 Summary:        Development files for Foreign Function Interface library
361 Summary(pl):    Pliki nag³ówkowe dla libffi
362 Group:          Development/Libraries
363 Requires:       libffi = %{epoch}:%{version}-%{release}
364
365 %description -n libffi-devel
366 Development files for Foreign Function Interface library.
367
368 %description -n libffi-devel -l pl
369 Pliki nag³ówkowe dla libffi.
370
371 %package -n libffi-static
372 Summary:        Static Foreign Function Interface library
373 Summary(pl):    Statyczna biblioteka libffi
374 Group:          Development/Libraries
375 Requires:       libffi-devel = %{epoch}:%{version}-%{release}
376
377 %description -n libffi-static
378 Static Foreign Function Interface library.
379
380 %description -n libffi-static -l pl
381 Statyczna biblioteka libffi.
382
383 %package java-tools
384 Summary:        Shared java tools
385 Summary(pl):    Wspó³dzielone narzêdzia javy
386 Group:          Development/Languages/Java
387 Provides:       jar = %{epoch}:%{version}-%{release}
388 Provides:       java-shared
389 Obsoletes:      fastjar
390 Obsoletes:      java-shared
391 Obsoletes:      jar
392
393 %description java-tools
394 This package contains tools that are common for every Java(tm)
395 implementation, such as rmic or jar.
396
397 %description java-tools -l pl
398 Pakiet ten zawiera narzêdzia wspólne dla ka¿dej implementacji
399 Javy(tm), takie jak rmic czy jar.
400
401 %package objc
402 Summary:        Objective C support for gcc
403 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
404 Group:          Development/Languages
405 Requires:       %{name} = %{epoch}:%{version}-%{release}
406 Requires:       libobjc = %{epoch}:%{version}-%{release}
407 Obsoletes:      egcc-objc
408 Obsoletes:      egcs-objc
409
410 %description objc
411 This package adds Objective C support to the GNU Compiler Collection.
412 Objective C is a object oriented derivative of the C language, mainly
413 used on systems running NeXTSTEP. This package does not include the
414 standard objective C object library.
415
416 %description objc -l pl
417 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
418 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
419 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
420 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
421
422 %package -n libobjc
423 Summary:        Objective C Libraries
424 Summary(pl):    Biblioteki Obiektowego C
425 Group:          Libraries
426 Obsoletes:      libobjc1
427
428 %description -n libobjc
429 Objective C Libraries.
430
431 %description -n libobjc -l pl
432 Biblioteki Obiektowego C.
433
434 %package -n libobjc-static
435 Summary:        Static Objective C Libraries
436 Summary(pl):    Statyczne Biblioteki Obiektowego C
437 Group:          Development/Libraries
438 Requires:       libobjc = %{epoch}:%{version}-%{release}
439
440 %description -n libobjc-static
441 Static Objective C Libraries.
442
443 %description -n libobjc-static -l pl
444 Statyczne biblioteki Obiektowego C.
445
446 %prep
447 # prerelease
448 #setup -q -n gcc-%{version}-%{_snap}
449 # snapshot
450 %setup -q -n gcc-4.0-%{_snap}
451 # final
452 #setup -q -n gcc-%{version}
453
454 %patch0 -p1
455 %patch1 -p1
456 %{!?debug:%patch2 -p1}
457 %patch3 -p1
458 %patch4 -p1
459
460 # because we distribute modified version of gcc...
461 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
462 perl -pi -e 's@(bug_report_url.*<URL:).*";@$1http://bugs.pld-linux.org/>";@' gcc/version.c
463
464 mv ChangeLog ChangeLog.general
465
466 %build
467 cd gcc
468 %{__autoconf}
469 cd ..
470 cp -f /usr/share/automake/config.sub .
471
472 rm -rf obj-%{_target_platform}
473 install -d obj-%{_target_platform}
474 cd obj-%{_target_platform}
475
476 CFLAGS="%{rpmcflags}" \
477 CXXFLAGS="%{rpmcflags}" \
478 TEXCONFIG=false \
479 ../configure \
480         --prefix=%{_prefix} \
481         --libdir=%{_libdir} \
482         --libexecdir=%{_libexecdir} \
483         --infodir=%{_infodir} \
484         --mandir=%{_mandir} \
485         --enable-shared \
486         --enable-threads=posix \
487         --enable-__cxa_atexit \
488         --enable-languages="c,c++%{?with_fortran:,f95}%{?with_objc:,objc}%{?with_ada:,ada}%{?with_java:,java}" \
489         --enable-c99 \
490         --enable-long-long \
491 %ifarch amd64
492         --disable-multilib \
493 %else
494         --enable-multilib \
495 %endif
496         --enable-nls \
497         --with-gnu-as \
498         --with-gnu-ld \
499         --with-system-zlib \
500         --with-slibdir=%{_slibdir} \
501         --without-x \
502         --enable-cmath \
503         %{_target_platform}
504
505 cd ..
506
507 %{__make} -C obj-%{_target_platform} \
508         %{!?with_bootstrap:profiledbootstrap} \
509         GCJFLAGS="%{rpmcflags}" \
510         BOOT_CFLAGS="%{rpmcflags}" \
511         STAGE1_CFLAGS="%{rpmcflags} -O0" \
512         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
513         mandir=%{_mandir} \
514         infodir=%{_infodir}
515
516 %install
517 rm -rf $RPM_BUILD_ROOT
518 install -d $RPM_BUILD_ROOT{/lib,%{_aclocaldir},%{_datadir},%{_infodir}}
519
520 cd obj-%{_target_platform}
521
522 %{__make} -j1 install \
523         mandir=%{_mandir} \
524         infodir=%{_infodir} \
525         DESTDIR=$RPM_BUILD_ROOT
526
527 install gcc/specs $RPM_BUILD_ROOT%{_libdir}/gcc/%{_target_platform}/%{version}
528
529 %ifarch sparc64
530 ln -sf  $RPM_BUILD_ROOT%{_bindir}/sparc64-pld-linux-gcc \
531         $RPM_BUILD_ROOT%{_bindir}/sparc-pld-linux-gcc
532 %endif
533
534 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
535 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
536
537 %if %{with fortran}
538 ln -sf gfortran $RPM_BUILD_ROOT%{_bindir}/g95
539 echo ".so gfortran.1" > $RPM_BUILD_ROOT%{_mandir}/man1/g95.1
540 %endif
541
542 %if %{with ada}
543 # move ada shared libraries to proper place...
544 mv -f   $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/adalib/*.so.1 \
545         $RPM_BUILD_ROOT%{_libdir}
546 # check if symlink to be made is valid
547 test -f $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so.1
548 ln -sf  libgnat-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so
549 ln -sf  libgnarl-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnarl-4.0.so
550 ln -sf  libgnat-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnat.so
551 ln -sf  libgnarl-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnarl.so
552 ln -sf  %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
553 %endif
554
555 cd ..
556
557 %if %{with java}
558 install -d java-doc
559 cp -f   libjava/READ* java-doc
560 cp -f   fastjar/README java-doc/README.fastjar
561 cp -f   libffi/README java-doc/README.libffi
562 cp -f   libffi/LICENSE java-doc/LICENSE.libffi
563 %endif
564 %if %{with objc}
565 cp -f   libobjc/README gcc/objc/README.libobjc
566 %endif
567
568 # avoid -L poisoning in *.la - there should be only -L%{_libdir}/gcc/*/%{version}
569 for f in libstdc++.la libsupc++.la %{?with_java:libgcj.la};
570 do
571         perl -pi -e 's@-L[^ ]*[acs.] @@g' $RPM_BUILD_ROOT%{_libdir}/$f
572 done
573 # normalize libdir, to avoid propagation of unnecessary RPATHs by libtool
574 for f in libstdc++.la libsupc++.la \
575         %{?with_fortran:libgfortran.la libgfortranbegin.la} \
576         %{?with_java:libgcj.la lib-org-w3c-dom.la lib-org-xml-sax.la libffi.la} \
577         %{?with_objc:libobjc.la};
578 do
579         perl -pi -e "s@^libdir='.*@libdir='/usr/%{_lib}'@" $RPM_BUILD_ROOT%{_libdir}/$f
580 done
581
582 # include/ contains install-tools/include/* and headers that were fixed up
583 # by fixincludes, we don't want former
584 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
585 mkdir   $gccdir/tmp
586 # we have to save these however
587 %{?with_java:mv -f $gccdir/include/{gcj,libffi/ffitarget.h} $gccdir/tmp}
588 %{?with_objc:mv -f $gccdir/include/objc $gccdir/tmp}
589 mv -f   $gccdir/include/syslimits.h $gccdir/tmp
590 rm -rf  $gccdir/include
591  mv -f  $gccdir/tmp $gccdir/include
592 cp -f   $gccdir/install-tools/include/*.h $gccdir/include
593 # but we don't want anything more from install-tools
594 rm -rf  $gccdir/install-tools
595
596 %find_lang gcc
597 %find_lang libstdc\+\+
598
599 %clean
600 rm -rf $RPM_BUILD_ROOT
601
602 %post
603 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
604
605 %postun
606 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
607
608 %post ada
609 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
610
611 %postun ada
612 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
613
614 %post fortran
615 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
616
617 %postun fortran
618 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
619
620 %post java
621 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
622
623 %postun java
624 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
625
626 %post   -p /sbin/ldconfig -n libgcc
627 %postun -p /sbin/ldconfig -n libgcc
628 %post   -p /sbin/ldconfig -n libmudflap
629 %postun -p /sbin/ldconfig -n libmudflap
630 %post   -p /sbin/ldconfig -n libgnat
631 %postun -p /sbin/ldconfig -n libgnat
632 %post   -p /sbin/ldconfig -n libstdc++
633 %postun -p /sbin/ldconfig -n libstdc++
634 %post   -p /sbin/ldconfig -n libgfortran
635 %postun -p /sbin/ldconfig -n libgfortran
636 %post   -p /sbin/ldconfig -n libgcj
637 %postun -p /sbin/ldconfig -n libgcj
638 %post   -p /sbin/ldconfig -n libffi
639 %postun -p /sbin/ldconfig -n libffi
640 %post   -p /sbin/ldconfig -n libobjc
641 %postun -p /sbin/ldconfig -n libobjc
642
643 %files -f gcc.lang
644 %defattr(644,root,root,755)
645 %doc ChangeLog.general MAINTAINERS bugs.html faq.html
646 %doc gcc/{ChangeLog,ONEWS,README.Portability}
647 %dir %{_libdir}/gcc
648 %dir %{_libdir}/gcc/*
649 %dir %{_libdir}/gcc/*/*
650 %dir %{_libdir}/gcc/*/*/include
651
652 %attr(755,root,root) %{_bindir}/*-gcc*
653 %attr(755,root,root) %{_bindir}/gcc
654 %attr(755,root,root) %{_bindir}/gccbug
655 %attr(755,root,root) %{_bindir}/gcov
656 %attr(755,root,root) %{_bindir}/cc
657 %attr(755,root,root) %{_bindir}/cpp
658
659 %{_mandir}/man1/cc.1*
660 %{_mandir}/man1/cpp.1*
661 %{_mandir}/man1/gcc.1*
662 %{_mandir}/man1/gcov.1*
663
664 %{_infodir}/cpp*
665 %{_infodir}/gcc*
666
667 %attr(755,root,root) /lib/cpp
668
669 %attr(755,root,root) %{_slibdir}/lib*.so
670 %{_libdir}/gcc/*/*/libgcov.a
671 %{_libdir}/gcc/*/*/libgcc.a
672 %{_libdir}/gcc/*/*/libgcc_eh.a
673 %{_libdir}/gcc/*/*/specs
674 %attr(644,root,root) %{_libdir}/gcc/*/*/crt*.o
675 %ifarch sparc64
676 %{_libdir}/gcc/*/*/*/libgcc.a
677 %{_libdir}/gcc/*/*/*/libgcc_eh.a
678 %attr(644,root,root) %{_libdir}/gcc/*/*/*/crt*.o
679 %endif
680 %ifarch ppc
681 %attr(644,root,root) %{_libdir}/gcc/*/*/ecrt*.o
682 %attr(644,root,root) %{_libdir}/gcc/*/*/ncrt*.o
683 %{_libdir}/gcc/*/*/nof
684 %dir %{_libdir}/nof
685 %endif
686 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1
687 %attr(755,root,root) %{_libdir}/gcc/*/*/collect2
688
689 %{_libdir}/gcc/*/*/include/*.h
690
691 %files -n libgcc
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_slibdir}/lib*.so.*
694
695 %files -n libmudflap
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/libmudflap*.so.*.*.*
698
699 %files -n libmudflap-devel
700 %defattr(644,root,root,755)
701 %{_includedir}/mf-runtime.h
702 %{_libdir}/libmudflap*.la
703 %attr(755,root,root) %{_libdir}/libmudflap*.so
704
705 %files -n libmudflap-static
706 %defattr(644,root,root,755)
707 %{_libdir}/libmudflap*.a
708
709 %if %{with ada}
710 %files ada
711 %defattr(644,root,root,755)
712 %doc gcc/ada/ChangeLog
713 %attr(755,root,root) %{_bindir}/gnat*
714 %attr(755,root,root) %{_bindir}/gpr*
715 %attr(755,root,root) %{_libdir}/libgnarl*.so
716 %attr(755,root,root) %{_libdir}/libgnat*.so
717 %attr(755,root,root) %{_libdir}/gcc/*/*/gnat1
718 %{_libdir}/gcc/*/*/adainclude
719 %dir %{_libdir}/gcc/*/*/adalib
720 %{_libdir}/gcc/*/*/adalib/*.ali
721 %{_libdir}/gcc/*/*/adalib/g-trasym.o
722 %{_libdir}/gcc/*/*/adalib/libgccprefix.a
723 %ifarch %{ix86}
724 %{_libdir}/gcc/*/*/adalib/libgmem.a
725 %endif
726 %{_datadir}/gnat
727 %{_infodir}/gnat*
728
729 %files -n libgnat
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libgnarl*.so.1
732 %attr(755,root,root) %{_libdir}/libgnat*.so.1
733
734 %files -n libgnat-static
735 %defattr(644,root,root,755)
736 %{_libdir}/gcc/*/*/adalib/libgnarl.a
737 %{_libdir}/gcc/*/*/adalib/libgnat.a
738 %endif
739
740 %files c++
741 %defattr(644,root,root,755)
742 %doc gcc/cp/{ChangeLog,NEWS}
743 %attr(755,root,root) %{_bindir}/g++
744 %attr(755,root,root) %{_bindir}/*-g++
745 %attr(755,root,root) %{_bindir}/c++
746 %attr(755,root,root) %{_bindir}/*-c++
747 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1plus
748 %{_libdir}/libsupc++.a
749 %{_libdir}/libsupc++.la
750 %{_mandir}/man1/g++.1*
751
752 %files -n libstdc++ -f libstdc++.lang
753 %defattr(644,root,root,755)
754 %doc libstdc++-v3/{ChangeLog,README}
755 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
756
757 %files -n libstdc++-devel
758 %defattr(644,root,root,755)
759 %doc libstdc++-v3/docs/html
760 %dir %{_includedir}/c++
761 %{_includedir}/c++/%{version}
762 %if %{with java}
763 %exclude %{_includedir}/c++/%{version}/java
764 %exclude %{_includedir}/c++/%{version}/javax
765 %exclude %{_includedir}/c++/%{version}/gcj
766 %exclude %{_includedir}/c++/%{version}/gnu
767 %endif
768 %exclude %{_includedir}/c++/%{version}/*/bits/stdc++.h.gch
769 %{_libdir}/libstdc++.la
770 %attr(755,root,root) %{_libdir}/libstdc++.so
771
772 %files -n libstdc++-static
773 %defattr(644,root,root,755)
774 %{_libdir}/libstdc++.a
775
776 %if %{with fortran}
777 %files fortran
778 %defattr(644,root,root,755)
779 %doc gcc/fortran/ChangeLog
780 %attr(755,root,root) %{_bindir}/g95
781 %attr(755,root,root) %{_bindir}/gfortran
782 %{_infodir}/gfortran*
783 %attr(755,root,root) %{_libdir}/gcc/*/*/f951
784 %{_libdir}/libgfortranbegin.a
785 %{_libdir}/libgfortranbegin.la
786 %{_libdir}/libgfortran.la
787 %attr(755,root,root) %{_libdir}/libgfortran.so
788 %{_mandir}/man1/g95.1*
789 %{_mandir}/man1/gfortran.1*
790
791 %files -n libgfortran
792 %defattr(644,root,root,755)
793 %doc libgfortran/{AUTHORS,README,ChangeLog}
794 %attr(755,root,root) %{_libdir}/libgfortran.so.*.*.*
795
796 %files -n libgfortran-static
797 %defattr(644,root,root,755)
798 %{_libdir}/libgfortran.a
799 %endif
800
801 %if %{with java}
802 %files java
803 %defattr(644,root,root,755)
804 %doc gcc/java/ChangeLog java-doc/*
805 %attr(755,root,root) %{_bindir}/gcj*
806 %attr(755,root,root) %{_bindir}/gij
807 %attr(755,root,root) %{_bindir}/grepjar
808 %attr(755,root,root) %{_bindir}/jcf-dump
809 %attr(755,root,root) %{_bindir}/jv-*
810 %attr(755,root,root) %{_bindir}/*-gcj*
811 %attr(755,root,root) %{_libdir}/gcc/*/*/jc1
812 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
813 %{_infodir}/gcj*
814 %{_mandir}/man1/gcj*
815 %{_mandir}/man1/gij*
816 %{_mandir}/man1/grepjar*
817 %{_mandir}/man1/jcf-*
818 %{_mandir}/man1/jv-*
819
820 %files java-tools
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_bindir}/grmi*
823 %attr(755,root,root) %{_bindir}/fastjar
824 %{_mandir}/man1/grmi*
825 %{_mandir}/man1/fastjar*
826 %{_infodir}/fastjar*
827
828 %files -n libgcj
829 %defattr(644,root,root,755)
830 %doc libjava/{ChangeLog,LIBGCJ_LICENSE,NEWS,README,THANKS}
831 %attr(755,root,root) %{_bindir}/addr2name.awk
832 %attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
833 %attr(755,root,root) %{_libdir}/libgij.so.*.*.*
834 %attr(755,root,root) %{_libdir}/lib-org*.so.*.*.*
835 %{_libdir}/logging.properties
836
837 %files -n libgcj-devel
838 %defattr(644,root,root,755)
839 %{_includedir}/c++/%{version}/java
840 %{_includedir}/c++/%{version}/javax
841 %{_includedir}/c++/%{version}/gcj
842 %{_includedir}/c++/%{version}/gnu
843 %{_libdir}/gcc/*/*/include/gcj
844 %dir %{_libdir}/security
845 %{_libdir}/security/*
846 %{_javadir}/libgcj*.jar
847 %{_libdir}/lib*cj.spec
848 %{_libdir}/lib*cj*.la
849 %attr(755,root,root) %{_libdir}/lib*cj*.so
850 %{_libdir}/libgij.la
851 %attr(755,root,root) %{_libdir}/libgij.so
852 %attr(755,root,root) %{_libdir}/lib-org-*.so
853 %{_libdir}/lib-org-*.la
854 %{_pkgconfigdir}/libgcj.pc
855
856 %files -n libgcj-static
857 %defattr(644,root,root,755)
858 %{_libdir}/lib*cj*.a
859 %{_libdir}/libgij.a
860 %{_libdir}/lib-org-*.a
861
862 %files -n libffi
863 %defattr(644,root,root,755)
864 %doc libffi/{ChangeLog,ChangeLog.libgcj,LICENSE,README}
865 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
866
867 %files -n libffi-devel
868 %defattr(644,root,root,755)
869 %{_libdir}/gcc/*/*/include/ffitarget.h
870 %attr(755,root,root) %{_libdir}/libffi.so
871 %{_libdir}/libffi.la
872 %{_includedir}/ffi.h
873
874 %files -n libffi-static
875 %defattr(644,root,root,755)
876 %{_libdir}/libffi.a
877 %endif
878
879 %if %{with objc}
880 %files objc
881 %defattr(644,root,root,755)
882 %doc gcc/objc/README
883 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1obj
884 %attr(755,root,root) %{_libdir}/libobjc.so
885 %{_libdir}/libobjc.la
886 %{_libdir}/gcc/*/*/include/objc
887
888 %files -n libobjc
889 %defattr(644,root,root,755)
890 %doc libobjc/{ChangeLog,README*}
891 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
892
893 %files -n libobjc-static
894 %defattr(644,root,root,755)
895 %{_libdir}/libobjc.a
896 %endif
This page took 0.204687 seconds and 4 git commands to generate.