]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- release 9,
[packages/gcc4.git] / gcc4.spec
1 %define         STDC_VERSION 2.10.0
2 Summary:        GNU Compiler Collection
3 Summary(pl):    Kolekcja kompilatorów GNU
4 Name:           gcc
5 Version:        2.95.2
6 Release:        9
7 License:        GPL
8 Group:          Development/Languages
9 Group(pl):      Programowanie/Jêzyki
10 Source0:        ftp://ftp.gnu.org/pub/gnu/gcc/%{name}-%{version}.tar.gz
11 Source1:        gcov.1
12 Patch0:         %{name}-info.patch
13 Patch1:         %{name}-pld-linux.patch
14 Patch2:         %{name}-libstdc++.patch
15 Patch3:         %{name}-bootstrap.patch
16 Patch4:         %{name}-cpp-macro-doc.patch
17 Patch5:         %{name}-default-arch.patch
18 Patch6:         %{name}-cvs-updates-20000220.patch.gz
19 Patch7:         %{name}-libstdc++-out-of-mem.patch
20 Patch8:         %{name}-libstdc++-wstring.patch
21 Patch9:         %{name}-libstdc++-wall3.patch
22 Patch10:        %{name}-libstdc++-bastring.patch
23 Patch11:        %{name}-manpage.patch
24 Patch12:        %{name}-cpp-dos-newlines.patch
25 Patch13:        %{name}-g++-is-tree.patch
26 Patch14:        %{name}-gpc.patch
27 Patch15:        %{name}-arm-config.patch
28 Patch16:        %{name}-m68k-pic.patch
29 Patch17:        %{name}-sparc32-rfi.patch
30 Patch18:        %{name}-builtin-apply.patch
31 Patch19:        %{name}-gcj-backport.patch
32 Patch20:        %{name}-ppc-ice.patch
33 Patch21:        %{name}-ppc-descriptions.patch
34 Patch22:        %{name}-ppc-andrew-dwarf-eh.patch
35
36 Patch23:        %{name}-alpha-complex-float.patch
37 Patch24:        %{name}-emit-rtl.patch
38 Patch25:        %{name}-empty-struct-init.patch
39 Patch26:        %{name}-gcj-vs-iconv.patch
40 Patch27:        %{name}-libobjc.patch
41 Patch28:        %{name}-pointer-arith.patch
42
43 Patch100:       %{name}-glibc-2.2.patch
44 Requires:       binutils >= 2.9.1.0.25
45 Requires:       cpp = %{version}
46 URL:            http://gcc.gnu.org/
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 A compiler aimed at integrating all the optimizations and features
51 necessary for a high-performance and stable development environment.
52
53 %description -l pl
54 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
55 wyprodukowania szybkiego i stablinego kodu wynikowego.
56
57 %package c++
58 Summary:        C++ support for gcc
59 Summary(fr):    Support C++ pour le compilateur gcc
60 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
61 Summary(tr):    gcc için C++ desteði
62 Group:          Development/Languages
63 Group(pl):      Programowanie/Jêzyki
64 Obsoletes:      egcc-c++
65 Obsoletes:      egcs-c++
66
67 %description c++
68 This package adds C++ support to the GNU C compiler. It includes
69 support for most of the current C++ specification, including templates
70 and exception handling. It does not include a standard C++ library,
71 which is available separately.
72
73 %description -l de c++
74 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
75 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
76 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
77 sie ist getrennt erhältlich.
78
79 %description -l fr c++
80 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
81 support pour la plupart des spécifications actuelles de C++, dont les
82 modéles et la gestion des exceptions. Il ne comprend pas une
83 bibliothéque C++ standard, qui est disponible séparément.
84
85 %description -l pl c++
86 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
87 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
88 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
89
90 %description -l tr c++
91 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
92 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
93 C++ kitaplýðý bu pakette yer almaz.
94
95 %package objc
96 Summary:        Objective C support for gcc
97 Summary(de):    Objektive C-Unterstützung für gcc
98 Summary(fr):    Gestion d'Objective C pour gcc
99 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
100 Summary(tr):    gcc için Objective C desteði
101 Group:          Development/Languages
102 Group(pl):      Programowanie/Jêzyki
103 Obsoletes:      egcc-objc
104 Obsoletes:      egcs-objc
105
106 %description objc
107 This package adds Objective C support to the GNU C compiler. Objective
108 C is a object oriented derivative of the C language, mainly used on
109 systems running NeXTSTEP. This package does not include the standard
110 objective C object library.
111
112 %description -l de objc
113 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
114 Objective C ist ein objektorientiertes Derivat von C, das zur
115 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
116 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
117
118 %description -l fr objc
119 Ce package ajoute un support Objective C au compilateur C GNU.
120 L'Objective C est un langage orienté objetdérivé du langage C,
121 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
122 pas la bibliothéque Objective C standard.
123
124 %description -l pl objc
125 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
126 pakiecie nie ma jeszcze bibliotek C-obj.
127
128 %description -l tr objc
129 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
130 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
131 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
132 kitaplýðý bu pakette yer almaz.
133
134 %package g77
135 Summary:        Fortran 77 support for gcc
136 Summary(pl):    Wspomaganie Fortran 77 dla gcc
137 Group:          Development/Languages
138 Group(pl):      Programowanie/Jêzyki
139 Obsoletes:      egcs-g77
140
141 %description g77
142 This apckage adds support for compiling Fortran 77 programs with the
143 GNU compiler.
144
145 %description -l pl g77
146 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
147 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
148
149 %package chill
150 Summary:        CHILL support for gcc
151 Summary(pl):    Wspomoganie CHILL dla gcc
152 Group:          Development/Languages
153 Group(pl):      Programowanie/Jêzyki
154 Requires:       %{name} = %{version}
155
156 %description chill
157 This package adds support for compiling CHILL programs with the GNU
158 compiler.
159
160 Chill is the "CCITT High-Level Language", where CCITT is the old name
161 for what is now ITU, the International Telecommunications Union. It is
162 is language in the Modula2 family, and targets many of the same
163 applications as Ada (especially large embedded systems). Chill was
164 never used much in the United States, but is still being used in
165 Europe, Brazil, Korea, and other places.
166
167 %package java
168 Summary:        Java support for gcc
169 Summary(pl):    Wspomoganie Java dla gcc
170 Group:          Development/Languages
171 Group(pl):      Programowanie/Jêzyki
172 Requires:       %{name} = %{version}
173 Requires:       libgcj >= 2.95.1
174
175 %description java
176 This package adds experimental support for compiling Java(tm) programs
177 and bytecode into native code. To use this you will also need the
178 libgcj package.
179
180 %package -n libstdc++
181 Summary:        GNU c++ library
182 Summary(pl):    Biblioteki GNU C++ 
183 Group:          Libraries
184 Group(pl):      Biblioteki
185 Group(fr):      Development/Librairies
186 Version:        %{STDC_VERSION}
187 Obsoletes:      libg++
188
189 %description -n libstdc++
190 This is the GNU implementation of the standard C++ libraries, along
191 with additional GNU tools. This package includes the shared libraries
192 necessary to run C++ applications.
193
194 %description -l de -n libstdc++
195 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
196 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
197 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
198
199 %description -l fr -n libstdc++
200 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
201 des outils GNU supplémentaires. Ce package comprend les librairies
202 partagées nécessaires à l'exécution d'application C++.
203
204 %description -l pl -n libstdc++  
205 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
206 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
207 uruchomienia aplikacji napisanych w C++.
208
209 %description -l tr -n libstdc++
210 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
211 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
212
213 %package -n libstdc++-devel
214 Summary:        Header files and libraries for C++ development
215 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
216 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
217 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
218 Group:          Development/Libraries
219 Group(pl):      Programowanie/Biblioteki
220 Group(fr):      Development/Librairies
221 Version:        %{STDC_VERSION}
222 Requires:       libstdc++ = %{STDC_VERSION}
223 Requires:       %{name}-c++
224 Obsoletes:      libg++-devel
225
226 %description -n libstdc++-devel
227 This is the GNU implementation of the standard C++ libraries. This
228 package includes the header files and libraries needed for C++
229 development.
230
231 %description -l pl -n libstdc++-devel
232 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
233 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
234 programowaniu w jêzyku C++.
235
236 %package -n libstdc++-static
237 Summary:        Static c++ standard library
238 Summary(pl):    Biblioeka statyczna c++
239 Group:          Development/Libraries
240 Group(pl):      Programowanie/Biblioteki
241 Group(fr):      Development/Librairies
242 Version:        %{STDC_VERSION}
243 Requires:       libstdc++-devel = %{STDC_VERSION}
244
245 %description -n libstdc++-static
246 Static c++ standard library.
247
248 %description -l pl -n libstdc++-static
249 Biblioteka statyczna C++.
250
251 %package -n cpp
252 Summary:        The C Pre Processor
253 Summary(pl):    Preprocesor C
254 Group:          Development/Languages
255 Group(pl):      Programowanie/Jêzyki
256 Obsoletes:      egcs-cpp
257
258 %description -n cpp
259 The C preprocessor is a "macro processor" that is used automatically
260 by the C compiler to transform your program before actual compilation.
261 It is called a macro processor because it allows you to define
262 "macros", which are brief abbreviations for longer constructs.
263
264 The C preprocessor provides four separate facilities that you can use
265 as you see fit:
266
267 - Inclusion of header files. These are files of declarations that can
268   be substituted into your program.
269 - Macro expansion. You can define "macros", which are abbreviations
270   for arbitrary fragments of C code, and then the C preprocessor will
271   replace the macros with their definitions throughout the program.
272 - Conditional compilation. Using special preprocessing directives, you
273   can include or exclude parts of the program according to various
274   conditions.
275 - Line control. If you use a program to combine or rearrange source
276   files into an intermediate file which is then compiled, you can use
277   line control to inform the compiler of where each source line
278   originally came from.
279
280 %description -l pl -n cpp
281 Przeprocesor C jest "makro procesorem" który jest automatycznie
282 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
283 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
284 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
285 d³ugich konstrukcji w jêzyku C.
286
287 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
288
289 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
290   deklaracji polecenia do³±czenia innego pliku.
291 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
292   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
293   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
294 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
295   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
296   fragmenty obrabianego strumienia tekstów.
297 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
298   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
299   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
300   odpowiada fragment pliku wynikowego.
301
302 %prep
303 %setup -q
304 %patch0 -p1
305 %patch1 -p1
306 %patch2 -p1
307 %patch3 -p1
308 %patch4 -p0
309 %patch5 -p0
310 %patch6 -p1
311 %patch7 -p0
312 %patch8 -p0
313 %patch9 -p0
314 %patch10 -p0
315 %patch11 -p0
316 %patch12 -p0
317 %patch13 -p1
318 %patch14 -p1
319 %ifarch arm
320 %patch15 -p0
321 %endif
322 %ifarch m68k
323 %patch16 -p0
324 %endif
325 %ifarch sparc sparc32
326 %patch17 -p0
327 %patch18 -p0
328 %patch19 -p1
329 %endif
330 %ifarch ppc
331 %patch20 -p0
332 %patch21 -p0
333 %patch22 -p0
334 %endif
335 %ifarch alpha
336 %patch23 -p1
337 %endif
338 %patch24 -p0
339 %patch25 -p0
340 %patch26 -p0
341 %patch27 -p0
342 %patch28 -p0
343 #%patch100 -p1
344
345 %build
346 (cd gcc; autoconf)
347 rm -rf obj-%{_target_platform}
348 install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
349
350 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
351 ../configure \
352         --prefix=%{_prefix} \
353         --infodir=%{_infodir} \
354         --enable-shared \
355 %ifnarch sparc sparc64
356         --enable-threads \
357         --enable-haifa \
358 %endif
359         --with-gnu-as \
360         --with-gnu-ld \
361         --with-gxx-include-dir="\$\{prefix\}/include/g++" \
362         %{_target_platform}
363
364 PATH=$PATH:/sbin:%{_sbindir}
365 touch  ../gcc/c-gperf.h
366
367 %{__make} LDFLAGS_FOR_TARGET="-s" \
368         mandir=%{_mandir} \
369         infodir=%{_infodir}
370
371 %install
372 rm -rf $RPM_BUILD_ROOT
373 install -d $RPM_BUILD_ROOT%{_datadir}
374
375 cd obj-%{_target_platform}
376 PATH=$PATH:/sbin:%{_sbindir}
377
378 %{__make} install \
379         prefix=$RPM_BUILD_ROOT%{_prefix} \
380         mandir=$RPM_BUILD_ROOT%{_mandir} \
381         infodir=$RPM_BUILD_ROOT%{_infodir}
382
383 %{__make} install \
384         prefix=$RPM_BUILD_ROOT%{_prefix} \
385         mandir=$RPM_BUILD_ROOT%{_mandir} \
386         infodir=$RPM_BUILD_ROOT%{_infodir} -C texinfo
387
388 strip $RPM_BUILD_ROOT%{_bindir}/* || :
389
390 strip $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/{cc1,cc1chill,cc1obj,cc1plus,cpp,f771,collect2,jc1,jvgenmain}
391 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so*
392
393 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
394
395 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
396 echo .so cccp.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cpp.1
397 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
398
399 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
400
401 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
402
403 install -d $RPM_BUILD_ROOT/lib
404 (cd $RPM_BUILD_ROOT; \
405 ln -sf ../`dirname usr/lib/gcc-lib/%{_target_cpu}*/*/cpp`/cpp $RPM_BUILD_ROOT/lib/cpp)
406
407 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/{info/*.info*,man/man1/*} \
408           ../READ* ../ChangeLog ../gcc/ch/chill.brochure
409
410 %post
411 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
412
413 %postun
414 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
415
416 %post g77
417 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
418
419 %postun g77
420 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
421
422 %post chill
423 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
424
425 %postun chill
426 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
427
428 %post -n cpp
429 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
430
431 %postun -n cpp
432 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
433
434 %post   -p /sbin/ldconfig -n libstdc++
435 %postun -p /sbin/ldconfig -n libstdc++
436
437 %clean
438 rm -rf $RPM_BUILD_ROOT
439
440 %files
441 %defattr(644,root,root,755)
442 %doc READ* ChangeLog.gz
443
444 %dir %{_libdir}/gcc-lib
445 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
446 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
447 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
448
449 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
450 %attr(755,root,root) %{_bindir}/gcc
451 %attr(755,root,root) %{_bindir}/gcov
452 %attr(755,root,root) %{_bindir}/protoize
453 %attr(755,root,root) %{_bindir}/unprotoize
454 %attr(755,root,root) %{_bindir}/cc
455
456 %{_mandir}/man1/gcc.1*
457 %{_mandir}/man1/gcov.1*
458 %{_infodir}/gcc*
459
460 %{_libdir}/gcc-lib/%{_target_cpu}*/*/SYSCALLS.c.X
461 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
462 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
463 %{_libdir}/gcc-lib/%{_target_cpu}*/*/lib*.map
464 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
465
466 %ifnarch alpha
467 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
468 %endif
469
470 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
471
472 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
473 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
474 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
475 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
476 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
477 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
478 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
479 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
480 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/va-*.h
481 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
482
483 %files c++
484 %defattr(644,root,root,755)
485
486 %{_mandir}/man1/g++.1.gz
487
488 %attr(755,root,root) %{_bindir}/g++
489 %attr(755,root,root) %{_bindir}/c++
490 %attr(755,root,root) %{_bindir}/c++filt
491 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
492
493 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/exception
494 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new
495 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/typeinfo
496 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/new.h
497
498 %files objc
499 %defattr(644,root,root,755)
500
501 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
502
503 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
504 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
505
506 %files g77
507 %defattr(644,root,root,755)
508
509 %attr(755,root,root) %{_bindir}/g77
510 %attr(755,root,root) %{_bindir}/f77
511
512 %{_infodir}/g77*
513
514 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
515 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
516
517 %{_mandir}/man1/g77.1*
518 %{_mandir}/man1/f77.1*
519
520 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
521
522 %files chill
523 %defattr(644,root,root,755)
524 %doc gcc/ch/chill.brochure.gz
525
526 %attr(755,root,root) %{_bindir}/chill
527
528 %{_infodir}/chill*
529
530 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
531 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
532 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
533
534 %files java
535 %defattr(644,root,root,755)
536
537 %attr(755,root,root) %{_bindir}/gcj
538 %attr(755,root,root) %{_bindir}/gcjh
539 %attr(755,root,root) %{_bindir}/jcf-dump
540 %attr(755,root,root) %{_bindir}/jv-scan
541
542 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
543 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
544
545 %files -n libstdc++
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
548
549 %files -n libstdc++-devel
550 %defattr(644,root,root,755)
551 %{_includedir}/g++
552 %attr(755,root,root) %{_libdir}/libstdc++.so
553
554 %files -n libstdc++-static
555 %defattr(644,root,root,755)
556 %attr(644,root,root) %{_libdir}/libstdc++.a
557
558 %files -n cpp
559 %defattr(644,root,root,755)
560 %attr(755,root,root) /lib/cpp
561
562 %{_mandir}/man1/cpp.1*
563 %{_mandir}/man1/cccp.1*
564 %{_infodir}/cpp.info*.gz
565
566 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp
This page took 0.171084 seconds and 4 git commands to generate.