]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- bconds readded.
[packages/gcc4.git] / gcc4.spec
1 #
2 # Conditional build:
3 #
4 %bcond_without  ada             # build without ADA support
5 %bcond_without  fortran         # build without Fortran support
6 %bcond_without  java            # build without Java support
7 %bcond_without  objc            # build without ObjC support
8 #
9 # TODO:
10 #               - http://gcc.gnu.org/PR11203 (inline-asm)
11 #               - http://gcc.gnu.org/PR18648 (missed tree-optimization)
12 #               - disable internal zlib usage
13 #               - bconds (ada, objc, fortran)
14 #               - translations from gcc.spec:HEAD
15 #
16 %define         _snap           20050102
17 #
18 Summary:        GNU Compiler Collection: the C compiler and shared files
19 Summary(pl):    Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
20 Name:           gcc
21 Epoch:          5
22 Version:        4.0.0
23 Release:        0.%{_snap}.0.4
24 License:        GPL
25 Group:          Development/Languages
26 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
27 #Source0:       ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
28 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/%{name}-4.0-%{_snap}.tar.bz2
29 # Source0-md5:  d5bf439e5a0653f503aaf6bf28609e33
30 Patch0:         %{name}-info.patch
31 Patch1:         %{name}-nolocalefiles.patch
32 Patch2:         %{name}-nodebug.patch
33 Patch3:         %{name}-ada-link-new-libgnat.patch
34 Patch4:         %{name}-ada-link.patch
35 Patch5:         %{name}-pr18910.patch
36 Patch6:         %{name}-pr19030.patch
37 Patch7:         %{name}-pr18241.patch
38 URL:            http://gcc.gnu.org/
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  binutils >= 2:2.15.94.0.1
42 BuildRequires:  bison
43 BuildRequires:  fileutils >= 4.0.41
44 BuildRequires:  flex
45 %if %{with ada}
46 BuildRequires:  gcc(ada)
47 BuildRequires:  gcc-ada
48 %endif
49 BuildRequires:  gettext-devel
50 BuildRequires:  glibc-devel >= 2.2.5-20
51 BuildRequires:  gmp-devel
52 BuildRequires:  libmpfr-devel
53 BuildRequires:  perl-devel
54 BuildRequires:  texinfo >= 4.1
55 BuildRequires:  zlib-devel
56 Requires:       binutils >= 2:2.15.94.0.1
57 Requires:       libgcc = %{epoch}:%{version}-%{release}
58 Provides:       cpp = %{epoch}:%{version}-%{release}
59 %{?with_ada:Provides:   gcc(ada)}
60 Obsoletes:      cpp
61 Obsoletes:      egcs-cpp
62 Obsoletes:      gcc-cpp
63 Obsoletes:      gcc-ksi
64 Obsoletes:      gont
65 Conflicts:      glibc-devel < 2.2.5-20
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _slibdir        /%{_lib}
69
70 %description
71 A compiler aimed at integrating all the optimizations and features
72 necessary for a high-performance and stable development environment.
73
74 This package contains the C compiler and some files shared by various
75 parts of the GNU Compiler Collection. In order to use another GCC
76 compiler you will need to install the appropriate subpackage.
77
78 %description -l pl
79 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
80 wyprodukowania szybkiego i stabilnego kodu wynikowego.
81
82 Ten pakiet zawiera kompilator C i pliki wspó³dzielone przez ró¿ne
83 czê¶ci kolekcji kompilatorów GNU (GCC). ¯eby u¿ywaæ innego kompilatora
84 z GCC, trzeba zainstalowaæ odpowiedni podpakiet.
85
86 %package -n libgcc
87 Summary:        Shared gcc library
88 Summary(pl):    Biblioteka gcc
89 Group:          Libraries
90 Obsoletes:      libgcc1
91
92 %description -n libgcc
93 Shared gcc library.
94
95 %description -n libgcc -l pl
96 Biblioteka dynamiczna gcc.
97
98 %package -n libmudflap
99 Summary:        GCC mudflap shared support library
100 Group:          Libraries
101
102 %description -n libmudflap
103 The libmudflap libraries are used by GCC for instrumenting pointer and
104 array dereferencing operations.
105
106 %package -n libmudflap-devel
107 Summary:        Development files for GCC mudflap library
108 Group:          Development/Libraries
109 Requires:       libmudflap = %{epoch}:%{version}-%{release}
110
111 %description -n libmudflap-devel
112 The libmudflap libraries are used by GCC for instrumenting pointer and
113 array dereferencing operations. This package contains development
114 files.
115
116 %package -n libmudflap-static
117 Summary:        Static GCC mudflap library
118 Group:          Development/Libraries
119 Requires:       libmudflap-devel = %{epoch}:%{version}-%{release}
120
121 %description -n libmudflap-static
122 The libmudflap libraries are used by GCC for instrumenting pointer and
123 array dereferencing operations. This package contains static
124 libraries.
125
126 %package ada
127 Summary:        Ada support for gcc
128 Summary(pl):    Obs³uga Ady do gcc
129 Group:          Development/Languages
130 Requires:       %{name} = %{epoch}:%{version}-%{release}
131 Requires:       libgnat = %{epoch}:%{version}-%{release}
132 Obsoletes:      gcc-gnat
133 Obsoletes:      gnat-devel
134
135 %description ada
136 This package adds experimental support for compiling Ada programs.
137
138 %description ada -l pl
139 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów w
140 Adzie.
141
142 %package -n libgnat
143 Summary:        Ada standard libraries
144 Summary(pl):    Biblioteki standardowe dla Ady
145 Group:          Development/Libraries
146 Obsoletes:      gnat
147 Obsoletes:      libgnat1
148
149 %description -n libgnat
150 This package contains shared libraries needed to run programs written
151 in Ada.
152
153 %description -n libgnat -l pl
154 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów
155 napisanych w Adzie.
156
157 %package -n libgnat-static
158 Summary:        Static Ada standard libraries
159 Summary(pl):    Statyczne biblioteki standardowe dla Ady
160 Group:          Development/Libraries
161 Obsoletes:      gnat-static
162
163 %description -n libgnat-static
164 This package contains static libraries for programs written in Ada.
165
166 %description -n libgnat-static -l pl
167 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
168 Adzie.
169
170 %package c++
171 Summary:        C++ support for gcc
172 Summary(pl):    Obs³uga C++ dla gcc
173 Group:          Development/Languages
174 Requires:       %{name} = %{epoch}:%{version}-%{release}
175 Obsoletes:      egcc-c++
176 Obsoletes:      egcs-c++
177
178 %description c++
179 This package adds C++ support to the GNU Compiler Collection. It
180 includes support for most of the current C++ specification, including
181 templates and exception handling. It does not include a standard C++
182 library, which is available separately.
183
184 %description c++ -l pl
185 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
186 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
187 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
188
189 %package -n libstdc++
190 Summary:        GNU C++ library
191 Summary(pl):    Biblioteki GNU C++
192 Group:          Libraries
193 Obsoletes:      libg++
194 Obsoletes:      libstdc++3
195
196 %description -n libstdc++
197 This is the GNU implementation of the standard C++ libraries, along
198 with additional GNU tools. This package includes the shared libraries
199 necessary to run C++ applications.
200
201 %description -n libstdc++ -l pl
202 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
203 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
204 uruchomienia aplikacji napisanych w C++.
205
206 %package -n libstdc++-devel
207 Summary:        Header files and documentation for C++ development
208 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
209 Group:          Development/Libraries
210 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
211 Requires:       glibc-devel
212 Requires:       libstdc++ = %{epoch}:%{version}-%{release}
213 Obsoletes:      libg++-devel
214 Obsoletes:      libstdc++3-devel
215
216 %description -n libstdc++-devel
217 This is the GNU implementation of the standard C++ libraries. This
218 package includes the header files needed for C++ development and
219 library documentation.
220
221 %description -n libstdc++-devel -l pl
222 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
223 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
224 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
225
226 %package -n libstdc++-static
227 Summary:        Static C++ standard library
228 Summary(pl):    Statyczna biblioteka standardowa C++
229 Group:          Development/Libraries
230 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
231
232 %description -n libstdc++-static
233 Static C++ standard library.
234
235 %description -n libstdc++-static -l pl
236 Statyczna biblioteka standardowa C++.
237
238 %package fortran
239 Summary:        Fortran 95 support for gcc
240 Summary(pl):    Obs³uga Fortranu 95 dla gcc
241 Group:          Development/Languages/Fortran
242 Requires:       libgfortran = %{epoch}:%{version}-%{release}
243 Obsoletes:      egcs-g77
244 Obsoletes:      gcc-g77
245
246 %description fortran
247 This package adds support for compiling Fortran 95 programs with the
248 GNU compiler.
249
250 %description fortran -l pl
251 Ten pakiet dodaje obs³ugê Fortranu 95 do kompilatora gcc. Jest
252 potrzebny do kompilowania programów pisanych w jêzyku Fortran 95.
253
254 %package -n libgfortran
255 Summary:        Fortran 95 Libraries
256 Summary(pl):    Biblioteki Fortranu 95
257 Group:          Development/Libraries
258 Obsoletes:      libg2c
259
260 %description -n libgfortran
261 Fortran 95 Libraries.
262
263 %description -n libgfortran -l pl
264 Biblioteki Fortranu 95.
265
266 %package -n libgfortran-static
267 Summary:        Static Fortran 95 Libraries
268 Summary(pl):    Statyczne Biblioteki Fortranu 95
269 Group:          Development/Libraries
270 Requires:       libgfortran = %{epoch}:%{version}-%{release}
271 Obsoletes:      libg2c-static
272
273 %description -n libgfortran-static
274 Static Fortran 95 Libraries.
275
276 %description -n libgfortran-static -l pl
277 Statyczne biblioteki Fortranu 95.
278
279 %package java
280 Summary:        Java support for gcc
281 Summary(pl):    Obs³uga Javy dla gcc
282 Group:          Development/Languages/Java
283 Requires:       %{name} = %{epoch}:%{version}-%{release}
284 Requires:       libgcj = %{epoch}:%{version}-%{release}
285 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
286 Requires:       java-shared
287 Provides:       gcj = %{epoch}:%{version}-%{release}
288
289 %description java
290 This package adds experimental support for compiling Java(tm) programs
291 and bytecode into native code. To use this you will also need the
292 libgcj package.
293
294 %description java -l pl
295 Wsparcie dla kompilowania programów Java(tm) zarówno do bajt-kodu jak
296 i do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
297 by³o przeprowadziæ kompilacjê.
298
299 %package -n libgcj
300 Summary:        Java Class Libraries
301 Summary(pl):    Biblioteki Klas Javy
302 Group:          Libraries
303 Requires:       zlib
304 Obsoletes:      libgcj3
305
306 %description -n libgcj
307 Java Class Libraries.
308
309 %description -n libgcj -l pl
310 Biblioteki Klas Javy.
311
312 %package -n libgcj-devel
313 Summary:        Development files for Java Class Libraries
314 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
315 Group:          Development/Libraries
316 Requires:       libgcj = %{epoch}:%{version}-%{release}
317 Obsoletes:      libgcj3-devel
318
319 %description -n libgcj-devel
320 Development files for Java Class Libraries.
321
322 %description -n libgcj-devel -l pl
323 Pliki nag³ówkowe dla Bibliotek Klas Javy.
324
325 %package -n libgcj-static
326 Summary:        Static Java Class Libraries
327 Summary(pl):    Statyczne Biblioteki Klas Javy
328 Group:          Development/Libraries
329 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
330 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
331
332 %description -n libgcj-static
333 Static Java Class Libraries.
334
335 %description -n libgcj-static -l pl
336 Statyczne Biblioteki Klas Javy.
337
338 %package -n libffi
339 Summary:        Foreign Function Interface library
340 Summary(pl):    Biblioteka zewnêtrznych wywo³añ funkcji
341 Group:          Libraries
342
343 %description -n libffi
344 The libffi library provides a portable, high level programming
345 interface to various calling conventions. This allows a programmer to
346 call any function specified by a call interface description at run
347 time.
348
349 %description -n libffi -l pl
350 Biblioteka libffi dostarcza przeno¶nego, wysokopoziomowego
351 miêdzymordzia do ró¿nych konwencji wywo³añ funkcji. Pozwala to
352 programi¶cie wywo³ywaæ dowolne funkcje podaj±c konwencjê wywo³ania w
353 czasie wykonania.
354
355 %package -n libffi-devel
356 Summary:        Development files for Foreign Function Interface library
357 Summary(pl):    Pliki nag³ówkowe dla libffi
358 Group:          Development/Libraries
359 Requires:       libffi = %{epoch}:%{version}-%{release}
360
361 %description -n libffi-devel
362 Development files for Foreign Function Interface library.
363
364 %description -n libffi-devel -l pl
365 Pliki nag³ówkowe dla libffi.
366
367 %package -n libffi-static
368 Summary:        Static Foreign Function Interface library
369 Summary(pl):    Statyczna biblioteka libffi
370 Group:          Development/Libraries
371 Requires:       libffi-devel = %{epoch}:%{version}-%{release}
372
373 %description -n libffi-static
374 Static Foreign Function Interface library.
375
376 %description -n libffi-static -l pl
377 Statyczna biblioteka libffi.
378
379 %package java-tools
380 Summary:        Shared java tools
381 Summary(pl):    Wspó³dzielone narzêdzia javy
382 Group:          Development/Languages/Java
383 Provides:       jar = %{epoch}:%{version}-%{release}
384 Provides:       java-shared
385 Obsoletes:      fastjar
386 Obsoletes:      java-shared
387 Obsoletes:      jar
388
389 %description java-tools
390 This package contains tools that are common for every Java(tm)
391 implementation, such as rmic or jar.
392
393 %description java-tools -l pl
394 Pakiet ten zawiera narzêdzia wspólne dla ka¿dej implementacji
395 Javy(tm), takie jak rmic czy jar.
396
397 %package objc
398 Summary:        Objective C support for gcc
399 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
400 Group:          Development/Languages
401 Requires:       %{name} = %{epoch}:%{version}-%{release}
402 Requires:       libobjc = %{epoch}:%{version}-%{release}
403 Obsoletes:      egcc-objc
404 Obsoletes:      egcs-objc
405
406 %description objc
407 This package adds Objective C support to the GNU Compiler Collection.
408 Objective C is a object oriented derivative of the C language, mainly
409 used on systems running NeXTSTEP. This package does not include the
410 standard objective C object library.
411
412 %description objc -l pl
413 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
414 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
415 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
416 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
417
418 %package -n libobjc
419 Summary:        Objective C Libraries
420 Summary(pl):    Biblioteki Obiektowego C
421 Group:          Libraries
422 Obsoletes:      libobjc1
423
424 %description -n libobjc
425 Objective C Libraries.
426
427 %description -n libobjc -l pl
428 Biblioteki Obiektowego C.
429
430 %package -n libobjc-static
431 Summary:        Static Objective C Libraries
432 Summary(pl):    Statyczne Biblioteki Obiektowego C
433 Group:          Development/Libraries
434 Requires:       libobjc = %{epoch}:%{version}-%{release}
435
436 %description -n libobjc-static
437 Static Objective C Libraries.
438
439 %description -n libobjc-static -l pl
440 Statyczne biblioteki Obiektowego C.
441
442 %prep
443 # prerelease
444 #setup -q -n gcc-%{version}-%{_snap}
445 # snapshot
446 %setup -q -n gcc-4.0-%{_snap}
447 # final
448 #setup -q -n gcc-%{version}
449
450 #patch0 -p1     NEEDS UPDATE
451 %patch1 -p1
452 %{!?debug:%patch2 -p1}
453 %patch3 -p1
454 %patch4 -p1
455 %patch5 -p1
456 %patch6 -p1
457 %patch7 -p1
458
459 # because we distribute modified version of gcc...
460 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
461 perl -pi -e 's@(bug_report_url.*<URL:).*";@$1http://bugs.pld-linux.org/>";@' gcc/version.c
462
463 mv ChangeLog ChangeLog.general
464
465 %build
466 cd gcc
467 %{__autoconf}
468 cd ..
469 cp -f /usr/share/automake/config.sub .
470
471 rm -rf obj-%{_target_platform}
472 install -d obj-%{_target_platform}
473 cd obj-%{_target_platform}
474
475 CFLAGS="%{rpmcflags}" \
476 CXXFLAGS="%{rpmcflags}" \
477 TEXCONFIG=false \
478 ../configure \
479         --prefix=%{_prefix} \
480         --libdir=%{_libdir} \
481         --libexecdir=%{_libexecdir} \
482         --infodir=%{_infodir} \
483         --mandir=%{_mandir} \
484         --enable-shared \
485         --enable-threads=posix \
486         --enable-__cxa_atexit \
487         --enable-languages="c,c++%{?with_fortran:,f95}%{?with_objc:,objc}%{?with_ada:,ada}%{?with_java:,java}" \
488         --enable-c99 \
489         --enable-long-long \
490 %ifarch amd64
491         --disable-multilib \
492 %else
493         --enable-multilib \
494 %endif
495         --enable-nls \
496         --with-gnu-as \
497         --with-gnu-ld \
498         --with-system-zlib \
499         --with-slibdir=%{_slibdir} \
500         --without-x \
501         --enable-cmath \
502         %{_target_platform}
503
504 cd ..
505
506 %{__make} -C obj-%{_target_platform} \
507         profiledbootstrap \
508         GCJFLAGS="%{rpmcflags}" \
509         BOOT_CFLAGS="%{rpmcflags}" \
510         STAGE1_CFLAGS="%{rpmcflags}" \
511         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
512         mandir=%{_mandir} \
513         infodir=%{_infodir}
514
515 %install
516 rm -rf $RPM_BUILD_ROOT
517 install -d $RPM_BUILD_ROOT{/lib,%{_aclocaldir},%{_datadir},%{_infodir}}
518
519 cd obj-%{_target_platform}
520
521 %{__make} -j1 install \
522         mandir=%{_mandir} \
523         infodir=%{_infodir} \
524         DESTDIR=$RPM_BUILD_ROOT
525
526 install gcc/specs $RPM_BUILD_ROOT%{_libdir}/gcc/%{_target_platform}/%{version}
527
528 %ifarch sparc64
529 ln -sf  $RPM_BUILD_ROOT%{_bindir}/sparc64-pld-linux-gcc \
530         $RPM_BUILD_ROOT%{_bindir}/sparc-pld-linux-gcc
531 %endif
532
533 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
534 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
535
536 %if %{with fortran}
537 ln -sf gfortran $RPM_BUILD_ROOT%{_bindir}/g95
538 echo ".so gfortran.1" > $RPM_BUILD_ROOT%{_mandir}/man1/g95.1
539 %endif
540
541 %if %{with ada}
542 # move ada shared libraries to proper place...
543 mv -f   $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/adalib/*.so.1 \
544         $RPM_BUILD_ROOT%{_libdir}
545 # check if symlink to be made is valid
546 test -f $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so.1
547 ln -sf  libgnat-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so
548 ln -sf  libgnarl-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnarl-4.0.so
549 ln -sf  libgnat-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnat.so
550 ln -sf  libgnarl-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnarl.so
551 ln -sf  %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
552 %endif
553
554 cd ..
555
556 %if %{with java}
557 install -d java-doc
558 cp -f   libjava/READ* java-doc
559 cp -f   fastjar/README java-doc/README.fastjar
560 cp -f   libffi/README java-doc/README.libffi
561 cp -f   libffi/LICENSE java-doc/LICENSE.libffi
562 %endif
563 %if %{with objc}
564 cp -f   libobjc/README gcc/objc/README.libobjc
565 %endif
566
567 # avoid -L poisoning in *.la - there should be only -L%{_libdir}/gcc/*/%{version}
568 for f in libstdc++.la libsupc++.la %{?with_java:libgcj.la};
569 do
570         perl -pi -e 's@-L[^ ]*[acs.] @@g' $RPM_BUILD_ROOT%{_libdir}/$f
571 done
572 # normalize libdir, to avoid propagation of unnecessary RPATHs by libtool
573 for f in libstdc++.la libsupc++.la \
574         %{?with_fortran:libgfortran.la libgfortranbegin.la} \
575         %{?with_java:libgcj.la lib-org-w3c-dom.la lib-org-xml-sax.la libffi.la} \
576         %{?with_objc:libobjc.la};
577 do
578         perl -pi -e "s@^libdir='.*@libdir='/usr/%{_lib}'@" $RPM_BUILD_ROOT%{_libdir}/$f
579 done
580
581 # include/ contains install-tools/include/* and headers that were fixed up
582 # by fixincludes, we don't want former
583 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
584 mkdir   $gccdir/tmp
585 # we have to save these however
586 mv -f   $gccdir/include/{%{?with_java:gcj,libffi/ffitarget.h,}%{?with_objc:objc,}syslimits.h} \
587         $gccdir/tmp
588 rm -rf  $gccdir/include
589 mv -f   $gccdir/tmp \
590         $gccdir/include
591 cp -f   $gccdir/install-tools/include/*.h \
592         $gccdir/include
593 # but we don't want anything more from install-tools
594 rm -rf  $gccdir/install-tools
595
596 %find_lang gcc
597 %find_lang libstdc\+\+
598
599 %clean
600 rm -rf $RPM_BUILD_ROOT
601
602 %post
603 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
604
605 %postun
606 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
607
608 %post ada
609 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
610
611 %postun ada
612 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
613
614 %post fortran
615 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
616
617 %postun fortran
618 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
619
620 %post java
621 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
622
623 %postun java
624 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
625
626 %post   -p /sbin/ldconfig -n libgcc
627 %postun -p /sbin/ldconfig -n libgcc
628 %post   -p /sbin/ldconfig -n libmudflap
629 %postun -p /sbin/ldconfig -n libmudflap
630 %post   -p /sbin/ldconfig -n libgnat
631 %postun -p /sbin/ldconfig -n libgnat
632 %post   -p /sbin/ldconfig -n libstdc++
633 %postun -p /sbin/ldconfig -n libstdc++
634 %post   -p /sbin/ldconfig -n libgfortran
635 %postun -p /sbin/ldconfig -n libgfortran
636 %post   -p /sbin/ldconfig -n libgcj
637 %postun -p /sbin/ldconfig -n libgcj
638 %post   -p /sbin/ldconfig -n libffi
639 %postun -p /sbin/ldconfig -n libffi
640 %post   -p /sbin/ldconfig -n libobjc
641 %postun -p /sbin/ldconfig -n libobjc
642
643 %files -f gcc.lang
644 %defattr(644,root,root,755)
645 %doc ChangeLog.general MAINTAINERS bugs.html faq.html
646 %doc gcc/{ChangeLog,ONEWS,README.Portability}
647 %dir %{_libdir}/gcc
648 %dir %{_libdir}/gcc/*
649 %dir %{_libdir}/gcc/*/*
650 %dir %{_libdir}/gcc/*/*/include
651
652 %attr(755,root,root) %{_bindir}/*-gcc*
653 %attr(755,root,root) %{_bindir}/gcc
654 %attr(755,root,root) %{_bindir}/gccbug
655 %attr(755,root,root) %{_bindir}/gcov
656 %attr(755,root,root) %{_bindir}/cc
657 %attr(755,root,root) %{_bindir}/cpp
658
659 %{_mandir}/man1/cc.1*
660 %{_mandir}/man1/cpp.1*
661 %{_mandir}/man1/gcc.1*
662 %{_mandir}/man1/gcov.1*
663
664 %{_infodir}/cpp*
665 %{_infodir}/gcc*
666
667 %attr(755,root,root) /lib/cpp
668
669 %attr(755,root,root) %{_slibdir}/lib*.so
670 %{_libdir}/gcc/*/*/libgcov.a
671 %{_libdir}/gcc/*/*/libgcc.a
672 %{_libdir}/gcc/*/*/libgcc_eh.a
673 %{_libdir}/gcc/*/*/specs
674 %attr(644,root,root) %{_libdir}/gcc/*/*/crt*.o
675 %ifarch sparc64
676 %{_libdir}/gcc/*/*/*/libgcc.a
677 %{_libdir}/gcc/*/*/*/libgcc_eh.a
678 %attr(644,root,root) %{_libdir}/gcc/*/*/*/crt*.o
679 %endif
680 %ifarch ppc
681 %attr(644,root,root) %{_libdir}/gcc/*/*/ecrt*.o
682 %attr(644,root,root) %{_libdir}/gcc/*/*/ncrt*.o
683 %{_libdir}/gcc/*/*/nof
684 %dir %{_libdir}/nof
685 %endif
686 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1
687 %attr(755,root,root) %{_libdir}/gcc/*/*/collect2
688
689 %{_libdir}/gcc/*/*/include/*.h
690
691 %files -n libgcc
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_slibdir}/lib*.so.*
694
695 %files -n libmudflap
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/libmudflap*.so.*.*.*
698
699 %files -n libmudflap-devel
700 %defattr(644,root,root,755)
701 %{_includedir}/mf-runtime.h
702 %{_libdir}/libmudflap*.la
703 %attr(755,root,root) %{_libdir}/libmudflap*.so
704
705 %files -n libmudflap-static
706 %defattr(644,root,root,755)
707 %{_libdir}/libmudflap*.a
708
709 %if %{with ada}
710 %files ada
711 %defattr(644,root,root,755)
712 %doc gcc/ada/ChangeLog
713 %attr(755,root,root) %{_bindir}/gnat*
714 %attr(755,root,root) %{_bindir}/gpr*
715 %attr(755,root,root) %{_libdir}/libgnarl*.so
716 %attr(755,root,root) %{_libdir}/libgnat*.so
717 %attr(755,root,root) %{_libdir}/gcc/*/*/gnat1
718 %{_libdir}/gcc/*/*/adainclude
719 %dir %{_libdir}/gcc/*/*/adalib
720 %{_libdir}/gcc/*/*/adalib/*.ali
721 %{_libdir}/gcc/*/*/adalib/g-trasym.o
722 %{_libdir}/gcc/*/*/adalib/libgccprefix.a
723 %ifarch %{ix86}
724 %{_libdir}/gcc/*/*/adalib/libgmem.a
725 %endif
726 %{_datadir}/gnat
727 %{_infodir}/gnat*
728
729 %files -n libgnat
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libgnarl*.so.1
732 %attr(755,root,root) %{_libdir}/libgnat*.so.1
733
734 %files -n libgnat-static
735 %defattr(644,root,root,755)
736 %{_libdir}/gcc/*/*/adalib/libgnarl.a
737 %{_libdir}/gcc/*/*/adalib/libgnat.a
738 %endif
739
740 %files c++
741 %defattr(644,root,root,755)
742 %doc gcc/cp/{ChangeLog,NEWS}
743 %attr(755,root,root) %{_bindir}/g++
744 %attr(755,root,root) %{_bindir}/*-g++
745 %attr(755,root,root) %{_bindir}/c++
746 %attr(755,root,root) %{_bindir}/*-c++
747 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1plus
748 %{_libdir}/libsupc++.a
749 %{_libdir}/libsupc++.la
750 %{_mandir}/man1/g++.1*
751
752 %files -n libstdc++ -f libstdc++.lang
753 %defattr(644,root,root,755)
754 %doc libstdc++-v3/{ChangeLog,README}
755 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
756
757 %files -n libstdc++-devel
758 %defattr(644,root,root,755)
759 %doc libstdc++-v3/docs/html
760 %dir %{_includedir}/c++
761 %{_includedir}/c++/%{version}
762 %if %{with java}
763 %exclude %{_includedir}/c++/%{version}/java
764 %exclude %{_includedir}/c++/%{version}/javax
765 %exclude %{_includedir}/c++/%{version}/gcj
766 %exclude %{_includedir}/c++/%{version}/gnu
767 %endif
768 %exclude %{_includedir}/c++/%{version}/*/bits/stdc++.h.gch
769 %{_libdir}/libstdc++.la
770 %attr(755,root,root) %{_libdir}/libstdc++.so
771
772 %files -n libstdc++-static
773 %defattr(644,root,root,755)
774 %{_libdir}/libstdc++.a
775
776 %if %{with fortran}
777 %files fortran
778 %defattr(644,root,root,755)
779 %doc gcc/fortran/ChangeLog
780 %attr(755,root,root) %{_bindir}/g95
781 %attr(755,root,root) %{_bindir}/gfortran
782 %{_infodir}/gfortran*
783 %attr(755,root,root) %{_libdir}/gcc/*/*/f951
784 %{_libdir}/libgfortranbegin.a
785 %{_libdir}/libgfortranbegin.la
786 %{_libdir}/libgfortran.la
787 %attr(755,root,root) %{_libdir}/libgfortran.so
788 %{_mandir}/man1/g95.1*
789 %{_mandir}/man1/gfortran.1*
790
791 %files -n libgfortran
792 %defattr(644,root,root,755)
793 %doc libgfortran/{AUTHORS,README,ChangeLog}
794 %attr(755,root,root) %{_libdir}/libgfortran.so.*.*.*
795
796 %files -n libgfortran-static
797 %defattr(644,root,root,755)
798 %{_libdir}/libgfortran.a
799 %endif
800
801 %if %{with java}
802 %files java
803 %defattr(644,root,root,755)
804 %doc gcc/java/ChangeLog java-doc/*
805 %attr(755,root,root) %{_bindir}/gcj*
806 %attr(755,root,root) %{_bindir}/gij
807 %attr(755,root,root) %{_bindir}/grepjar
808 %attr(755,root,root) %{_bindir}/jcf-dump
809 %attr(755,root,root) %{_bindir}/jv-*
810 %attr(755,root,root) %{_bindir}/*-gcj*
811 %attr(755,root,root) %{_libdir}/gcc/*/*/jc1
812 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
813 %{_infodir}/gcj*
814 %{_mandir}/man1/gcj*
815 %{_mandir}/man1/gij*
816 %{_mandir}/man1/grepjar*
817 %{_mandir}/man1/jcf-*
818 %{_mandir}/man1/jv-*
819
820 %files java-tools
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_bindir}/grmi*
823 %attr(755,root,root) %{_bindir}/fastjar
824 %{_mandir}/man1/grmi*
825 %{_mandir}/man1/fastjar*
826 %{_infodir}/fastjar*
827
828 %files -n libgcj
829 %defattr(644,root,root,755)
830 %doc libjava/{ChangeLog,LIBGCJ_LICENSE,NEWS,README,THANKS}
831 %attr(755,root,root) %{_bindir}/addr2name.awk
832 %attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
833 %attr(755,root,root) %{_libdir}/libgij.so.*.*.*
834 %attr(755,root,root) %{_libdir}/lib-org*.so.*.*.*
835 %{_libdir}/logging.properties
836
837 %files -n libgcj-devel
838 %defattr(644,root,root,755)
839 %{_includedir}/c++/%{version}/java
840 %{_includedir}/c++/%{version}/javax
841 %{_includedir}/c++/%{version}/gcj
842 %{_includedir}/c++/%{version}/gnu
843 %{_libdir}/gcc/*/*/include/gcj
844 %dir %{_libdir}/security
845 %{_libdir}/security/*
846 %dir %{_datadir}/java
847 %{_datadir}/java/libgcj*.jar
848 %{_libdir}/lib*cj.spec
849 %{_libdir}/lib*cj*.la
850 %attr(755,root,root) %{_libdir}/lib*cj*.so
851 %{_libdir}/libgij.la
852 %attr(755,root,root) %{_libdir}/libgij.so
853 %attr(755,root,root) %{_libdir}/lib-org-*.so
854 %{_libdir}/lib-org-*.la
855 %{_pkgconfigdir}/libgcj.pc
856
857 %files -n libgcj-static
858 %defattr(644,root,root,755)
859 %{_libdir}/lib*cj*.a
860 %{_libdir}/libgij.a
861 %{_libdir}/lib-org-*.a
862
863 %files -n libffi
864 %defattr(644,root,root,755)
865 %doc libffi/{ChangeLog,ChangeLog.libgcj,LICENSE,README}
866 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
867
868 %files -n libffi-devel
869 %defattr(644,root,root,755)
870 %{_libdir}/gcc/*/*/include/ffitarget.h
871 %attr(755,root,root) %{_libdir}/libffi.so
872 %{_libdir}/libffi.la
873 %{_includedir}/ffi.h
874
875 %files -n libffi-static
876 %defattr(644,root,root,755)
877 %{_libdir}/libffi.a
878 %endif
879
880 %if %{with objc}
881 %files objc
882 %defattr(644,root,root,755)
883 %doc gcc/objc/README
884 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1obj
885 %attr(755,root,root) %{_libdir}/libobjc.so
886 %{_libdir}/libobjc.la
887 %{_libdir}/gcc/*/*/include/objc
888
889 %files -n libobjc
890 %defattr(644,root,root,755)
891 %doc libobjc/{ChangeLog,README*}
892 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
893
894 %files -n libobjc-static
895 %defattr(644,root,root,755)
896 %{_libdir}/libobjc.a
897 %endif
This page took 0.127833 seconds and 4 git commands to generate.