]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
removed chill doc
[packages/gcc4.git] / gcc4.spec
1 %define         STDC_VERSION    3.0.0
2 %define         GCJ_VERSION     3.0.0
3 %define         snap            2001-05-07
4 %define         rsnap           %(echo %{snap} | sed -e "s#-##g")
5 Summary:        GNU Compiler Collection
6 Summary(pl):    Kolekcja kompilatorów GNU
7 Name:           gcc
8 Version:        3.0
9 Release:        0.%{rsnap}
10 License:        GPL
11 Group:          Development/Languages
12 Group(de):      Entwicklung/Sprachen
13 Group(pl):      Programowanie/Jêzyki
14 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/%{snap}/%{name}-%{rsnap}.tar.gz
15 Patch0:         %{name}-disableshared.patch
16 BuildRequires:  bison
17 BuildRequires:  texinfo
18 BuildRequires:  zlib-devel
19 BuildRequires:  fileutils >= 4.0.41
20 BuildRequires:  autoconf
21 Requires:       binutils >= 2.9.1.0.25
22 Requires:       cpp = %{version}
23 URL:            http://gcc.gnu.org/
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A compiler aimed at integrating all the optimizations and features
28 necessary for a high-performance and stable development environment.
29
30 %description -l pl
31 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
32 wyprodukowania szybkiego i stablinego kodu wynikowego.
33
34 %package c++
35 Summary:        C++ support for gcc
36 Summary(fr):    Support C++ pour le compilateur gcc
37 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
38 Summary(tr):    gcc için C++ desteði
39 Group:          Development/Languages
40 Group(de):      Entwicklung/Sprachen
41 Group(pl):      Programowanie/Jêzyki
42 Obsoletes:      egcc-c++
43 Obsoletes:      egcs-c++
44
45 %description c++
46 This package adds C++ support to the GNU C compiler. It includes
47 support for most of the current C++ specification, including templates
48 and exception handling. It does not include a standard C++ library,
49 which is available separately.
50
51 %description -l de c++
52 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
53 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
54 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
55 sie ist getrennt erhältlich.
56
57 %description -l fr c++
58 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
59 support pour la plupart des spécifications actuelles de C++, dont les
60 modéles et la gestion des exceptions. Il ne comprend pas une
61 bibliothéque C++ standard, qui est disponible séparément.
62
63 %description -l pl c++
64 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
65 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
66 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
67
68 %description -l tr c++
69 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
70 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
71 C++ kitaplýðý bu pakette yer almaz.
72
73 %package objc
74 Summary:        Objective C support for gcc
75 Summary(de):    Objektive C-Unterstützung für gcc
76 Summary(fr):    Gestion d'Objective C pour gcc
77 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
78 Summary(tr):    gcc için Objective C desteði
79 Group:          Development/Languages
80 Group(de):      Entwicklung/Sprachen
81 Group(pl):      Programowanie/Jêzyki
82 Obsoletes:      egcc-objc
83 Obsoletes:      egcs-objc
84
85 %description objc
86 This package adds Objective C support to the GNU C compiler. Objective
87 C is a object oriented derivative of the C language, mainly used on
88 systems running NeXTSTEP. This package does not include the standard
89 objective C object library.
90
91 %description -l de objc
92 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
93 Objective C ist ein objektorientiertes Derivat von C, das zur
94 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
95 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
96
97 %description -l fr objc
98 Ce package ajoute un support Objective C au compilateur C GNU.
99 L'Objective C est un langage orienté objetdérivé du langage C,
100 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
101 pas la bibliothéque Objective C standard.
102
103 %description -l pl objc
104 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
105 pakiecie nie ma jeszcze bibliotek C-obj.
106
107 %description -l tr objc
108 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
109 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
110 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
111 kitaplýðý bu pakette yer almaz.
112
113 %package g77
114 Summary:        Fortran 77 support for gcc
115 Summary(pl):    Wspomaganie Fortran 77 dla gcc
116 Group:          Development/Languages
117 Group(de):      Entwicklung/Sprachen
118 Group(pl):      Programowanie/Jêzyki
119 Obsoletes:      egcs-g77
120
121 %description g77
122 This apckage adds support for compiling Fortran 77 programs with the
123 GNU compiler.
124
125 %description -l pl g77
126 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
127 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
128
129 %package chill
130 Summary:        CHILL support for gcc
131 Summary(pl):    Wspomoganie CHILL dla gcc
132 Group:          Development/Languages
133 Group(de):      Entwicklung/Sprachen
134 Group(pl):      Programowanie/Jêzyki
135 Requires:       %{name} = %{version}
136
137 %description chill
138 This package adds support for compiling CHILL programs with the GNU
139 compiler.
140
141 Chill is the "CCITT High-Level Language", where CCITT is the old name
142 for what is now ITU, the International Telecommunications Union. It is
143 is language in the Modula2 family, and targets many of the same
144 applications as Ada (especially large embedded systems). Chill was
145 never used much in the United States, but is still being used in
146 Europe, Brazil, Korea, and other places.
147
148 %package java
149 Summary:        Java support for gcc
150 Summary(pl):    Wspomoganie Java dla gcc
151 Group:          Development/Languages
152 Group(de):      Entwicklung/Sprachen
153 Group(pl):      Programowanie/Jêzyki
154 Requires:       %{name} = %{version}
155 Requires:       libgcj >= 2.95.1
156
157 %description java
158 This package adds experimental support for compiling Java(tm) programs
159 and bytecode into native code. To use this you will also need the
160 libgcj package.
161
162 %description -l pl java
163 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak
164 i do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc przeprowadziæ
165 kompilacjê.
166
167 %package -n libgcj
168 Summary:        Java Class Libraries
169 Summary(pl):    Biblioteki Klas Javy
170 Group:          Libraries
171 Version:        %{GCJ_VERSION}
172 Requires:       zlib
173
174 %description -n libgcj
175 Java Class Libraries
176
177 %description -n libgcj -l pl
178 Biblioteki Klass Javy
179
180 %package -n libgcj-devel
181 Summary:        Development files for Java Class Libraries
182 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
183 Group:          Development/Libraries
184 Group(de):      Entwicklung/Libraries
185 Group(fr):      Development/Librairies
186 Group(pl):      Programowanie/Biblioteki
187 Version:        %{GCJ_VERSION}
188 Requires:       libgcj = %{GCJ_VERSION}
189 Requires:       %{name}-java
190
191 %description -n libgcj-devel
192 Development files for Java Class Libraries
193
194 %description -n libgcj-devel -l pl
195 Pliki nag³ówkowe dla Bibliotek Klass Javy
196
197 %package -n libgcj-static
198 Summary:        Static Java Class Libraries
199 Summary(pl):    Statyczne Biblioteki Klass Javy
200 Group:          Development/Libraries
201 Group(de):      Entwicklung/Libraries
202 Group(fr):      Development/Librairies
203 Group(pl):      Programowanie/Biblioteki
204 Version:        %{GCJ_VERSION}
205 Requires:       libstdc++-devel = %{GCJ_VERSION}
206
207 %description -n libgcj-static
208 Static Java Class Libraries
209
210 %description -l pl -n libgcj-static
211 Statyczne Biblioteki Klass Javy
212
213 %package -n libstdc++
214 Summary:        GNU c++ library
215 Summary(pl):    Biblioteki GNU C++ 
216 Group:          Libraries
217 Group(de):      Libraries
218 Group(fr):      Librairies
219 Group(pl):      Biblioteki
220 Version:        %{STDC_VERSION}
221 Obsoletes:      libg++
222
223 %description -n libstdc++
224 This is the GNU implementation of the standard C++ libraries, along
225 with additional GNU tools. This package includes the shared libraries
226 necessary to run C++ applications.
227
228 %description -l de -n libstdc++
229 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
230 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
231 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
232
233 %description -l fr -n libstdc++
234 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
235 des outils GNU supplémentaires. Ce package comprend les librairies
236 partagées nécessaires à l'exécution d'application C++.
237
238 %description -l pl -n libstdc++  
239 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
240 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
241 uruchomienia aplikacji napisanych w C++.
242
243 %description -l tr -n libstdc++
244 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
245 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
246
247 %package -n libstdc++-devel
248 Summary:        Header files and libraries for C++ development
249 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
250 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
251 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
252 Group:          Development/Libraries
253 Group(de):      Entwicklung/Libraries
254 Group(fr):      Development/Librairies
255 Group(pl):      Programowanie/Biblioteki
256 Version:        %{STDC_VERSION}
257 Requires:       libstdc++ = %{STDC_VERSION}
258 Requires:       %{name}-c++
259 Obsoletes:      libg++-devel
260
261 %description -n libstdc++-devel
262 This is the GNU implementation of the standard C++ libraries. This
263 package includes the header files and libraries needed for C++
264 development.
265
266 %description -l pl -n libstdc++-devel
267 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
268 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
269 programowaniu w jêzyku C++.
270
271 %package -n libstdc++-static
272 Summary:        Static c++ standard library
273 Summary(pl):    Biblioeka statyczna c++
274 Group:          Development/Libraries
275 Group(de):      Entwicklung/Libraries
276 Group(fr):      Development/Librairies
277 Group(pl):      Programowanie/Biblioteki
278 Version:        %{STDC_VERSION}
279 Requires:       libstdc++-devel = %{STDC_VERSION}
280
281 %description -n libstdc++-static
282 Static c++ standard library.
283
284 %description -l pl -n libstdc++-static
285 Biblioteka statyczna C++.
286
287 %package -n cpp
288 Summary:        The C Pre Processor
289 Summary(pl):    Preprocesor C
290 Group:          Development/Languages
291 Group(de):      Entwicklung/Sprachen
292 Group(pl):      Programowanie/Jêzyki
293 Obsoletes:      egcs-cpp
294
295 %description -n cpp
296 The C preprocessor is a "macro processor" that is used automatically
297 by the C compiler to transform your program before actual compilation.
298 It is called a macro processor because it allows you to define
299 "macros", which are brief abbreviations for longer constructs.
300
301 The C preprocessor provides four separate facilities that you can use
302 as you see fit:
303
304 - Inclusion of header files. These are files of declarations that can
305   be substituted into your program.
306 - Macro expansion. You can define "macros", which are abbreviations
307   for arbitrary fragments of C code, and then the C preprocessor will
308   replace the macros with their definitions throughout the program.
309 - Conditional compilation. Using special preprocessing directives, you
310   can include or exclude parts of the program according to various
311   conditions.
312 - Line control. If you use a program to combine or rearrange source
313   files into an intermediate file which is then compiled, you can use
314   line control to inform the compiler of where each source line
315   originally came from.
316
317 %description -l pl -n cpp
318 Przeprocesor C jest "makro procesorem" który jest automatycznie
319 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
320 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
321 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
322 d³ugich konstrukcji w jêzyku C.
323
324 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
325
326 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
327   deklaracji polecenia do³±czenia innego pliku.
328 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
329   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
330   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
331 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
332   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
333   fragmenty obrabianego strumienia tekstów.
334 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
335   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
336   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
337   odpowiada fragment pliku wynikowego.
338
339 %prep
340 %setup -q -n %{name}-%{rsnap}
341 %patch0 -p1
342
343 %build
344 cd gcc && autoconf; cd ..
345 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
346
347 CFLAGS="%{rpmcflags}" \
348 CXXFLAGS="%{rpmcflags}" \
349 TEXCONFIG=false ../configure \
350         --prefix=%{_prefix} \
351         --infodir=%{_infodir} \
352         --mandir=%{_mandir} \
353         --enable-shared \
354 %ifarch sparc
355         --with-cpu=sparc \
356 %endif
357 %ifarch sparc64
358         --with-cpu=ultrasparc \
359 %endif
360         --enable-threads=posix \
361         --enable-haifa \
362         --enable-languages="c,gcov,c++,objc,java,f77" \
363         --enable-long-long \
364         --enable-namespaces \
365         --enable-multilib \
366         --with-gnu-as \
367         --with-gnu-ld \
368         --with-system-zlib \
369         --without-x \
370         --disable-nls \
371         %{_target_platform}
372
373 PATH=$PATH:/sbin:%{_sbindir}
374
375 cd ..
376 %{__make} -C obj-%{_target_platform} bootstrap-lean \
377         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
378         mandir=%{_mandir} \
379         infodir=%{_infodir}
380
381 %install
382 rm -rf $RPM_BUILD_ROOT
383 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
384
385 cd obj-%{_target_platform}
386 PATH=$PATH:/sbin:%{_sbindir}
387
388 %{__make} install \
389         prefix=$RPM_BUILD_ROOT%{_prefix} \
390         mandir=$RPM_BUILD_ROOT%{_mandir} \
391         infodir=$RPM_BUILD_ROOT%{_infodir}
392
393 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
394
395 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
396
397 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
398
399 (cd $RPM_BUILD_ROOT%{_libdir} ; ln -sf libstdc++.so.*.*.* $RPM_BUILD_ROOT%{_libdir}/libstdc++.so)
400
401 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
402
403 gzip -9nf ../READ* ../ChangeLog
404
405 %post
406 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
407
408 %postun
409 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
410
411 %post g77
412 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
413
414 %postun g77
415 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
416
417 %post chill
418 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
419
420 %postun chill
421 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
422
423 %post -n cpp
424 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
425
426 %postun -n cpp
427 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
428
429 %post   -p /sbin/ldconfig -n libstdc++
430 %postun -p /sbin/ldconfig -n libstdc++
431
432 %clean
433 rm -rf $RPM_BUILD_ROOT
434
435 %files
436 %defattr(644,root,root,755)
437 %doc READ* ChangeLog.gz
438 %dir %{_libdir}/gcc-lib
439 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
440 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
441 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
442 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
443 %attr(755,root,root) %{_bindir}/gcc
444 %attr(755,root,root) %{_bindir}/gccbug
445 %attr(755,root,root) %{_bindir}/gcov
446 %attr(755,root,root) %{_bindir}/cc
447
448 %{_mandir}/man1/gcc.1*
449 %{_mandir}/man1/gcov.1*
450 %{_infodir}/gcc*
451
452 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
453 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
454 #%ifnarch alpha
455 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
456 #%endif
457 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
458 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
459
460 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
461 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
462 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
463 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
464 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
465 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
466 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
467 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
468 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
469
470 %files c++
471 %defattr(644,root,root,755)
472 %{_mandir}/man1/g++.1.gz
473 %attr(755,root,root) %{_bindir}/g++
474 %attr(755,root,root) %{_bindir}/c++
475 %attr(755,root,root) %{_bindir}/c++filt
476 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
477 %attr(755,root,root) %{_libdir}/libsupc++.la
478 %{_libdir}/libsupc++.a
479 %{_infodir}/c-tree*
480 %{_infodir}/g++int*
481
482 %files objc
483 %defattr(644,root,root,755)
484 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
485 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
486 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
487 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
488 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
489
490 %files g77
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/g77
493 %attr(755,root,root) %{_bindir}/f77
494 %{_infodir}/g77*
495 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
496 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
497 %{_mandir}/man1/g77.1*
498 %{_mandir}/man1/f77.1*
499 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
500
501 %ifarch no_longer_supported_by_gcc_team
502 %files chill
503 %defattr(644,root,root,755)
504 %doc gcc/ch/chill.brochure.gz
505
506 %attr(755,root,root) %{_bindir}/chill
507 %{_infodir}/chill*
508 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
509 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
510 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
511 %endif
512
513 %files java
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_bindir}/gcj*
516 %attr(755,root,root) %{_bindir}/gij
517 %attr(755,root,root) %{_bindir}/jcf-dump
518 %attr(755,root,root) %{_bindir}/jv-*
519 %attr(755,root,root) %{_bindir}/fastjar
520 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
521 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
522 %{_infodir}/gcj*
523
524 %files -n libgcj
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
527
528 %files -n libgcj-devel
529 %defattr(644,root,root,755)
530 %{_includedir}/java
531 %{_includedir}/gcj
532 %{_includedir}/j*.h
533 %{_includedir}/gnu/*
534 %{_libdir}/lib*cj.spec
535 %{_datadir}/libgcj.jar
536 %attr(755,root,root) %{_libdir}/lib*cj*.la
537 %attr(755,root,root) %{_libdir}/lib*cj*.so
538
539 %files -n libgcj-static
540 %defattr(644,root,root,755)
541 %{_libdir}/lib*cj*.a
542
543 %files -n libstdc++
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
546
547 %files -n libstdc++-devel
548 %defattr(644,root,root,755)
549 %{_includedir}/g++*
550 %{_prefix}/%{_target_cpu}*
551 %attr(755,root,root) %{_libdir}/libstdc++.so
552
553 %files -n libstdc++-static
554 %defattr(644,root,root,755)
555 %attr(644,root,root) %{_libdir}/libstdc++.a
556
557 %files -n cpp
558 %defattr(644,root,root,755)
559 %attr(755,root,root) /lib/cpp
560 %attr(755,root,root) %{_bindir}/cpp
561 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
562 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
563 %{_mandir}/man1/cpp.1*
564 %{_infodir}/cpp*
This page took 0.07261 seconds and 4 git commands to generate.