]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- ksi compiler added
[packages/gcc4.git] / gcc4.spec
1 %define         GCC_VERSION     3.0.3
2 %define         STDC_VERSION    3.0.3
3 %define         GCJ_VERSION     3.0.3
4 %define         KSI_VERSION     pre42
5 Summary:        GNU Compiler Collection
6 Summary(pl):    Kolekcja kompilatorów GNU
7 Name:           gcc
8 Version:        %{GCC_VERSION}
9 Release:        3
10 License:        GPL
11 Group:          Development/Languages
12 Group(de):      Entwicklung/Sprachen
13 Group(pl):      Programowanie/Jêzyki
14 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
15 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
16 Patch0:         gcc-DESTDIR.patch
17 Patch1:         gcc-paths.patch
18 BuildRequires:  bison
19 BuildRequires:  texinfo
20 BuildRequires:  zlib-devel
21 BuildRequires:  fileutils >= 4.0.41
22 BuildRequires:  autoconf
23 Requires:       binutils >= 2.9.1.0.25
24 Requires:       cpp = %{version}
25 URL:            http://gcc.gnu.org/
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _slibdir        /lib
29
30 %description
31 A compiler aimed at integrating all the optimizations and features
32 necessary for a high-performance and stable development environment.
33
34 %description -l pl
35 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
36 wyprodukowania szybkiego i stablinego kodu wynikowego.
37
38 %package c++
39 Summary:        C++ support for gcc
40 Summary(fr):    Support C++ pour le compilateur gcc
41 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
42 Summary(tr):    gcc için C++ desteði
43 Group:          Development/Languages
44 Group(de):      Entwicklung/Sprachen
45 Group(pl):      Programowanie/Jêzyki
46 Obsoletes:      egcc-c++
47 Obsoletes:      egcs-c++
48
49 %description c++
50 This package adds C++ support to the GNU C compiler. It includes
51 support for most of the current C++ specification, including templates
52 and exception handling. It does not include a standard C++ library,
53 which is available separately.
54
55 %description -l de c++
56 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
57 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
58 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
59 sie ist getrennt erhältlich.
60
61 %description -l fr c++
62 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
63 support pour la plupart des spécifications actuelles de C++, dont les
64 modéles et la gestion des exceptions. Il ne comprend pas une
65 bibliothéque C++ standard, qui est disponible séparément.
66
67 %description -l pl c++
68 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
69 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
70 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
71
72 %description -l tr c++
73 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
74 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
75 C++ kitaplýðý bu pakette yer almaz.
76
77 %package objc
78 Summary:        Objective C support for gcc
79 Summary(de):    Objektive C-Unterstützung für gcc
80 Summary(fr):    Gestion d'Objective C pour gcc
81 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
82 Summary(tr):    gcc için Objective C desteði
83 Group:          Development/Languages
84 Group(de):      Entwicklung/Sprachen
85 Group(pl):      Programowanie/Jêzyki
86 Obsoletes:      egcc-objc
87 Obsoletes:      egcs-objc
88
89 %description objc
90 This package adds Objective C support to the GNU C compiler. Objective
91 C is a object oriented derivative of the C language, mainly used on
92 systems running NeXTSTEP. This package does not include the standard
93 objective C object library.
94
95 %description -l de objc
96 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
97 Objective C ist ein objektorientiertes Derivat von C, das zur
98 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
99 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
100
101 %description -l fr objc
102 Ce package ajoute un support Objective C au compilateur C GNU.
103 L'Objective C est un langage orienté objetdérivé du langage C,
104 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
105 pas la bibliothéque Objective C standard.
106
107 %description -l pl objc
108 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
109 pakiecie nie ma jeszcze bibliotek C-obj.
110
111 %description -l tr objc
112 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
113 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
114 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
115 kitaplýðý bu pakette yer almaz.
116
117 %package g77
118 Summary:        Fortran 77 support for gcc
119 Summary(pl):    Wspomaganie Fortran 77 dla gcc
120 Group:          Development/Languages
121 Group(de):      Entwicklung/Sprachen
122 Group(pl):      Programowanie/Jêzyki
123 Obsoletes:      egcs-g77
124
125 %description g77
126 This apckage adds support for compiling Fortran 77 programs with the
127 GNU compiler.
128
129 %description -l pl g77
130 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
131 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
132
133 %package chill
134 Summary:        CHILL support for gcc
135 Summary(pl):    Wspomoganie CHILL dla gcc
136 Group:          Development/Languages
137 Group(de):      Entwicklung/Sprachen
138 Group(pl):      Programowanie/Jêzyki
139 Requires:       %{name} = %{version}
140
141 %description chill
142 This package adds support for compiling CHILL programs with the GNU
143 compiler.
144
145 Chill is the "CCITT High-Level Language", where CCITT is the old name
146 for what is now ITU, the International Telecommunications Union. It is
147 is language in the Modula2 family, and targets many of the same
148 applications as Ada (especially large embedded systems). Chill was
149 never used much in the United States, but is still being used in
150 Europe, Brazil, Korea, and other places.
151
152 %package java
153 Summary:        Java support for gcc
154 Summary(pl):    Wspomoganie Java dla gcc
155 Group:          Development/Languages
156 Group(de):      Entwicklung/Sprachen
157 Group(pl):      Programowanie/Jêzyki
158 Requires:       %{name} = %{version}
159 Requires:       libgcj >= 3.0.0
160
161 %description java
162 This package adds experimental support for compiling Java(tm) programs
163 and bytecode into native code. To use this you will also need the
164 libgcj package.
165
166 %description -l pl java
167 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
168 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
169 przeprowadziæ kompilacjê.
170
171 %package -n libgcj
172 Summary:        Java Class Libraries
173 Summary(pl):    Biblioteki Klas Javy
174 Group:          Libraries
175 Group(de):      Libraries
176 Group(es):      Bibliotecas
177 Group(fr):      Librairies
178 Group(pl):      Biblioteki
179 Version:        %{GCJ_VERSION}
180 Epoch:          2
181 Requires:       zlib
182
183 %description -n libgcj
184 Java Class Libraries
185
186 %description -n libgcj -l pl
187 Biblioteki Klass Javy
188
189 %package -n libgcj-devel
190 Summary:        Development files for Java Class Libraries
191 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
192 Group:          Development/Libraries
193 Group(de):      Entwicklung/Libraries
194 Group(fr):      Development/Librairies
195 Group(pl):      Programowanie/Biblioteki
196 Version:        %{GCJ_VERSION}
197 Epoch:          2
198 Requires:       libgcj = %{GCJ_VERSION}
199 Requires:       %{name}-java
200
201 %description -n libgcj-devel
202 Development files for Java Class Libraries
203
204 %description -n libgcj-devel -l pl
205 Pliki nag³ówkowe dla Bibliotek Klass Javy
206
207 %package -n libgcj-static
208 Summary:        Static Java Class Libraries
209 Summary(pl):    Statyczne Biblioteki Klass Javy
210 Group:          Development/Libraries
211 Group(de):      Entwicklung/Libraries
212 Group(fr):      Development/Librairies
213 Group(pl):      Programowanie/Biblioteki
214 Version:        %{GCJ_VERSION}
215 Epoch:          2
216 Requires:       libstdc++-devel = %{GCJ_VERSION}
217
218 %description -n libgcj-static
219 Static Java Class Libraries
220
221 %description -l pl -n libgcj-static
222 Statyczne Biblioteki Klass Javy
223
224 %package -n libstdc++
225 Summary:        GNU c++ library
226 Summary(pl):    Biblioteki GNU C++ 
227 Group:          Libraries
228 Group(de):      Libraries
229 Group(es):      Bibliotecas
230 Group(fr):      Librairies
231 Group(pl):      Biblioteki
232 Version:        %{STDC_VERSION}
233 Obsoletes:      libg++
234
235 %description -n libstdc++
236 This is the GNU implementation of the standard C++ libraries, along
237 with additional GNU tools. This package includes the shared libraries
238 necessary to run C++ applications.
239
240 %description -l de -n libstdc++
241 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
242 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
243 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
244
245 %description -l fr -n libstdc++
246 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
247 des outils GNU supplémentaires. Ce package comprend les librairies
248 partagées nécessaires à l'exécution d'application C++.
249
250 %description -l pl -n libstdc++  
251 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
252 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
253 uruchomienia aplikacji napisanych w C++.
254
255 %description -l tr -n libstdc++
256 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
257 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
258
259 %package -n libstdc++-devel
260 Summary:        Header files and libraries for C++ development
261 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
262 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
263 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
264 Group:          Development/Libraries
265 Group(de):      Entwicklung/Libraries
266 Group(fr):      Development/Librairies
267 Group(pl):      Programowanie/Biblioteki
268 Version:        %{STDC_VERSION}
269 Requires:       libstdc++ = %{STDC_VERSION}
270 Requires:       %{name}-c++
271 Obsoletes:      libg++-devel
272
273 %description -n libstdc++-devel
274 This is the GNU implementation of the standard C++ libraries. This
275 package includes the header files and libraries needed for C++
276 development.
277
278 %description -l pl -n libstdc++-devel
279 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
280 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
281 programowaniu w jêzyku C++.
282
283 %package -n libstdc++-static
284 Summary:        Static c++ standard library
285 Summary(pl):    Biblioteka statyczna c++
286 Group:          Development/Libraries
287 Group(de):      Entwicklung/Libraries
288 Group(fr):      Development/Librairies
289 Group(pl):      Programowanie/Biblioteki
290 Version:        %{STDC_VERSION}
291 Requires:       libstdc++-devel = %{STDC_VERSION}
292
293 %description -n libstdc++-static
294 Static c++ standard library.
295
296 %description -l pl -n libstdc++-static
297 Biblioteka statyczna C++.
298
299 %package -n libgcc
300 Summary:        Shared gcc library
301 Summary(pl):    Biblioteka gcc
302 Group:          Libraries
303 Group(de):      Libraries
304 Group(fr):      Librairies
305 Group(pl):      Biblioteki
306 Version:        %{version}
307
308 %description -n libgcc
309 Shared gcc library.
310
311 %description -l pl -n libgcc
312 Biblioteka dynamiczna gcc.
313
314 %package -n cpp
315 Summary:        The C Pre Processor
316 Summary(pl):    Preprocesor C
317 Group:          Development/Languages
318 Group(de):      Entwicklung/Sprachen
319 Group(pl):      Programowanie/Jêzyki
320 Version:        %{version}
321 Obsoletes:      egcs-cpp
322 Obsoletes:      gcc-cpp
323
324 %description -n cpp
325 The C preprocessor is a "macro processor" that is used automatically
326 by the C compiler to transform your program before actual compilation.
327 It is called a macro processor because it allows you to define
328 "macros", which are brief abbreviations for longer constructs.
329
330 The C preprocessor provides four separate facilities that you can use
331 as you see fit:
332
333 - Inclusion of header files. These are files of declarations that can
334   be substituted into your program.
335 - Macro expansion. You can define "macros", which are abbreviations
336   for arbitrary fragments of C code, and then the C preprocessor will
337   replace the macros with their definitions throughout the program.
338 - Conditional compilation. Using special preprocessing directives, you
339   can include or exclude parts of the program according to various
340   conditions.
341 - Line control. If you use a program to combine or rearrange source
342   files into an intermediate file which is then compiled, you can use
343   line control to inform the compiler of where each source line
344   originally came from.
345
346 %description -l pl -n cpp
347 Przeprocesor C jest "makro procesorem" który jest automatycznie
348 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
349 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
350 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
351 d³ugich konstrukcji w jêzyku C.
352
353 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
354
355 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
356   deklaracji polecenia do³±czenia innego pliku.
357 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
358   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
359   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
360 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
361   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
362   fragmenty obrabianego strumienia tekstów.
363 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
364   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
365   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
366   odpowiada fragment pliku wynikowego.
367
368 %package ksi
369 Summary:        Ksi support for gcc
370 Summary(pl):    Wspomoganie Ksi dla gcc
371 Group:          Development/Languages
372 Group(de):      Entwicklung/Sprachen
373 Group(pl):      Programowanie/Jêzyki
374 Requires:       %{name} = %{version}
375
376 %description ksi
377 This package adds experimental support for compiling Ksi programs
378 into native code. You proabably don't need it, unless your are going
379 to develop a compiler using Ksi as intermediate representation or
380 you are using such compiler (like Gont).
381
382 %description -l pl ksi
383 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
384 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
385 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jakos reprezentacji
386 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
387
388
389 %prep
390 %setup -q -n %{name}-%{GCC_VERSION}
391 %setup -q -a1
392 mv ksi-%{KSI_VERSION} gcc/ksi
393 %patch0 -p1
394 %patch1 -p1
395
396 %build
397 # cd gcc && autoconf; cd ..
398 # autoconf is not needed!
399 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
400
401 CFLAGS="%{rpmcflags}" \
402 CXXFLAGS="%{rpmcflags}" \
403 TEXCONFIG=false ../configure \
404         --prefix=%{_prefix} \
405         --infodir=%{_infodir} \
406         --mandir=%{_mandir} \
407         --enable-shared \
408         --enable-threads=posix \
409         --enable-haifa \
410         --enable-languages="c,c++,f77,gcov,java,objc,ksi" \
411         --enable-long-long \
412         --enable-namespaces \
413         --enable-multilib \
414         --with-gnu-as \
415         --with-gnu-ld \
416         --with-system-zlib \
417         --with-slibdir=%{_slibdir} \
418         --without-x \
419         %{_target_platform}
420
421 PATH=$PATH:/sbin:%{_sbindir}
422
423 cd ..
424 %{__make} -C obj-%{_target_platform} bootstrap-lean \
425         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
426         mandir=%{_mandir} \
427         infodir=%{_infodir}
428
429 %install
430 rm -rf $RPM_BUILD_ROOT
431 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
432
433 cd obj-%{_target_platform}
434 PATH=$PATH:/sbin:%{_sbindir}
435
436 %{__make} install \
437         prefix=$RPM_BUILD_ROOT%{_prefix} \
438         mandir=$RPM_BUILD_ROOT%{_mandir} \
439         infodir=$RPM_BUILD_ROOT%{_infodir} \
440         DESTDIR=$RPM_BUILD_ROOT
441
442 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
443
444 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
445
446 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
447
448 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
449  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/ ; \
450  ln -sf ../../../${LIBSTDC} libstdc++.so)
451
452 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
453         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
454
455 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
456
457 gzip -9nf ../READ* ../ChangeLog ../gcc/ksi/README ../gcc/ksi/NEWS
458
459 %post
460 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
461
462 %postun
463 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
464
465 %post g77
466 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
467
468 %postun g77
469 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
470
471 %post chill
472 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
473
474 %postun chill
475 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
476
477 %post -n cpp
478 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
479
480 %postun -n cpp
481 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
482
483 %post ksi
484 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
485
486 %postun ksi
487 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
488
489 %post   -p /sbin/ldconfig -n libgcc
490 %postun -p /sbin/ldconfig -n libgcc
491 %post   -p /sbin/ldconfig -n libstdc++
492 %postun -p /sbin/ldconfig -n libstdc++
493 %post   -p /sbin/ldconfig -n libgcj
494 %postun -p /sbin/ldconfig -n libgcj
495
496 %clean
497 rm -rf $RPM_BUILD_ROOT
498
499 %files
500 %defattr(644,root,root,755)
501 %doc READ* ChangeLog.gz
502 %dir %{_libdir}/gcc-lib
503 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
504 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
505 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
506 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
507 %attr(755,root,root) %{_bindir}/gcc
508 %attr(755,root,root) %{_bindir}/gccbug
509 %attr(755,root,root) %{_bindir}/gcov
510 %attr(755,root,root) %{_bindir}/cc
511
512 %{_mandir}/man1/gcc.1*
513 %{_mandir}/man1/gcov.1*
514 %{_infodir}/gcc*
515
516 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
517 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
518 #%ifnarch alpha
519 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
520 #%endif
521 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
522 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
523
524 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
525 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
526 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
527 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
528 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
529 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
530 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
531 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
532 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
533
534 %files c++
535 %defattr(644,root,root,755)
536 %{_mandir}/man1/g++.1.gz
537 %attr(755,root,root) %{_bindir}/g++
538 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
539 %attr(755,root,root) %{_bindir}/c++
540 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
541 %attr(755,root,root) %{_bindir}/c++filt
542 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
543 %attr(755,root,root) %{_libdir}/libsupc++.la
544 %{_libdir}/libsupc++.a
545
546 %files objc
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
549 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
550 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
551 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
552 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
553
554 %files g77
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_bindir}/g77
557 %attr(755,root,root) %{_bindir}/f77
558 %{_infodir}/g77*
559 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
560 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
561 %{_mandir}/man1/g77.1*
562 %{_mandir}/man1/f77.1*
563 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
564
565 %files ksi
566 %doc gcc/ksi/*.gz
567 %defattr(644,root,root,755)
568 %{_infodir}/ksi*
569 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
570
571 %ifarch no_longer_supported_by_gcc_team
572 %files chill
573 %defattr(644,root,root,755)
574 %doc gcc/ch/chill.brochure.gz
575
576 %attr(755,root,root) %{_bindir}/chill
577 %{_infodir}/chill*
578 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
579 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
580 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
581 %endif
582
583 %files java
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_bindir}/gcj*
586 %attr(755,root,root) %{_bindir}/gij
587 %attr(755,root,root) %{_bindir}/jcf-dump
588 %attr(755,root,root) %{_bindir}/jv-*
589 %attr(755,root,root) %{_bindir}/jar
590 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
591 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
592 %{_infodir}/gcj*
593
594 %files -n libgcj
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_bindir}/addr2name.awk
597 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
598
599 %files -n libgcj-devel
600 %defattr(644,root,root,755)
601 %{_includedir}/java
602 %{_includedir}/gcj
603 %{_includedir}/j*.h
604 %{_includedir}/gnu/*
605 %{_libdir}/lib*cj.spec
606 %{_datadir}/libgcj.jar
607 %attr(755,root,root) %{_libdir}/lib*cj*.la
608 %attr(755,root,root) %{_libdir}/lib*cj*.so
609
610 %files -n libgcj-static
611 %defattr(644,root,root,755)
612 %{_libdir}/lib*cj*.a
613
614 %files -n libstdc++
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
617
618 %files -n libstdc++-devel
619 %defattr(644,root,root,755)
620 %{_includedir}/g++*
621 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
622
623 %files -n libstdc++-static
624 %defattr(644,root,root,755)
625 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
626
627 %files -n libgcc
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_slibdir}/lib*.so*
630
631 %files -n cpp
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_slibdir}/cpp
634 %attr(755,root,root) %{_bindir}/cpp
635 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
636 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
637 %{_mandir}/man1/cpp.1*
638 %{_infodir}/cpp*
This page took 0.101231 seconds and 4 git commands to generate.