]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- added paths patch, it fixes finding cpp0 and tradcpp0 by gcc
[packages/gcc4.git] / gcc4.spec
1 %define         GCC_VERSION     3.0.3
2 %define         STDC_VERSION    3.0.3
3 %define         GCJ_VERSION     3.0.3
4 Summary:        GNU Compiler Collection
5 Summary(pl):    Kolekcja kompilatorów GNU
6 Name:           gcc
7 Version:        %{GCC_VERSION}
8 Release:        1
9 License:        GPL
10 Group:          Development/Languages
11 Group(de):      Entwicklung/Sprachen
12 Group(pl):      Programowanie/Jêzyki
13 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
14 Patch0:         gcc-DESTDIR.patch
15 Patch1:         gcc-paths.patch
16 BuildRequires:  bison
17 BuildRequires:  texinfo
18 BuildRequires:  zlib-devel
19 BuildRequires:  fileutils >= 4.0.41
20 BuildRequires:  autoconf
21 Requires:       binutils >= 2.9.1.0.25
22 Requires:       cpp = %{version}
23 URL:            http://gcc.gnu.org/
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _slibdir        /lib
27
28 %description
29 A compiler aimed at integrating all the optimizations and features
30 necessary for a high-performance and stable development environment.
31
32 %description -l pl
33 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
34 wyprodukowania szybkiego i stablinego kodu wynikowego.
35
36 %package c++
37 Summary:        C++ support for gcc
38 Summary(fr):    Support C++ pour le compilateur gcc
39 Summary(pl):    Wspomaganie C++ dla kompilatora gcc
40 Summary(tr):    gcc için C++ desteði
41 Group:          Development/Languages
42 Group(de):      Entwicklung/Sprachen
43 Group(pl):      Programowanie/Jêzyki
44 Obsoletes:      egcc-c++
45 Obsoletes:      egcs-c++
46
47 %description c++
48 This package adds C++ support to the GNU C compiler. It includes
49 support for most of the current C++ specification, including templates
50 and exception handling. It does not include a standard C++ library,
51 which is available separately.
52
53 %description -l de c++
54 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
55 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
56 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
57 sie ist getrennt erhältlich.
58
59 %description -l fr c++
60 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
61 support pour la plupart des spécifications actuelles de C++, dont les
62 modéles et la gestion des exceptions. Il ne comprend pas une
63 bibliothéque C++ standard, qui est disponible séparément.
64
65 %description -l pl c++
66 Programy z tego pakietu zapewniaj± wsparcie dla C++ do gcc. Posiada
67 wspomaganie dla du¿ej ilo¶ci obecnych specyfikacji C++, nie posiada
68 natomiast standardowych bibliotek C++, które s± w oddzielnym pakiecie.
69
70 %description -l tr c++
71 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
72 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
73 C++ kitaplýðý bu pakette yer almaz.
74
75 %package objc
76 Summary:        Objective C support for gcc
77 Summary(de):    Objektive C-Unterstützung für gcc
78 Summary(fr):    Gestion d'Objective C pour gcc
79 Summary(pl):    Wspomaganie obiektowego C dla kompilatora gcc
80 Summary(tr):    gcc için Objective C desteði
81 Group:          Development/Languages
82 Group(de):      Entwicklung/Sprachen
83 Group(pl):      Programowanie/Jêzyki
84 Obsoletes:      egcc-objc
85 Obsoletes:      egcs-objc
86
87 %description objc
88 This package adds Objective C support to the GNU C compiler. Objective
89 C is a object oriented derivative of the C language, mainly used on
90 systems running NeXTSTEP. This package does not include the standard
91 objective C object library.
92
93 %description -l de objc
94 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
95 Objective C ist ein objektorientiertes Derivat von C, das zur
96 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
97 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
98
99 %description -l fr objc
100 Ce package ajoute un support Objective C au compilateur C GNU.
101 L'Objective C est un langage orienté objetdérivé du langage C,
102 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
103 pas la bibliothéque Objective C standard.
104
105 %description -l pl objc
106 Ten pakiet jest wsparciem obiektowego C dla kompilatora gcc. W
107 pakiecie nie ma jeszcze bibliotek C-obj.
108
109 %description -l tr objc
110 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
111 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
112 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
113 kitaplýðý bu pakette yer almaz.
114
115 %package g77
116 Summary:        Fortran 77 support for gcc
117 Summary(pl):    Wspomaganie Fortran 77 dla gcc
118 Group:          Development/Languages
119 Group(de):      Entwicklung/Sprachen
120 Group(pl):      Programowanie/Jêzyki
121 Obsoletes:      egcs-g77
122
123 %description g77
124 This apckage adds support for compiling Fortran 77 programs with the
125 GNU compiler.
126
127 %description -l pl g77
128 Ten pakiet jest wsparciem Fortran 77 dla kompilatora gcc. Jest
129 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
130
131 %package chill
132 Summary:        CHILL support for gcc
133 Summary(pl):    Wspomoganie CHILL dla gcc
134 Group:          Development/Languages
135 Group(de):      Entwicklung/Sprachen
136 Group(pl):      Programowanie/Jêzyki
137 Requires:       %{name} = %{version}
138
139 %description chill
140 This package adds support for compiling CHILL programs with the GNU
141 compiler.
142
143 Chill is the "CCITT High-Level Language", where CCITT is the old name
144 for what is now ITU, the International Telecommunications Union. It is
145 is language in the Modula2 family, and targets many of the same
146 applications as Ada (especially large embedded systems). Chill was
147 never used much in the United States, but is still being used in
148 Europe, Brazil, Korea, and other places.
149
150 %package java
151 Summary:        Java support for gcc
152 Summary(pl):    Wspomoganie Java dla gcc
153 Group:          Development/Languages
154 Group(de):      Entwicklung/Sprachen
155 Group(pl):      Programowanie/Jêzyki
156 Requires:       %{name} = %{version}
157 Requires:       libgcj >= 3.0.0
158
159 %description java
160 This package adds experimental support for compiling Java(tm) programs
161 and bytecode into native code. To use this you will also need the
162 libgcj package.
163
164 %description -l pl java
165 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
166 do natywnego kodu. Bêdziesz potrzebowa³ pakietu libgcj by móc
167 przeprowadziæ kompilacjê.
168
169 %package -n libgcj
170 Summary:        Java Class Libraries
171 Summary(pl):    Biblioteki Klas Javy
172 Group:          Libraries
173 Group(de):      Libraries
174 Group(es):      Bibliotecas
175 Group(fr):      Librairies
176 Group(pl):      Biblioteki
177 Version:        %{GCJ_VERSION}
178 Epoch:          2
179 Requires:       zlib
180
181 %description -n libgcj
182 Java Class Libraries
183
184 %description -n libgcj -l pl
185 Biblioteki Klass Javy
186
187 %package -n libgcj-devel
188 Summary:        Development files for Java Class Libraries
189 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klass Javy
190 Group:          Development/Libraries
191 Group(de):      Entwicklung/Libraries
192 Group(fr):      Development/Librairies
193 Group(pl):      Programowanie/Biblioteki
194 Version:        %{GCJ_VERSION}
195 Epoch:          2
196 Requires:       libgcj = %{GCJ_VERSION}
197 Requires:       %{name}-java
198
199 %description -n libgcj-devel
200 Development files for Java Class Libraries
201
202 %description -n libgcj-devel -l pl
203 Pliki nag³ówkowe dla Bibliotek Klass Javy
204
205 %package -n libgcj-static
206 Summary:        Static Java Class Libraries
207 Summary(pl):    Statyczne Biblioteki Klass Javy
208 Group:          Development/Libraries
209 Group(de):      Entwicklung/Libraries
210 Group(fr):      Development/Librairies
211 Group(pl):      Programowanie/Biblioteki
212 Version:        %{GCJ_VERSION}
213 Epoch:          2
214 Requires:       libstdc++-devel = %{GCJ_VERSION}
215
216 %description -n libgcj-static
217 Static Java Class Libraries
218
219 %description -l pl -n libgcj-static
220 Statyczne Biblioteki Klass Javy
221
222 %package -n libstdc++
223 Summary:        GNU c++ library
224 Summary(pl):    Biblioteki GNU C++ 
225 Group:          Libraries
226 Group(de):      Libraries
227 Group(es):      Bibliotecas
228 Group(fr):      Librairies
229 Group(pl):      Biblioteki
230 Version:        %{STDC_VERSION}
231 Obsoletes:      libg++
232
233 %description -n libstdc++
234 This is the GNU implementation of the standard C++ libraries, along
235 with additional GNU tools. This package includes the shared libraries
236 necessary to run C++ applications.
237
238 %description -l de -n libstdc++
239 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
240 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
241 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
242
243 %description -l fr -n libstdc++
244 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
245 des outils GNU supplémentaires. Ce package comprend les librairies
246 partagées nécessaires à l'exécution d'application C++.
247
248 %description -l pl -n libstdc++  
249 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
250 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
251 uruchomienia aplikacji napisanych w C++.
252
253 %description -l tr -n libstdc++
254 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
255 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
256
257 %package -n libstdc++-devel
258 Summary:        Header files and libraries for C++ development
259 Summary(de):    Header-Dateien und Libraries zur Entwicklung mit C++
260 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
261 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
262 Group:          Development/Libraries
263 Group(de):      Entwicklung/Libraries
264 Group(fr):      Development/Librairies
265 Group(pl):      Programowanie/Biblioteki
266 Version:        %{STDC_VERSION}
267 Requires:       libstdc++ = %{STDC_VERSION}
268 Requires:       %{name}-c++
269 Obsoletes:      libg++-devel
270
271 %description -n libstdc++-devel
272 This is the GNU implementation of the standard C++ libraries. This
273 package includes the header files and libraries needed for C++
274 development.
275
276 %description -l pl -n libstdc++-devel
277 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
278 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
279 programowaniu w jêzyku C++.
280
281 %package -n libstdc++-static
282 Summary:        Static c++ standard library
283 Summary(pl):    Biblioteka statyczna c++
284 Group:          Development/Libraries
285 Group(de):      Entwicklung/Libraries
286 Group(fr):      Development/Librairies
287 Group(pl):      Programowanie/Biblioteki
288 Version:        %{STDC_VERSION}
289 Requires:       libstdc++-devel = %{STDC_VERSION}
290
291 %description -n libstdc++-static
292 Static c++ standard library.
293
294 %description -l pl -n libstdc++-static
295 Biblioteka statyczna C++.
296
297 %package -n libgcc
298 Summary:        Shared gcc library
299 Summary(pl):    Biblioteka gcc
300 Group:          Libraries
301 Group(de):      Libraries
302 Group(fr):      Librairies
303 Group(pl):      Biblioteki
304 Version:        %{version}
305
306 %description -n libgcc
307 Shared gcc library.
308
309 %description -l pl -n libgcc
310 Biblioteka dynamiczna gcc.
311
312 %package -n cpp
313 Summary:        The C Pre Processor
314 Summary(pl):    Preprocesor C
315 Group:          Development/Languages
316 Group(de):      Entwicklung/Sprachen
317 Group(pl):      Programowanie/Jêzyki
318 Version:        %{version}
319 Obsoletes:      egcs-cpp
320 Obsoletes:      gcc-cpp
321
322 %description -n cpp
323 The C preprocessor is a "macro processor" that is used automatically
324 by the C compiler to transform your program before actual compilation.
325 It is called a macro processor because it allows you to define
326 "macros", which are brief abbreviations for longer constructs.
327
328 The C preprocessor provides four separate facilities that you can use
329 as you see fit:
330
331 - Inclusion of header files. These are files of declarations that can
332   be substituted into your program.
333 - Macro expansion. You can define "macros", which are abbreviations
334   for arbitrary fragments of C code, and then the C preprocessor will
335   replace the macros with their definitions throughout the program.
336 - Conditional compilation. Using special preprocessing directives, you
337   can include or exclude parts of the program according to various
338   conditions.
339 - Line control. If you use a program to combine or rearrange source
340   files into an intermediate file which is then compiled, you can use
341   line control to inform the compiler of where each source line
342   originally came from.
343
344 %description -l pl -n cpp
345 Przeprocesor C jest "makro procesorem" który jest automatycznie
346 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
347 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
348 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
349 d³ugich konstrukcji w jêzyku C.
350
351 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
352
353 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
354   deklaracji polecenia do³±czenia innego pliku.
355 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
356   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
357   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
358 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
359   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
360   fragmenty obrabianego strumienia tekstów.
361 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
362   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
363   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
364   odpowiada fragment pliku wynikowego.
365
366 %prep
367 %setup -q -n %{name}-%{GCC_VERSION}
368 %patch0 -p1
369 %patch1 -p1
370
371 %build
372 # cd gcc && autoconf; cd ..
373 # autoconf is not needed!
374 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform} 
375
376 CFLAGS="%{rpmcflags}" \
377 CXXFLAGS="%{rpmcflags}" \
378 TEXCONFIG=false ../configure \
379         --prefix=%{_prefix} \
380         --infodir=%{_infodir} \
381         --mandir=%{_mandir} \
382         --enable-shared \
383 %ifarch sparc
384         --with-cpu=sparc \
385 %endif
386 %ifarch sparc64
387         --with-cpu=ultrasparc \
388 %endif
389         --enable-threads=posix \
390         --enable-haifa \
391         --enable-languages="c,c++,f77,gcov,java,objc" \
392         --enable-long-long \
393         --enable-namespaces \
394         --enable-multilib \
395         --with-gnu-as \
396         --with-gnu-ld \
397         --with-system-zlib \
398         --with-slibdir=%{_slibdir} \
399         --without-x \
400         %{_target_platform}
401
402 PATH=$PATH:/sbin:%{_sbindir}
403
404 cd ..
405 %{__make} -C obj-%{_target_platform} bootstrap-lean \
406         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
407         mandir=%{_mandir} \
408         infodir=%{_infodir}
409
410 %install
411 rm -rf $RPM_BUILD_ROOT
412 install -d $RPM_BUILD_ROOT{/lib,%{_datadir}}
413
414 cd obj-%{_target_platform}
415 PATH=$PATH:/sbin:%{_sbindir}
416
417 %{__make} install \
418         prefix=$RPM_BUILD_ROOT%{_prefix} \
419         mandir=$RPM_BUILD_ROOT%{_mandir} \
420         infodir=$RPM_BUILD_ROOT%{_infodir} \
421         DESTDIR=$RPM_BUILD_ROOT
422
423 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
424
425 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
426
427 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
428
429 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
430  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/ ; \
431  ln -sf ../../../${LIBSTDC} libstdc++.so)
432
433 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
434         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
435
436 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
437
438 gzip -9nf ../READ* ../ChangeLog
439
440 %post
441 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
442
443 %postun
444 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
445
446 %post g77
447 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
448
449 %postun g77
450 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
451
452 %post chill
453 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
454
455 %postun chill
456 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
457
458 %post -n cpp
459 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
460
461 %postun -n cpp
462 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
463
464 %post   -p /sbin/ldconfig -n libgcc
465 %postun -p /sbin/ldconfig -n libgcc
466 %post   -p /sbin/ldconfig -n libstdc++
467 %postun -p /sbin/ldconfig -n libstdc++
468 %post   -p /sbin/ldconfig -n libgcj
469 %postun -p /sbin/ldconfig -n libgcj
470
471 %clean
472 rm -rf $RPM_BUILD_ROOT
473
474 %files
475 %defattr(644,root,root,755)
476 %doc READ* ChangeLog.gz
477 %dir %{_libdir}/gcc-lib
478 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
479 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
480 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
481 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
482 %attr(755,root,root) %{_bindir}/gcc
483 %attr(755,root,root) %{_bindir}/gccbug
484 %attr(755,root,root) %{_bindir}/gcov
485 %attr(755,root,root) %{_bindir}/cc
486
487 %{_mandir}/man1/gcc.1*
488 %{_mandir}/man1/gcov.1*
489 %{_infodir}/gcc*
490
491 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
492 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
493 #%ifnarch alpha
494 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
495 #%endif
496 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
497 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
498
499 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
500 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
501 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
502 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/proto.h
503 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
504 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
505 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
506 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
507 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
508
509 %files c++
510 %defattr(644,root,root,755)
511 %{_mandir}/man1/g++.1.gz
512 %attr(755,root,root) %{_bindir}/g++
513 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
514 %attr(755,root,root) %{_bindir}/c++
515 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
516 %attr(755,root,root) %{_bindir}/c++filt
517 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
518 %attr(755,root,root) %{_libdir}/libsupc++.la
519 %{_libdir}/libsupc++.a
520
521 %files objc
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
524 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.a
525 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.so*
526 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libobjc.la
527 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
528
529 %files g77
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_bindir}/g77
532 %attr(755,root,root) %{_bindir}/f77
533 %{_infodir}/g77*
534 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
535 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libg2c.a
536 %{_mandir}/man1/g77.1*
537 %{_mandir}/man1/f77.1*
538 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
539
540 %ifarch no_longer_supported_by_gcc_team
541 %files chill
542 %defattr(644,root,root,755)
543 %doc gcc/ch/chill.brochure.gz
544
545 %attr(755,root,root) %{_bindir}/chill
546 %{_infodir}/chill*
547 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1chill
548 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/chill*.o
549 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libchill.a
550 %endif
551
552 %files java
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_bindir}/gcj*
555 %attr(755,root,root) %{_bindir}/gij
556 %attr(755,root,root) %{_bindir}/jcf-dump
557 %attr(755,root,root) %{_bindir}/jv-*
558 %attr(755,root,root) %{_bindir}/jar
559 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
560 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
561 %{_infodir}/gcj*
562
563 %files -n libgcj
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_bindir}/addr2name.awk
566 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
567
568 %files -n libgcj-devel
569 %defattr(644,root,root,755)
570 %{_includedir}/java
571 %{_includedir}/gcj
572 %{_includedir}/j*.h
573 %{_includedir}/gnu/*
574 %{_libdir}/lib*cj.spec
575 %{_datadir}/libgcj.jar
576 %attr(755,root,root) %{_libdir}/lib*cj*.la
577 %attr(755,root,root) %{_libdir}/lib*cj*.so
578
579 %files -n libgcj-static
580 %defattr(644,root,root,755)
581 %{_libdir}/lib*cj*.a
582
583 %files -n libstdc++
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
586
587 %files -n libstdc++-devel
588 %defattr(644,root,root,755)
589 %{_includedir}/g++*
590 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
591
592 %files -n libstdc++-static
593 %defattr(644,root,root,755)
594 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
595
596 %files -n libgcc
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_slibdir}/lib*.so*
599
600 %files -n cpp
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_slibdir}/cpp
603 %attr(755,root,root) %{_bindir}/cpp
604 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
605 %{_mandir}/man1/cpp.1*
606 %{_infodir}/cpp*
This page took 0.096306 seconds and 4 git commands to generate.