]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- dep. loop (gcc-java <-> libgcj-devel <-> gcc-java) killed.
[packages/gcc4.git] / gcc4.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # exclude gij/libgij.so
4 #
5 # TODO:
6 #               - http://gcc.gnu.org/PR11203 (inline-asm)
7 #               - http://gcc.gnu.org/PR18648 (missed tree-optimization)
8 #               - http://gcc.gnu.org/PR18910 (ICE: regression)
9 #               - http://gcc.gnu.org/PR19030 (ICE: regression)
10 #               - disable internal zlib usage
11 #               - bconds
12 #               - translations from gcc.spec:HEAD
13 #
14 %define         _snap           20041226
15 #
16 Summary:        GNU Compiler Collection: the C compiler and shared files
17 Summary(pl):    Kolekcja kompilatorów GNU: kompilator C i pliki wspó³dzielone
18 Name:           gcc
19 Epoch:          5
20 Version:        4.0.0
21 Release:        0.%{_snap}.0.1
22 License:        GPL
23 Group:          Development/Languages
24 #Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
25 #Source0:       ftp://gcc.gnu.org/pub/gcc/prerelease-%{version}-%{_snap}/gcc-%{version}-%{_snap}.tar.bz2
26 Source0:        ftp://gcc.gnu.org/pub/gcc/snapshots/4.0-%{_snap}/%{name}-4.0-%{_snap}.tar.bz2
27 # Source0-md5:  b2ddfb0e168bcbc72f1282ba03e9140a
28 Patch0:         %{name}-info.patch
29 Patch1:         %{name}-nolocalefiles.patch
30 Patch2:         %{name}-nodebug.patch
31 Patch3:         %{name}-ada-link-new-libgnat.patch
32 Patch4:         %{name}-ada-link.patch
33 Patch5:         %{name}-pr19103.patch
34 URL:            http://gcc.gnu.org/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  binutils >= 2:2.15.94.0.1
38 BuildRequires:  bison
39 BuildRequires:  fileutils >= 4.0.41
40 BuildRequires:  flex
41 BuildRequires:  gcc(ada)
42 BuildRequires:  gcc-ada
43 BuildRequires:  gettext-devel
44 BuildRequires:  glibc-devel >= 2.2.5-20
45 BuildRequires:  gmp-devel
46 BuildRequires:  libmpfr-devel
47 BuildRequires:  perl-devel
48 BuildRequires:  texinfo >= 4.1
49 BuildRequires:  zlib-devel
50 Requires:       binutils >= 2:2.15.94.0.1
51 Requires:       libgcc = %{epoch}:%{version}-%{release}
52 Provides:       cpp = %{epoch}:%{version}-%{release}
53 Provides:       gcc(ada)
54 Obsoletes:      cpp
55 Obsoletes:      egcs-cpp
56 Obsoletes:      gcc-cpp
57 Obsoletes:      gcc-ksi
58 Obsoletes:      gont
59 Conflicts:      glibc-devel < 2.2.5-20
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         _slibdir        /%{_lib}
63
64 %description
65 A compiler aimed at integrating all the optimizations and features
66 necessary for a high-performance and stable development environment.
67
68 This package contains the C compiler and some files shared by various
69 parts of the GNU Compiler Collection. In order to use another GCC
70 compiler you will need to install the appropriate subpackage.
71
72 %description -l pl
73 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
74 wyprodukowania szybkiego i stabilnego kodu wynikowego.
75
76 Ten pakiet zawiera kompilator C i pliki wspó³dzielone przez ró¿ne
77 czê¶ci kolekcji kompilatorów GNU (GCC). ¯eby u¿ywaæ innego kompilatora
78 z GCC, trzeba zainstalowaæ odpowiedni podpakiet.
79
80 %package -n libgcc
81 Summary:        Shared gcc library
82 Summary(pl):    Biblioteka gcc
83 Group:          Libraries
84 Obsoletes:      libgcc1
85
86 %description -n libgcc
87 Shared gcc library.
88
89 %description -n libgcc -l pl
90 Biblioteka dynamiczna gcc.
91
92 %package -n libmudflap
93 Summary:        GCC mudflap shared support library
94 Group:          Libraries
95
96 %description -n libmudflap
97 The libmudflap libraries are used by GCC for instrumenting pointer and
98 array dereferencing operations.
99
100 %package -n libmudflap-devel
101 Summary:        Development files for GCC mudflap library
102 Group:          Development/Libraries
103 Requires:       libmudflap = %{epoch}:%{version}-%{release}
104
105 %description -n libmudflap-devel
106 The libmudflap libraries are used by GCC for instrumenting pointer and
107 array dereferencing operations. This package contains development
108 files.
109
110 %package -n libmudflap-static
111 Summary:        Static GCC mudflap library
112 Group:          Development/Libraries
113 Requires:       libmudflap-devel = %{epoch}:%{version}-%{release}
114
115 %description -n libmudflap-static
116 The libmudflap libraries are used by GCC for instrumenting pointer and
117 array dereferencing operations. This package contains static
118 libraries.
119
120 %package ada
121 Summary:        Ada support for gcc
122 Summary(pl):    Obs³uga Ady do gcc
123 Group:          Development/Languages
124 Requires:       %{name} = %{epoch}:%{version}-%{release}
125 Requires:       libgnat = %{epoch}:%{version}-%{release}
126 Obsoletes:      gcc-gnat
127 Obsoletes:      gnat-devel
128
129 %description ada
130 This package adds experimental support for compiling Ada programs.
131
132 %description ada -l pl
133 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów w
134 Adzie.
135
136 %package -n libgnat
137 Summary:        Ada standard libraries
138 Summary(pl):    Biblioteki standardowe dla Ady
139 Group:          Development/Libraries
140 Obsoletes:      gnat
141 Obsoletes:      libgnat1
142
143 %description -n libgnat
144 This package contains shared libraries needed to run programs written
145 in Ada.
146
147 %description -n libgnat -l pl
148 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów
149 napisanych w Adzie.
150
151 %package -n libgnat-static
152 Summary:        Static Ada standard libraries
153 Summary(pl):    Statyczne biblioteki standardowe dla Ady
154 Group:          Development/Libraries
155 Obsoletes:      gnat-static
156
157 %description -n libgnat-static
158 This package contains static libraries for programs written in Ada.
159
160 %description -n libgnat-static -l pl
161 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
162 Adzie.
163
164 %package c++
165 Summary:        C++ support for gcc
166 Summary(pl):    Obs³uga C++ dla gcc
167 Group:          Development/Languages
168 Requires:       %{name} = %{epoch}:%{version}-%{release}
169 Obsoletes:      egcc-c++
170 Obsoletes:      egcs-c++
171
172 %description c++
173 This package adds C++ support to the GNU Compiler Collection. It
174 includes support for most of the current C++ specification, including
175 templates and exception handling. It does not include a standard C++
176 library, which is available separately.
177
178 %description c++ -l pl
179 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
180 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
181 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
182
183 %package -n libstdc++
184 Summary:        GNU C++ library
185 Summary(pl):    Biblioteki GNU C++
186 Group:          Libraries
187 Obsoletes:      libg++
188 Obsoletes:      libstdc++3
189
190 %description -n libstdc++
191 This is the GNU implementation of the standard C++ libraries, along
192 with additional GNU tools. This package includes the shared libraries
193 necessary to run C++ applications.
194
195 %description -n libstdc++ -l pl
196 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
197 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
198 uruchomienia aplikacji napisanych w C++.
199
200 %package -n libstdc++-devel
201 Summary:        Header files and documentation for C++ development
202 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
203 Group:          Development/Libraries
204 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
205 Requires:       glibc-devel
206 Requires:       libstdc++ = %{epoch}:%{version}-%{release}
207 Obsoletes:      libg++-devel
208 Obsoletes:      libstdc++3-devel
209
210 %description -n libstdc++-devel
211 This is the GNU implementation of the standard C++ libraries. This
212 package includes the header files needed for C++ development and
213 library documentation.
214
215 %description -n libstdc++-devel -l pl
216 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
217 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
218 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
219
220 %package -n libstdc++-static
221 Summary:        Static C++ standard library
222 Summary(pl):    Statyczna biblioteka standardowa C++
223 Group:          Development/Libraries
224 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
225
226 %description -n libstdc++-static
227 Static C++ standard library.
228
229 %description -n libstdc++-static -l pl
230 Statyczna biblioteka standardowa C++.
231
232 %package fortran
233 Summary:        Fortran 95 support for gcc
234 Summary(pl):    Obs³uga Fortranu 95 dla gcc
235 Group:          Development/Languages/Fortran
236 Requires:       libgfortran = %{epoch}:%{version}-%{release}
237 Obsoletes:      egcs-g77
238 Obsoletes:      gcc-g77
239
240 %description fortran
241 This package adds support for compiling Fortran 95 programs with the
242 GNU compiler.
243
244 %description fortran -l pl
245 Ten pakiet dodaje obs³ugê Fortranu 95 do kompilatora gcc. Jest
246 potrzebny do kompilowania programów pisanych w jêzyku Fortran 95.
247
248 %package -n libgfortran
249 Summary:        Fortran 95 Libraries
250 Summary(pl):    Biblioteki Fortranu 95
251 Group:          Development/Libraries
252 Obsoletes:      libg2c
253
254 %description -n libgfortran
255 Fortran 95 Libraries.
256
257 %description -n libgfortran -l pl
258 Biblioteki Fortranu 95.
259
260 %package -n libgfortran-static
261 Summary:        Static Fortran 95 Libraries
262 Summary(pl):    Statyczne Biblioteki Fortranu 95
263 Group:          Development/Libraries
264 Requires:       libgfortran = %{epoch}:%{version}-%{release}
265 Obsoletes:      libg2c-static
266
267 %description -n libgfortran-static
268 Static Fortran 95 Libraries.
269
270 %description -n libgfortran-static -l pl
271 Statyczne biblioteki Fortranu 95.
272
273 %package java
274 Summary:        Java support for gcc
275 Summary(pl):    Obs³uga Javy dla gcc
276 Group:          Development/Languages/Java
277 Requires:       %{name} = %{epoch}:%{version}-%{release}
278 Requires:       libgcj = %{epoch}:%{version}-%{release}
279 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
280 Requires:       java-shared
281 Provides:       gcj = %{epoch}:%{version}-%{release}
282
283 %description java
284 This package adds experimental support for compiling Java(tm) programs
285 and bytecode into native code. To use this you will also need the
286 libgcj package.
287
288 %description java -l pl
289 Wsparcie dla kompilowania programów Java(tm) zarówno do bajt-kodu jak
290 i do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
291 by³o przeprowadziæ kompilacjê.
292
293 %package -n libgcj
294 Summary:        Java Class Libraries
295 Summary(pl):    Biblioteki Klas Javy
296 Group:          Libraries
297 Requires:       zlib
298 Obsoletes:      libgcj3
299
300 %description -n libgcj
301 Java Class Libraries.
302
303 %description -n libgcj -l pl
304 Biblioteki Klas Javy.
305
306 %package -n libgcj-devel
307 Summary:        Development files for Java Class Libraries
308 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
309 Group:          Development/Libraries
310 Requires:       libgcj = %{epoch}:%{version}-%{release}
311 Obsoletes:      libgcj3-devel
312
313 %description -n libgcj-devel
314 Development files for Java Class Libraries.
315
316 %description -n libgcj-devel -l pl
317 Pliki nag³ówkowe dla Bibliotek Klas Javy.
318
319 %package -n libgcj-static
320 Summary:        Static Java Class Libraries
321 Summary(pl):    Statyczne Biblioteki Klas Javy
322 Group:          Development/Libraries
323 Requires:       libgcj-devel = %{epoch}:%{version}-%{release}
324 Requires:       libstdc++-devel = %{epoch}:%{version}-%{release}
325
326 %description -n libgcj-static
327 Static Java Class Libraries.
328
329 %description -n libgcj-static -l pl
330 Statyczne Biblioteki Klas Javy.
331
332 %package -n libffi
333 Summary:        Foreign Function Interface library
334 Summary(pl):    Biblioteka zewnêtrznych wywo³añ funkcji
335 Group:          Libraries
336
337 %description -n libffi
338 The libffi library provides a portable, high level programming
339 interface to various calling conventions. This allows a programmer to
340 call any function specified by a call interface description at run
341 time.
342
343 %description -n libffi -l pl
344 Biblioteka libffi dostarcza przeno¶nego, wysokopoziomowego
345 miêdzymordzia do ró¿nych konwencji wywo³añ funkcji. Pozwala to
346 programi¶cie wywo³ywaæ dowolne funkcje podaj±c konwencjê wywo³ania w
347 czasie wykonania.
348
349 %package -n libffi-devel
350 Summary:        Development files for Foreign Function Interface library
351 Summary(pl):    Pliki nag³ówkowe dla libffi
352 Group:          Development/Libraries
353 Requires:       libffi = %{epoch}:%{version}-%{release}
354
355 %description -n libffi-devel
356 Development files for Foreign Function Interface library.
357
358 %description -n libffi-devel -l pl
359 Pliki nag³ówkowe dla libffi.
360
361 %package -n libffi-static
362 Summary:        Static Foreign Function Interface library
363 Summary(pl):    Statyczna biblioteka libffi
364 Group:          Development/Libraries
365 Requires:       libffi-devel = %{epoch}:%{version}-%{release}
366
367 %description -n libffi-static
368 Static Foreign Function Interface library.
369
370 %description -n libffi-static -l pl
371 Statyczna biblioteka libffi.
372
373 %package java-tools
374 Summary:        Shared java tools
375 Summary(pl):    Wspó³dzielone narzêdzia javy
376 Group:          Development/Languages/Java
377 Provides:       jar = %{epoch}:%{version}-%{release}
378 Provides:       java-shared
379 Obsoletes:      fastjar
380 Obsoletes:      java-shared
381 Obsoletes:      jar
382
383 %description java-tools
384 This package contains tools that are common for every Java(tm)
385 implementation, such as rmic or jar.
386
387 %description java-tools -l pl
388 Pakiet ten zawiera narzêdzia wspólne dla ka¿dej implementacji
389 Javy(tm), takie jak rmic czy jar.
390
391 %package objc
392 Summary:        Objective C support for gcc
393 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
394 Group:          Development/Languages
395 Requires:       %{name} = %{epoch}:%{version}-%{release}
396 Requires:       libobjc = %{epoch}:%{version}-%{release}
397 Obsoletes:      egcc-objc
398 Obsoletes:      egcs-objc
399
400 %description objc
401 This package adds Objective C support to the GNU Compiler Collection.
402 Objective C is a object oriented derivative of the C language, mainly
403 used on systems running NeXTSTEP. This package does not include the
404 standard objective C object library.
405
406 %description objc -l pl
407 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
408 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
409 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
410 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
411
412 %package -n libobjc
413 Summary:        Objective C Libraries
414 Summary(pl):    Biblioteki Obiektowego C
415 Group:          Libraries
416 Obsoletes:      libobjc1
417
418 %description -n libobjc
419 Objective C Libraries.
420
421 %description -n libobjc -l pl
422 Biblioteki Obiektowego C.
423
424 %package -n libobjc-static
425 Summary:        Static Objective C Libraries
426 Summary(pl):    Statyczne Biblioteki Obiektowego C
427 Group:          Development/Libraries
428 Requires:       libobjc = %{epoch}:%{version}-%{release}
429
430 %description -n libobjc-static
431 Static Objective C Libraries.
432
433 %description -n libobjc-static -l pl
434 Statyczne biblioteki Obiektowego C.
435
436 %prep
437 # prerelease
438 #setup -q -n gcc-%{version}-%{_snap}
439 # snapshot
440 %setup -q -n gcc-4.0-%{_snap}
441 # final
442 #setup -q -n gcc-%{version}
443
444 #patch0 -p1     NEEDS UPDATE
445 %patch1 -p1
446 %{!?debug:%patch2 -p1}
447 %patch3 -p1
448 %patch4 -p1
449 %patch5 -p0
450
451 # because we distribute modified version of gcc...
452 perl -pi -e 's/(version.*)";/$1 (PLD Linux)";/' gcc/version.c
453 perl -pi -e 's@(bug_report_url.*<URL:).*";@$1http://bugs.pld-linux.org/>";@' gcc/version.c
454
455 mv ChangeLog ChangeLog.general
456
457 %build
458 cd gcc
459 %{__autoconf}
460 cd ..
461 cp -f /usr/share/automake/config.sub .
462
463 rm -rf obj-%{_target_platform}
464 install -d obj-%{_target_platform}
465 cd obj-%{_target_platform}
466
467 CFLAGS="%{rpmcflags}" \
468 CXXFLAGS="%{rpmcflags}" \
469 TEXCONFIG=false \
470 ../configure \
471         --prefix=%{_prefix} \
472         --libdir=%{_libdir} \
473         --libexecdir=%{_libexecdir} \
474         --infodir=%{_infodir} \
475         --mandir=%{_mandir} \
476         --enable-shared \
477         --enable-threads=posix \
478         --enable-__cxa_atexit \
479         --enable-languages="c,c++,f95,objc,ada,java" \
480         --enable-c99 \
481         --enable-long-long \
482 %ifarch amd64
483         --disable-multilib \
484 %else
485         --enable-multilib \
486 %endif
487         --enable-nls \
488         --with-gnu-as \
489         --with-gnu-ld \
490         --with-system-zlib \
491         --with-slibdir=%{_slibdir} \
492         --without-x \
493         --enable-cmath \
494         %{_target_platform}
495
496 cd ..
497
498 %{__make} -C obj-%{_target_platform} \
499         profiledbootstrap \
500         GCJFLAGS="%{rpmcflags}" \
501         BOOT_CFLAGS="%{rpmcflags}" \
502         STAGE1_CFLAGS="%{rpmcflags}" \
503         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
504         mandir=%{_mandir} \
505         infodir=%{_infodir}
506
507 %install
508 rm -rf $RPM_BUILD_ROOT
509 install -d $RPM_BUILD_ROOT{/lib,%{_aclocaldir},%{_datadir},%{_infodir}}
510
511 cd obj-%{_target_platform}
512
513 %{__make} -j1 install \
514         mandir=%{_mandir} \
515         infodir=%{_infodir} \
516         DESTDIR=$RPM_BUILD_ROOT
517
518 %ifarch sparc64
519 ln -sf  $RPM_BUILD_ROOT%{_bindir}/sparc64-pld-linux-gcc \
520         $RPM_BUILD_ROOT%{_bindir}/sparc-pld-linux-gcc
521 %endif
522
523 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
524 echo ".so gcc.1" > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
525
526 ln -sf gfortran $RPM_BUILD_ROOT%{_bindir}/g95
527 echo ".so gfortran.1" > $RPM_BUILD_ROOT%{_mandir}/man1/g95.1
528
529 # move ada shared libraries to proper place...
530 mv -f   $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/adalib/*.so.1 \
531         $RPM_BUILD_ROOT%{_libdir}
532 # check if symlink to be made is valid
533 test -f $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so.1
534 ln -sf  libgnat-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnat-4.0.so
535 ln -sf  libgnarl-4.0.so.1 $RPM_BUILD_ROOT%{_libdir}/libgnarl-4.0.so
536 ln -sf  libgnat-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnat.so
537 ln -sf  libgnarl-4.0.so $RPM_BUILD_ROOT%{_libdir}/libgnarl.so
538 ln -sf  %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
539
540 cd ..
541
542 install -d java-doc
543 cp -f   libjava/READ* java-doc
544 cp -f   fastjar/README java-doc/README.fastjar
545 cp -f   libffi/README java-doc/README.libffi
546 cp -f   libffi/LICENSE java-doc/LICENSE.libffi
547 cp -f   libobjc/README gcc/objc/README.libobjc
548
549 # avoid -L poisoning in *.la - there should be only -L%{_libdir}/gcc/*/%{version}
550 for f in libstdc++.la libsupc++.la libgcj.la;
551 do
552         perl -pi -e 's@-L[^ ]*[acs.] @@g' $RPM_BUILD_ROOT%{_libdir}/$f
553 done
554 # normalize libdir, to avoid propagation of unnecessary RPATHs by libtool
555 for f in libstdc++.la libsupc++.la libgfortran.la libgfortranbegin.la \
556         libgcj.la lib-org-w3c-dom.la lib-org-xml-sax.la libffi.la libobjc.la;
557 do
558         perl -pi -e "s@^libdir='.*@libdir='/usr/%{_lib}'@" $RPM_BUILD_ROOT%{_libdir}/$f
559 done
560
561 # include/ contains install-tools/include/* and headers that were fixed up
562 # by fixincludes, we don't want former
563 gccdir=$(echo $RPM_BUILD_ROOT%{_libdir}/gcc/*/*/)
564 mkdir   $gccdir/tmp
565 # we have to save these however
566 mv -f   $gccdir/include/{gcj,libffi/ffitarget.h,objc,syslimits.h} \
567         $gccdir/tmp
568 rm -rf  $gccdir/include
569 mv -f   $gccdir/tmp \
570         $gccdir/include
571 cp -f   $gccdir/install-tools/include/*.h \
572         $gccdir/include
573 # but we don't want anything more from install-tools
574 rm -rf  $gccdir/install-tools
575
576 %find_lang gcc
577 %find_lang libstdc\+\+
578
579 %clean
580 rm -rf $RPM_BUILD_ROOT
581
582 %post
583 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
584
585 %postun
586 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
587
588 %post ada
589 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
590
591 %postun ada
592 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
593
594 %post fortran
595 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
596
597 %postun fortran
598 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
599
600 %post java
601 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
602
603 %postun java
604 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
605
606 %post   -p /sbin/ldconfig -n libgcc
607 %postun -p /sbin/ldconfig -n libgcc
608 %post   -p /sbin/ldconfig -n libmudflap
609 %postun -p /sbin/ldconfig -n libmudflap
610 %post   -p /sbin/ldconfig -n libgnat
611 %postun -p /sbin/ldconfig -n libgnat
612 %post   -p /sbin/ldconfig -n libstdc++
613 %postun -p /sbin/ldconfig -n libstdc++
614 %post   -p /sbin/ldconfig -n libgfortran
615 %postun -p /sbin/ldconfig -n libgfortran
616 %post   -p /sbin/ldconfig -n libgcj
617 %postun -p /sbin/ldconfig -n libgcj
618 %post   -p /sbin/ldconfig -n libffi
619 %postun -p /sbin/ldconfig -n libffi
620 %post   -p /sbin/ldconfig -n libobjc
621 %postun -p /sbin/ldconfig -n libobjc
622
623 %files -f gcc.lang
624 %defattr(644,root,root,755)
625 %doc ChangeLog.general MAINTAINERS bugs.html faq.html
626 %doc gcc/{ChangeLog,ONEWS,README.Portability}
627 %dir %{_libdir}/gcc
628 %dir %{_libdir}/gcc/*
629 %dir %{_libdir}/gcc/*/*
630 %dir %{_libdir}/gcc/*/*/include
631
632 %attr(755,root,root) %{_bindir}/*-gcc*
633 %attr(755,root,root) %{_bindir}/gcc
634 %attr(755,root,root) %{_bindir}/gccbug
635 %attr(755,root,root) %{_bindir}/gcov
636 %attr(755,root,root) %{_bindir}/cc
637 %attr(755,root,root) %{_bindir}/cpp
638
639 %{_mandir}/man1/cc.1*
640 %{_mandir}/man1/cpp.1*
641 %{_mandir}/man1/gcc.1*
642 %{_mandir}/man1/gcov.1*
643
644 %{_infodir}/cpp*
645 %{_infodir}/gcc*
646
647 %attr(755,root,root) /lib/cpp
648
649 %attr(755,root,root) %{_slibdir}/lib*.so
650 %{_libdir}/gcc/*/*/libgcov.a
651 %{_libdir}/gcc/*/*/libgcc.a
652 %{_libdir}/gcc/*/*/libgcc_eh.a
653 %{_libdir}/gcc/*/*/specs
654 %attr(644,root,root) %{_libdir}/gcc/*/*/crt*.o
655 %ifarch sparc64
656 %{_libdir}/gcc/*/*/*/libgcc.a
657 %{_libdir}/gcc/*/*/*/libgcc_eh.a
658 %attr(644,root,root) %{_libdir}/gcc/*/*/*/crt*.o
659 %endif
660 %ifarch ppc
661 %attr(644,root,root) %{_libdir}/gcc/*/*/ecrt*.o
662 %attr(644,root,root) %{_libdir}/gcc/*/*/ncrt*.o
663 %{_libdir}/gcc/*/*/nof
664 %dir %{_libdir}/nof
665 %endif
666 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1
667 %attr(755,root,root) %{_libdir}/gcc/*/*/collect2
668
669 %{_libdir}/gcc/*/*/include/*.h
670
671 %files -n libgcc
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_slibdir}/lib*.so.*
674
675 %files -n libmudflap
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/libmudflap*.so.*.*.*
678
679 %files -n libmudflap-devel
680 %defattr(644,root,root,755)
681 %{_includedir}/mf-runtime.h
682 %{_libdir}/libmudflap*.la
683 %attr(755,root,root) %{_libdir}/libmudflap*.so
684
685 %files -n libmudflap-static
686 %defattr(644,root,root,755)
687 %{_libdir}/libmudflap*.a
688
689 %files ada
690 %defattr(644,root,root,755)
691 %doc gcc/ada/ChangeLog
692 %attr(755,root,root) %{_bindir}/gnat*
693 %attr(755,root,root) %{_bindir}/gpr*
694 %attr(755,root,root) %{_libdir}/libgnarl*.so
695 %attr(755,root,root) %{_libdir}/libgnat*.so
696 %attr(755,root,root) %{_libdir}/gcc/*/*/gnat1
697 %{_libdir}/gcc/*/*/adainclude
698 %dir %{_libdir}/gcc/*/*/adalib
699 %{_libdir}/gcc/*/*/adalib/*.ali
700 %{_libdir}/gcc/*/*/adalib/g-trasym.o
701 %{_libdir}/gcc/*/*/adalib/libgccprefix.a
702 %ifarch %{ix86}
703 %{_libdir}/gcc/*/*/adalib/libgmem.a
704 %endif
705 %{_datadir}/gnat
706 %{_infodir}/gnat*
707
708 %files -n libgnat
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libgnarl*.so.1
711 %attr(755,root,root) %{_libdir}/libgnat*.so.1
712
713 %files -n libgnat-static
714 %defattr(644,root,root,755)
715 %{_libdir}/gcc/*/*/adalib/libgnarl.a
716 %{_libdir}/gcc/*/*/adalib/libgnat.a
717
718 %files c++
719 %defattr(644,root,root,755)
720 %doc gcc/cp/{ChangeLog,NEWS}
721 %attr(755,root,root) %{_bindir}/g++
722 %attr(755,root,root) %{_bindir}/*-g++
723 %attr(755,root,root) %{_bindir}/c++
724 %attr(755,root,root) %{_bindir}/*-c++
725 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1plus
726 %{_libdir}/libsupc++.a
727 %{_libdir}/libsupc++.la
728 %{_mandir}/man1/g++.1*
729
730 %files -n libstdc++ -f libstdc++.lang
731 %defattr(644,root,root,755)
732 %doc libstdc++-v3/{ChangeLog,README}
733 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
734
735 %files -n libstdc++-devel
736 %defattr(644,root,root,755)
737 %doc libstdc++-v3/docs/html
738 %dir %{_includedir}/c++
739 %{_includedir}/c++/%{version}
740 %exclude %{_includedir}/c++/%{version}/java
741 %exclude %{_includedir}/c++/%{version}/javax
742 %exclude %{_includedir}/c++/%{version}/gcj
743 %exclude %{_includedir}/c++/%{version}/gnu
744 %exclude %{_includedir}/c++/%{version}/*/bits/stdc++.h.gch
745 %{_libdir}/libstdc++.la
746 %attr(755,root,root) %{_libdir}/libstdc++.so
747
748 %files -n libstdc++-static
749 %defattr(644,root,root,755)
750 %{_libdir}/libstdc++.a
751
752 %files fortran
753 %defattr(644,root,root,755)
754 %doc gcc/fortran/ChangeLog
755 %attr(755,root,root) %{_bindir}/g95
756 %attr(755,root,root) %{_bindir}/gfortran
757 %{_infodir}/gfortran*
758 %attr(755,root,root) %{_libdir}/gcc/*/*/f951
759 %{_libdir}/libgfortranbegin.a
760 %{_libdir}/libgfortranbegin.la
761 %{_libdir}/libgfortran.la
762 %attr(755,root,root) %{_libdir}/libgfortran.so
763 %{_mandir}/man1/g95.1*
764 %{_mandir}/man1/gfortran.1*
765
766 %files -n libgfortran
767 %defattr(644,root,root,755)
768 %doc libgfortran/{AUTHORS,README,ChangeLog}
769 %attr(755,root,root) %{_libdir}/libgfortran.so.*.*.*
770
771 %files -n libgfortran-static
772 %defattr(644,root,root,755)
773 %{_libdir}/libgfortran.a
774
775 %files java
776 %defattr(644,root,root,755)
777 %doc gcc/java/ChangeLog java-doc/*
778 %attr(755,root,root) %{_bindir}/gcj*
779 %{!?with_bootstrap:%attr(755,root,root) %{_bindir}/gij}
780 %attr(755,root,root) %{_bindir}/grepjar
781 %attr(755,root,root) %{_bindir}/jcf-dump
782 %attr(755,root,root) %{_bindir}/jv-*
783 %attr(755,root,root) %{_bindir}/*-gcj*
784 %attr(755,root,root) %{_libdir}/gcc/*/*/jc1
785 %attr(755,root,root) %{_libdir}/gcc/*/*/jvgenmain
786 %{_infodir}/gcj*
787 %{_mandir}/man1/gcj*
788 %{!?with_bootstrap:%{_mandir}/man1/gij*}
789 %{_mandir}/man1/grepjar*
790 %{_mandir}/man1/jcf-*
791 %{_mandir}/man1/jv-*
792
793 %files java-tools
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_bindir}/grmi*
796 %attr(755,root,root) %{_bindir}/fastjar
797 %{_mandir}/man1/grmi*
798 %{_mandir}/man1/fastjar*
799 %{_infodir}/fastjar*
800
801 %files -n libgcj
802 %defattr(644,root,root,755)
803 %doc libjava/{ChangeLog,LIBGCJ_LICENSE,NEWS,README,THANKS}
804 %attr(755,root,root) %{_bindir}/addr2name.awk
805 %attr(755,root,root) %{_libdir}/lib*cj*.so.*.*.*
806 %{!?with_bootstrap:%attr(755,root,root) %{_libdir}/libgij.so.*.*.*}
807 %attr(755,root,root) %{_libdir}/lib-org*.so.*.*.*
808 %{_libdir}/logging.properties
809
810 %files -n libgcj-devel
811 %defattr(644,root,root,755)
812 %{_includedir}/c++/%{version}/java
813 %{_includedir}/c++/%{version}/javax
814 %{_includedir}/c++/%{version}/gcj
815 %{_includedir}/c++/%{version}/gnu
816 %{_libdir}/gcc/*/*/include/gcj
817 %dir %{_libdir}/security
818 %{_libdir}/security/*
819 %dir %{_datadir}/java
820 %{_datadir}/java/libgcj*.jar
821 %{_libdir}/lib*cj.spec
822 %{_libdir}/lib*cj*.la
823 %attr(755,root,root) %{_libdir}/lib*cj*.so
824 %{!?with_bootstrap:%{_libdir}/libgij.la}
825 %{!?with_bootstrap:%attr(755,root,root) %{_libdir}/libgij.so}
826 %attr(755,root,root) %{_libdir}/lib-org-*.so
827 %{_libdir}/lib-org-*.la
828 %{_pkgconfigdir}/libgcj.pc
829
830 %files -n libgcj-static
831 %defattr(644,root,root,755)
832 %{_libdir}/lib*cj*.a
833 %{!?with_bootstrap:%{_libdir}/libgij.a}
834 %{_libdir}/lib-org-*.a
835
836 %files -n libffi
837 %defattr(644,root,root,755)
838 %doc libffi/{ChangeLog,ChangeLog.libgcj,LICENSE,README}
839 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
840
841 %files -n libffi-devel
842 %defattr(644,root,root,755)
843 %{_libdir}/gcc/*/*/include/ffitarget.h
844 %attr(755,root,root) %{_libdir}/libffi.so
845 %{_libdir}/libffi.la
846 %{_includedir}/ffi.h
847
848 %files -n libffi-static
849 %defattr(644,root,root,755)
850 %{_libdir}/libffi.a
851
852 %files objc
853 %defattr(644,root,root,755)
854 %doc gcc/objc/README
855 %attr(755,root,root) %{_libdir}/gcc/*/*/cc1obj
856 %attr(755,root,root) %{_libdir}/libobjc.so
857 %{_libdir}/libobjc.la
858 %{_libdir}/gcc/*/*/include/objc
859
860 %files -n libobjc
861 %defattr(644,root,root,755)
862 %doc libobjc/{ChangeLog,README*}
863 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
864
865 %files -n libobjc-static
866 %defattr(644,root,root,755)
867 %{_libdir}/libobjc.a
This page took 2.166574 seconds and 4 git commands to generate.