]> git.pld-linux.org Git - packages/gcc4.git/blob - gcc4.spec
- resurrected info patch and non-english-man-pages
[packages/gcc4.git] / gcc4.spec
1 #
2 # Conditional build:
3 # _without_ada  - build without ADA support
4 # _without_java - build without Java support
5 #
6 %define         DASHED_SNAP     %{nil}
7 %define         SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
8 %define         GCC_VERSION     3.2.1
9 %define         KSI_VERSION     pre55
10
11 Summary:        GNU Compiler Collection
12 Summary(pl):    Kolekcja kompilatorów GNU
13 Name:           gcc
14 Version:        %{GCC_VERSION}
15 Release:        0.pre.1
16 License:        GPL
17 Group:          Development/Languages
18 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-3.2.tar.bz2
19 Source1:        ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
20 Source2:        %{name}-non-english-man-pages.tar.bz2
21 Patch0:         %{name}-slibdir.patch
22 Patch1:         %{name}-paths.patch
23 Patch2:         %{name}-ada-no-addr2line.patch
24 Patch3:         %{name}-ada-no-prefix.o.patch
25 Patch4:         %{name}-nolocalefiles.patch
26 Patch5:         %{name}-march-i686-fix.patch
27 Patch6:         %{name}-info.patch
28 # -- stolen patches from RH --
29 Patch10:        gcc32-ada-link.patch
30 Patch11:        gcc32-attr-visibility.patch
31 Patch12:        gcc32-attr-visibility2.patch
32 Patch13:        gcc32-attr-visibility3.patch
33 Patch14:        gcc32-attr-visibility4.patch
34 Patch15:        gcc32-attr-visibility5.patch
35 Patch16:        gcc32-boehm-gc-libs.patch
36 Patch17:        gcc32-bogus-inline.patch
37 Patch18:        gcc32-c++-nrv-test.patch
38 Patch19:        gcc32-c++-pretty_function.patch
39 Patch20:        gcc32-c++-tsubst-asm.patch
40 Patch21:        gcc32-cfg-eh.patch
41 Patch22:        gcc32-debug-pr7241.patch
42 Patch23:        gcc32-doc-gcov.patch 
43 Patch24:        gcc32-duplicate-decl.patch
44 Patch25:        gcc32-dwarf2-pr6381.patch 
45 Patch26:        gcc32-dwarf2-pr6436-test.patch
46 Patch27:        gcc32-fde-merge-compat.patch 
47 Patch28:        gcc32-fold-const-associate.patch
48 Patch29:        gcc32-hard-reg-sharing.patch
49 Patch30:        gcc32-hard-reg-sharing2.patch 
50 Patch31:        gcc32-i386-default-momit-leaf-frame-pointer.patch
51 Patch32:        gcc32-i386-memtest-test.patch 
52 Patch33:        gcc32-i386-no-default-momit-leaf-frame-pointer.patch
53 Patch34:        gcc32-i386-pic-label-thunk.patch
54 Patch35:        gcc32-i386-profile-olfp.patch
55 Patch36:        gcc32-inline-label.patch 
56 Patch37:        gcc32-java-no-rpath.patch
57 Patch38:        gcc32-pr6842.patch 
58 Patch39:        gcc32-sparc-sll1.patch
59 Patch40:        gcc32-test-rh65771.patch 
60 Patch41:        gcc32-test-rotate.patch  
61 Patch42:        gcc32-tls-dwarf2.patch 
62 Patch43:        gcc32-tls.patch      
63 Patch44:        gcc32-tls2.patch 
64 Patch45:        gcc32-tls3.patch
65 Patch46:        gcc32-tls4.patch 
66 Patch47:        gcc32-tls5.patch    
67 Patch100:       gcc-pre-3.2.1.patch.gz
68 BuildRequires:  autoconf
69 BuildRequires:  bison
70 BuildRequires:  fileutils >= 4.0.41
71 BuildRequires:  gcc
72 %{!?_without_ada:BuildRequires: gcc-ada}
73 BuildRequires:  glibc-devel >= 2.2.5-20
74 BuildRequires:  perl-devel
75 BuildRequires:  texinfo >= 4.1
76 BuildRequires:  zlib-devel
77 Requires:       binutils >= 2.12.90.0.4
78 Requires:       cpp = %{GCC_VERSION}
79 Requires:       libgcc = %{GCC_VERSION}
80 Conflicts:      glibc-devel < 2.2.5-20
81 URL:            http://gcc.gnu.org/
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _slibdir        /lib
85
86 %description
87 A compiler aimed at integrating all the optimizations and features
88 necessary for a high-performance and stable development environment.
89
90 %description -l pl
91 Kompilator, posiadaj±cy du¿e mo¿liwo¶ci optymalizacyjne niezbêdne do
92 wyprodukowania szybkiego i stablinego kodu wynikowego.
93
94 %package -n libgcc
95 Summary:        Shared gcc library
96 Summary(pl):    Biblioteka gcc
97 Group:          Libraries
98 Version:        %{GCC_VERSION}
99
100 %description -n libgcc
101 Shared gcc library.
102
103 %description -n libgcc -l pl
104 Biblioteka dynamiczna gcc.
105
106 %package c++
107 Summary:        C++ support for gcc
108 Summary(pl):    Obs³uga C++ dla gcc
109 Group:          Development/Languages
110 Obsoletes:      egcc-c++
111 Obsoletes:      egcs-c++
112 Requires:       gcc = %{GCC_VERSION}
113
114 %description c++
115 This package adds C++ support to the GNU C compiler. It includes
116 support for most of the current C++ specification, including templates
117 and exception handling. It does not include a standard C++ library,
118 which is available separately.
119
120 %description c++ -l de
121 Dieses Paket enthält die C++-Unterstützung für den GNU-C-Compiler. Es
122 unterstützt die aktuelle C++-Spezifikation, inkl. Templates und
123 Ausnahmeverarbeitung. Eine C++-Standard-Library ist nicht enthalten -
124 sie ist getrennt erhältlich.
125
126 %description c++ -l fr
127 Ce package ajoute un support C++ au compilateur c GNU. Il comprend un
128 support pour la plupart des spécifications actuelles de C++, dont les
129 modéles et la gestion des exceptions. Il ne comprend pas une
130 bibliothéque C++ standard, qui est disponible séparément.
131
132 %description c++ -l pl
133 Ten pakiet dodaje obs³ugê C++ do kompilatora gcc. Ma wsparcie dla
134 du¿ej ilo¶ci obecnych specyfikacji C++, nie zawiera natomiast
135 standardowych bibliotek C++, które s± w oddzielnym pakiecie.
136
137 %description c++ -l tr
138 Bu paket, GNU C derleyicisine C++ desteði ekler. 'Template'ler ve
139 aykýrý durum iþleme gibi çoðu güncel C++ tanýmlarýna uyar. Standart
140 C++ kitaplýðý bu pakette yer almaz.
141
142 %package objc
143 Summary:        Objective C support for gcc
144 Summary(de):    Objektive C-Unterstützung für gcc
145 Summary(fr):    Gestion d'Objective C pour gcc
146 Summary(pl):    Obs³uga obiektowego C dla kompilatora gcc
147 Summary(tr):    gcc için Objective C desteði
148 Group:          Development/Languages
149 Obsoletes:      egcc-objc
150 Obsoletes:      egcs-objc
151 Requires:       libobjc = %{GCC_VERSION}
152 Requires:       gcc = %{GCC_VERSION}
153
154 %description objc
155 This package adds Objective C support to the GNU C compiler. Objective
156 C is a object oriented derivative of the C language, mainly used on
157 systems running NeXTSTEP. This package does not include the standard
158 objective C object library.
159
160 %description objc -l de
161 Dieses Paket ergänzt den GNU-C-Compiler durch Objective-C-Support.
162 Objective C ist ein objektorientiertes Derivat von C, das zur
163 Hauptsache auf Systemen mit NeXTSTEP zum Einsatz kommt. Die
164 Standard-Objective-C-Objekt-Library ist nicht Teil des Pakets.
165
166 %description objc -l fr
167 Ce package ajoute un support Objective C au compilateur C GNU.
168 L'Objective C est un langage orienté objetdérivé du langage C,
169 principalement utilisé sur les systèmes NeXTSTEP. Ce package n'inclue
170 pas la bibliothéque Objective C standard.
171
172 %description objc -l pl
173 Ten pakiet dodaje obs³ugê obiektowego C do kompilatora gcc. Obiektowe
174 C (objc) jest zorientowan± obiektowo pochodn± jêzyka C, u¿ywan±
175 g³ównie w systemach u¿ywaj±cych NeXTSTEP. W pakiecie nie ma
176 standardowej biblioteki objc (która znajduje siê w osobnym pakiecie).
177
178 %description objc -l tr
179 Bu paket, GNU C derleyicisine Objective C desteði ekler. Objective C,
180 C dilinin nesne yönelik bir türevidir ve NeXTSTEP altýnda çalýþan
181 sistemlerde yaygýn olarak kullanýlýr. Standart Objective C nesne
182 kitaplýðý bu pakette yer almaz.
183
184 %package -n libobjc
185 Summary:        Objective C Libraries
186 Summary(pl):    Biblioteki Obiektowego C
187 Group:          Libraries
188 Version:        %{GCC_VERSION}
189 Epoch:          3
190
191 %description -n libobjc
192 Objective C Libraries.
193
194 %description -n libobjc -l pl
195 Biblioteki Obiektowego C.
196
197 %package -n libobjc-static
198 Summary:        Static Objective C Libraries
199 Summary(pl):    Statyczne Biblioteki Obiektowego C
200 Group:          Development/Libraries
201 Version:        %{GCC_VERSION}
202 Epoch:          4
203 Requires:       libobjc = %{GCC_VERSION}
204
205 %description -n libobjc-static
206 Static Objective C Libraries.
207
208 %description -n libobjc-static -l pl
209 Statyczne biblioteki Obiektowego C.
210
211 %package g77
212 Summary:        Fortran 77 support for gcc
213 Summary(pl):    Obs³uga Fortranu 77 dla gcc
214 Group:          Development/Languages
215 Version:        %{GCC_VERSION}
216 Obsoletes:      egcs-g77
217 Requires:       libg2c = %{GCC_VERSION}
218
219 %description g77
220 This apckage adds support for compiling Fortran 77 programs with the
221 GNU compiler.
222
223 %description g77 -l pl
224 Ten pakiet dodaje obs³ugê Fortranu 77 do kompilatora gcc. Jest
225 potrzebny do kompilowania programów pisanych w jêzyku Fortran 77.
226
227 %package -n libg2c
228 Summary:        Fortran 77 Libraries
229 Summary(pl):    Biblioteki Fortranu 77
230 Group:          Libraries
231 Version:        %{GCC_VERSION}
232
233 %description -n libg2c
234 Fortran 77 Libraries.
235
236 %description -n libg2c -l pl
237 Biblioteki Fortranu 77.
238
239 %package -n libg2c-static
240 Summary:        Static Fortran 77 Libraries
241 Summary(pl):    Statyczne Biblioteki Fortranu 77
242 Group:          Development/Libraries
243 Version:        %{GCC_VERSION}
244 Epoch:          2
245 Requires:       libg2c = %{GCC_VERSION}
246
247 %description -n libg2c-static
248 Static Fortran 77 Libraries.
249
250 %description -n libg2c-static -l pl
251 Statyczne biblioteki Fortranu 77.
252
253 %package java
254 Summary:        Java support for gcc
255 Summary(pl):    Obs³uga Javy dla gcc
256 Group:          Development/Languages
257 Version:        %{GCC_VERSION}
258 Requires:       %{name} = %{version}
259 Requires:       libgcj >= 3.0.0
260 Provides:       gcj = %{epoch}:%{GCC_VERSION}-%{release}
261 Provides:       jar = %{epoch}:%{GCC_VERSION}-%{release}
262
263 %description java
264 This package adds experimental support for compiling Java(tm) programs
265 and bytecode into native code. To use this you will also need the
266 libgcj package.
267
268 %description -l pl java
269 Wsparcie dla kompilowania programów Java(tm) zrówno do bajt-kodu jak i
270 do natywnego kodu. Dodatkowo wymagany jest pakiet libgcj, aby mo¿na
271 by³o przeprowadziæ kompilacjê.
272
273 %package -n libgcj
274 Summary:        Java Class Libraries
275 Summary(pl):    Biblioteki Klas Javy
276 Group:          Libraries
277 Version:        %{GCC_VERSION}
278 Epoch:          2
279 Requires:       zlib
280
281 %description -n libgcj
282 Java Class Libraries.
283
284 %description -n libgcj -l pl
285 Biblioteki Klas Javy.
286
287 %package -n libgcj-devel
288 Summary:        Development files for Java Class Libraries
289 Summary(pl):    Pliki nag³ówkowe dla Bibliotek Klas Javy
290 Group:          Development/Libraries
291 Version:        %{GCC_VERSION}
292 Epoch:          2
293 Requires:       libgcj = %{GCC_VERSION}
294 Requires:       %{name}-java
295
296 %description -n libgcj-devel
297 Development files for Java Class Libraries.
298
299 %description -n libgcj-devel -l pl
300 Pliki nag³ówkowe dla Bibliotek Klas Javy.
301
302 %package -n libgcj-static
303 Summary:        Static Java Class Libraries
304 Summary(pl):    Statyczne Biblioteki Klas Javy
305 Group:          Development/Libraries
306 Version:        %{GCC_VERSION}
307 Epoch:          2
308 Requires:       libstdc++-devel = %{GCC_VERSION}
309 Requires:       libgcj-devel = %{GCC_VERSION}
310
311 %description -n libgcj-static
312 Static Java Class Libraries.
313
314 %description -n libgcj-static -l pl
315 Statyczne Biblioteki Klas Javy.
316
317 %package -n libstdc++
318 Summary:        GNU c++ library
319 Summary(pl):    Biblioteki GNU C++ 
320 Group:          Libraries
321 Version:        %{GCC_VERSION}
322 Epoch:          1
323 Obsoletes:      libg++
324
325 %description -n libstdc++
326 This is the GNU implementation of the standard C++ libraries, along
327 with additional GNU tools. This package includes the shared libraries
328 necessary to run C++ applications.
329
330 %description -n libstdc++ -l de
331 Dies ist die GNU-Implementierung der Standard-C++-Libraries mit
332 weiteren GNU-Tools. Dieses Paket enthält die zum Ausführen von
333 C++-Anwendungen erforderlichen gemeinsam genutzten Libraries.
334
335 %description -n libstdc++ -l fr
336 Ceci est l'implémentation GNU des librairies C++ standard, ainsi que
337 des outils GNU supplémentaires. Ce package comprend les librairies
338 partagées nécessaires à l'exécution d'application C++.
339
340 %description -n libstdc++ -l pl
341 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
342 bibliotek C++. Znajduj± siê w nim biblioteki dynamiczne niezbêdne do
343 uruchomienia aplikacji napisanych w C++.
344
345 %description -n libstdc++ -l tr
346 Bu paket, standart C++ kitaplýklarýnýn GNU gerçeklemesidir ve C++
347 uygulamalarýnýn koþturulmasý için gerekli kitaplýklarý içerir.
348
349 %package -n libstdc++-devel
350 Summary:        Header files and documentatino for C++ development
351 Summary(de):    Header-Dateien zur Entwicklung mit C++
352 Summary(fr):    Fichiers d'en-tête et biblitothèques pour développer en C++.
353 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki standardowej C++
354 Summary(tr):    C++ ile program geliþtirmek için gerekli dosyalar
355 Group:          Development/Libraries
356 Version:        %{GCC_VERSION}
357 Epoch:          1
358 Requires:       libstdc++ = %{GCC_VERSION}
359 Requires:       %{name}-c++
360 Obsoletes:      libg++-devel
361
362 %description -n libstdc++-devel
363 This is the GNU implementation of the standard C++ libraries. This
364 package includes the header files needed for C++ development and
365 library documentation.
366
367 %description -n libstdc++-devel -l pl
368 Pakiet ten zawiera biblioteki bêd±ce implementacj± standardowych
369 bibliotek C++. Znajduj± siê w nim pliki nag³ówkowe wykorzystywane przy
370 programowaniu w jêzyku C++ oraz dokumentacja biblioteki standardowej.
371
372 %package -n libstdc++-static
373 Summary:        Static C++ standard library
374 Summary(pl):    Statyczna biblioteka standardowa C++
375 Group:          Development/Libraries
376 Version:        %{GCC_VERSION}
377 Epoch:          1
378 Requires:       libstdc++-devel = %{GCC_VERSION}
379
380 %description -n libstdc++-static
381 Static C++ standard library.
382
383 %description -n libstdc++-static -l pl
384 Statycza biblioteka standardowa C++.
385
386 %package ada
387 Summary:        Ada support for gcc
388 Summary(pl):    Obs³uga Ady do gcc
389 Group:          Development/Languages
390 Version:        %{GCC_VERSION}
391 Requires:       libgnat = %{GCC_VERSION}
392 Requires:       gcc = %{GCC_VERSION}
393 Obsoletes:      gcc-gnat
394 Obsoletes:      gnat-devel
395
396 %description ada
397 This package adds experimental support for compiling Ada programs.
398
399 %description -l pl ada
400 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
401 w Adzie.
402
403 %package -n libgnat
404 Summary:        Ada standard libraries
405 Summary(pl):    Biblioteki standardowe dla Ady
406 Group:          Libraries
407 Version:        %{GCC_VERSION}
408 Obsoletes:      gnat
409
410 %description -n libgnat
411 This package contains shared libraries needed to run programs written
412 in Ada.
413
414 %description -n libgnat -l pl
415 Ten pakiet zawiera biblioteki potrzebne do uruchamiania programów napisanych
416 w Adzie.
417
418 %package -n libgnat-static
419 Summary:        Static Ada standard libraries
420 Summary(pl):    Statyczne biblioteki standardowe dla Ady
421 Group:          Libraries
422 Version:        %{GCC_VERSION}
423 Obsoletes:      gnat-static
424
425 %description -n libgnat-static
426 This package contains static libraries for programs written in Ada.
427
428 %description -n libgnat-static -l pl
429 Ten pakiet zawiera biblioteki statyczne dla programów napisanych w
430 Adzie.
431
432 %package ksi
433 Summary:        Ksi support for gcc
434 Summary(pl):    Obs³uga Ksi dla gcc
435 Version:        %{GCC_VERSION}.%{KSI_VERSION}
436 Group:          Development/Languages
437 Requires:       gcc = %{GCC_VERSION}
438
439 %description ksi
440 This package adds experimental support for compiling Ksi programs
441 into native code. You proabably don't need it, unless your are going
442 to develop a compiler using Ksi as intermediate representation or
443 you are using such compiler (like Gont).
444
445 %description ksi -l pl
446 Ten pakiet dodaje eksperymentalne wsparcie dla kompilacji programów
447 w Ksi do kodu maszynowego. Prawdopodobnie nie potrzebujesz go, chyba
448 ¿e zamierzasz pisaæ kompilator u¿ywaj±cy Ksi jako reprezentacji
449 po¶rednicz±cej, lub u¿ywasz takiego kompilatora (jak Gont).
450
451 %package -n cpp
452 Summary:        The C Pre Processor
453 Summary(pl):    Preprocesor C
454 Group:          Development/Languages
455 Version:        %{GCC_VERSION}
456 Obsoletes:      egcs-cpp
457 Obsoletes:      gcc-cpp
458
459 %description -n cpp
460 The C preprocessor is a "macro processor" that is used automatically
461 by the C compiler to transform your program before actual compilation.
462 It is called a macro processor because it allows you to define
463 "macros", which are brief abbreviations for longer constructs.
464
465 The C preprocessor provides four separate facilities that you can use
466 as you see fit:
467
468 - Inclusion of header files. These are files of declarations that can
469   be substituted into your program.
470 - Macro expansion. You can define "macros", which are abbreviations
471   for arbitrary fragments of C code, and then the C preprocessor will
472   replace the macros with their definitions throughout the program.
473 - Conditional compilation. Using special preprocessing directives, you
474   can include or exclude parts of the program according to various
475   conditions.
476 - Line control. If you use a program to combine or rearrange source
477   files into an intermediate file which is then compiled, you can use
478   line control to inform the compiler of where each source line
479   originally came from.
480
481 %description -n cpp -l pl
482 Przeprocesor C jest "makro procesorem" który jest automatycznie
483 u¿ywany przez kompilator C do obróbki kompilowanego programu przed
484 w³a¶ciw± kompilacj±. Jest on nazywany makroprocesorem, poniewa¿
485 umo¿liwia definiowanie i rozwijanie makr umo¿liwiaj±cych skracanie
486 d³ugich konstrukcji w jêzyku C.
487
488 Preprocesor C umo¿liwia wykonywanie czterech ró¿nych typów operacji:
489
490 - Do³±czanie plików (np. nag³ówkowych). Wstawia pliki w miejscu
491   deklaracji polecenia do³±czenia innego pliku.
492 - Rozwijanie makr. Mo¿na definiowaæ "makra" nadaj±c im identyfikatory,
493   których pó¼niejsze u¿ycie powoduje podczas rozwijania podmienienie
494   indentyfikatora deklarowan± wcze¶niej warto¶ci±.
495 - Kompilacja warunkowa. W zale¿no¶ci od obecno¶ci symboli i dyrektyw w
496   ¶rodowisku preprocesora s± w³±czane warunkowo, b±d¼ nie, pewne
497   fragmenty obrabianego strumienia tekstów.
498 - Kontrola linii ¼ród³a. Niezale¿nie od tego jakim przeobra¿eniom
499   podlega wynikowy strumieñ danych w wyniku rozwijania makr i do³±czania
500   s± zapamiêtywane informacje o tym, której linii pliku ¼ród³owego
501   odpowiada fragment pliku wynikowego.
502
503 %prep
504 %setup -q -a1 -n %{name}-3.2
505 mv ksi-%{KSI_VERSION} gcc/ksi
506 %patch100 -p1
507
508 %patch0 -p1
509 %patch1 -p1
510 %patch2 -p1
511 %patch3 -p1
512 %patch4 -p1
513 %ifarch %{ix86}
514 %patch5 -p0
515 %endif
516
517 %patch10 
518 %patch11 
519 %patch12 
520 %patch13 
521 %patch14 
522 %patch15 
523 %patch16 
524 %patch17 
525 %patch18 
526 %patch19 
527 %patch20 
528 %patch21 
529 %patch22 
530 %patch23 
531 %patch24 
532 %patch25 
533 %patch26 
534 %patch27 
535 %patch28 
536 %patch29 
537 %patch30 
538 %patch31 
539 %patch32 
540 %patch33 
541 %patch34 
542 %patch35 
543 %patch36 
544 %patch37 
545 %patch38 
546 %patch39 
547 %patch40 
548 %patch41 
549 %patch42 
550 %patch43
551 %patch44 
552 %patch45 
553 %patch46
554 %patch47
555
556 %patch6 -p1
557
558 %build
559 # cd gcc && autoconf; cd ..
560 # autoconf is not needed!
561 rm -rf obj-%{_target_platform} && install -d obj-%{_target_platform} && cd obj-%{_target_platform}
562
563 CFLAGS="%{rpmcflags}" \
564 CXXFLAGS="%{rpmcflags}" \
565 TEXCONFIG=false ../configure \
566         --prefix=%{_prefix} \
567         --infodir=%{_infodir} \
568         --mandir=%{_mandir} \
569         --enable-shared \
570         --enable-threads=posix \
571         --enable-__cxa_atexit \
572         --enable-languages="c,c++,f77,gcov,objc,ksi%{!?_without_ada:,ada}%{!?_without_java:,java}" \
573         --enable-c99 \
574         --enable-long-long \
575         --enable-multilib \
576         --enable-nls \
577         --with-gnu-as \
578         --with-gnu-ld \
579         --with-system-zlib \
580         --with-slibdir=%{_slibdir} \
581         --without-x \
582         %{_target_platform}
583
584 PATH=$PATH:/sbin:%{_sbindir}
585
586 # this dirty hack is relict of setting, where objdir is subdir of srcdir
587 %if %{!?_without_ada:1}%{?_without_ada:0}
588 sed -e 's/srcdir=\$(fsrcdir)/srcdir=\$(fsrcdir) VPATH=\$(fsrcdir)/' \
589         gcc/ada/Makefile > makefile.tmp
590 mv -f makefile.tmp gcc/ada/Makefile
591 %endif
592
593 cd ..
594 %{__make} -C obj-%{_target_platform} bootstrap-lean \
595         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
596         mandir=%{_mandir} \
597         infodir=%{_infodir}
598
599 %if %{!?_without_ada:1}%{?_without_ada:0}
600 %{__make} -C obj-%{_target_platform}/gcc gnatlib gnattools gnatlib-shared \
601         LDFLAGS_FOR_TARGET="%{rpmldflags}" \
602         mandir=%{_mandir} \
603         infodir=%{_infodir}
604
605 # make Gnat Reference Manual
606 %{__make} -C obj-%{_target_platform}/gcc/ada doc
607 %endif
608
609 %install
610 rm -rf $RPM_BUILD_ROOT
611 install -d $RPM_BUILD_ROOT{/lib,%{_datadir},%{_infodir}}
612
613 cd obj-%{_target_platform}
614 PATH=$PATH:/sbin:%{_sbindir}
615
616 %{__make} install \
617         prefix=$RPM_BUILD_ROOT%{_prefix} \
618         mandir=$RPM_BUILD_ROOT%{_mandir} \
619         infodir=$RPM_BUILD_ROOT%{_infodir} \
620         slibdir=$RPM_BUILD_ROOT/lib
621
622 ln -sf gcc $RPM_BUILD_ROOT%{_bindir}/cc
623 echo .so gcc.1 > $RPM_BUILD_ROOT%{_mandir}/man1/cc.1
624
625 ln -sf g77 $RPM_BUILD_ROOT%{_bindir}/f77
626 echo .so g77.1 > $RPM_BUILD_ROOT%{_mandir}/man1/f77.1
627
628 (cd $RPM_BUILD_ROOT%{_libdir} ; LIBSTDC=$(ls libstdc++.so.*.*.*) ; \
629  cd $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/ ; \
630  ln -sf ../../../${LIBSTDC} libstdc++.so ; \
631  ln -sf ../../../libstdc++.la libstdc++.la)
632
633 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.a \
634         $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/
635
636 LIBSTDC=$(ls -d $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/* | sed -e "s#$RPM_BUILD_ROOT##g")
637 mv $RPM_BUILD_ROOT%{_libdir}/libstdc++.la $RPM_BUILD_ROOT%{_libdir}/libstdc++.la.old
638 sed -e "s#^libdir='/usr/lib'#libdir='$LIBSTDC'#g" $RPM_BUILD_ROOT%{_libdir}/libstdc++.la.old \
639  > $RPM_BUILD_ROOT%{_libdir}/libstdc++.la
640
641 %if %{!?_without_ada:1}%{?_without_ada:0}
642 # move ada shared libraries to proper place...
643 mv $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*-*so.1 \
644         $RPM_BUILD_ROOT%{_libdir}
645 rm -f $RPM_BUILD_ROOT%{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.so.1
646 (cd $RPM_BUILD_ROOT%{_libdir} && \
647  ln -s libgnat-*so.1 libgnat.so.1 && \
648  ln -s libgnarl-*so.1 libgnarl.so.1)
649 %endif
650
651 ln -sf %{_bindir}/cpp $RPM_BUILD_ROOT/lib/cpp
652
653 cd ..
654
655 %if %{!?_without_ada:1}%{?_without_ada:0}
656 install obj-%{_target_platform}/gcc/ada/gnat_rm.info* $RPM_BUILD_ROOT%{_infodir}
657 install obj-%{_target_platform}/gcc/ada/gnat_ug_unx.info* $RPM_BUILD_ROOT%{_infodir}
658 %endif
659
660 %if %{!?_without_java:1}%{?_without_java:0}
661 install -d java-doc
662 cp -f libjava/doc/cni.sgml libjava/READ* java-doc
663 cp -f fastjar/README java-doc/README.fastjar
664 cp -f libffi/README java-doc/README.libffi
665 cp -f libffi/LICENSE java-doc/LICENSE.libffi
666
667 cp -f libobjc/README gcc/objc/README.libobjc
668 %endif
669
670 bzip2 -dc %{SOURCE2} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
671 mv -f $RPM_BUILD_ROOT%{_mandir}/ja/man1/{cccp,cpp}.1
672
673 %find_lang %{name}
674 %find_lang libstdc\+\+
675
676 %clean
677 rm -rf $RPM_BUILD_ROOT
678
679 %post
680 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
681
682 %postun
683 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
684
685 %post g77
686 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
687
688 %postun g77
689 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
690
691 %post java
692 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
693
694 %postun java
695 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
696
697 %post ksi
698 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
699
700 %postun ksi
701 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
702
703 %post -n cpp
704 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
705
706 %postun -n cpp
707 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
708
709 %post   -p /sbin/ldconfig -n libgcc
710 %postun -p /sbin/ldconfig -n libgcc
711 %post   -p /sbin/ldconfig -n libstdc++
712 %postun -p /sbin/ldconfig -n libstdc++
713 %post   -p /sbin/ldconfig -n libobjc
714 %postun -p /sbin/ldconfig -n libobjc
715 %post   -p /sbin/ldconfig -n libg2c
716 %postun -p /sbin/ldconfig -n libg2c
717 %post   -p /sbin/ldconfig -n libgcj
718 %postun -p /sbin/ldconfig -n libgcj
719 %post   -p /sbin/ldconfig -n libgnat
720 %postun -p /sbin/ldconfig -n libgnat
721
722 %files -f %{name}.lang
723 %defattr(644,root,root,755)
724 %doc READ* ChangeLog
725 %dir %{_libdir}/gcc-lib
726 %dir %{_libdir}/gcc-lib/%{_target_cpu}*
727 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*
728 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/include
729 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-gcc
730 %attr(755,root,root) %{_bindir}/gcc
731 %attr(755,root,root) %{_bindir}/gccbug
732 %attr(755,root,root) %{_bindir}/gcov
733 %attr(755,root,root) %{_bindir}/cc
734
735 %{_mandir}/man1/gcc.1*
736 %{_mandir}/man1/cc.1*
737 %{_mandir}/man1/gcov.1*
738 %lang(fr) %{_mandir}/fr/man1/gcc.1*
739 %lang(ja) %{_mandir}/ja/man1/gcc.1*
740 %{_infodir}/gcc*
741
742 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc.a
743 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libgcc_eh.a
744 %{_libdir}/gcc-lib/%{_target_cpu}*/*/specs
745 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/crt*.o
746 %ifarch ppc
747 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ecrt*.o
748 %attr(644,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ncrt*.o
749 %{_libdir}/gcc-lib/%{_target_cpu}*/*/nof
750 %dir %{_libdir}/nof
751 %endif
752 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1
753 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/collect2
754
755 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/float.h
756 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/iso646.h
757 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/limits.h
758 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdarg.h
759 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stdbool.h
760 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/stddef.h
761 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/syslimits.h
762 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/varargs.h
763 %ifarch %{ix86}
764 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/mmintrin.h
765 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/xmmintrin.h
766 %endif
767 %ifarch ppc
768 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/altivec.h
769 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/ppc-asm.h
770 %endif
771
772 %files -n libgcc
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{_slibdir}/lib*.so*
775
776 %files c++
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_bindir}/g++
779 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-g++
780 %attr(755,root,root) %{_bindir}/c++
781 %attr(755,root,root) %{_bindir}/%{_target_cpu}*-c++
782 %attr(755,root,root) %{_bindir}/c++filt
783 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1plus
784 %attr(755,root,root) %{_libdir}/libsupc++.la
785 %ifarch ppc
786 %attr(755,root,root) %{_libdir}/nof/libsupc++.la
787 %{_libdir}/nof/libsupc++.a
788 %endif
789 %{_libdir}/libsupc++.a
790 %{_mandir}/man1/g++.1*
791 %lang(es) %{_mandir}/es/man1/c++filt.1*
792 %lang(ja) %{_mandir}/ja/man1/g++.1*
793
794 %files -n libstdc++ -f libstdc++.lang
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_libdir}/libstdc++.so.*.*.*
797 %ifarch ppc
798 %attr(755,root,root) %{_libdir}/nof/libstdc++.so.*.*.*
799 %endif
800
801 %files -n libstdc++-devel
802 %defattr(644,root,root,755)
803 %doc libstdc++-v3/docs/html
804 %dir %{_includedir}/c++
805 %{_includedir}/c++/%{GCC_VERSION}
806 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.so
807 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.la
808 %attr(755,root,root) %{_libdir}/libstdc++.la
809 %ifarch ppc
810 %attr(755,root,root) %{_libdir}/nof/libstdc++.so
811 %attr(755,root,root) %{_libdir}/nof/libstdc++.la
812 %endif
813
814 %files -n libstdc++-static
815 %defattr(644,root,root,755)
816 %{_libdir}/gcc-lib/%{_target_cpu}*/*/libstdc++.a
817 %ifarch ppc
818 %{_libdir}/nof/libstdc++.a
819 %endif
820
821 %files objc
822 %defattr(644,root,root,755)
823 %doc gcc/objc/READ*
824 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cc1obj
825 %attr(755,root,root) %{_libdir}/libobjc.so
826 %attr(755,root,root) %{_libdir}/libobjc.la
827 %ifarch ppc
828 %attr(755,root,root) %{_libdir}/nof/libobjc.so
829 %attr(755,root,root) %{_libdir}/nof/libobjc.la
830 %endif
831 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/objc
832
833 %files -n libobjc
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{_libdir}/libobjc.so.*.*.*
836 %ifarch ppc
837 %attr(755,root,root) %{_libdir}/nof/libobjc.so.*.*.*
838 %endif
839
840 %files -n libobjc-static
841 %defattr(644,root,root,755)
842 %{_libdir}/libobjc.a
843 %ifarch ppc
844 %{_libdir}/nof/libobjc.a
845 %endif
846
847 %files g77
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_bindir}/g77
850 %attr(755,root,root) %{_bindir}/f77
851 %{_infodir}/g77*
852 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/f771
853 %{_libdir}/libfrtbegin.a
854 %attr(755,root,root) %{_libdir}/libg2c.la
855 %attr(755,root,root) %{_libdir}/libg2c.so
856 %ifarch ppc
857 %{_libdir}/nof/libfrtbegin.a
858 %attr(755,root,root) %{_libdir}/nof/libg2c.la
859 %attr(755,root,root) %{_libdir}/nof/libg2c.so
860 %endif
861 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/g2c.h
862 %{_mandir}/man1/g77.1*
863 %{_mandir}/man1/f77.1*
864 %lang(ja) %{_mandir}/ja/man1/g77.1*
865 %lang(ja) %{_mandir}/ja/man1/f77.1*
866
867 %files -n libg2c
868 %defattr(644,root,root,755)
869 %attr(755,root,root) %{_libdir}/libg2c.so.*.*.*
870 %ifarch ppc
871 %attr(755,root,root) %{_libdir}/nof/libg2c.so.*.*.*
872 %endif
873
874 %files -n libg2c-static
875 %{_libdir}/libg2c.a
876 %ifarch ppc
877 %{_libdir}/nof/libg2c.a
878 %endif
879
880 %if %{!?_without_java:1}%{?_without_java:0}
881 %files java
882 %defattr(644,root,root,755)
883 %doc java-doc/*
884 %attr(755,root,root) %{_bindir}/gcj*
885 %attr(755,root,root) %{_bindir}/gij
886 %attr(755,root,root) %{_bindir}/jcf-dump
887 %attr(755,root,root) %{_bindir}/jv-*
888 %attr(755,root,root) %{_bindir}/rmi*
889 %attr(755,root,root) %{_bindir}/jar
890 %attr(755,root,root) %{_bindir}/grepjar
891 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jc1
892 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/jvgenmain
893 %{_infodir}/gcj*
894 %{_mandir}/man1/jcf-*
895 %{_mandir}/man1/jv-*
896 %{_mandir}/man1/gij*
897 %{_mandir}/man1/gcj*
898 %{_mandir}/man1/rmi*
899
900 %files -n libgcj
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_bindir}/addr2name.awk
903 %attr(755,root,root) %{_libdir}/lib*cj*.so.*
904 %ifarch ppc
905 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so.*
906 %endif
907
908 %files -n libgcj-devel
909 %defattr(644,root,root,755)
910 %{_includedir}/java
911 %{_includedir}/javax
912 %{_includedir}/org
913 %{_includedir}/gcj
914 %{_includedir}/j*.h
915 %{_includedir}/gnu/*
916 %{_libdir}/gcc-lib/%{_target_cpu}*/*/include/gcj
917 %{_libdir}/security/*
918 %dir %{_datadir}/java
919 %{_datadir}/java/libgcj*.jar
920 %{_libdir}/lib*cj.spec
921 %attr(755,root,root) %{_libdir}/lib*cj*.la
922 %attr(755,root,root) %{_libdir}/lib*cj*.so
923 %ifarch ppc
924 %{_libdir}/nof/lib*cj.spec
925 %attr(755,root,root) %{_libdir}/nof/lib*cj*.la
926 %attr(755,root,root) %{_libdir}/nof/lib*cj*.so
927 %endif
928
929 %files -n libgcj-static
930 %defattr(644,root,root,755)
931 %{_libdir}/lib*cj*.a
932 %ifarch ppc
933 %{_libdir}/nof/lib*cj*.a
934 %endif
935 %endif
936
937 %if %{!?_without_ada:1}%{?_without_ada:0}
938 %files ada
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/gnat1
941 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adainclude
942 %dir %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib
943 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/*.ali
944 %ifnarch ppc
945 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgmem.a
946 %endif
947 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/Makefile.adalib
948 %attr(755,root,root) %{_bindir}/gnat*
949 %{_infodir}/gnat*
950 %attr(755,root,root) %{_libdir}/libgnat.so.1
951 %attr(755,root,root) %{_libdir}/libgnarl.so.1
952
953 %files -n libgnat
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/libgna*-*so.1
956
957 %files -n libgnat-static
958 %defattr(644,root,root,755)
959 %{_libdir}/gcc-lib/%{_target_cpu}*/*/adalib/libgna*.a
960 %endif
961
962 %files ksi
963 %defattr(644,root,root,755)
964 %doc gcc/ksi/README gcc/ksi/NEWS gcc/ksi/t/*.{ksi,c,foo}
965 %{_infodir}/ksi*
966 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/ksi1
967
968 %files -n cpp
969 %defattr(644,root,root,755)
970 %attr(755,root,root) %{_slibdir}/cpp
971 %attr(755,root,root) %{_bindir}/cpp
972 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/cpp0
973 %attr(755,root,root) %{_libdir}/gcc-lib/%{_target_cpu}*/*/tradcpp0
974 %{_mandir}/man1/cpp.1*
975 %lang(ja) %{_mandir}/ja/man1/cpp.1*
976 %{_infodir}/cpp*
This page took 0.090118 seconds and 3 git commands to generate.