]> git.pld-linux.org Git - packages/gc.git/blob - gc.spec
838ad5e3e7fd47580e2905210fc9451a51f593f3
[packages/gc.git] / gc.spec
1 Summary:        Conservative garbage collector
2 Summary(pl):    Konserwatywny od¶miecacz pamiêci
3 Name:           gc
4 Version:        6.4
5 Release:        2
6 License:        BSD-like
7 Group:          Libraries
8 Source0:        http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}%{version}.tar.gz
9 # Source0-md5:  ef03495e980b834a99c0e27eedaa546e
10 URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
11 BuildRequires:  autoconf >= 2.53
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _includedir     %{_prefix}/include/gc
17
18 %description
19 Gc is a conservative garbage collector for C and C++. It is used as a
20 replacement for standard malloc() and free(). GC_malloc will attempt
21 to reclaim inaccessible space automatically by invoking a conservative
22 garbage collector at appropriate points.
23
24 %description -l pl
25 Gc jest konserwatywnym od¶miecaczem pamiêci dla C i C++. Jest u¿ywany
26 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
27 próbuje odzyskaæ niedostêpna pamiêæ automatycznie przez wywo³ywanie
28 konserwatywnego od¶miecacza pamiêci w odpowiednich miejscach.
29
30 %package devel
31 Summary:        Headers for conservative garbage collector
32 Summary(pl):    Nag³ówki dla konserwatywnego od¶miecacza pamiêci
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Headers for conservative garbage collector
38
39 %description devel -l pl
40 Nag³ówki dla konserwatywnego od¶miecacza pamiêci
41
42 %package static
43 Summary:        Static version of gc library
44 Summary(pl):    Statyczna wersja biblioteki gc
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static version of gc library
50
51 %description static -l pl
52 Statyczna wersja biblioteki gc
53
54 %prep
55 %setup -q -n %{name}%{version}
56
57 # kill libtool.m4 inclusion
58 %{__perl} -pi -e 's/^sinclude.*//' acinclude.m4
59
60 %{__perl} -pi -e 's/^dist_pkgdata_DATA/EXTRA_DIST/' doc/Makefile.am
61
62 %build
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         --enable-threads=posix
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{_includedir}/gc/private
77 install include/private/* $RPM_BUILD_ROOT%{_includedir}/gc/private/
78 install -D doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}}
89 %doc doc/*.html
90 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
91
92 %files devel
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_libdir}/lib*.so
95 %{_libdir}/lib*.la
96 %{_includedir}
97 %{_mandir}/man3/gc.3*
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/lib*.a
This page took 0.037345 seconds and 3 git commands to generate.