]> git.pld-linux.org Git - packages/gc.git/blob - gc.spec
0529998ecfd89832b708333087c558caa5ee0885
[packages/gc.git] / gc.spec
1 Summary:        The Boehm-Demers-Weiser conservative garbage collector
2 Summary(pl.UTF-8):      Konserwatywny odśmiecacz pamięci Boehma-Demersa-Weisera
3 Name:           gc
4 Version:        6.8
5 Release:        1
6 License:        BSD-like
7 Group:          Libraries
8 Source0:        http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}%{version}.tar.gz
9 # Source0-md5:  418d38bd9c66398386a372ec0435250e
10 URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
11 BuildRequires:  autoconf >= 2.53
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _includedir     %{_prefix}/include/gc
17
18 %description
19 Gc is a conservative garbage collector for C and C++. It is used as a
20 replacement for standard malloc() and free(). GC_malloc will attempt
21 to reclaim inaccessible space automatically by invoking a conservative
22 garbage collector at appropriate points.
23
24 %description -l pl.UTF-8
25 Gc jest konserwatywnym odśmiecaczem pamięci dla C i C++. Jest używany
26 jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
27 próbuje odzyskać niedostępna pamięć automatycznie przez wywoływanie
28 konserwatywnego odśmiecacza pamięci w odpowiednich miejscach.
29
30 %package devel
31 Summary:        Headers for conservative garbage collector
32 Summary(pl.UTF-8):      Nagłówki dla konserwatywnego odśmiecacza pamięci
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Headers for conservative garbage collector
38
39 %description devel -l pl.UTF-8
40 Nagłówki dla konserwatywnego odśmiecacza pamięci
41
42 %package static
43 Summary:        Static version of gc library
44 Summary(pl.UTF-8):      Statyczna wersja biblioteki gc
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static version of gc library
50
51 %description static -l pl.UTF-8
52 Statyczna wersja biblioteki gc
53
54 %prep
55 %setup -q -n %{name}%{version}
56
57 # kill libtool.m4 inclusion
58 %{__perl} -pi -e 's/^sinclude.*//' acinclude.m4
59
60 %{__perl} -pi -e 's/^dist_pkgdata_DATA/EXTRA_DIST/' doc/Makefile.am
61
62 %build
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoconf}
66 %{__automake}
67 %configure \
68 %ifnarch sparc64
69         CPPFLAGS="-DUSE_LIBC_PRIVATES" \
70 %endif
71         --enable-threads=posix
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 install -d $RPM_BUILD_ROOT%{_includedir}/gc/private
81 install include/private/* $RPM_BUILD_ROOT%{_includedir}/gc/private
82 install -D doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}}
93 %doc doc/*.html
94 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/lib*.so
99 %{_libdir}/lib*.la
100 %{_includedir}
101 %{_mandir}/man3/gc.3*
102
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/lib*.a
This page took 0.148367 seconds and 3 git commands to generate.