]> git.pld-linux.org Git - packages/gawk.git/blob - gawk.spec
- added mktemp patch (security)
[packages/gawk.git] / gawk.spec
1 Summary:        GNU utilities text processor.
2 Summary(de):    GNU-Utilities Text-Prozessor
3 Summary(fr):    Traitement de texte des utilitaires GNU
4 Summary(pl):    Narzêdzia do obróbki plików tekstowych z GNU
5 Summary(tr):    GNU araçlarý metin düzenleyici
6 Name:           gawk
7 Version:        3.0.3
8 Release:        9
9 Copyright:      GPL
10 Group:          Utilities/Text
11 Group(pl):      Narzêdzia/Tekst
12 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
13 Source1:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}-ps.tar.gz
14 Patch0:         gawk-unaligned.patch
15 Patch1:         gawk-info.patch
16 Patch2:         gawk-mktemp.patch
17 Patch3:         gawk-DESTDIR.patch
18 Buildroot:      /tmp/%{name}-%{version}-root
19
20 %define         _libexecdir     %{_prefix}/lib
21 %define         _libdir         %{_prefix}/lib
22 %define         _exec_prefix    /
23
24 %description
25 This is GNU Awk. It should be upwardly compatible with the Bell Labs
26 research version of awk.  It is almost completely compliant with the
27 1993 POSIX 1003.2 standard for awk.
28
29 Gawk can be used to process text files and is considered a standard
30 Linux tool.
31
32 %description -l de
33 Dies ist GNU Awk. Es sollte aufwärtskompatibel mit der Bell Labs-
34 Version von awk sein. Es ist fast vollständig konform mit dem 1993 
35 POSIX 1003.2-Standard für awk.
36 Gawk läßt sich zum Verarbeiten von Textdateien einsetzen und gilt als
37 ein Standard-Linux-Tool.
38
39 %description -l fr
40 awk de GNU, compatible vers le haut avec les versions awk des Bell Labs.
41 Il est presque totalement conforme au standard 1993 POSIX 1003.2 de awk.
42
43 gawk sert à traiter les fichiers texte est est considéré comme un outil
44 standard de Linux.
45
46 %description -l pl
47 Pakiet zawiera implementacjê GNU interpretera jêzyka awk, który powinien
48 byæ kompatybilny z aplikacj± o tej samej nazwie zrobion± przez Bell Labs.
49 GNU awk jest w pe³ni zgodny ze standardem 1993 POSIX 1003.2.
50
51 Gawk (GNU awk) jest zaawansowanym jêzykiem skryptowym, doskonale nadaj±cym
52 sie do obróbki plików tekstowych. Jest to jedno z podstawowych narzêdzi
53 systemu Linux.
54
55 %description -l tr
56 Gawk metin dosyalarýný iþlemek için kullanýlan standart Linux araçlarýndan
57 biridir.
58
59 %prep
60 %setup -q -b 1
61 %patch0 -p1
62 %patch1 -p1
63 %patch2 -p1
64 %patch3 -p1
65
66 %build
67 LDFLAGS="-s"; export LDFLAGS
68 %configure
69 make
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT/usr/bin
74
75 make install \
76         DESTDIR=$RPM_BUILD_ROOT 
77
78 echo ".so gawk.1" > $RPM_BUILD_ROOT%{_mandir}/man1/awk.1
79 ln -sf %{_bindir}/gawk $RPM_BUILD_ROOT/usr/bin/awk 
80 ln -sf %{_bindir}/gawk $RPM_BUILD_ROOT/usr/bin/gawk 
81
82 gzip -9f $RPM_BUILD_ROOT{%{_infodir}/gawk.info*,%{_mandir}/man1/*} \
83         README ACKNOWLEDGMENT FUTURES LIMITATIONS NEWS PORTS \
84         README_d/README.linux POSIX.STD doc/gawk.ps doc/awkcard.ps
85
86 %post
87 /sbin/install-info %{_infodir}/gawk.info.gz /etc/info-dir
88
89 %preun
90 if [ "$1" = "0" ]; then
91         /sbin/install-info --delete %{_infodir}/gawk.info.gz /etc/info-dir
92 fi
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc *gz README_d/README.linux.gz doc/*.ps.gz
100 %attr(755,root,root) /usr/bin/*
101 %attr(755,root,root) %{_bindir}/*
102 %{_mandir}/man1/*
103 %{_infodir}/*info*
104 %attr(755,root,root) %{_libdir}/awk
105 %{_datadir}/awk
106
107 %changelog
108 * Mon Apr 19 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
109   [3.0.3-8]
110 - recompiles on new rpm.
111
112 * Wed Apr 14 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
113   [3.0.3-7]
114 - removed man group from man pages,
115 - gzipping %doc.
116
117 * Sat Jan 02 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
118   [3.0.3-5]
119 - added %post, %preun with {un}registering gawk info
120   pages (added gawk-info.patch),
121 - added gzipping man pages,
122 - added using LDFLAGS="-s" to ./configure enviroment.
123
124 * Mon Oct 26 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
125   [3.0.3-4]
126 - awk(1) man page is now maked as nroff include to gawk(1) instead
127   making sym link to gawk.1 (this allow compress man pages in future),
128 - removed INSTALL and COPYING from %doc (copyright statment is in Copyright
129   field).
130
131 * Sun Jul 19 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
132 - added pl translation,
133 - added -q %setup parameter,
134 - buildroot canged to /tmp/%{name}-%{version}-root.
135
136 * Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
137 - don't package %{_infodir}/dir
138
139 * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
140 - translations modified for de, fr, tr
141
142 * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
143 - upgraded to 3.0.3
144 - added documentation and buildroot
145
146 * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
147 - built against glibc
This page took 0.076963 seconds and 4 git commands to generate.