]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- added home_etc.patch
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use
5 #                         mozilla instead. To compile wit this option, You
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       5:1.5
9 %define         snap    20031025
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.10
17 Release:        2
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
22 Source0:        http://dl.sf.net/%{name}/%{name}-%{version}.tar.bz2
23 # Source0-md5:  1707493228c2174e8ecd856789506ecd
24 Source1:        %{name}-config-tool.1
25 Patch0:         %{name}-desktop.patch
26 Patch1:         %{name}-home_etc.patch
27 URL:            http://galeon.sourceforge.net/
28 BuildRequires:  GConf2-devel >= 2.0.0
29 BuildRequires:  ORBit2-devel >= 2.7.5-1
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  bison
33 BuildRequires:  gettext-devel
34 BuildRequires:  gnome-vfs2-devel >= 2.0.0
35 BuildRequires:  gtk+2-devel >= 2.0.6
36 BuildRequires:  intltool
37 BuildRequires:  libbonobo-devel >= 2.3.1-4
38 BuildRequires:  libbonoboui-devel >= 2.3.3-2
39 BuildRequires:  libglade2-devel >= 2.0.0
40 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 2.4.0
44 BuildRequires:  mozilla-devel >= %{minmozver}
45 BuildRequires:  nautilus-devel >= 2.3.7-3
46 BuildRequires:  openssl-devel >= 0.9.7c
47 BuildRequires:  scrollkeeper >= 0.1.4
48 BuildRequires:  rpm-build >= 4.1-10
49 Requires(post): GConf2
50 Requires(post): mozilla
51 Requires(post): scrollkeeper
52 Requires:       libbonobo >= 2.3.1-4
53 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 # can be provided by mozilla or mozilla-embedded
57 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
58
59 %if %{?_with_gcc2:1}%{!?_with_gcc2:0}
60 %define         __cc            gcc2
61 %define         __cxx           gcc2
62 %endif
63
64 %description
65 GNOME browser based on Gecko (Mozilla rendering engine).
66
67 %description -l pl
68 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
69 interpretacji stron Mozilli).
70
71 %description -l pt_BR
72 O galeon é um browser para o GNOME baseado no mozilla.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78
79 # regenerate - didn't compile with ORBit2 2.7.2
80 cd idl
81 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
82 mv Galeon*.[ch] ../src
83
84 %build
85 rm -f missing
86 glib-gettextize --copy --force
87 intltoolize --copy --force
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoheader}
91 %{__autoconf}
92 %{__automake}
93 %configure \
94         --with-mozilla-libs=%{_libdir} \
95         --with-mozilla-includes=%{_includedir}/mozilla \
96         --with-mozilla-home=%{_libdir}/mozilla \
97         --enable-nls \
98         --disable-included-gettext \
99         --disable-schemas-install \
100         --disable-werror \
101         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
102         --enable-nautilus-view=yes
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT%{_mandir}/man1
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
114
115 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
116
117 # galeon-2.0.mo, but gnome/help/galeon
118 %find_lang galeon-2.0 --with-gnome --all-name
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post
124 /usr/bin/scrollkeeper-update
125 %gconf_schema_install
126
127 %postun -p /usr/bin/scrollkeeper-update
128
129 %files -f galeon-2.0.lang
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README*
132 %attr(755,root,root) %{_bindir}/*
133 %attr(755,root,root) %{_libdir}/%{name}
134 %{_libdir}/bonobo/servers/*
135 %{_datadir}/galeon
136 %{_desktopdir}/*
137 %{_datadir}/gnome-2.0/ui/*.xml
138 %{_omf_dest_dir}/%{name}
139 %{_datadir}/sounds/galeon
140 %{_pixmapsdir}/*
141 %{_sysconfdir}/gconf/schemas/*
142 %{_sysconfdir}/sound/events/*
143 %{_mandir}/man1/*
This page took 0.033639 seconds and 4 git commands to generate.