]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- updated to 1.3.15
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without nautilus # disable nautilus view
4 %bcond_with gcc2        # compile using gcc2 to get working gcc2-compiled java
5                         # plugin (better get gcc3-compiled one).
6                         # Flash plugin seems to still not work, use
7                         # mozilla instead. To compile wit this option, You
8                         # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.6
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.15
19 Release:        1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  9334cbdf0734f626470e788ce37d21a6
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-locale-names.patch
30 URL:            http://galeon.sourceforge.net/
31 BuildRequires:  GConf2-devel >= 2.4.0
32 BuildRequires:  ORBit2-devel >= 2.8.3
33 BuildRequires:  autoconf >= 2.52
34 BuildRequires:  automake
35 BuildRequires:  bison
36 BuildRequires:  gettext-devel
37 BuildRequires:  glib2-devel >= 1:2.4.0
38 BuildRequires:  gnome-vfs2-devel >= 2.4.0
39 BuildRequires:  gtk+2-devel >= 2:2.4.0
40 BuildRequires:  intltool
41 BuildRequires:  libbonoboui-devel >= 2.4.0
42 BuildRequires:  libglade2-devel >= 1:2.4.0
43 BuildRequires:  libgnomeui-devel >= 2.4.0
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool
46 BuildRequires:  libxml2-devel >= 2.6.6
47 BuildRequires:  mozilla-devel >= %{minmozver}
48 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
49 BuildRequires:  rpm-build >= 4.1-10
50 BuildRequires:  scrollkeeper >= 0.1.4
51 Requires(post): GConf2
52 Requires(post): scrollkeeper
53 Requires:       glib2 >= 1:2.4.0
54 Requires:       gtk+2 >= 2:2.4.0
55 Requires:       libbonobo >= 2.4.0
56 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 # can be provided by mozilla or mozilla-embedded
60 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
61
62 %if %{with gcc2}
63 %define         __cc            gcc2
64 %define         __cxx           gcc2
65 %endif
66
67 %description
68 GNOME browser based on Gecko (Mozilla rendering engine).
69
70 %description -l pl
71 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
72 interpretacji stron Mozilli).
73
74 %description -l pt_BR
75 O galeon é um browser para o GNOME baseado no mozilla.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81 %patch2 -p1
82
83 mv po/{no,nb}.po
84
85 # regenerate - didn't compile with ORBit2 2.7.2
86 cd idl
87 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
88 mv Galeon*.[ch] ../src
89
90 %build
91 rm -f missing
92 cp /usr/share/automake/mkinstalldirs .
93 glib-gettextize --copy --force
94 intltoolize --copy --force
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoheader}
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         --disable-schemas-install \
102         %if %{with nautilus}
103         --enable-nautilus-view=yes
104         %else
105         --enable-nautilus-view=no
106         %endif
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_mandir}/man1
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
118
119 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
120
121 # galeon-2.0.mo, but gnome/help/galeon
122 %find_lang galeon-2.0 --with-gnome --all-name
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post
128 /usr/bin/scrollkeeper-update
129 %gconf_schema_install
130
131 %postun -p /usr/bin/scrollkeeper-update
132
133 %files -f galeon-2.0.lang
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog NEWS README*
136 %attr(755,root,root) %{_bindir}/*
137 %attr(755,root,root) %{_libdir}/%{name}
138 %{_libdir}/bonobo/servers/*
139 %{_datadir}/galeon
140 %{_desktopdir}/*
141 %{_datadir}/gnome-2.0/ui/*.xml
142 %{_omf_dest_dir}/%{name}
143 %{_datadir}/sounds/galeon
144 %{_pixmapsdir}/*
145 %{_sysconfdir}/gconf/schemas/*
146 %{_sysconfdir}/sound/events/*
147 %{_mandir}/man1/*
This page took 0.058036 seconds and 4 git commands to generate.