]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- 1.3.10
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use
5 #                         mozilla instead. To compile wit this option, You
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       5:1.5
9 %define         snap    20031025
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.10
17 Release:        1
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
22 Source0:        http://dl.sf.net/%{name}/%{name}-%{version}.tar.bz2
23 # Source0-md5:  1707493228c2174e8ecd856789506ecd
24 Source1:        %{name}-config-tool.1
25 URL:            http://galeon.sourceforge.net/
26 BuildRequires:  GConf2-devel >= 2.0.0
27 BuildRequires:  ORBit2-devel >= 2.7.5-1
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  bison
31 BuildRequires:  gettext-devel
32 BuildRequires:  gnome-vfs2-devel >= 2.0.0
33 BuildRequires:  gtk+2-devel >= 2.0.6
34 BuildRequires:  intltool
35 BuildRequires:  libbonobo-devel >= 2.3.1-4
36 BuildRequires:  libbonoboui-devel >= 2.3.3-2
37 BuildRequires:  libglade2-devel >= 2.0.0
38 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libxml2-devel >= 2.4.0
41 BuildRequires:  mozilla-devel >= %{minmozver}
42 BuildRequires:  nautilus-devel >= 2.3.7-3
43 BuildRequires:  openssl-devel >= 0.9.7c
44 BuildRequires:  scrollkeeper >= 0.1.4
45 BuildRequires:  rpm-build >= 4.1-10
46 Requires(post): GConf2
47 Requires(post): mozilla
48 Requires(post): scrollkeeper
49 Requires:       libbonobo >= 2.3.1-4
50 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 # can be provided by mozilla or mozilla-embedded
54 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
55
56 %if %{?_with_gcc2:1}%{!?_with_gcc2:0}
57 %define         __cc            gcc2
58 %define         __cxx           gcc2
59 %endif
60
61 %description
62 GNOME browser based on Gecko (Mozilla rendering engine).
63
64 %description -l pl
65 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
66 interpretacji stron Mozilli).
67
68 %description -l pt_BR
69 O galeon é um browser para o GNOME baseado no mozilla.
70
71 %prep
72 %setup -q
73
74 # regenerate - didn't compile with ORBit2 2.7.2
75 cd idl
76 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
77 mv Galeon*.[ch] ../src
78
79 %build
80 rm -f missing
81 glib-gettextize --copy --force
82 intltoolize --copy --force
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoheader}
86 %{__autoconf}
87 %{__automake}
88 %configure \
89         --with-mozilla-libs=%{_libdir} \
90         --with-mozilla-includes=%{_includedir}/mozilla \
91         --with-mozilla-home=%{_libdir}/mozilla \
92         --enable-nls \
93         --disable-included-gettext \
94         --disable-schemas-install \
95         --disable-werror \
96         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
97         --enable-nautilus-view=yes
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_mandir}/man1
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
109
110 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
111
112 # galeon-2.0.mo, but gnome/help/galeon
113 %find_lang galeon-2.0 --with-gnome --all-name
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post
119 /usr/bin/scrollkeeper-update
120 %gconf_schema_install
121
122 %postun -p /usr/bin/scrollkeeper-update
123
124 %files -f galeon-2.0.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README*
127 %attr(755,root,root) %{_bindir}/*
128 %attr(755,root,root) %{_libdir}/%{name}
129 %{_libdir}/bonobo/servers/*
130 %{_datadir}/galeon
131 %{_desktopdir}/*
132 %{_datadir}/gnome-2.0/ui/*.xml
133 %{_omf_dest_dir}/%{name}
134 %{_datadir}/sounds/galeon
135 %{_pixmapsdir}/*
136 %{_sysconfdir}/gconf/schemas/*
137 %{_sysconfdir}/sound/events/*
138 %{_mandir}/man1/*
This page took 0.306439 seconds and 4 git commands to generate.