]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- release++ to rebuild with new mozilla
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without nautilus # disable nautilus view
4 %bcond_with gcc2        # compile using gcc2 to get working gcc2-compiled java
5                         # plugin (better get gcc3-compiled one).
6                         # Flash plugin seems to still not work, use
7                         # mozilla instead. To compile wit this option, You
8                         # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.7
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.18
19 Release:        2
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  d04164ebf26c65fdfd23fc1278edfce1
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-po.patch
30 Patch3:         %{name}-mozilla.patch
31 URL:            http://galeon.sourceforge.net/
32 BuildRequires:  GConf2-devel >= 2.4.0
33 BuildRequires:  ORBit2-devel >= 2.8.3
34 BuildRequires:  autoconf >= 2.52
35 BuildRequires:  automake
36 BuildRequires:  bison
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 1:2.4.4
39 BuildRequires:  gnome-vfs2-devel >= 2.4.0
40 BuildRequires:  gtk+2-devel >= 2:2.4.4
41 BuildRequires:  intltool
42 BuildRequires:  libbonoboui-devel >= 2.4.0
43 BuildRequires:  libglade2-devel >= 1:2.4.0
44 BuildRequires:  libgnomeui-devel >= 2.6.0
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool
47 BuildRequires:  libxml2-devel >= 2.6.6
48 BuildRequires:  mozilla-devel >= %{minmozver}
49 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
50 BuildRequires:  pkgconfig
51 BuildRequires:  rpm-build >= 4.1-10
52 BuildRequires:  scrollkeeper >= 0.1.4
53 Requires(post): GConf2
54 Requires(post,postun):  scrollkeeper
55 Requires:       glib2 >= 1:2.4.4
56 Requires:       gtk+2 >= 2:2.4.4
57 Requires:       libbonobo >= 2.4.0
58 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 # can be provided by mozilla or mozilla-embedded
62 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
63
64 %if %{with gcc2}
65 %define         __cc            gcc2
66 %define         __cxx           gcc2
67 %endif
68
69 %description
70 GNOME browser based on Gecko (Mozilla rendering engine).
71
72 %description -l pl
73 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
74 interpretacji stron Mozilli).
75
76 %description -l pt_BR
77 O galeon é um browser para o GNOME baseado no mozilla.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84 %patch3 -p1
85
86 # regenerate - didn't compile with ORBit2 2.7.2
87 cd idl
88 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
89 mv Galeon*.[ch] ../src
90
91 %build
92 rm -f missing
93 cp /usr/share/automake/mkinstalldirs .
94 glib-gettextize --copy --force
95 intltoolize --copy --force
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoheader}
99 %{__autoconf}
100 %{__automake}
101 %configure \
102         --disable-schemas-install \
103         %if %{with nautilus}
104         --enable-nautilus-view=yes
105         %else
106         --enable-nautilus-view=no
107         %endif
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT%{_mandir}/man1
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
119
120 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
121
122 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
123
124 # galeon-2.0.mo, but gnome/help/galeon
125 %find_lang galeon-2.0 --with-gnome --all-name
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post
131 umask 022
132 /usr/bin/scrollkeeper-update
133 %gconf_schema_install
134 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
135
136 %postun
137 umask 022
138 /usr/bin/scrollkeeper-update
139 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
140
141 %files -f galeon-2.0.lang
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog NEWS README*
144 %attr(755,root,root) %{_bindir}/*
145 %attr(755,root,root) %{_libdir}/%{name}
146 %{_libdir}/bonobo/servers/*
147 %{_datadir}/galeon
148 %{_desktopdir}/*
149 %{_datadir}/gnome-2.0/ui/*.xml
150 %{_omf_dest_dir}/%{name}
151 %{_datadir}/sounds/galeon
152 %{_pixmapsdir}/*
153 %{_sysconfdir}/gconf/schemas/*
154 %{_sysconfdir}/sound/events/*
155 %{_mandir}/man1/*
This page took 0.05316 seconds and 4 git commands to generate.