]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- ahh, what the hell: openssl 0.9.7c
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use
5 #                         mozilla instead. To compile wit this option, You
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.5b
9 %define         snap    20030905
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.9
17 Release:        2
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
22 Source0:        http://dl.sf.net/%{name}/%{name}-%{version}.tar.bz2
23 # Source0-md5:  f948047373884a0dc8d841930d11680c
24 Source1:        %{name}-config-tool.1
25 URL:            http://galeon.sourceforge.net/
26 Patch0:         %{name}-desktop.patch
27 Patch1:         %{name}-history-xml.patch
28 BuildRequires:  GConf2-devel >= 2.0.0
29 BuildRequires:  ORBit2-devel >= 2.7.5-1
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  bison
33 BuildRequires:  gettext-devel
34 BuildRequires:  gnome-vfs2-devel >= 2.0.0
35 BuildRequires:  gtk+2-devel >= 2.0.6
36 BuildRequires:  intltool
37 BuildRequires:  libbonobo-devel >= 2.3.1-4
38 BuildRequires:  libbonoboui-devel >= 2.3.3-2
39 BuildRequires:  libglade2-devel >= 2.0.0
40 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libxml2-devel >= 2.4.0
43 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
44 BuildRequires:  nautilus-devel >= 2.3.7-3
45 BuildRequires:  openssl-devel >= 0.9.7c
46 BuildRequires:  scrollkeeper >= 0.1.4
47 BuildRequires:  rpm-build >= 4.1-10
48 Requires(post): GConf2
49 Requires(post): mozilla
50 Requires(post): scrollkeeper
51 Requires:       libbonobo >= 2.3.1-4
52 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 # can be provided by mozilla or mozilla-embedded
56 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
57
58 %if %{?_with_gcc2:1}%{!?_with_gcc2:0}
59 %define         __cc            gcc2
60 %define         __cxx           gcc2
61 %endif
62
63 %description
64 GNOME browser based on Gecko (Mozilla rendering engine).
65
66 %description -l pl
67 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
68 interpretacji stron Mozilli).
69
70 %description -l pt_BR
71 O galeon é um browser para o GNOME baseado no mozilla.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76 %patch1 -p1
77
78 # regenerate - didn't compile with ORBit2 2.7.2
79 cd idl
80 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
81 mv Galeon*.[ch] ../src
82
83 %build
84 rm -f missing
85 glib-gettextize --copy --force
86 intltoolize --copy --force
87 %{__libtoolize}
88 %{__aclocal}
89 %{__autoheader}
90 %{__autoconf}
91 %{__automake}
92 %configure \
93         --with-mozilla-libs=%{_libdir} \
94         --with-mozilla-includes=%{_includedir}/mozilla \
95         --with-mozilla-home=%{_libdir}/mozilla \
96         --enable-nls \
97         --disable-included-gettext \
98         --disable-schemas-install \
99         --disable-werror \
100         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
101         --enable-nautilus-view=yes
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT%{_mandir}/man1
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
113
114 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
115
116 # galeon-2.0.mo, but gnome/help/galeon
117 %find_lang galeon-2.0 --with-gnome --all-name
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 /usr/bin/scrollkeeper-update
124 %gconf_schema_install
125
126 %postun -p /usr/bin/scrollkeeper-update
127
128 %files -f galeon-2.0.lang
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog NEWS README*
131 %attr(755,root,root) %{_bindir}/*
132 %attr(755,root,root) %{_libdir}/%{name}
133 %{_libdir}/bonobo/servers/*
134 %{_datadir}/galeon
135 %{_desktopdir}/*
136 %{_datadir}/gnome-2.0/ui/*.xml
137 %{_omf_dest_dir}/%{name}
138 %{_datadir}/sounds/galeon
139 %{_pixmapsdir}/*
140 %{_sysconfdir}/gconf/schemas/*
141 %{_sysconfdir}/sound/events/*
142 %{_mandir}/man1/*
This page took 0.040822 seconds and 4 git commands to generate.