]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- up to version 1.3.18
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without nautilus # disable nautilus view
4 %bcond_with gcc2        # compile using gcc2 to get working gcc2-compiled java
5                         # plugin (better get gcc3-compiled one).
6                         # Flash plugin seems to still not work, use
7                         # mozilla instead. To compile wit this option, You
8                         # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.7
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.18
19 Release:        1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  d04164ebf26c65fdfd23fc1278edfce1
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-po.patch
30 Patch3:         %{name}-mozilla.patch
31 URL:            http://galeon.sourceforge.net/
32 BuildRequires:  GConf2-devel >= 2.4.0
33 BuildRequires:  ORBit2-devel >= 2.8.3
34 BuildRequires:  autoconf >= 2.52
35 BuildRequires:  automake
36 BuildRequires:  bison
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 1:2.4.4
39 BuildRequires:  gnome-vfs2-devel >= 2.4.0
40 BuildRequires:  gtk+2-devel >= 2:2.4.4
41 BuildRequires:  intltool
42 BuildRequires:  libbonoboui-devel >= 2.4.0
43 BuildRequires:  libglade2-devel >= 1:2.4.0
44 BuildRequires:  libgnomeui-devel >= 2.6.0
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool
47 BuildRequires:  libxml2-devel >= 2.6.6
48 BuildRequires:  mozilla-devel >= %{minmozver}
49 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
50 BuildRequires:  rpm-build >= 4.1-10
51 BuildRequires:  scrollkeeper >= 0.1.4
52 Requires(post): GConf2
53 Requires(post,postun):  scrollkeeper
54 Requires:       glib2 >= 1:2.4.4
55 Requires:       gtk+2 >= 2:2.4.4
56 Requires:       libbonobo >= 2.4.0
57 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 # can be provided by mozilla or mozilla-embedded
61 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
62
63 %if %{with gcc2}
64 %define         __cc            gcc2
65 %define         __cxx           gcc2
66 %endif
67
68 %description
69 GNOME browser based on Gecko (Mozilla rendering engine).
70
71 %description -l pl
72 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
73 interpretacji stron Mozilli).
74
75 %description -l pt_BR
76 O galeon é um browser para o GNOME baseado no mozilla.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83 %patch3 -p1
84
85 # regenerate - didn't compile with ORBit2 2.7.2
86 cd idl
87 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
88 mv Galeon*.[ch] ../src
89
90 %build
91 rm -f missing
92 cp /usr/share/automake/mkinstalldirs .
93 glib-gettextize --copy --force
94 intltoolize --copy --force
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoheader}
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         --disable-schemas-install \
102         %if %{with nautilus}
103         --enable-nautilus-view=yes
104         %else
105         --enable-nautilus-view=no
106         %endif
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_mandir}/man1
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
118
119 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
120
121 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
122
123 # galeon-2.0.mo, but gnome/help/galeon
124 %find_lang galeon-2.0 --with-gnome --all-name
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post
130 umask 022
131 /usr/bin/scrollkeeper-update
132 %gconf_schema_install
133 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
134
135 %postun
136 umask 022
137 /usr/bin/scrollkeeper-update
138 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
139
140 %files -f galeon-2.0.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README*
143 %attr(755,root,root) %{_bindir}/*
144 %attr(755,root,root) %{_libdir}/%{name}
145 %{_libdir}/bonobo/servers/*
146 %{_datadir}/galeon
147 %{_desktopdir}/*
148 %{_datadir}/gnome-2.0/ui/*.xml
149 %{_omf_dest_dir}/%{name}
150 %{_datadir}/sounds/galeon
151 %{_pixmapsdir}/*
152 %{_sysconfdir}/gconf/schemas/*
153 %{_sysconfdir}/sound/events/*
154 %{_mandir}/man1/*
This page took 0.035566 seconds and 4 git commands to generate.