]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- raw version.
[packages/galeon.git] / galeon.spec
1 # Note that this is NOT a relocatable package
2 %define ver      0.4
3 %define rel      1
4 %define prefix   /usr
5
6 Summary:   Galeon
7 Name:      galeon
8 Version:   %ver
9 Release:   %rel
10 Copyright: GPL
11 Group:     Applications/Internet
12 Source:    galeon-%{PACKAGE_VERSION}.tar.gz
13 URL:       http://galeon.sourceforge.net
14 BuildRoot: /tmp/galeon-%{PACKAGE_VERSION}-root
15 Packager:  Marco Pesenti Gritti <mpeseng@tin.it>
16 Autoreq: 0
17 Requires: gnome-libs >= 1.0.0
18 Requires: ORBit >= 0.4.0
19
20 Docdir: %{prefix}/doc
21
22 %description
23 Gnome browser based on Gecko (Mozilla rendering engine)
24 %prep
25 %setup
26
27 %build
28 if [ ! -f configure ]; then
29   CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%{prefix} \
30     --with-gnome --without-debug --sysconfdir=/etc
31 else
32   CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix} \
33     --with-gnome --without-debug --sysconfdir=/etc
34 fi
35
36 if [ "$SMP" != "" ]; then
37   (make "MAKE=make -k -j $SMP"; exit 0)
38   make
39 else
40   make
41 fi
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 make prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT/etc install
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(-, root, root)
53
54 %doc AUTHORS COPYING ChangeLog NEWS README
55 %{prefix}/bin/*
56 %{prefix}/share/*
This page took 0.049836 seconds and 4 git commands to generate.