]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- corrected schemas option in configure
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use 
5 #                         mozilla instead. To compile wit this option, You 
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.3b-0.2
9 %define         snap            20030213
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o gnome baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.2
17 Release:        0.1
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 Source0:        http://unc.dl.sourceforge.net/sourceforge/galeon/%{name}-%{version}.tar.gz
22 Source1:        %{name}-config-tool.1
23 URL:            http://galeon.sourceforge.net/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  GConf2-devel
27 BuildRequires:  ORBit2-devel
28 BuildRequires:  bison
29 BuildRequires:  bonobo-activation-devel >= 2.1.0
30 BuildRequires:  gettext-devel
31 BuildRequires:  gnome-vfs2-devel
32 BuildRequires:  gtk+2-devel >= 2.0.6
33 BuildRequires:  intltool
34 BuildRequires:  libglade2-devel
35 BuildRequires:  libgnomeui-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libxml2-devel
38 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
39 BuildRequires:  nautilus-devel >= 2.0.0
40 BuildRequires:  openssl-devel >= 0.9.7
41 BuildRequires:  scrollkeeper
42 BuildRequires:  bonobo-activation >= 2.1.0-3
43 BuildRequires:  rpm-build >= 4.1-10
44 Requires:       mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
45 Requires(post): GConf2
46 Requires(post): mozilla
47 Requires(post): scrollkeeper
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 # can be provided by mozilla or mozilla-embedded
51 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
52
53 %if%{?_with_gcc2:1}%{!?_with_gcc2:0}
54 %define         __cc            gcc2
55 %define         __cxx           gcc2
56 %endif
57
58 %description
59 Gnome browser based on Gecko (Mozilla rendering engine).
60
61 %description -l pl
62 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
63 interpretacji stron Mozilli).
64
65 %description -l pt_BR
66 O galeon é um browser para o gnome baseado no mozilla.
67
68 %prep
69 %setup -q -n %{name}-%{version}
70
71 %build
72 rm -f missing
73 glib-gettextize --copy --force
74 intltoolize --copy --force
75 %{__libtoolize}
76 %{__aclocal}
77 %{__autoheader}
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         --with-mozilla-libs=%{_libdir} \
82         --with-mozilla-includes=%{_includedir}/mozilla \
83         --with-mozilla-home=%{_libdir}/mozilla \
84         --enable-nls \
85         --disable-included-gettext \
86         --disable-schemas-install \
87         --disable-werror \
88         --with-mozilla-snapshot=1.3 \
89         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
90         --enable-nautilus-view=yes
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT%{_mandir}/man1
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT 
100
101 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
102
103 %find_lang galeon-2.0
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post
109 /usr/bin/scrollkeeper-update
110 umask 022
111 rm -f %{_libdir}/mozilla/component.reg
112 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
113 %gconf_schema_install
114
115 %postun -p /usr/bin/scrollkeeper-update
116
117 %files -f galeon-2.0.lang
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README*
120 %attr(755,root,root) %{_bindir}/*
121 %{_libdir}/%{name}
122 %{_libdir}/bonobo/servers/*
123 %{_datadir}/galeon
124 %{_datadir}/applications/*
125 %{_datadir}/gnome/help/*
126 %{_datadir}/gnome-2.0/ui/*.xml
127 %{_omf_dest_dir}/%{name}
128 %{_datadir}/sounds/galeon
129 %{_pixmapsdir}/*
130 %{_sysconfdir}/gconf/schemas/*
131 %{_sysconfdir}/sound/events/*
132 %{_mandir}/man1/*
This page took 0.036114 seconds and 4 git commands to generate.