]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- rebuild with latest mozilla, release 2
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use 
5 #                         mozilla instead. To compile wit this option, You 
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.4a
9 %define         snap            20030419
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o gnome baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.4
17 #Release:       0.%{snap}.1
18 Release:        2
19 Epoch:          2
20 License:        GPL
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
23 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
24 Source1:        %{name}-config-tool.1
25 URL:            http://galeon.sourceforge.net/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  GConf2-devel >= 2.0.0
29 BuildRequires:  ORBit2-devel >= 2.0.0
30 BuildRequires:  bison
31 BuildRequires:  bonobo-activation-devel >= 2.2.0
32 BuildRequires:  gettext-devel
33 BuildRequires:  gnome-vfs2-devel >= 2.0.0
34 BuildRequires:  gtk+2-devel >= 2.0.6
35 BuildRequires:  intltool
36 BuildRequires:  libbonoboui-devel >= 2.1.1
37 BuildRequires:  libglade2-devel >= 2.0.0
38 BuildRequires:  libgnomeui-devel >= 2.0.5
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libxml2-devel >= 2.4.0
41 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
42 BuildRequires:  nautilus-devel >= 2.0.0
43 BuildRequires:  openssl-devel >= 0.9.7
44 BuildRequires:  scrollkeeper >= 0.1.4
45 BuildRequires:  bonobo-activation >= 2.2.0
46 BuildRequires:  rpm-build >= 4.1-10
47 Requires:       mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
48 Requires(post): GConf2
49 Requires(post): mozilla
50 Requires(post): scrollkeeper
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 # can be provided by mozilla or mozilla-embedded
54 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
55
56 %if%{?_with_gcc2:1}%{!?_with_gcc2:0}
57 %define         __cc            gcc2
58 %define         __cxx           gcc2
59 %endif
60
61 %description
62 Gnome browser based on Gecko (Mozilla rendering engine).
63
64 %description -l pl
65 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
66 interpretacji stron Mozilli).
67
68 %description -l pt_BR
69 O galeon é um browser para o gnome baseado no mozilla.
70
71 %prep
72 %setup -q
73
74 %build
75 rm -f missing
76 glib-gettextize --copy --force
77 intltoolize --copy --force
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoheader}
81 %{__autoconf}
82 %{__automake}
83 %configure \
84         --with-mozilla-libs=%{_libdir} \
85         --with-mozilla-includes=%{_includedir}/mozilla \
86         --with-mozilla-home=%{_libdir}/mozilla \
87         --enable-nls \
88         --disable-included-gettext \
89         --disable-schemas-install \
90         --disable-werror \
91         --with-mozilla-snapshot=1.4a \
92         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
93         --enable-nautilus-view=yes
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{_mandir}/man1
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT 
103
104 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
105
106 %find_lang galeon-2.0
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 /usr/bin/scrollkeeper-update
113 umask 022
114 rm -f %{_libdir}/mozilla/component.reg
115 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
116 %gconf_schema_install
117
118 %postun -p /usr/bin/scrollkeeper-update
119
120 %files -f galeon-2.0.lang
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog NEWS README*
123 %attr(755,root,root) %{_bindir}/*
124 %{_libdir}/%{name}
125 %{_libdir}/bonobo/servers/*
126 %{_datadir}/galeon
127 %{_datadir}/applications/*
128 %{_datadir}/gnome/help/*
129 %{_datadir}/gnome-2.0/ui/*.xml
130 %{_omf_dest_dir}/%{name}
131 %{_datadir}/sounds/galeon
132 %{_pixmapsdir}/*
133 %{_sysconfdir}/gconf/schemas/*
134 %{_sysconfdir}/sound/events/*
135 %{_mandir}/man1/*
This page took 0.093426 seconds and 4 git commands to generate.