]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
db41bbd1eba29b288b1cd53ea4f797356e13696f
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without nautilus # disable nautilus view
4 %bcond_with gcc2        # compile using gcc2 to get working gcc2-compiled java
5                         # plugin (better get gcc3-compiled one).
6                         # Flash plugin seems to still not work, use
7                         # mozilla instead. To compile wit this option, You
8                         # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.6
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.12
19 Release:        1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  dac3aac7df1169da9b065d053644a69c
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 URL:            http://galeon.sourceforge.net/
30 BuildRequires:  GConf2-devel >= 2.4.0
31 BuildRequires:  ORBit2-devel >= 2.8.3
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  bison
35 BuildRequires:  gettext-devel
36 BuildRequires:  gnome-vfs2-devel >= 2.4.0
37 BuildRequires:  gtk+2-devel >= 2.2.0
38 BuildRequires:  intltool
39 BuildRequires:  libbonobo-devel >= 2.4.0
40 BuildRequires:  libbonoboui-devel >= 2.4.0
41 BuildRequires:  libglade2-devel >= 2.0.1
42 BuildRequires:  libgnomeui-devel >= 2.4.0
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2.4.0
46 BuildRequires:  mozilla-devel >= %{minmozver}
47 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
48 BuildRequires:  openssl-devel >= 0.9.7c
49 BuildRequires:  rpm-build >= 4.1-10
50 BuildRequires:  scrollkeeper >= 0.1.4
51 Requires(post): GConf2
52 Requires(post): scrollkeeper
53 Requires:       libbonobo >= 2.4.0
54 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 # can be provided by mozilla or mozilla-embedded
58 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
59
60 %if %{with gcc2}
61 %define         __cc            gcc2
62 %define         __cxx           gcc2
63 %endif
64
65 %description
66 GNOME browser based on Gecko (Mozilla rendering engine).
67
68 %description -l pl
69 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
70 interpretacji stron Mozilli).
71
72 %description -l pt_BR
73 O galeon é um browser para o GNOME baseado no mozilla.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79
80 # regenerate - didn't compile with ORBit2 2.7.2
81 cd idl
82 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
83 mv Galeon*.[ch] ../src
84
85 %build
86 rm -f missing
87 cp /usr/share/automake/mkinstalldirs .
88 glib-gettextize --copy --force
89 intltoolize --copy --force
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoheader}
93 %{__autoconf}
94 %{__automake}
95 %configure \
96         --with-mozilla-libs=%{_libdir} \
97         --with-mozilla-includes=%{_includedir}/mozilla \
98         --with-mozilla-home=%{_libdir}/mozilla \
99         --enable-nls \
100         --disable-included-gettext \
101         --disable-schemas-install \
102         --disable-werror \
103         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
104         %if %{with nautilus}
105         --enable-nautilus-view=yes
106         %else
107         --enable-nautilus-view=no
108         %endif
109         
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_mandir}/man1
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
121
122 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
123
124 # galeon-2.0.mo, but gnome/help/galeon
125 %find_lang galeon-2.0 --with-gnome --all-name
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post
131 /usr/bin/scrollkeeper-update
132 %gconf_schema_install
133
134 %postun -p /usr/bin/scrollkeeper-update
135
136 %files -f galeon-2.0.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog NEWS README*
139 %attr(755,root,root) %{_bindir}/*
140 %attr(755,root,root) %{_libdir}/%{name}
141 %{_libdir}/bonobo/servers/*
142 %{_datadir}/galeon
143 %{_desktopdir}/*
144 %{_datadir}/gnome-2.0/ui/*.xml
145 %{_omf_dest_dir}/%{name}
146 %{_datadir}/sounds/galeon
147 %{_pixmapsdir}/*
148 %{_sysconfdir}/gconf/schemas/*
149 %{_sysconfdir}/sound/events/*
150 %{_mandir}/man1/*
This page took 0.068626 seconds and 3 git commands to generate.