]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- massive attack: source-md5
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use 
5 #                         mozilla instead. To compile wit this option, You 
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.4b
9 %define         snap            20030518
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o gnome baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.4
17 Release:        1.%{snap}.1
18 #Release:       1
19 Epoch:          2
20 License:        GPL
21 Group:          X11/Applications/Networking
22 #Source0:       http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
23 Source0:        %{name}-%{version}-%{snap}.tar.bz2
24 # Source0-md5:  08dc2d55849a5d719ec694bf9ad91091
25 Source1:        %{name}-config-tool.1
26 URL:            http://galeon.sourceforge.net/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  GConf2-devel >= 2.0.0
30 BuildRequires:  ORBit2-devel >= 2.0.0
31 BuildRequires:  bison
32 BuildRequires:  gettext-devel
33 BuildRequires:  gnome-vfs2-devel >= 2.0.0
34 BuildRequires:  gtk+2-devel >= 2.0.6
35 BuildRequires:  intltool
36 BuildRequires:  libbonobo-devel >= 2.3.1-4
37 BuildRequires:  libbonoboui-devel >= 2.1.1
38 BuildRequires:  libglade2-devel >= 2.0.0
39 BuildRequires:  libgnomeui-devel >= 2.0.5
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libxml2-devel >= 2.4.0
42 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
43 BuildRequires:  nautilus-devel >= 2.0.0
44 BuildRequires:  openssl-devel >= 0.9.7
45 BuildRequires:  scrollkeeper >= 0.1.4
46 BuildRequires:  rpm-build >= 4.1-10
47 Requires:       libbonobo >= 2.3.1-4
48 Requires:       mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
49 Requires(post): GConf2
50 Requires(post): mozilla
51 Requires(post): scrollkeeper
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 # can be provided by mozilla or mozilla-embedded
55 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
56
57 %if%{?_with_gcc2:1}%{!?_with_gcc2:0}
58 %define         __cc            gcc2
59 %define         __cxx           gcc2
60 %endif
61
62 %description
63 Gnome browser based on Gecko (Mozilla rendering engine).
64
65 %description -l pl
66 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
67 interpretacji stron Mozilli).
68
69 %description -l pt_BR
70 O galeon é um browser para o gnome baseado no mozilla.
71
72 %prep
73 %setup -q
74
75 %build
76 rm -f missing
77 glib-gettextize --copy --force
78 intltoolize --copy --force
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoheader}
82 %{__autoconf}
83 %{__automake}
84 %configure \
85         --with-mozilla-libs=%{_libdir} \
86         --with-mozilla-includes=%{_includedir}/mozilla \
87         --with-mozilla-home=%{_libdir}/mozilla \
88         --enable-nls \
89         --disable-included-gettext \
90         --disable-schemas-install \
91         --disable-werror \
92         --with-mozilla-snapshot=1.4b \
93         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
94         --enable-nautilus-view=yes
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT%{_mandir}/man1
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT 
104
105 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
106
107 %find_lang galeon-2.0
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 /usr/bin/scrollkeeper-update
114 umask 022
115 rm -f %{_libdir}/mozilla/component.reg
116 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
117 %gconf_schema_install
118
119 %postun -p /usr/bin/scrollkeeper-update
120
121 %files -f galeon-2.0.lang
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog NEWS README*
124 %attr(755,root,root) %{_bindir}/*
125 %{_libdir}/%{name}
126 %{_libdir}/bonobo/servers/*
127 %{_datadir}/galeon
128 %{_datadir}/applications/*
129 %{_datadir}/gnome/help/*
130 %{_datadir}/gnome-2.0/ui/*.xml
131 %{_omf_dest_dir}/%{name}
132 %{_datadir}/sounds/galeon
133 %{_pixmapsdir}/*
134 %{_sysconfdir}/gconf/schemas/*
135 %{_sysconfdir}/sound/events/*
136 %{_mandir}/man1/*
This page took 0.046915 seconds and 3 git commands to generate.