]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
a061d51e524d272c3efedfb6d26cf6d64919032b
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without nautilus # disable nautilus view
4 %bcond_with gcc2        # compile using gcc2 to get working gcc2-compiled java
5                         # plugin (better get gcc3-compiled one).
6                         # Flash plugin seems to still not work, use
7                         # mozilla instead. To compile wit this option, You
8                         # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.7
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.17
19 Release:        1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  781ac1c9e15fa4c2b367b195e78d1ab2
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-locale-names.patch
30 Patch3:         %{name}-po.patch
31 Patch4:         %{name}-mozilla.patch
32 URL:            http://galeon.sourceforge.net/
33 BuildRequires:  GConf2-devel >= 2.4.0
34 BuildRequires:  ORBit2-devel >= 2.8.3
35 BuildRequires:  autoconf >= 2.52
36 BuildRequires:  automake
37 BuildRequires:  bison
38 BuildRequires:  gettext-devel
39 BuildRequires:  glib2-devel >= 1:2.4.4
40 BuildRequires:  gnome-vfs2-devel >= 2.4.0
41 BuildRequires:  gtk+2-devel >= 2:2.4.4
42 BuildRequires:  intltool
43 BuildRequires:  libbonoboui-devel >= 2.4.0
44 BuildRequires:  libglade2-devel >= 1:2.4.0
45 BuildRequires:  libgnomeui-devel >= 2.6.0
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool
48 BuildRequires:  libxml2-devel >= 2.6.6
49 BuildRequires:  mozilla-devel >= %{minmozver}
50 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
51 BuildRequires:  rpm-build >= 4.1-10
52 BuildRequires:  scrollkeeper >= 0.1.4
53 Requires(post): GConf2
54 Requires(post,postun):  scrollkeeper
55 Requires:       glib2 >= 1:2.4.4
56 Requires:       gtk+2 >= 2:2.4.4
57 Requires:       libbonobo >= 2.4.0
58 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 # can be provided by mozilla or mozilla-embedded
62 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
63
64 %if %{with gcc2}
65 %define         __cc            gcc2
66 %define         __cxx           gcc2
67 %endif
68
69 %description
70 GNOME browser based on Gecko (Mozilla rendering engine).
71
72 %description -l pl
73 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
74 interpretacji stron Mozilli).
75
76 %description -l pt_BR
77 O galeon é um browser para o GNOME baseado no mozilla.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84 %patch3 -p1
85 %patch4 -p1
86
87 mv po/{no,nb}.po
88
89 # regenerate - didn't compile with ORBit2 2.7.2
90 cd idl
91 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
92 mv Galeon*.[ch] ../src
93
94 %build
95 rm -f missing
96 cp /usr/share/automake/mkinstalldirs .
97 glib-gettextize --copy --force
98 intltoolize --copy --force
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoheader}
102 %{__autoconf}
103 %{__automake}
104 %configure \
105         --disable-schemas-install \
106         %if %{with nautilus}
107         --enable-nautilus-view=yes
108         %else
109         --enable-nautilus-view=no
110         %endif
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_mandir}/man1
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
122
123 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
124
125 # galeon-2.0.mo, but gnome/help/galeon
126 %find_lang galeon-2.0 --with-gnome --all-name
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 umask 022
133 /usr/bin/scrollkeeper-update
134 %gconf_schema_install
135 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
136
137 %postun
138 umask 022
139 /usr/bin/scrollkeeper-update
140 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
141
142 %files -f galeon-2.0.lang
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog NEWS README*
145 %attr(755,root,root) %{_bindir}/*
146 %attr(755,root,root) %{_libdir}/%{name}
147 %{_libdir}/bonobo/servers/*
148 %{_datadir}/galeon
149 %{_desktopdir}/*
150 %{_datadir}/gnome-2.0/ui/*.xml
151 %{_omf_dest_dir}/%{name}
152 %{_datadir}/sounds/galeon
153 %{_pixmapsdir}/*
154 %{_sysconfdir}/gconf/schemas/*
155 %{_sysconfdir}/sound/events/*
156 %{_mandir}/man1/*
This page took 0.113778 seconds and 3 git commands to generate.