]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- added uint patch, fixed build with current ORBit2
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use 
5 #                         mozilla instead. To compile wit this option, You 
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.4b
9 %define         snap            20030518
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o gnome baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.5
17 #Release:       1.%{snap}.1
18 Release:        3
19 Epoch:          2
20 License:        GPL
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
23 # Source0-md5:  6d0a503e82e0c676712859ee273dcd81
24 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
25 Source1:        %{name}-config-tool.1
26 URL:            http://galeon.sourceforge.net/
27 Patch0:         %{name}-desktop.patch
28 # s/uint/guint/ (or missing include alternatively)
29 Patch1:         %{name}-uint.patch
30 BuildRequires:  GConf2-devel >= 2.0.0
31 BuildRequires:  ORBit2-devel >= 2.0.0
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  bison
35 BuildRequires:  gettext-devel
36 BuildRequires:  gnome-vfs2-devel >= 2.0.0
37 BuildRequires:  gtk+2-devel >= 2.0.6
38 BuildRequires:  intltool
39 BuildRequires:  libbonobo-devel >= 2.3.1-4
40 BuildRequires:  libbonoboui-devel >= 2.1.1
41 BuildRequires:  libglade2-devel >= 2.0.0
42 BuildRequires:  libgnomeui-devel >= 2.0.5
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libxml2-devel >= 2.4.0
45 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
46 BuildRequires:  nautilus-devel >= 2.0.0
47 BuildRequires:  openssl-devel >= 0.9.7
48 BuildRequires:  scrollkeeper >= 0.1.4
49 BuildRequires:  rpm-build >= 4.1-10
50 Requires:       libbonobo >= 2.3.1-4
51 Requires:       mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
52 Requires(post): GConf2
53 Requires(post): mozilla
54 Requires(post): scrollkeeper
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 # can be provided by mozilla or mozilla-embedded
58 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
59
60 %if%{?_with_gcc2:1}%{!?_with_gcc2:0}
61 %define         __cc            gcc2
62 %define         __cxx           gcc2
63 %endif
64
65 %description
66 Gnome browser based on Gecko (Mozilla rendering engine).
67
68 %description -l pl
69 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
70 interpretacji stron Mozilli).
71
72 %description -l pt_BR
73 O galeon é um browser para o gnome baseado no mozilla.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79
80 # regenerate - didn't compile with ORBit2 2.7.2
81 cd idl
82 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
83 mv Galeon*.[ch] ../src
84
85 %build
86 rm -f missing
87 glib-gettextize --copy --force
88 intltoolize --copy --force
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoheader}
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         --with-mozilla-libs=%{_libdir} \
96         --with-mozilla-includes=%{_includedir}/mozilla \
97         --with-mozilla-home=%{_libdir}/mozilla \
98         --enable-nls \
99         --disable-included-gettext \
100         --disable-schemas-install \
101         --disable-werror \
102         --with-mozilla-snapshot=1.4b \
103         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
104         --enable-nautilus-view=yes
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_mandir}/man1
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT 
114
115 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
116
117 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
118
119 # galeon-2.0.mo, but gnome/help/galeon
120 %find_lang galeon-2.0 --with-gnome --all-name
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post
126 /usr/bin/scrollkeeper-update
127 %gconf_schema_install
128
129 %postun -p /usr/bin/scrollkeeper-update
130
131 %files -f galeon-2.0.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README*
134 %attr(755,root,root) %{_bindir}/*
135 %attr(755,root,root) %{_libdir}/%{name}
136 %{_libdir}/bonobo/servers/*
137 %{_datadir}/galeon
138 %{_desktopdir}/*
139 %{_datadir}/gnome-2.0/ui/*.xml
140 %{_omf_dest_dir}/%{name}
141 %{_datadir}/sounds/galeon
142 %{_pixmapsdir}/*
143 %{_sysconfdir}/gconf/schemas/*
144 %{_sysconfdir}/sound/events/*
145 %{_mandir}/man1/*
This page took 0.072284 seconds and 3 git commands to generate.