]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
2493709bb61a3b61c9fc723f0f0abfa5ccf37d99
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without nautilus # disable nautilus view
4 %bcond_with gcc2        # compile using gcc2 to get working gcc2-compiled java
5                         # plugin (better get gcc3-compiled one).
6                         # Flash plugin seems to still not work, use
7                         # mozilla instead. To compile wit this option, You
8                         # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.7
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.17
19 Release:        1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  781ac1c9e15fa4c2b367b195e78d1ab2
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-locale-names.patch
30 Patch3:         %{name}-po.patch
31 Patch4:         %{name}-mozilla.patch
32 Patch5:         %{name}-mozilla173.patch
33 URL:            http://galeon.sourceforge.net/
34 BuildRequires:  GConf2-devel >= 2.4.0
35 BuildRequires:  ORBit2-devel >= 2.8.3
36 BuildRequires:  autoconf >= 2.52
37 BuildRequires:  automake
38 BuildRequires:  bison
39 BuildRequires:  gettext-devel
40 BuildRequires:  glib2-devel >= 1:2.4.4
41 BuildRequires:  gnome-vfs2-devel >= 2.4.0
42 BuildRequires:  gtk+2-devel >= 2:2.4.4
43 BuildRequires:  intltool
44 BuildRequires:  libbonoboui-devel >= 2.4.0
45 BuildRequires:  libglade2-devel >= 1:2.4.0
46 BuildRequires:  libgnomeui-devel >= 2.6.0
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  libtool
49 BuildRequires:  libxml2-devel >= 2.6.6
50 BuildRequires:  mozilla-devel >= %{minmozver}
51 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
52 BuildRequires:  rpm-build >= 4.1-10
53 BuildRequires:  scrollkeeper >= 0.1.4
54 Requires(post): GConf2
55 Requires(post,postun):  scrollkeeper
56 Requires:       glib2 >= 1:2.4.4
57 Requires:       gtk+2 >= 2:2.4.4
58 Requires:       libbonobo >= 2.4.0
59 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 # can be provided by mozilla or mozilla-embedded
63 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
64
65 %if %{with gcc2}
66 %define         __cc            gcc2
67 %define         __cxx           gcc2
68 %endif
69
70 %description
71 GNOME browser based on Gecko (Mozilla rendering engine).
72
73 %description -l pl
74 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
75 interpretacji stron Mozilli).
76
77 %description -l pt_BR
78 O galeon é um browser para o GNOME baseado no mozilla.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86 %patch4 -p1
87 %patch5 -p1
88
89 mv po/{no,nb}.po
90
91 # regenerate - didn't compile with ORBit2 2.7.2
92 cd idl
93 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
94 mv Galeon*.[ch] ../src
95
96 %build
97 rm -f missing
98 cp /usr/share/automake/mkinstalldirs .
99 glib-gettextize --copy --force
100 intltoolize --copy --force
101 %{__libtoolize}
102 %{__aclocal}
103 %{__autoheader}
104 %{__autoconf}
105 %{__automake}
106 %configure \
107         --disable-schemas-install \
108         %if %{with nautilus}
109         --enable-nautilus-view=yes
110         %else
111         --enable-nautilus-view=no
112         %endif
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT%{_mandir}/man1
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
124
125 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
126
127 # galeon-2.0.mo, but gnome/help/galeon
128 %find_lang galeon-2.0 --with-gnome --all-name
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 umask 022
135 /usr/bin/scrollkeeper-update
136 %gconf_schema_install
137 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
138
139 %postun
140 umask 022
141 /usr/bin/scrollkeeper-update
142 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
143
144 %files -f galeon-2.0.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog NEWS README*
147 %attr(755,root,root) %{_bindir}/*
148 %attr(755,root,root) %{_libdir}/%{name}
149 %{_libdir}/bonobo/servers/*
150 %{_datadir}/galeon
151 %{_desktopdir}/*
152 %{_datadir}/gnome-2.0/ui/*.xml
153 %{_omf_dest_dir}/%{name}
154 %{_datadir}/sounds/galeon
155 %{_pixmapsdir}/*
156 %{_sysconfdir}/gconf/schemas/*
157 %{_sysconfdir}/sound/events/*
158 %{_mandir}/man1/*
This page took 0.062156 seconds and 3 git commands to generate.