]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
10afb61de672c611f921ad530f203fe53571f158
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use 
5 #                         mozilla instead. To compile wit this option, You 
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.4a
9 %define         snap            20030419
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o gnome baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.4
17 Release:        0.%{snap}.1
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 #Source0:       http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
22 Source0:        %{name}-%{version}-%{snap}.tar.bz2
23 Source1:        %{name}-config-tool.1
24 URL:            http://galeon.sourceforge.net/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  GConf2-devel >= 2.0.0
28 BuildRequires:  ORBit2-devel >= 2.0.0
29 BuildRequires:  bison
30 BuildRequires:  bonobo-activation-devel >= 2.2.0
31 BuildRequires:  gettext-devel
32 BuildRequires:  gnome-vfs2-devel >= 2.0.0
33 BuildRequires:  gtk+2-devel >= 2.0.6
34 BuildRequires:  intltool
35 BuildRequires:  libbonoboui-devel >= 2.1.1
36 BuildRequires:  libglade2-devel >= 2.0.0
37 BuildRequires:  libgnomeui-devel >= 2.0.5
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libxml2-devel >= 2.4.0
40 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
41 BuildRequires:  nautilus-devel >= 2.0.0
42 BuildRequires:  openssl-devel >= 0.9.7
43 BuildRequires:  scrollkeeper >= 0.1.4
44 BuildRequires:  bonobo-activation >= 2.2.0
45 BuildRequires:  rpm-build >= 4.1-10
46 Requires:       mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
47 Requires(post): GConf2
48 Requires(post): mozilla
49 Requires(post): scrollkeeper
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 # can be provided by mozilla or mozilla-embedded
53 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
54
55 %if%{?_with_gcc2:1}%{!?_with_gcc2:0}
56 %define         __cc            gcc2
57 %define         __cxx           gcc2
58 %endif
59
60 %description
61 Gnome browser based on Gecko (Mozilla rendering engine).
62
63 %description -l pl
64 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
65 interpretacji stron Mozilli).
66
67 %description -l pt_BR
68 O galeon é um browser para o gnome baseado no mozilla.
69
70 %prep
71 %setup -q
72
73 %build
74 rm -f missing
75 glib-gettextize --copy --force
76 intltoolize --copy --force
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoheader}
80 %{__autoconf}
81 %{__automake}
82 %configure \
83         --with-mozilla-libs=%{_libdir} \
84         --with-mozilla-includes=%{_includedir}/mozilla \
85         --with-mozilla-home=%{_libdir}/mozilla \
86         --enable-nls \
87         --disable-included-gettext \
88         --disable-schemas-install \
89         --disable-werror \
90         --with-mozilla-snapshot=1.4a \
91         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
92         --enable-nautilus-view=yes
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT%{_mandir}/man1
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT 
102
103 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
104
105 %find_lang galeon-2.0
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 /usr/bin/scrollkeeper-update
112 umask 022
113 rm -f %{_libdir}/mozilla/component.reg
114 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
115 %gconf_schema_install
116
117 %postun -p /usr/bin/scrollkeeper-update
118
119 %files -f galeon-2.0.lang
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog NEWS README*
122 %attr(755,root,root) %{_bindir}/*
123 %{_libdir}/%{name}
124 %{_libdir}/bonobo/servers/*
125 %{_datadir}/galeon
126 %{_datadir}/applications/*
127 %{_datadir}/gnome/help/*
128 %{_datadir}/gnome-2.0/ui/*.xml
129 %{_omf_dest_dir}/%{name}
130 %{_datadir}/sounds/galeon
131 %{_pixmapsdir}/*
132 %{_sysconfdir}/gconf/schemas/*
133 %{_sysconfdir}/sound/events/*
134 %{_mandir}/man1/*
This page took 0.039732 seconds and 3 git commands to generate.