]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
0e6608e1a428c4d463ab7561e8463443fe7ff5ac
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without nautilus # disable nautilus view
4 %bcond_with gcc2        # compile using gcc2 to get working gcc2-compiled java
5                         # plugin (better get gcc3-compiled one).
6                         # Flash plugin seems to still not work, use
7                         # mozilla instead. To compile wit this option, You
8                         # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.6
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.11a
19 Release:        1.%{snap}.1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        %{name}-%{version}-%{snap}.tar.bz2
24 # Source0-md5:  d8eed28c9dbc11ec49d4a9e13a3b4bef
25 #Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 URL:            http://galeon.sourceforge.net/
30 BuildRequires:  GConf2-devel >= 2.4.0
31 BuildRequires:  ORBit2-devel >= 2.8.3
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  bison
35 BuildRequires:  gettext-devel
36 BuildRequires:  gnome-vfs2-devel >= 2.4.0
37 BuildRequires:  gtk+2-devel >= 2.2.0
38 BuildRequires:  intltool
39 BuildRequires:  libbonobo-devel >= 2.4.0
40 BuildRequires:  libbonoboui-devel >= 2.4.0
41 BuildRequires:  libglade2-devel >= 2.0.1
42 BuildRequires:  libgnomeui-devel >= 2.4.0
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2.4.0
46 BuildRequires:  mozilla-devel >= %{minmozver}
47 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
48 BuildRequires:  openssl-devel >= 0.9.7c
49 BuildRequires:  rpm-build >= 4.1-10
50 BuildRequires:  scrollkeeper >= 0.1.4
51 Requires(post): GConf2
52 Requires(post): mozilla
53 Requires(post): scrollkeeper
54 Requires:       libbonobo >= 2.4.0
55 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 # can be provided by mozilla or mozilla-embedded
59 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
60
61 %if %{with gcc2}
62 %define         __cc            gcc2
63 %define         __cxx           gcc2
64 %endif
65
66 %description
67 GNOME browser based on Gecko (Mozilla rendering engine).
68
69 %description -l pl
70 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
71 interpretacji stron Mozilli).
72
73 %description -l pt_BR
74 O galeon é um browser para o GNOME baseado no mozilla.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79 %patch1 -p1
80
81 # regenerate - didn't compile with ORBit2 2.7.2
82 cd idl
83 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
84 mv Galeon*.[ch] ../src
85
86 %build
87 rm -f missing
88 cp /usr/share/automake/mkinstalldirs .
89 glib-gettextize --copy --force
90 intltoolize --copy --force
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoheader}
94 %{__autoconf}
95 %{__automake}
96 %configure \
97         --with-mozilla-libs=%{_libdir} \
98         --with-mozilla-includes=%{_includedir}/mozilla \
99         --with-mozilla-home=%{_libdir}/mozilla \
100         --enable-nls \
101         --disable-included-gettext \
102         --disable-schemas-install \
103         --disable-werror \
104         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
105         %if %{with nautilus}
106         --enable-nautilus-view=yes
107         %else
108         --enable-nautilus-view=no
109         %endif
110         
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_mandir}/man1
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
122
123 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
124
125 # galeon-2.0.mo, but gnome/help/galeon
126 %find_lang galeon-2.0 --with-gnome --all-name
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 /usr/bin/scrollkeeper-update
133 %gconf_schema_install
134
135 %postun -p /usr/bin/scrollkeeper-update
136
137 %files -f galeon-2.0.lang
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README*
140 %attr(755,root,root) %{_bindir}/*
141 %attr(755,root,root) %{_libdir}/%{name}
142 %{_libdir}/bonobo/servers/*
143 %{_datadir}/galeon
144 %{_desktopdir}/*
145 %{_datadir}/gnome-2.0/ui/*.xml
146 %{_omf_dest_dir}/%{name}
147 %{_datadir}/sounds/galeon
148 %{_pixmapsdir}/*
149 %{_sysconfdir}/gconf/schemas/*
150 %{_sysconfdir}/sound/events/*
151 %{_mandir}/man1/*
This page took 0.049131 seconds and 3 git commands to generate.