]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- BR: libtool
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use
5 #                         mozilla instead. To compile wit this option, You
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       5:1.5
9 %define         snap    20031025
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.10
17 Release:        1
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
22 Source0:        http://dl.sf.net/%{name}/%{name}-%{version}.tar.bz2
23 # Source0-md5:  1707493228c2174e8ecd856789506ecd
24 Source1:        %{name}-config-tool.1
25 Patch0:         %{name}-desktop.patch
26 URL:            http://galeon.sourceforge.net/
27 BuildRequires:  GConf2-devel >= 2.0.0
28 BuildRequires:  ORBit2-devel >= 2.7.5-1
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  bison
32 BuildRequires:  gettext-devel
33 BuildRequires:  gnome-vfs2-devel >= 2.0.0
34 BuildRequires:  gtk+2-devel >= 2.0.6
35 BuildRequires:  intltool
36 BuildRequires:  libbonobo-devel >= 2.3.1-4
37 BuildRequires:  libbonoboui-devel >= 2.3.3-2
38 BuildRequires:  libglade2-devel >= 2.0.0
39 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool
42 BuildRequires:  libxml2-devel >= 2.4.0
43 BuildRequires:  mozilla-devel >= %{minmozver}
44 BuildRequires:  nautilus-devel >= 2.3.7-3
45 BuildRequires:  openssl-devel >= 0.9.7c
46 BuildRequires:  scrollkeeper >= 0.1.4
47 BuildRequires:  rpm-build >= 4.1-10
48 Requires(post): GConf2
49 Requires(post): mozilla
50 Requires(post): scrollkeeper
51 Requires:       libbonobo >= 2.3.1-4
52 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 # can be provided by mozilla or mozilla-embedded
56 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
57
58 %if %{?_with_gcc2:1}%{!?_with_gcc2:0}
59 %define         __cc            gcc2
60 %define         __cxx           gcc2
61 %endif
62
63 %description
64 GNOME browser based on Gecko (Mozilla rendering engine).
65
66 %description -l pl
67 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
68 interpretacji stron Mozilli).
69
70 %description -l pt_BR
71 O galeon é um browser para o GNOME baseado no mozilla.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 # regenerate - didn't compile with ORBit2 2.7.2
78 cd idl
79 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
80 mv Galeon*.[ch] ../src
81
82 %build
83 rm -f missing
84 glib-gettextize --copy --force
85 intltoolize --copy --force
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoheader}
89 %{__autoconf}
90 %{__automake}
91 %configure \
92         --with-mozilla-libs=%{_libdir} \
93         --with-mozilla-includes=%{_includedir}/mozilla \
94         --with-mozilla-home=%{_libdir}/mozilla \
95         --enable-nls \
96         --disable-included-gettext \
97         --disable-schemas-install \
98         --disable-werror \
99         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
100         --enable-nautilus-view=yes
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT%{_mandir}/man1
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
112
113 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
114
115 # galeon-2.0.mo, but gnome/help/galeon
116 %find_lang galeon-2.0 --with-gnome --all-name
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post
122 /usr/bin/scrollkeeper-update
123 %gconf_schema_install
124
125 %postun -p /usr/bin/scrollkeeper-update
126
127 %files -f galeon-2.0.lang
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog NEWS README*
130 %attr(755,root,root) %{_bindir}/*
131 %attr(755,root,root) %{_libdir}/%{name}
132 %{_libdir}/bonobo/servers/*
133 %{_datadir}/galeon
134 %{_desktopdir}/*
135 %{_datadir}/gnome-2.0/ui/*.xml
136 %{_omf_dest_dir}/%{name}
137 %{_datadir}/sounds/galeon
138 %{_pixmapsdir}/*
139 %{_sysconfdir}/gconf/schemas/*
140 %{_sysconfdir}/sound/events/*
141 %{_mandir}/man1/*
This page took 0.061307 seconds and 3 git commands to generate.