]> git.pld-linux.org Git - packages/gai.git/blob - gai.spec
2aab700b228ff3ab63fb0d1c4b4c9b6461306d45
[packages/gai.git] / gai.spec
1 #
2 # Conditional build:
3 %bcond_without  gl      # without OpenGL support
4 %bcond_without  gnome   # without GNOME support
5 %bcond_without  rox     # without ROX support
6 %bcond_without  sdl     # without SDL support
7 #
8 Summary:        General Applet Interface library
9 Summary(pl):    Ogólna biblioteka interfejsu apletu
10 Name:           gai
11 Version:        0.5.3
12 Release:        1
13 License:        LGPL
14 Group:          X11/Libraries
15 Source0:        http://dl.sourceforge.net/gai/%{name}-%{version}.tar.bz2
16 # Source0-md5:  732016d4cf133a50d2226153db395b85
17 Patch0:         %{name}-opt.patch
18 URL:            http://gai.sourceforge.net/
19 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2}
20 BuildRequires:  autoconf >= 2.53
21 %{?with_gl:BuildRequires:       gtkglext-devel >= 1.0}
22 %{?with_gnome:BuildRequires:    gnome-panel-devel >= 2.4.0}
23 BuildRequires:  gtk+2-devel >= 2.0
24 BuildRequires:  pkgconfig
25 %{?with_rox:BuildRequires:      rox >= 2.1}
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %description
32 This library is intended to simplify the development and use of
33 dockapps. With this library the programmer can focus on what the
34 applet shall do, not on the interface.
35
36 %description -l pl
37 Zamiarem tej biblioteki jest uproszczenie tworzenia i u¿ywania
38 apletów. Przy pomocy tej biblioteki programista mo¿e siê skupiæ na tym
39 co aplet powinien robiæ a nie na jego interfejsie.
40
41 %package devel
42 Summary:        Development files for the GAI
43 Summary(pl):    Pliki rozwojowe dla GAI
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}
46 %{?with_gl:Requires:    gtkglext-devel >= 1.0}
47 %{?with_gnome:Requires: gnome-panel-devel >= 2.4.0}
48 Requires:       gtk+2-devel >= 2.0
49
50 %description devel
51 Header files required for development using GAI.
52
53 %description devel -l pl
54 Pliki nag³ówkowe wymagane do tworzenia programów z u¿yciem GAI.
55
56 %prep
57 %setup -q 
58 %patch0 -p1
59
60 %build
61 %{__autoconf}
62 %configure \
63         %{!?with_gl:--disable-gl} \
64         %{!?with_gnome:--disable-gnome} \
65         %{!?with_rox:--disable-rox} \
66         %{!?with_sdl:--disable-sdl}
67
68 %{__make} \
69         OPT="%{rpmcflags}"
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         PREFIX=$RPM_BUILD_ROOT%{_prefix}
76
77 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78 cp -rf examples/[!C]* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog README README.gai THANKS TODO WINDOWMANAGERS 
89 %attr(755,root,root) %{_libdir}/libgai.so.*.*.*
90
91 %files devel
92 %defattr(644,root,root,755)
93 %doc docs/*
94 %attr(755,root,root) %{_libdir}/libgai.so
95 %{_includedir}/gai
96 %{_pkgconfigdir}/gai.pc
97 %{_examplesdir}/%{name}-%{version}
This page took 0.087929 seconds and 3 git commands to generate.