]> git.pld-linux.org Git - packages/gai.git/blob - gai.spec
0525e7bf49220c301fe99b91ddce214295e0d3b4
[packages/gai.git] / gai.spec
1 #
2 # Conditional build:
3 %bcond_without  gl      # without OpenGL support
4 %bcond_without  gnome   # without GNOME support
5 %bcond_without  rox     # without ROX support
6 %bcond_without  sdl     # without SDL support
7 #
8 Summary:        General Applet Interface library
9 Summary(pl):    Ogólna biblioteka interfejsu apletu
10 Name:           gai
11 Version:        0.5.8
12 Release:        1
13 License:        LGPL
14 Group:          X11/Libraries
15 Source0:        http://dl.sourceforge.net/sourceforge/gai/%{name}-%{version}.tar.bz2
16 # Source0-md5:  29d90cb37fe5341009b27ffd09f871cb
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-libdir.patch
19 URL:            http://gai.sourceforge.net/
20 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2}
21 BuildRequires:  autoconf >= 2.53
22 %{?with_gl:BuildRequires:       gtkglext-devel >= 1.0}
23 %{?with_gnome:BuildRequires:    gnome-panel-devel >= 2.4.0}
24 BuildRequires:  gtk+2-devel >= 2.0
25 BuildRequires:  pkgconfig
26 %{?with_rox:BuildRequires:      rox >= 2.1}
27 BuildRequires:  zlib-devel
28 %{?with_gnome:Provides: gai(gnome) = %{version}-%{release}}
29 %{?with_rox:Provides:   gai(rox) = %{version}-%{release}}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
33
34 %description
35 This library is intended to simplify the development and use of
36 dockapps. With this library the programmer can focus on what the
37 applet shall do, not on the interface.
38
39 %description -l pl
40 Zamiarem tej biblioteki jest uproszczenie tworzenia i u¿ywania
41 apletów. Przy pomocy tej biblioteki programista mo¿e siê skupiæ na tym
42 co aplet powinien robiæ a nie na jego interfejsie.
43
44 %package devel
45 Summary:        Development files for the GAI
46 Summary(pl):    Pliki rozwojowe dla GAI
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 %if %{with gnome}
50 Requires:       gnome-panel-devel >= 2.4.0
51 Requires:       gai(gnome) = %{version}-%{release}
52 Provides:       gai-devel(gnome) = %{version}-%{release}
53 %endif
54 %{?with_gl:Requires:    gtkglext-devel >= 1.0}
55 %if %{with rox}
56 Requires:       gai(rox) = %{version}-%{release}
57 Provides:       gai-devel(rox) = %{version}-%{release}
58 %endif
59 Requires:       gtk+2-devel >= 2.0
60
61 %description devel
62 Header files required for development using GAI.
63
64 %description devel -l pl
65 Pliki nag³ówkowe wymagane do tworzenia programów z u¿yciem GAI.
66
67 %prep
68 %setup -q 
69 %patch0 -p1
70 %patch1 -p1
71
72 %build
73 %{__autoconf}
74 %configure \
75         %{!?with_gl:--disable-gl} \
76         %{!?with_gnome:--disable-gnome} \
77         %{!?with_rox:--disable-rox} \
78         %{!?with_sdl:--disable-sdl}
79
80 %{__make} \
81         OPT="%{rpmcflags} -fPIC"
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT \
88         PREFIX=%{_prefix} \
89         LIBDIR=%{_libdir}
90
91 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
92 cp -rf examples/[!C]* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS ChangeLog README README.gai THANKS TODO WINDOWMANAGERS 
103 %attr(755,root,root) %{_libdir}/libgai.so.*.*.*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %doc docs/*
108 %attr(755,root,root) %{_libdir}/libgai.so
109 %{_includedir}/gai
110 %{_pkgconfigdir}/gai.pc
111 %{_examplesdir}/%{name}-%{version}
This page took 0.075683 seconds and 3 git commands to generate.