]> git.pld-linux.org Git - packages/g-wrap.git/blob - g-wrap.spec
- release 6 (libffi 3.4.x)
[packages/g-wrap.git] / g-wrap.spec
1 Summary:        A utility for automatically generating glue code to export C libraries to Guile Scheme and RScheme
2 Summary(pl.UTF-8):      Narzędzie do eksportowania bibliotek C do interpreterów Scheme
3 Summary(pt_BR.UTF-8):   Um utilitário para geração automática de código para exportar bibliotecas C para guile scheme e rscheme
4 Name:           g-wrap
5 Version:        1.9.15
6 Release:        6
7 Epoch:          2
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        http://download.savannah.gnu.org/releases/g-wrap/%{name}-%{version}.tar.gz
11 # Source0-md5:  037d465a28782636a995cf0179f1d7ff
12 Patch0:         %{name}-info.patch
13 Patch1:         %{name}-guile3.patch
14 URL:            http://www.nongnu.org/g-wrap/
15 BuildRequires:  autoconf >= 2.61
16 BuildRequires:  automake >= 1:1.12
17 BuildRequires:  glib2-devel >= 2.0
18 BuildRequires:  guile-devel >= 5:2.0
19 BuildRequires:  libffi-devel
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  pkgconfig(libffi)
23 BuildRequires:  texinfo
24 Requires:       guile >= 5:2.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is a tool for specifying types, functions, and constants to
29 import into a Scheme interpreter, and for generating code (in C) to
30 interface these to the Guile and RScheme interpreters in particular.
31
32 %description -l pl.UTF-8
33 To jest narzędzie do specyfikowania typów, funkcji i stałych dla
34 interpretera Scheme i generowania kodu (w C) do udostępnienia ich dla
35 interpreterów Guile i RScheme.
36
37 %description -l pt_BR.UTF-8
38 O g-wrap é uma ferramenta para especificar tipos, funções e constantes
39 para importação em um interpretador scheme e para geração de código em
40 C para fazer a interface com os interpretadores guile e rscheme.
41
42 %package devel
43 Summary:        Headers for developing programs using g-wrap
44 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijnia programów z użyciem g-wrap
45 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para o g-wrap
46 Group:          Development/Libraries
47 Requires:       %{name} = %{epoch}:%{version}-%{release}
48 Requires:       guile-devel >= 5:2.0
49 Requires:       libffi-devel
50
51 %description devel
52 headers for developing programs using g-wrap.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe do rozwijania programów z użyciem g-wrap.
56
57 %description devel -l pt_BR.UTF-8
58 Arquivos de inclusao e bibliotecas para o g-wrap.
59
60 %package static
61 Summary:        Static libraries for developing programs using g-wrap
62 Summary(pl.UTF-8):      Biblioteki statyczne g-wrap
63 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com g-wrap
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
66
67 %description static
68 Static libraries for developing programs using g-wrap.
69
70 %description static -l pl.UTF-8
71 Statyczne biblioteki g-wrap.
72
73 %description static -l pt_BR.UTF-8
74 Bibliotecas estáticas para desenvolvimento com a biblioteca g-wrap.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79 %patch1 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         --disable-Werror \
89         --disable-silent-rules
90
91 %{__make} -j1
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgwrap-*.la
101 # dlopened modules
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/g-wrap/modules/libgw-*.{a,la}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %post   devel -p /sbin/postshell
111 -/usr/sbin/fix-info-dir -c %{_infodir}
112
113 %postun devel -p /sbin/postshell
114 -/usr/sbin/fix-info-dir -c %{_infodir}
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS ChangeLog NEWS README THANKS TODO
119 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libgwrap-core-runtime.so.2
121 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libgwrap-guile-runtime.so.2
123 %dir %{_libdir}/g-wrap
124 %dir %{_libdir}/g-wrap/modules
125 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-gw-glib.so*
126 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-standard.so*
127 %{_datadir}/guile/site/g-wrap
128 %{_datadir}/guile/site/g-wrap.scm
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/g-wrap-config
133 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so
134 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so
135 %{_includedir}/g-wrap
136 %{_includedir}/g-wrap-wct.h
137 %{_pkgconfigdir}/g-wrap-2.0-guile.pc
138 %{_aclocaldir}/g-wrap.m4
139 %{_mandir}/man1/g-wrap-config.1*
140 %{_infodir}/g-wrap.info*
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libgwrap-guile-runtime.a
145 %{_libdir}/libgwrap-core-runtime.a
This page took 0.054934 seconds and 4 git commands to generate.