]> git.pld-linux.org Git - packages/g-wrap.git/blob - g-wrap.spec
- release 2
[packages/g-wrap.git] / g-wrap.spec
1 Summary:        A utility for automatically generating glue code to export C libraries to Guile Scheme and RScheme
2 Summary(pl.UTF-8):      Narzędzie do eksportowania bibliotek C do interpreterów Scheme
3 Summary(pt_BR.UTF-8):   Um utilitário para geração automática de código para exportar bibliotecas C para guile scheme e rscheme
4 Name:           g-wrap
5 Version:        1.9.13
6 Release:        2
7 Epoch:          2
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        http://download.savannah.gnu.org/releases/g-wrap/%{name}-%{version}.tar.gz
11 # Source0-md5:  5952a389fd00f123dfb86d269a1d6d67
12 Patch0:         %{name}-info.patch
13 URL:            http://www.nongnu.org/g-wrap/
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake >= 1.5
16 BuildRequires:  glib2-devel >= 2.0
17 BuildRequires:  guile-devel >= 5:1.8.3
18 BuildRequires:  libffi-devel >= 7:3.0
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 BuildRequires:  texinfo
22 Requires:       guile >= 5:1.8.3
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This is a tool for specifying types, functions, and constants to
27 import into a Scheme interpreter, and for generating code (in C) to
28 interface these to the Guile and RScheme interpreters in particular.
29
30 %description -l pl.UTF-8
31 To jest narzędzie do specyfikowania typów, funkcji i stałych dla
32 interpretera Scheme i generowania kodu (w C) do udostępnienia ich dla
33 interpreterów Guile i RScheme.
34
35 %description -l pt_BR.UTF-8
36 O g-wrap é uma ferramenta para especificar tipos, funções e constantes
37 para importação em um interpretador scheme e para geração de código em
38 C para fazer a interface com os interpretadores guile e rscheme.
39
40 %package devel
41 Summary:        Headers for developing programs using g-wrap
42 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijnia programów z użyciem g-wrap
43 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para o g-wrap
44 Group:          Development/Libraries
45 Requires:       %{name} = %{epoch}:%{version}-%{release}
46 Requires:       guile-devel >= 5:1.8
47 Requires:       libffi-devel >= 7:3.0
48
49 %description devel
50 headers for developing programs using g-wrap.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe do rozwijania programów z użyciem g-wrap.
54
55 %description devel -l pt_BR.UTF-8
56 Arquivos de inclusao e bibliotecas para o g-wrap.
57
58 %package static
59 Summary:        Static libraries for developing programs using g-wrap
60 Summary(pl.UTF-8):      Biblioteki statyczne g-wrap
61 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com g-wrap
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
64
65 %description static
66 Static libraries for developing programs using g-wrap.
67
68 %description static -l pl.UTF-8
69 Statyczne biblioteki g-wrap.
70
71 %description static -l pt_BR.UTF-8
72 Bibliotecas estáticas para desenvolvimento com a biblioteca g-wrap.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77
78 %build
79 %{__libtoolize}
80 %{__aclocal} -I m4
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --disable-Werror
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %{__rm} $RPM_BUILD_ROOT%{_libdir}/g-wrap/modules/libgw-*.{a,la}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %post   devel -p /sbin/postshell
104 -/usr/sbin/fix-info-dir -c %{_infodir}
105
106 %postun devel -p /sbin/postshell
107 -/usr/sbin/fix-info-dir -c %{_infodir}
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS ChangeLog NEWS README THANKS TODO
112 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libgwrap-core-runtime.so.2
114 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libgwrap-guile-runtime.so.2
116 %dir %{_libdir}/g-wrap
117 %dir %{_libdir}/g-wrap/modules
118 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-gw-glib.so*
119 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-standard.so*
120 %{_datadir}/guile/site/g-wrap
121 %{_datadir}/guile/site/g-wrap.scm
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/g-wrap-config
126 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so
127 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so
128 %{_libdir}/libgwrap-core-runtime.la
129 %{_libdir}/libgwrap-guile-runtime.la
130 %{_includedir}/g-wrap
131 %{_includedir}/g-wrap-wct.h
132 %{_pkgconfigdir}/g-wrap-2.0-guile.pc
133 %{_aclocaldir}/g-wrap.m4
134 %{_mandir}/man1/g-wrap-config.1*
135 %{_infodir}/g-wrap.info*
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libgwrap-guile-runtime.a
140 %{_libdir}/libgwrap-core-runtime.a
This page took 0.061683 seconds and 4 git commands to generate.