]> git.pld-linux.org Git - packages/g-wrap.git/blob - g-wrap.spec
- updated to 1.9.14
[packages/g-wrap.git] / g-wrap.spec
1 Summary:        A utility for automatically generating glue code to export C libraries to Guile Scheme and RScheme
2 Summary(pl.UTF-8):      Narzędzie do eksportowania bibliotek C do interpreterów Scheme
3 Summary(pt_BR.UTF-8):   Um utilitário para geração automática de código para exportar bibliotecas C para guile scheme e rscheme
4 Name:           g-wrap
5 Version:        1.9.14
6 Release:        1
7 Epoch:          2
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        http://download.savannah.gnu.org/releases/g-wrap/%{name}-%{version}.tar.gz
11 # Source0-md5:  fef7ec5e2ff5192221ed6e97fe93bcb9
12 Patch0:         %{name}-info.patch
13 URL:            http://www.nongnu.org/g-wrap/
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake >= 1.5
16 BuildRequires:  glib2-devel >= 2.0
17 BuildRequires:  guile-devel >= 5:1.8.3
18 BuildRequires:  libffi-devel
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 BuildRequires:  pkgconfig(libffi)
22 BuildRequires:  texinfo
23 Requires:       guile >= 5:1.8.3
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a tool for specifying types, functions, and constants to
28 import into a Scheme interpreter, and for generating code (in C) to
29 interface these to the Guile and RScheme interpreters in particular.
30
31 %description -l pl.UTF-8
32 To jest narzędzie do specyfikowania typów, funkcji i stałych dla
33 interpretera Scheme i generowania kodu (w C) do udostępnienia ich dla
34 interpreterów Guile i RScheme.
35
36 %description -l pt_BR.UTF-8
37 O g-wrap é uma ferramenta para especificar tipos, funções e constantes
38 para importação em um interpretador scheme e para geração de código em
39 C para fazer a interface com os interpretadores guile e rscheme.
40
41 %package devel
42 Summary:        Headers for developing programs using g-wrap
43 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijnia programów z użyciem g-wrap
44 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para o g-wrap
45 Group:          Development/Libraries
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47 Requires:       guile-devel >= 5:1.8.3
48 Requires:       libffi-devel
49
50 %description devel
51 headers for developing programs using g-wrap.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe do rozwijania programów z użyciem g-wrap.
55
56 %description devel -l pt_BR.UTF-8
57 Arquivos de inclusao e bibliotecas para o g-wrap.
58
59 %package static
60 Summary:        Static libraries for developing programs using g-wrap
61 Summary(pl.UTF-8):      Biblioteki statyczne g-wrap
62 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com g-wrap
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
65
66 %description static
67 Static libraries for developing programs using g-wrap.
68
69 %description static -l pl.UTF-8
70 Statyczne biblioteki g-wrap.
71
72 %description static -l pt_BR.UTF-8
73 Bibliotecas estáticas para desenvolvimento com a biblioteca g-wrap.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         --disable-Werror
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %{__rm} $RPM_BUILD_ROOT%{_libdir}/g-wrap/modules/libgw-*.{a,la}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %post   devel -p /sbin/postshell
105 -/usr/sbin/fix-info-dir -c %{_infodir}
106
107 %postun devel -p /sbin/postshell
108 -/usr/sbin/fix-info-dir -c %{_infodir}
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS ChangeLog NEWS README THANKS TODO
113 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libgwrap-core-runtime.so.2
115 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libgwrap-guile-runtime.so.2
117 %dir %{_libdir}/g-wrap
118 %dir %{_libdir}/g-wrap/modules
119 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-gw-glib.so*
120 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-standard.so*
121 %{_datadir}/guile/site/g-wrap
122 %{_datadir}/guile/site/g-wrap.scm
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/g-wrap-config
127 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so
128 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so
129 %{_libdir}/libgwrap-core-runtime.la
130 %{_libdir}/libgwrap-guile-runtime.la
131 %{_includedir}/g-wrap
132 %{_includedir}/g-wrap-wct.h
133 %{_pkgconfigdir}/g-wrap-2.0-guile.pc
134 %{_aclocaldir}/g-wrap.m4
135 %{_mandir}/man1/g-wrap-config.1*
136 %{_infodir}/g-wrap.info*
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libgwrap-guile-runtime.a
141 %{_libdir}/libgwrap-core-runtime.a
This page took 0.090035 seconds and 4 git commands to generate.