]> git.pld-linux.org Git - packages/g-wrap.git/blob - g-wrap.spec
- rel 4; add git fixes for guile 2
[packages/g-wrap.git] / g-wrap.spec
1 Summary:        A utility for automatically generating glue code to export C libraries to Guile Scheme and RScheme
2 Summary(pl.UTF-8):      Narzędzie do eksportowania bibliotek C do interpreterów Scheme
3 Summary(pt_BR.UTF-8):   Um utilitário para geração automática de código para exportar bibliotecas C para guile scheme e rscheme
4 Name:           g-wrap
5 Version:        1.9.13
6 Release:        4
7 Epoch:          2
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        http://download.savannah.gnu.org/releases/g-wrap/%{name}-%{version}.tar.gz
11 # Source0-md5:  5952a389fd00f123dfb86d269a1d6d67
12 Patch0:         %{name}-info.patch
13 Patch1:         %{name}-git.patch
14 URL:            http://www.nongnu.org/g-wrap/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake >= 1.5
17 BuildRequires:  glib2-devel >= 2.0
18 BuildRequires:  guile-devel >= 5:1.8.3
19 BuildRequires:  libffi-devel
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  texinfo
23 Requires:       guile >= 5:1.8.3
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a tool for specifying types, functions, and constants to
28 import into a Scheme interpreter, and for generating code (in C) to
29 interface these to the Guile and RScheme interpreters in particular.
30
31 %description -l pl.UTF-8
32 To jest narzędzie do specyfikowania typów, funkcji i stałych dla
33 interpretera Scheme i generowania kodu (w C) do udostępnienia ich dla
34 interpreterów Guile i RScheme.
35
36 %description -l pt_BR.UTF-8
37 O g-wrap é uma ferramenta para especificar tipos, funções e constantes
38 para importação em um interpretador scheme e para geração de código em
39 C para fazer a interface com os interpretadores guile e rscheme.
40
41 %package devel
42 Summary:        Headers for developing programs using g-wrap
43 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijnia programów z użyciem g-wrap
44 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para o g-wrap
45 Group:          Development/Libraries
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47 Requires:       guile-devel >= 5:1.8
48 Requires:       libffi-devel
49
50 %description devel
51 headers for developing programs using g-wrap.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe do rozwijania programów z użyciem g-wrap.
55
56 %description devel -l pt_BR.UTF-8
57 Arquivos de inclusao e bibliotecas para o g-wrap.
58
59 %package static
60 Summary:        Static libraries for developing programs using g-wrap
61 Summary(pl.UTF-8):      Biblioteki statyczne g-wrap
62 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com g-wrap
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
65
66 %description static
67 Static libraries for developing programs using g-wrap.
68
69 %description static -l pl.UTF-8
70 Statyczne biblioteki g-wrap.
71
72 %description static -l pt_BR.UTF-8
73 Bibliotecas estáticas para desenvolvimento com a biblioteca g-wrap.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79
80 touch config.rpath
81
82 %build
83 %{__libtoolize}
84 %{__aclocal} -I m4
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --disable-Werror
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/g-wrap/modules/libgw-*.{a,la}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %post   devel -p /sbin/postshell
108 -/usr/sbin/fix-info-dir -c %{_infodir}
109
110 %postun devel -p /sbin/postshell
111 -/usr/sbin/fix-info-dir -c %{_infodir}
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog NEWS README THANKS TODO
116 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libgwrap-core-runtime.so.2
118 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libgwrap-guile-runtime.so.2
120 %dir %{_libdir}/g-wrap
121 %dir %{_libdir}/g-wrap/modules
122 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-gw-glib.so*
123 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-standard.so*
124 %{_datadir}/guile/site/g-wrap
125 %{_datadir}/guile/site/g-wrap.scm
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/g-wrap-config
130 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so
131 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so
132 %{_libdir}/libgwrap-core-runtime.la
133 %{_libdir}/libgwrap-guile-runtime.la
134 %{_includedir}/g-wrap
135 %{_includedir}/g-wrap-wct.h
136 %{_pkgconfigdir}/g-wrap-2.0-guile.pc
137 %{_aclocaldir}/g-wrap.m4
138 %{_mandir}/man1/g-wrap-config.1*
139 %{_infodir}/g-wrap.info*
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libgwrap-guile-runtime.a
144 %{_libdir}/libgwrap-core-runtime.a
This page took 0.081194 seconds and 4 git commands to generate.