]> git.pld-linux.org Git - packages/g-wrap.git/blob - g-wrap.spec
- updated to 1.9.8
[packages/g-wrap.git] / g-wrap.spec
1 Summary:        A utility for automatically generating glue code to export C libraries to Guile Scheme and RScheme
2 Summary(pl.UTF-8):      Narzędzie do eksportowania bibliotek C do interpreterów Scheme
3 Summary(pt_BR.UTF-8):   Um utilitário para geração automática de código para exportar bibliotecas C para guile scheme e rscheme
4 Name:           g-wrap
5 Version:        1.9.8
6 Release:        1
7 Epoch:          2
8 License:        LGPL
9 Group:          Libraries
10 Source0:        http://download.savannah.gnu.org/releases/g-wrap/%{name}-%{version}.tar.gz
11 # Source0-md5:  b6deb04db3e1008f7d1db4ab7df594b2
12 Patch0:         %{name}-info.patch
13 Patch1:         %{name}-glib2.patch
14 Patch2:         %{name}-srfi.patch
15 URL:            http://www.nongnu.org/g-wrap/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1.5
18 BuildRequires:  glib2-devel >= 2.0
19 BuildRequires:  guile-devel >= 5:1.8
20 BuildRequires:  libffi-devel
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  texinfo
24 Requires:       guile > 5:1.8
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is a tool for specifying types, functions, and constants to
29 import into a Scheme interpreter, and for generating code (in C) to
30 interface these to the Guile and RScheme interpreters in particular.
31
32 %description -l pl.UTF-8
33 To jest narzędzie do specyfikowania typów, funkcji i stałych dla
34 interpretera Scheme i generowania kodu (w C) do udostępnienia ich dla
35 interpreterów Guile i RScheme.
36
37 %description -l pt_BR.UTF-8
38 O g-wrap é uma ferramenta para especificar tipos, funções e constantes
39 para importação em um interpretador scheme e para geração de código em
40 C para fazer a interface com os interpretadores guile e rscheme.
41
42 %package devel
43 Summary:        Headers for developing programs using g-wrap
44 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijnia programów z użyciem g-wrap
45 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para o g-wrap
46 Group:          Development/Libraries
47 Requires:       %{name} = %{epoch}:%{version}-%{release}
48 Requires:       guile-devel >= 5:1.8
49
50 %description devel
51 headers for developing programs using g-wrap.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe do rozwijania programów z użyciem g-wrap.
55
56 %description devel -l pt_BR.UTF-8
57 Arquivos de inclusao e bibliotecas para o g-wrap.
58
59 %package static
60 Summary:        Static libraries for developing programs using g-wrap
61 Summary(pl.UTF-8):      Biblioteki statyczne g-wrap
62 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com g-wrap
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
65
66 %description static
67 Static libraries for developing programs using g-wrap.
68
69 %description static -l pl.UTF-8
70 Statyczne biblioteki g-wrap.
71
72 %description static -l pt_BR.UTF-8
73 Bibliotecas estáticas para desenvolvimento com a biblioteca g-wrap.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 # disappeared from g-wrap sources, but not present in guile 1.8.1
98 install -D lib/srfi/srfi-35.scm $RPM_BUILD_ROOT%{_datadir}/guile/site/srfi/srfi-35.scm
99
100 rm -f $RPM_BUILD_ROOT%{_libdir}/g-wrap/modules/libgw-*.{a,la}
101 # example module, API not exported
102 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*miscutils*.{a,la}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %post devel
111 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
112
113 %postun devel
114 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS ChangeLog NEWS README THANKS TODO
119 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so.*.*.*
120 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so.*.*.*
121 %attr(755,root,root) %{_libdir}/libgw-guile-miscutils.so.*.*.*
122 %attr(755,root,root) %{_libdir}/libmiscutils.so.*.*.*
123 %dir %{_libdir}/g-wrap
124 %dir %{_libdir}/g-wrap/modules
125 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-gw-glib.so*
126 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-standard.so*
127 %dir %{_datadir}/guile
128 %dir %{_datadir}/guile/site
129 %{_datadir}/guile/site/g-wrap
130 %dir %{_datadir}/guile/site/srfi
131 %{_datadir}/guile/site/srfi/srfi-35.scm
132 %{_datadir}/guile/site/g-wrap.scm
133 %{_infodir}/g-wrap.info*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/g-wrap-config
138 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so
139 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so
140 %{_libdir}/libgwrap-core-runtime.la
141 %{_libdir}/libgwrap-guile-runtime.la
142 %{_includedir}/g-wrap
143 %{_includedir}/g-wrap*.h
144 %{_pkgconfigdir}/g-wrap-2.0-guile.pc
145 %{_aclocaldir}/g-wrap.m4
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libgwrap-guile-runtime.a
150 %{_libdir}/libgwrap-core-runtime.a
This page took 0.062845 seconds and 4 git commands to generate.