]> git.pld-linux.org Git - packages/g-wrap.git/blob - g-wrap.spec
6c84852b153c9e8ad9a9512814e34f56a4c0e14d
[packages/g-wrap.git] / g-wrap.spec
1 Summary:        A utility for automatically generating glue code to export C libraries to Guile Scheme and RScheme
2 Summary(pl.UTF-8):      Narzędzie do eksportowania bibliotek C do interpreterów Scheme
3 Summary(pt_BR.UTF-8):   Um utilitário para geração automática de código para exportar bibliotecas C para guile scheme e rscheme
4 Name:           g-wrap
5 Version:        1.9.11
6 Release:        2
7 Epoch:          2
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        http://download.savannah.gnu.org/releases/g-wrap/%{name}-%{version}.tar.gz
11 # Source0-md5:  f6f54c2a2ce3d8257ccaf19f923cbe45
12 Patch0:         %{name}-info.patch
13 Patch1:         %{name}-pc.patch
14 URL:            http://www.nongnu.org/g-wrap/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake >= 1.5
17 BuildRequires:  glib2-devel >= 2.0
18 BuildRequires:  guile-devel >= 5:1.8.3
19 BuildRequires:  libffi-devel >= 7:3.0
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  texinfo
23 Requires:       guile >= 5:1.8.3
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a tool for specifying types, functions, and constants to
28 import into a Scheme interpreter, and for generating code (in C) to
29 interface these to the Guile and RScheme interpreters in particular.
30
31 %description -l pl.UTF-8
32 To jest narzędzie do specyfikowania typów, funkcji i stałych dla
33 interpretera Scheme i generowania kodu (w C) do udostępnienia ich dla
34 interpreterów Guile i RScheme.
35
36 %description -l pt_BR.UTF-8
37 O g-wrap é uma ferramenta para especificar tipos, funções e constantes
38 para importação em um interpretador scheme e para geração de código em
39 C para fazer a interface com os interpretadores guile e rscheme.
40
41 %package devel
42 Summary:        Headers for developing programs using g-wrap
43 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijnia programów z użyciem g-wrap
44 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para o g-wrap
45 Group:          Development/Libraries
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47 Requires:       guile-devel >= 5:1.8
48 Requires:       libffi-devel >= 7:3.0
49
50 %description devel
51 headers for developing programs using g-wrap.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe do rozwijania programów z użyciem g-wrap.
55
56 %description devel -l pt_BR.UTF-8
57 Arquivos de inclusao e bibliotecas para o g-wrap.
58
59 %package static
60 Summary:        Static libraries for developing programs using g-wrap
61 Summary(pl.UTF-8):      Biblioteki statyczne g-wrap
62 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com g-wrap
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
65
66 %description static
67 Static libraries for developing programs using g-wrap.
68
69 %description static -l pl.UTF-8
70 Statyczne biblioteki g-wrap.
71
72 %description static -l pt_BR.UTF-8
73 Bibliotecas estáticas para desenvolvimento com a biblioteca g-wrap.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79
80 %build
81 %{__libtoolize}
82 %{__aclocal} -I m4
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --disable-Werror
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 rm -f $RPM_BUILD_ROOT%{_libdir}/g-wrap/modules/libgw-*.{a,la}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %post   devel -p /sbin/postshell
106 -/usr/sbin/fix-info-dir -c %{_infodir}
107
108 %postun devel -p /sbin/postshell
109 -/usr/sbin/fix-info-dir -c %{_infodir}
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS ChangeLog NEWS README THANKS TODO
114 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libgwrap-core-runtime.so.2
116 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libgwrap-guile-runtime.so.2
118 %dir %{_libdir}/g-wrap
119 %dir %{_libdir}/g-wrap/modules
120 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-gw-glib.so*
121 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-standard.so*
122 %{_datadir}/guile/site/g-wrap
123 %{_datadir}/guile/site/g-wrap.scm
124 %{_infodir}/g-wrap.info*
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/g-wrap-config
129 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so
130 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so
131 %{_libdir}/libgwrap-core-runtime.la
132 %{_libdir}/libgwrap-guile-runtime.la
133 %{_includedir}/g-wrap
134 %{_includedir}/g-wrap-wct.h
135 %{_pkgconfigdir}/g-wrap-2.0-guile.pc
136 %{_aclocaldir}/g-wrap.m4
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libgwrap-guile-runtime.a
141 %{_libdir}/libgwrap-core-runtime.a
This page took 0.074354 seconds and 3 git commands to generate.