]> git.pld-linux.org Git - packages/g-wrap.git/blob - g-wrap.spec
- tabs in preamble
[packages/g-wrap.git] / g-wrap.spec
1 Summary:        A utility for automatically generating glue code to export C libraries to Guile Scheme and RScheme
2 Summary(pl.UTF-8):      Narzędzie do eksportowania bibliotek C do interpreterów Scheme
3 Summary(pt_BR.UTF-8):   Um utilitário para geração automática de código para exportar bibliotecas C para guile scheme e rscheme
4 Name:           g-wrap
5 Version:        1.9.7
6 Release:        1
7 Epoch:          2
8 License:        LGPL
9 Group:          Libraries
10 Source0:        http://download.savannah.gnu.org/releases/g-wrap/%{name}-%{version}.tar.gz
11 # Source0-md5:  4e980fd3f464d53ecee12184569c32bf
12 Patch0:         %{name}-info.patch
13 Patch1:         %{name}-glib2.patch
14 URL:            http://www.nongnu.org/g-wrap/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake
17 BuildRequires:  glib2-devel >= 2.0
18 BuildRequires:  guile-devel >= 5:1.8
19 BuildRequires:  libffi-devel
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  texinfo
23 Requires:       guile > 5:1.8
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a tool for specifying types, functions, and constants to
28 import into a Scheme interpreter, and for generating code (in C) to
29 interface these to the Guile and RScheme interpreters in particular.
30
31 %description -l pl.UTF-8
32 To jest narzędzie do specyfikowania typów, funkcji i stałych dla
33 interpretera Scheme i generowania kodu (w C) do udostępnienia ich dla
34 interpreterów Guile i RScheme.
35
36 %description -l pt_BR.UTF-8
37 O g-wrap é uma ferramenta para especificar tipos, funções e constantes
38 para importação em um interpretador scheme e para geração de código em
39 C para fazer a interface com os interpretadores guile e rscheme.
40
41 %package devel
42 Summary:        Headers for developing programs using g-wrap
43 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijnia programów z użyciem g-wrap
44 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para o g-wrap
45 Group:          Development/Libraries
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47 Requires:       guile-devel >= 5:1.8
48
49 %description devel
50 headers for developing programs using g-wrap.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe do rozwijania programów z użyciem g-wrap.
54
55 %description devel -l pt_BR.UTF-8
56 Arquivos de inclusao e bibliotecas para o g-wrap.
57
58 %package static
59 Summary:        Static libraries for developing programs using g-wrap
60 Summary(pl.UTF-8):      Biblioteki statyczne g-wrap
61 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com g-wrap
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
64
65 %description static
66 Static libraries for developing programs using g-wrap.
67
68 %description static -l pl.UTF-8
69 Statyczne biblioteki g-wrap.
70
71 %description static -l pt_BR.UTF-8
72 Bibliotecas estáticas para desenvolvimento com a biblioteca g-wrap.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 rm -f $RPM_BUILD_ROOT%{_libdir}/g-wrap/modules/libgw-*.{a,la}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %post devel
104 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
105
106 %postun devel
107 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS ChangeLog NEWS README THANKS TODO
112 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so.*.*.*
113 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so.*.*.*
114 %dir %{_libdir}/g-wrap
115 %dir %{_libdir}/g-wrap/modules
116 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-gw-glib.so*
117 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-standard.so*
118 %dir %{_datadir}/guile
119 %dir %{_datadir}/guile/site
120 %{_datadir}/guile/site/g-wrap
121 %dir %{_datadir}/guile/site/srfi
122 # srfi-34.scm already in recent guile
123 %{_datadir}/guile/site/srfi/srfi-35.scm
124 %{_datadir}/guile/site/g-wrap.scm
125 %{_infodir}/g-wrap.info*
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/g-wrap-config
130 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so
131 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so
132 %{_libdir}/libgwrap-core-runtime.la
133 %{_libdir}/libgwrap-guile-runtime.la
134 %{_includedir}/g-wrap
135 %{_includedir}/g-wrap*.h
136 %{_pkgconfigdir}/g-wrap-2.0-guile.pc
137 %{_aclocaldir}/g-wrap.m4
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libgwrap-guile-runtime.a
142 %{_libdir}/libgwrap-core-runtime.a
This page took 0.057441 seconds and 3 git commands to generate.