]> git.pld-linux.org Git - packages/freevo.git/blob - freevo.spec
BR: rpmbuild(macros) >= 1.710
[packages/freevo.git] / freevo.spec
1 Summary:        Freevo - open-source home theatre PC platform
2 Summary(pl.UTF-8):      Freevo - zestaw kina domowego oparty na platformie PC i otwartych źródłach
3 Name:           freevo
4 Version:        1.7.2
5 Release:        6
6 License:        GPL
7 Group:          Applications/Multimedia
8 Source0:        http://dl.sourceforge.net/freevo/%{name}-%{version}.tar.gz
9 # Source0-md5:  1c05c080cd89d70e07e393f74aaa1730
10 Source1:        %{name}-boot_config
11 Patch0:         %{name}-setup.py-elementtree.patch
12 Patch1:         %{name}-xmltv.py.patch
13 URL:            http://freevo.sourceforge.net/
14 BuildRequires:  rpmbuild(macros) >= 1.710
15 BuildRequires:  python-BeautifulSoup
16 BuildRequires:  python-PIL >= 1.1.4
17 BuildRequires:  python-TwistedCore >= 2.0.1-1
18 BuildRequires:  python-TwistedWeb
19 BuildRequires:  python-devel
20 BuildRequires:  python-elementtree
21 BuildRequires:  python-kaa-imlib2
22 BuildRequires:  python-kaa-metadata
23 BuildRequires:  python-mmpython >= 0.4.9
24 BuildRequires:  python-pygame >= 1.5.6
25 BuildRequires:  python-libxml2
26 BuildRequires:  rpm-pythonprov
27 %pyrequires_eq  python-libs
28 Requires:       aumix >= 2.8
29 Requires:       lsdvd
30 Requires:       mplayer
31 Requires:       python-Numeric
32 Requires:       python-PIL >= 1.1.4
33 Requires:       python-TwistedWeb
34 Requires:       python-kaa-metadata
35 Requires:       python-kaa-imlib2
36 Requires:       python-mmpython >= 0.4.9
37 Requires:       python-numpy
38 Requires:       python-pygame >= 1.5.6
39 #Suggests:      tvtime
40 #Suggests:      xine-ui
41 #Suggests:      xmltv
42 BuildArch:      noarch
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Freevo is a Linux application that turns a PC with a TV capture card
47 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
48 other applications such as xine, mplayer, tvtime and mencoder to play
49 and record video and audio.
50
51 %description -l pl.UTF-8
52 Freevo to linuksowa aplikacja zamieniająca PC z kartą telewizyjną
53 i/lub wyjściem TV-out na samodzielną multimedialną szafę grającą /
54 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
55 mplayer, tvtime i mencoder służące do odtwarzania i nagrywania obrazu
56 i dźwięku.
57
58 %package boot
59 Summary:        Files to enable a standalone Freevo system (started from initscript)
60 Summary(pl.UTF-8):      Pliki do włączania samodzielnego systemu Freevo (uruchamiane z initscriptów)
61 Group:          Applications/Multimedia
62 Requires(post,preun):   /sbin/chkconfig
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       rc-scripts
65
66 %description boot
67 Freevo is a Linux application that turns a PC with a TV capture card
68 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
69 other applications such as mplayer and mencoder to play and record
70 video and audio.
71
72 Note: This installs the initscripts necessary for a standalone Freevo
73 system.
74
75 %description boot -l pl.UTF-8
76 Freevo to linuksowa aplikacja zamieniająca PC z kartą telewizyjną
77 i/lub wyjściem TV-out na samodzielną multimedialną szafę grającą /
78 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
79 mplayer, tvtime i mencoder służące do odtwarzania i nagrywania obrazu
80 i dźwięku.
81
82 Ten pakiet instaluje skrypty inicjalizujące potrzebne do samodzielnego
83 systemu Freevo.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p0
89
90 find . -name CVS | xargs rm -rf
91 find . -name ".cvsignore" | xargs rm -f
92 find . -name "*.pyc" | xargs rm -f
93 find . -name "*.pyo" | xargs rm -f
94 find . -name "*.py" | xargs chmod 644
95
96 %build
97 env %py_build
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 %py_install \
102         --record=INSTALLED_FILES
103
104 install local_conf.py.example $RPM_BUILD_ROOT%{_docdir}
105
106 install -d $RPM_BUILD_ROOT%{_datadir}/freevo/contrib/lirc
107 cp -av contrib/lirc $RPM_BUILD_ROOT%{_datadir}/freevo/contrib
108 install -d $RPM_BUILD_ROOT%{_sysconfdir}/freevo
109 ## The following is needed to let RPM know that the files should be backed up
110 touch $RPM_BUILD_ROOT%{_sysconfdir}/freevo/freevo.conf
111 #
112 ## boot scripts
113 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
114 install -d $RPM_BUILD_ROOT%{_bindir}
115 install boot/freevo $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
116 install boot/freevo_dep $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
117 install boot/recordserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_recordserver
118 install boot/webserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_webserver
119 install boot/recordserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_recordserver_init
120 install boot/webserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_webserver_init
121 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/freevo/boot_config
122 #
123 #
124 install -d $RPM_BUILD_ROOT/var/log/freevo
125 install -d $RPM_BUILD_ROOT/var/cache/freevo
126 install -d $RPM_BUILD_ROOT/var/cache/freevo/{thumbnails,audio}
127 install -d $RPM_BUILD_ROOT/var/cache/xmltv/logos
128
129 mv $RPM_BUILD_ROOT%{_datadir}/locale/{no,nb}
130 %find_lang %{name}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post
136 if [ "$1" = 1 ]; then
137         echo "Remember to run 'freevo setup' after installing!"
138 fi
139
140 %post boot
141 # Add the service, but don't automatically invoke it
142 # user has to enable it via ntsysv
143 /sbin/chkconfig --add freevo
144 /sbin/chkconfig --level 234 freevo off
145 #/sbin/chkconfig --add freevo_dep
146 /sbin/chkconfig --add freevo_recordserver
147 /sbin/chkconfig --level 234 freevo_recordserver off
148 /sbin/chkconfig --add freevo_webserver
149 /sbin/chkconfig --level 234 freevo_webserver off
150
151 %preun boot
152 if [ "$1" = 0 ] ; then
153         /sbin/chkconfig --del freevo
154 #       /sbin/chkconfig --del freevo_dep
155         /sbin/chkconfig --del freevo_recordserver
156         /sbin/chkconfig --del freevo_webserver
157 fi
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc ChangeLog FAQ INSTALL README TODO Docs local_conf.py.example
162 %doc contrib/lirc
163 %{_docdir}/local_conf.py.example
164 %attr(755,root,root) %{_bindir}/freevo
165 #%dir %{_docdir}/installation
166 #%dir %{_docdir}/plugin_writing
167 %{_datadir}/freevo
168 %dir %{_sysconfdir}/freevo
169 %attr(1777,root,root) %dir /var/log/freevo
170 %attr(1777,root,root) %dir /var/cache/freevo
171 %attr(1777,root,root) %dir /var/cache/freevo/audio
172 %attr(1777,root,root) %dir /var/cache/freevo/thumbnails
173 %attr(1777,root,root) %dir /var/cache/xmltv
174 %attr(1777,root,root) %dir /var/cache/xmltv/logos
175 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/freevo.conf
176 #%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freevo/record_config.py
177 %{py_sitescriptdir}/freevo
178 #%dir %{_datadir}/fxd
179 #%{_datadir}/fxd/webradio.fxd
180
181 %files boot
182 %defattr(644,root,root,755)
183 %attr(754,root,root) /etc/rc.d/init.d/*
184 %attr(755,root,root) %{_bindir}/freevo_*
185 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/boot_config
This page took 0.090262 seconds and 4 git commands to generate.