]> git.pld-linux.org Git - packages/freevo.git/blob - freevo.spec
fddcce974567c966b3699236ad57d0696cc87314
[packages/freevo.git] / freevo.spec
1 Summary:        Freevo - open-source home theatre PC platform
2 Summary(pl):    Freevo - zestaw kina domowego oparty na platformie PC i otwartych ¼ród³ach
3 Name:           freevo
4 Version:        1.5.4
5 Release:        1
6 License:        GPL
7 Group:          Applications/Multimedia
8 Source0:        http://dl.sourceforge.net/freevo/%{name}-%{version}.tar.gz
9 # Source0-md5:  22ada48e84e5e3d7f80110c842ed18ca
10 Source1:        %{name}-boot_config
11 URL:            http://freevo.sourceforge.net/
12 BuildRequires:  SDL_image >= 1.2.3
13 BuildRequires:  SDL_mixer >= 1.2.5
14 BuildRequires:  SDL_ttf >= 2.0.6
15 BuildRequires:  docbook-utils
16 BuildRequires:  libexif-devel >= 0.5.10
17 BuildRequires:  libjpeg-devel >= 6b
18 BuildRequires:  python-Imaging >= 1.1.4
19 BuildRequires:  python-PyXML
20 BuildRequires:  python-Twisted >= 2.0.1-1
21 BuildRequires:  python-TwistedWeb
22 BuildRequires:  python-devel
23 BuildRequires:  python-mmpython >= 0.4.8
24 BuildRequires:  python-mx-Tools >= 2.0.5
25 BuildRequires:  python-numpy >= 23.1
26 BuildRequires:  python-pygame >= 1.5.6
27 Requires:       aumix >= 2.8
28 Requires:       lsdvd
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Freevo is a Linux application that turns a PC with a TV capture card
34 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
35 other applications such as xine, mplayer, tvtime and mencoder to play
36 and record video and audio.
37
38 %description -l pl
39 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
40 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
41 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
42 mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania obrazu
43 i d¼wiêku.
44
45 %package boot
46 Summary:        Files to enable a standalone Freevo system (started from initscript)
47 Summary(pl):    Pliki do w³±czania samodzielnego systemu Freevo (uruchamiane z initscriptów)
48 Group:          Applications/Multimedia
49 Requires(post,preun):   /sbin/chkconfig
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       rc-scripts
52
53 %description boot
54 Freevo is a Linux application that turns a PC with a TV capture card
55 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
56 other applications such as mplayer and mencoder to play and record
57 video and audio.
58
59 Note: This installs the initscripts necessary for a standalone Freevo
60 system.
61
62 %description boot -l pl
63 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
64 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
65 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
66 mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania obrazu
67 i d¼wiêku.
68
69 Ten pakiet instaluje skrypty inicjalizuj±ce potrzebne do samodzielnego
70 systemu Freevo.
71
72 %prep
73 %setup -q
74
75 find . -name CVS | xargs rm -rf
76 find . -name ".cvsignore" | xargs rm -f
77 find . -name "*.pyc" | xargs rm -f
78 find . -name "*.pyo" | xargs rm -f
79 find . -name "*.py" | xargs chmod 644
80
81 %build
82 env CFLAGS="%{rpmcflags}" \
83 python setup.py build
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 python setup.py install \
88         --root=$RPM_BUILD_ROOT \
89         --record=INSTALLED_FILES
90
91 install local_conf.py.example $RPM_BUILD_ROOT%{_docdir}
92
93 install -d $RPM_BUILD_ROOT%{_datadir}/freevo/contrib/lirc
94 cp -av contrib/lirc $RPM_BUILD_ROOT%{_datadir}/freevo/contrib
95 install -d $RPM_BUILD_ROOT%{_sysconfdir}/freevo
96 ## The following is needed to let RPM know that the files should be backed up
97 touch $RPM_BUILD_ROOT%{_sysconfdir}/freevo/freevo.conf
98 #
99 ## boot scripts
100 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
101 install -d $RPM_BUILD_ROOT%{_bindir}
102 install boot/freevo $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
103 install boot/freevo_dep $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
104 install boot/recordserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_recordserver
105 install boot/webserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_webserver
106 install boot/recordserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_recordserver_init
107 install boot/webserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_webserver_init
108 install -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/freevo/boot_config
109 #
110 #
111 install -d $RPM_BUILD_ROOT/var/log/freevo
112 install -d $RPM_BUILD_ROOT/var/cache/freevo
113 install -d $RPM_BUILD_ROOT/var/cache/freevo/{thumbnails,audio}
114 install -d $RPM_BUILD_ROOT/var/cache/xmltv/logos
115
116 %find_lang %{name}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post
122 if [ "$1" = 1 ]; then
123         echo "Remember to run 'freevo setup' after installing!"
124 fi
125
126 %post boot
127 # Add the service, but don't automatically invoke it
128 # user has to enable it via ntsysv
129 /sbin/chkconfig --add freevo
130 /sbin/chkconfig --level 234 freevo off
131 #/sbin/chkconfig --add freevo_dep
132 /sbin/chkconfig --add freevo_recordserver
133 /sbin/chkconfig --level 234 freevo_recordserver off
134 /sbin/chkconfig --add freevo_webserver
135 /sbin/chkconfig --level 234 freevo_webserver off
136
137 %preun boot
138 if [ "$1" = 0 ] ; then
139         /sbin/chkconfig --del freevo
140 #       /sbin/chkconfig --del freevo_dep
141         /sbin/chkconfig --del freevo_recordserver
142         /sbin/chkconfig --del freevo_webserver
143 fi
144
145 %files -f %{name}.lang
146 %defattr(644,root,root,755)
147 %doc ChangeLog FAQ INSTALL README TODO Docs local_conf.py.example
148 %doc contrib/lirc
149 %{_docdir}/local_conf.py.example
150 %attr(755,root,root) %{_bindir}/*
151 #%dir %{_docdir}/installation
152 #%dir %{_docdir}/plugin_writing
153 %{_datadir}/freevo
154 %dir %{_sysconfdir}/freevo
155 %attr(1777,root,root) %dir /var/log/freevo
156 %attr(1777,root,root) %dir /var/cache/freevo
157 %attr(1777,root,root) %dir /var/cache/freevo/audio
158 %attr(1777,root,root) %dir /var/cache/freevo/thumbnails
159 %attr(1777,root,root) %dir /var/cache/xmltv
160 %attr(1777,root,root) %dir /var/cache/xmltv/logos
161 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/freevo.conf
162 #%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freevo/record_config.py
163 %{py_sitescriptdir}/freevo
164 %dir %{_datadir}/fxd
165 %{_datadir}/fxd/webradio.fxd
166
167 %files boot
168 %defattr(644,root,root,755)
169 %attr(754,root,root) /etc/rc.d/init.d/*
170 %attr(755,root,root) %{_bindir}/freevo_*
171 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/boot_config
This page took 0.066653 seconds and 3 git commands to generate.