]> git.pld-linux.org Git - packages/freevo.git/blob - freevo.spec
f328ebbde69b04683f81324a7c00e8b7f0ccd40e
[packages/freevo.git] / freevo.spec
1 Summary:        Freevo - open-source home theatre PC platform
2 Summary(pl):    Freevo - zestaw kina domowego oparty na platformie PC i otwartych ¼ród³ach
3 Name:           freevo
4 Version:        1.6.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Multimedia
8 Source0:        http://dl.sourceforge.net/freevo/%{name}-%{version}.tar.gz
9 # Source0-md5:  c454414a2453817ae5a73241d61fac2f
10 Source1:        %{name}-boot_config
11 URL:            http://freevo.sourceforge.net/
12 BuildRequires:  python-Imaging >= 1.1.4
13 BuildRequires:  python-Twisted >= 2.0.1-1
14 BuildRequires:  python-TwistedWeb
15 BuildRequires:  python-devel
16 BuildRequires:  python-elementtree
17 BuildRequires:  python-mmpython >= 0.4.9
18 BuildRequires:  python-pygame >= 1.5.6
19 BuildRequires:  rpm-pythonprov
20 %pyrequires_eq  python-libs
21 Requires:       aumix >= 2.8
22 Requires:       lsdvd
23 Requires:       mplayer
24 Requires:       python-Imaging >= 1.1.4
25 Requires:       python-TwistedWeb
26 Requires:       python-mmpython >= 0.4.9
27 Requires:       python-pygame >= 1.5.6
28 #Suggests:      tvtime
29 #Suggests:      xine-ui
30 #Suggests:      xmltv
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Freevo is a Linux application that turns a PC with a TV capture card
36 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
37 other applications such as xine, mplayer, tvtime and mencoder to play
38 and record video and audio.
39
40 %description -l pl
41 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
42 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
43 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
44 mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania obrazu
45 i d¼wiêku.
46
47 %package boot
48 Summary:        Files to enable a standalone Freevo system (started from initscript)
49 Summary(pl):    Pliki do w³±czania samodzielnego systemu Freevo (uruchamiane z initscriptów)
50 Group:          Applications/Multimedia
51 Requires(post,preun):   /sbin/chkconfig
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       rc-scripts
54
55 %description boot
56 Freevo is a Linux application that turns a PC with a TV capture card
57 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
58 other applications such as mplayer and mencoder to play and record
59 video and audio.
60
61 Note: This installs the initscripts necessary for a standalone Freevo
62 system.
63
64 %description boot -l pl
65 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
66 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
67 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
68 mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania obrazu
69 i d¼wiêku.
70
71 Ten pakiet instaluje skrypty inicjalizuj±ce potrzebne do samodzielnego
72 systemu Freevo.
73
74 %prep
75 %setup -q
76
77 find . -name CVS | xargs rm -rf
78 find . -name ".cvsignore" | xargs rm -f
79 find . -name "*.pyc" | xargs rm -f
80 find . -name "*.pyo" | xargs rm -f
81 find . -name "*.py" | xargs chmod 644
82
83 %build
84 env CFLAGS="%{rpmcflags}" \
85 python setup.py build
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 python setup.py install \
90         --root=$RPM_BUILD_ROOT \
91         --record=INSTALLED_FILES
92
93 install local_conf.py.example $RPM_BUILD_ROOT%{_docdir}
94
95 install -d $RPM_BUILD_ROOT%{_datadir}/freevo/contrib/lirc
96 cp -av contrib/lirc $RPM_BUILD_ROOT%{_datadir}/freevo/contrib
97 install -d $RPM_BUILD_ROOT%{_sysconfdir}/freevo
98 ## The following is needed to let RPM know that the files should be backed up
99 touch $RPM_BUILD_ROOT%{_sysconfdir}/freevo/freevo.conf
100 #
101 ## boot scripts
102 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
103 install -d $RPM_BUILD_ROOT%{_bindir}
104 install boot/freevo $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
105 install boot/freevo_dep $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
106 install boot/recordserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_recordserver
107 install boot/webserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_webserver
108 install boot/recordserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_recordserver_init
109 install boot/webserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_webserver_init
110 install -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/freevo/boot_config
111 #
112 #
113 install -d $RPM_BUILD_ROOT/var/log/freevo
114 install -d $RPM_BUILD_ROOT/var/cache/freevo
115 install -d $RPM_BUILD_ROOT/var/cache/freevo/{thumbnails,audio}
116 install -d $RPM_BUILD_ROOT/var/cache/xmltv/logos
117
118 %find_lang %{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post
124 if [ "$1" = 1 ]; then
125         echo "Remember to run 'freevo setup' after installing!"
126 fi
127
128 %post boot
129 # Add the service, but don't automatically invoke it
130 # user has to enable it via ntsysv
131 /sbin/chkconfig --add freevo
132 /sbin/chkconfig --level 234 freevo off
133 #/sbin/chkconfig --add freevo_dep
134 /sbin/chkconfig --add freevo_recordserver
135 /sbin/chkconfig --level 234 freevo_recordserver off
136 /sbin/chkconfig --add freevo_webserver
137 /sbin/chkconfig --level 234 freevo_webserver off
138
139 %preun boot
140 if [ "$1" = 0 ] ; then
141         /sbin/chkconfig --del freevo
142 #       /sbin/chkconfig --del freevo_dep
143         /sbin/chkconfig --del freevo_recordserver
144         /sbin/chkconfig --del freevo_webserver
145 fi
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc ChangeLog FAQ INSTALL README TODO Docs local_conf.py.example
150 %doc contrib/lirc
151 %{_docdir}/local_conf.py.example
152 %attr(755,root,root) %{_bindir}/freevo
153 #%dir %{_docdir}/installation
154 #%dir %{_docdir}/plugin_writing
155 %{_datadir}/freevo
156 %dir %{_sysconfdir}/freevo
157 %attr(1777,root,root) %dir /var/log/freevo
158 %attr(1777,root,root) %dir /var/cache/freevo
159 %attr(1777,root,root) %dir /var/cache/freevo/audio
160 %attr(1777,root,root) %dir /var/cache/freevo/thumbnails
161 %attr(1777,root,root) %dir /var/cache/xmltv
162 %attr(1777,root,root) %dir /var/cache/xmltv/logos
163 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/freevo.conf
164 #%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freevo/record_config.py
165 %{py_sitescriptdir}/freevo
166 %dir %{_datadir}/fxd
167 %{_datadir}/fxd/webradio.fxd
168
169 %files boot
170 %defattr(644,root,root,755)
171 %attr(754,root,root) /etc/rc.d/init.d/*
172 %attr(755,root,root) %{_bindir}/freevo_*
173 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/boot_config
This page took 0.060674 seconds and 3 git commands to generate.