]> git.pld-linux.org Git - packages/freevo.git/blob - freevo.spec
b1d40bb848bb7c7bb27934099b4822751cdf841f
[packages/freevo.git] / freevo.spec
1 Summary:        Freevo - open-source home theatre PC platform
2 Summary(pl):    Freevo - zestaw kina domowego oparty na platformie PC i otwartych ¼ród³ach
3 Name:           freevo
4 Version:        1.6.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Multimedia
8 Source0:        http://dl.sourceforge.net/freevo/%{name}-%{version}.tar.gz
9 # Source0-md5:  c454414a2453817ae5a73241d61fac2f
10 Source1:        %{name}-boot_config
11 URL:            http://freevo.sourceforge.net/
12 BuildRequires:  python-Imaging >= 1.1.4
13 BuildRequires:  python-Twisted >= 2.0.1-1
14 BuildRequires:  python-TwistedWeb
15 BuildRequires:  python-devel
16 BuildRequires:  python-elementtree
17 BuildRequires:  python-mmpython >= 0.4.9
18 BuildRequires:  python-pygame >= 1.5.6
19 BuildRequires:  rpm-pythonprov
20 %pyrequires_eq  python-libs
21 Requires:       aumix >= 2.8
22 Requires:       lsdvd
23 Requires:       mplayer
24 Requires:       python-Imaging >= 1.1.4
25 Requires:       python-TwistedWeb
26 Requires:       python-mmpython >= 0.4.9
27 Requires:       python-numpy
28 Requires:       python-pygame >= 1.5.6
29 #Suggests:      tvtime
30 #Suggests:      xine-ui
31 #Suggests:      xmltv
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Freevo is a Linux application that turns a PC with a TV capture card
37 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
38 other applications such as xine, mplayer, tvtime and mencoder to play
39 and record video and audio.
40
41 %description -l pl
42 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
43 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
44 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
45 mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania obrazu
46 i d¼wiêku.
47
48 %package boot
49 Summary:        Files to enable a standalone Freevo system (started from initscript)
50 Summary(pl):    Pliki do w³±czania samodzielnego systemu Freevo (uruchamiane z initscriptów)
51 Group:          Applications/Multimedia
52 Requires(post,preun):   /sbin/chkconfig
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       rc-scripts
55
56 %description boot
57 Freevo is a Linux application that turns a PC with a TV capture card
58 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
59 other applications such as mplayer and mencoder to play and record
60 video and audio.
61
62 Note: This installs the initscripts necessary for a standalone Freevo
63 system.
64
65 %description boot -l pl
66 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
67 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
68 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak xine,
69 mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania obrazu
70 i d¼wiêku.
71
72 Ten pakiet instaluje skrypty inicjalizuj±ce potrzebne do samodzielnego
73 systemu Freevo.
74
75 %prep
76 %setup -q
77
78 find . -name CVS | xargs rm -rf
79 find . -name ".cvsignore" | xargs rm -f
80 find . -name "*.pyc" | xargs rm -f
81 find . -name "*.pyo" | xargs rm -f
82 find . -name "*.py" | xargs chmod 644
83
84 %build
85 env CFLAGS="%{rpmcflags}" \
86 python setup.py build
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 python setup.py install \
91         --root=$RPM_BUILD_ROOT \
92         --record=INSTALLED_FILES
93
94 install local_conf.py.example $RPM_BUILD_ROOT%{_docdir}
95
96 install -d $RPM_BUILD_ROOT%{_datadir}/freevo/contrib/lirc
97 cp -av contrib/lirc $RPM_BUILD_ROOT%{_datadir}/freevo/contrib
98 install -d $RPM_BUILD_ROOT%{_sysconfdir}/freevo
99 ## The following is needed to let RPM know that the files should be backed up
100 touch $RPM_BUILD_ROOT%{_sysconfdir}/freevo/freevo.conf
101 #
102 ## boot scripts
103 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
104 install -d $RPM_BUILD_ROOT%{_bindir}
105 install boot/freevo $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
106 install boot/freevo_dep $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
107 install boot/recordserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_recordserver
108 install boot/webserver $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/freevo_webserver
109 install boot/recordserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_recordserver_init
110 install boot/webserver_init $RPM_BUILD_ROOT%{_bindir}/freevo_webserver_init
111 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/freevo/boot_config
112 #
113 #
114 install -d $RPM_BUILD_ROOT/var/log/freevo
115 install -d $RPM_BUILD_ROOT/var/cache/freevo
116 install -d $RPM_BUILD_ROOT/var/cache/freevo/{thumbnails,audio}
117 install -d $RPM_BUILD_ROOT/var/cache/xmltv/logos
118
119 %find_lang %{name}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post
125 if [ "$1" = 1 ]; then
126         echo "Remember to run 'freevo setup' after installing!"
127 fi
128
129 %post boot
130 # Add the service, but don't automatically invoke it
131 # user has to enable it via ntsysv
132 /sbin/chkconfig --add freevo
133 /sbin/chkconfig --level 234 freevo off
134 #/sbin/chkconfig --add freevo_dep
135 /sbin/chkconfig --add freevo_recordserver
136 /sbin/chkconfig --level 234 freevo_recordserver off
137 /sbin/chkconfig --add freevo_webserver
138 /sbin/chkconfig --level 234 freevo_webserver off
139
140 %preun boot
141 if [ "$1" = 0 ] ; then
142         /sbin/chkconfig --del freevo
143 #       /sbin/chkconfig --del freevo_dep
144         /sbin/chkconfig --del freevo_recordserver
145         /sbin/chkconfig --del freevo_webserver
146 fi
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc ChangeLog FAQ INSTALL README TODO Docs local_conf.py.example
151 %doc contrib/lirc
152 %{_docdir}/local_conf.py.example
153 %attr(755,root,root) %{_bindir}/freevo
154 #%dir %{_docdir}/installation
155 #%dir %{_docdir}/plugin_writing
156 %{_datadir}/freevo
157 %dir %{_sysconfdir}/freevo
158 %attr(1777,root,root) %dir /var/log/freevo
159 %attr(1777,root,root) %dir /var/cache/freevo
160 %attr(1777,root,root) %dir /var/cache/freevo/audio
161 %attr(1777,root,root) %dir /var/cache/freevo/thumbnails
162 %attr(1777,root,root) %dir /var/cache/xmltv
163 %attr(1777,root,root) %dir /var/cache/xmltv/logos
164 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/freevo.conf
165 #%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freevo/record_config.py
166 %{py_sitescriptdir}/freevo
167 #%dir %{_datadir}/fxd
168 #%{_datadir}/fxd/webradio.fxd
169
170 %files boot
171 %defattr(644,root,root,755)
172 %attr(754,root,root) /etc/rc.d/init.d/*
173 %attr(755,root,root) %{_bindir}/freevo_*
174 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freevo/boot_config
This page took 0.037658 seconds and 3 git commands to generate.